new port: sysutils/ganglia-webfrontend: GUI for the ganglia cluster monitor
The Ganglia cluster monitoring system is an easy to install and configure cluster monitor. The ganglia-webfrontend port is a port of the web-based GUI. This port depends on the ganglia-monitor-core port which is in PR ports/48551. PR: ports/48552 Submitted by: Brooks Davis <brooks@freebsd.org>
This commit is contained in:
parent
96d9d7a997
commit
97db409c48
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=89811
7 changed files with 184 additions and 0 deletions
|
@ -106,6 +106,7 @@
|
|||
SUBDIR += ftrace
|
||||
SUBDIR += fvcool
|
||||
SUBDIR += ganglia-monitor-core
|
||||
SUBDIR += ganglia-webfrontend
|
||||
SUBDIR += gcombust
|
||||
SUBDIR += gconf-editor
|
||||
SUBDIR += gfslicer
|
||||
|
|
68
sysutils/ganglia-webfrontend/Makefile
Normal file
68
sysutils/ganglia-webfrontend/Makefile
Normal file
|
@ -0,0 +1,68 @@
|
|||
# Ports collection makefile for: ganglia-webfrontend
|
||||
# Date created: Thu Fed 20, 2003
|
||||
# Whom: Brooks Davis <brooks@freebsd.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ganglia-webfrontend
|
||||
PORTVERSION= 2.5.3
|
||||
CATEGORIES= sysutils net parallel www
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ganglia
|
||||
|
||||
MAINTAINER= brooks@FreeBSD.org
|
||||
COMMENT= "Ganglia cluster monitor, web frontend"
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4 \
|
||||
${LOCALBASE}/sbin/gmetad:${PORTSDIR}/sysutils/ganglia-monitor-core
|
||||
|
||||
PLIST_SUB+= WEBFRONTDIR="${WEBFRONTDIR}"
|
||||
NO_BUILD= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
# The Ganglia Web Frontend port supports a number of options that may be
|
||||
# tweaked at buildtime. Perform a "make options" to see more
|
||||
# information on these variables.
|
||||
WWWDOCROOT?= www/data
|
||||
WEBFRONTURL?= ganglia
|
||||
WWWOWN?= www
|
||||
WWWGRP?= www
|
||||
|
||||
# Set custom variables:
|
||||
#
|
||||
WEBFRONTDIR= ${WWWDOCROOT}/${WEBFRONTURL}
|
||||
PKGOPTS= ${FILESDIR}/pkg-opts
|
||||
EXCEPTFILES= AUTHORS ChangeLog COPYING
|
||||
|
||||
options:
|
||||
@ ${ECHO_MSG} "===> Build options for ${PKGNAME}:"
|
||||
@ ${CAT} ${PKGOPTS}
|
||||
|
||||
post-extract:
|
||||
.if !defined(BATCH)
|
||||
@ ${TEST} -r ${PKGOPTS} && \
|
||||
(${ECHO_MSG} '-------------------------------------------------------------------------'; \
|
||||
${ECHO_MSG} 'Perform a "make options" to see a list of available installation options.'; \
|
||||
${ECHO_MSG} '-------------------------------------------------------------------------')
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/conf.php
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/${WEBFRONTDIR}
|
||||
${MKDIR} -m 0775 ${PREFIX}/${WEBFRONTDIR}
|
||||
cd ${WRKSRC} && ${FIND} * \( -name conf.php\* \
|
||||
${EXCEPTFILES:S/^/-o -name /} \) \
|
||||
-a -prune -o -print \
|
||||
| ${TAR} cTf - - | ${TAR} xUCf ${PREFIX}/${WEBFRONTDIR} -
|
||||
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${WEBFRONTDIR}
|
||||
${INSTALL} -c -o ${WWWOWN} -g ${WWWGRP} \
|
||||
${WRKSRC}/conf.php ${PREFIX}/${WEBFRONTDIR}/conf.php.sample
|
||||
if [ ! -f ${PREFIX}/${WEBFRONTDIR}/conf.php ]; then \
|
||||
${INSTALL} -c -o ${WWWOWN} -g ${WWWGRP} \
|
||||
${WRKSRC}/conf.php ${PREFIX}/${WEBFRONTDIR} ;\
|
||||
fi
|
||||
|
||||
.include <bsd.port.mk>
|
1
sysutils/ganglia-webfrontend/distinfo
Normal file
1
sysutils/ganglia-webfrontend/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (ganglia-webfrontend-2.5.3.tar.gz) = bb16ba799049a52de4dd13c9495c704f
|
20
sysutils/ganglia-webfrontend/files/patch-conf.php
Normal file
20
sysutils/ganglia-webfrontend/files/patch-conf.php
Normal file
|
@ -0,0 +1,20 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- conf.php.orig Thu Feb 20 18:10:49 2003
|
||||
+++ conf.php Thu Feb 20 18:14:37 2003
|
||||
@@ -22,12 +22,12 @@
|
||||
#$gmetad_root = "/usr/local/gmetad";
|
||||
|
||||
# The high-performance gmetad.
|
||||
-$gmetad_root = "/var/lib/ganglia";
|
||||
+$gmetad_root = "/var/db/ganglia";
|
||||
$rrds = "$gmetad_root/rrds";
|
||||
|
||||
# Leave this alone if rrdtool is installed in $gmetad_root,
|
||||
# otherwise, change it if it's installed elsewhere (like /usr/bin)
|
||||
-define("RRDTOOL", "/usr/bin/rrdtool");
|
||||
+define("RRDTOOL", "%%PREFIX%%/bin/rrdtool");
|
||||
|
||||
#
|
||||
# If you want to grab data from a different ganglia source specify it here.
|
21
sysutils/ganglia-webfrontend/files/pkg-opts
Normal file
21
sysutils/ganglia-webfrontend/files/pkg-opts
Normal file
|
@ -0,0 +1,21 @@
|
|||
* WWWDOCROOT [www/data]
|
||||
The DocumentRoot of your webserver under ${PREFIX}
|
||||
|
||||
* WEBFRONTURL [ganglia]
|
||||
The base URL of the Ganglia Web Frontend on your webserver.
|
||||
|
||||
The Ganglia Web Frontend will be installed under
|
||||
${PREFIX}/${WWWDOCROOT}/${WEBFRONTURL} and will be visible as
|
||||
http://<;hostname>/${WEBFRONTURL}
|
||||
|
||||
* WWWOWN [www]
|
||||
The user ID under which your webserver executes
|
||||
|
||||
It is recommended that you do not change this option unless you're
|
||||
REALLY sure what you're doing.
|
||||
|
||||
* WWWGRP [www]
|
||||
The group ID under which your webserver executes
|
||||
|
||||
It is recommended that you do not change this option unless you're
|
||||
REALLY sure what you're doing.
|
12
sysutils/ganglia-webfrontend/pkg-descr
Normal file
12
sysutils/ganglia-webfrontend/pkg-descr
Normal file
|
@ -0,0 +1,12 @@
|
|||
Ganglia provides a complete real-time monitoring and execution
|
||||
environment that is in use by hundreds of universities, private and
|
||||
government laboratories and commercial cluster implementors around the
|
||||
world. Whether you want to monitor hundreds of computers in real-time
|
||||
across a university campus or around the world, ganglia is for you.
|
||||
|
||||
The ganglia web frontend provides access to the data collected by the
|
||||
monitoring core.
|
||||
|
||||
WWW: http://ganglia.sourceforge.net/
|
||||
|
||||
-- Brooks Davis <brooks@FreeBSD.org>
|
61
sysutils/ganglia-webfrontend/pkg-plist
Normal file
61
sysutils/ganglia-webfrontend/pkg-plist
Normal file
|
@ -0,0 +1,61 @@
|
|||
%%WEBFRONTDIR%%/auth.php
|
||||
%%WEBFRONTDIR%%/class.TemplatePower.inc.php
|
||||
%%WEBFRONTDIR%%/cluster_legend.html
|
||||
%%WEBFRONTDIR%%/cluster_view.php
|
||||
%%WEBFRONTDIR%%/footer.php
|
||||
%%WEBFRONTDIR%%/functions.php
|
||||
%%WEBFRONTDIR%%/ganglia.php
|
||||
%%WEBFRONTDIR%%/get_context.php
|
||||
%%WEBFRONTDIR%%/get_ganglia.php
|
||||
%%WEBFRONTDIR%%/graph.php
|
||||
%%WEBFRONTDIR%%/grid_tree.php
|
||||
%%WEBFRONTDIR%%/header.php
|
||||
%%WEBFRONTDIR%%/host_view.php
|
||||
%%WEBFRONTDIR%%/index.php
|
||||
%%WEBFRONTDIR%%/meta_view.php
|
||||
%%WEBFRONTDIR%%/node_legend.html
|
||||
%%WEBFRONTDIR%%/physical_view.php
|
||||
%%WEBFRONTDIR%%/private_clusters
|
||||
%%WEBFRONTDIR%%/show_node.php
|
||||
%%WEBFRONTDIR%%/styles.css
|
||||
%%WEBFRONTDIR%%/templates/Rocks/images/ganglia.jpg
|
||||
%%WEBFRONTDIR%%/templates/Rocks/images/rocks.jpg
|
||||
%%WEBFRONTDIR%%/templates/Rocks/images/hardhat.png
|
||||
%%WEBFRONTDIR%%/templates/Rocks/header.tpl
|
||||
%%WEBFRONTDIR%%/templates/default/images/cluster_0-24.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/cluster_25-49.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/cluster_50-74.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/cluster_75-100.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/cluster_overloaded.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/cluster_private.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/logo.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/node_0-24.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/node_25-49.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/node_50-74.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/node_75-100.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/node_dead.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/node_overloaded.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/grid_0-24.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/grid_25-49.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/grid_50-74.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/grid_75-100.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/grid_overloaded.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/images/grid_private.jpg
|
||||
%%WEBFRONTDIR%%/templates/default/cluster_view.tpl
|
||||
%%WEBFRONTDIR%%/templates/default/footer.tpl
|
||||
%%WEBFRONTDIR%%/templates/default/header-nobanner.tpl
|
||||
%%WEBFRONTDIR%%/templates/default/header.tpl
|
||||
%%WEBFRONTDIR%%/templates/default/host_view.tpl
|
||||
%%WEBFRONTDIR%%/templates/default/meta_view.tpl
|
||||
%%WEBFRONTDIR%%/templates/default/physical_view.tpl
|
||||
%%WEBFRONTDIR%%/templates/default/show_node.tpl
|
||||
%%WEBFRONTDIR%%/templates/default/grid_tree.tpl
|
||||
%%WEBFRONTDIR%%/conf.php.sample
|
||||
%%WEBFRONTDIR%%/conf.php
|
||||
@dirrm %%WEBFRONTDIR%%/addons
|
||||
@dirrm %%WEBFRONTDIR%%/templates/Rocks/images
|
||||
@dirrm %%WEBFRONTDIR%%/templates/Rocks
|
||||
@dirrm %%WEBFRONTDIR%%/templates/default/images
|
||||
@dirrm %%WEBFRONTDIR%%/templates/default
|
||||
@dirrm %%WEBFRONTDIR%%/templates
|
||||
@dirrm %%WEBFRONTDIR%%
|
Loading…
Reference in a new issue