Fixes for recent kernel changes, this will screw over people (like me)
who have a -CURRENT before: Fri May 5 9:58:59 2000 UTC by phk .. however, since no __FreeBSD_version bump was performed, I can't handle this with the usual Makefile magic. Submitted by: kuriyama-san Reviewed by: Matt Ayres <mayres@chc-chimes.com> ("it works now")
This commit is contained in:
parent
9073addd94
commit
982787c28b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=28539
28 changed files with 378 additions and 14 deletions
|
@ -14,7 +14,7 @@ MASTER_SITES= ftp://ucd-snmp.ucdavis.edu/ \
|
|||
|
||||
MAINTAINER= billf@FreeBSD.org
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_AUTOCONF= YES
|
||||
CONFIGURE_ARGS+= --enable-shared
|
||||
.if defined(BATCH)
|
||||
CONFIGURE_ARGS+= --with-defaults --with-sys-contact=nobody@no.where
|
||||
|
@ -71,5 +71,4 @@ post-install:
|
|||
fi
|
||||
${SETENV} OBJFORMAT="${PORTOBJFORMAT}" ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
29
net-mgmt/net-snmp-devel/files/patch-al
Normal file
29
net-mgmt/net-snmp-devel/files/patch-al
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- configure.in~ Sat May 6 01:46:26 2000
|
||||
+++ configure.in Wed May 17 11:09:08 2000
|
||||
@@ -1286,6 +1286,26 @@
|
||||
AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
|
||||
[
|
||||
|
||||
+dnl 4.4 compatible but renamed on FreeBSD
|
||||
+AC_TRY_COMPILE([
|
||||
+#include <sys/types.h>
|
||||
+#define KERNEL
|
||||
+#define _KERNEL
|
||||
+#include <sys/socket.h>
|
||||
+#undef KERNEL
|
||||
+#undef _KERNEL
|
||||
+#include <net/route.h>
|
||||
+],[
|
||||
+
|
||||
+#ifndef STRUCT_RTENTRY_HAS_RT_DST
|
||||
+#define rt_dst rt_nodes->rn_key
|
||||
+#endif
|
||||
+
|
||||
+ struct rtentry rt;
|
||||
+ rt.rt_nodes[0].rn_bit = 1;
|
||||
+ rt.rt_dst;
|
||||
+ ], ac_cv_RTENTRY_TYPE="BSD-4.4")
|
||||
+
|
||||
dnl 4.4 compat
|
||||
AC_TRY_COMPILE([
|
||||
#include <sys/types.h>
|
12
net-mgmt/net-snmp-devel/files/patch-am
Normal file
12
net-mgmt/net-snmp-devel/files/patch-am
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/vmstat_freebsd2.c~ Sat Dec 18 08:41:14 1999
|
||||
+++ agent/mibgroup/ucd-snmp/vmstat_freebsd2.c Wed May 17 11:18:59 2000
|
||||
@@ -9,6 +9,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
12
net-mgmt/net-snmp-devel/files/patch-an
Normal file
12
net-mgmt/net-snmp-devel/files/patch-an
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/memory_freebsd2.c~ Tue Mar 14 06:27:00 2000
|
||||
+++ agent/mibgroup/ucd-snmp/memory_freebsd2.c Wed May 17 11:19:23 2000
|
||||
@@ -10,6 +10,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
|
@ -14,7 +14,7 @@ MASTER_SITES= ftp://ucd-snmp.ucdavis.edu/ \
|
|||
|
||||
MAINTAINER= billf@FreeBSD.org
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_AUTOCONF= YES
|
||||
CONFIGURE_ARGS+= --enable-shared
|
||||
.if defined(BATCH)
|
||||
CONFIGURE_ARGS+= --with-defaults --with-sys-contact=nobody@no.where
|
||||
|
@ -71,5 +71,4 @@ post-install:
|
|||
fi
|
||||
${SETENV} OBJFORMAT="${PORTOBJFORMAT}" ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
29
net-mgmt/net-snmp/files/patch-al
Normal file
29
net-mgmt/net-snmp/files/patch-al
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- configure.in~ Sat May 6 01:46:26 2000
|
||||
+++ configure.in Wed May 17 11:09:08 2000
|
||||
@@ -1286,6 +1286,26 @@
|
||||
AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
|
||||
[
|
||||
|
||||
+dnl 4.4 compatible but renamed on FreeBSD
|
||||
+AC_TRY_COMPILE([
|
||||
+#include <sys/types.h>
|
||||
+#define KERNEL
|
||||
+#define _KERNEL
|
||||
+#include <sys/socket.h>
|
||||
+#undef KERNEL
|
||||
+#undef _KERNEL
|
||||
+#include <net/route.h>
|
||||
+],[
|
||||
+
|
||||
+#ifndef STRUCT_RTENTRY_HAS_RT_DST
|
||||
+#define rt_dst rt_nodes->rn_key
|
||||
+#endif
|
||||
+
|
||||
+ struct rtentry rt;
|
||||
+ rt.rt_nodes[0].rn_bit = 1;
|
||||
+ rt.rt_dst;
|
||||
+ ], ac_cv_RTENTRY_TYPE="BSD-4.4")
|
||||
+
|
||||
dnl 4.4 compat
|
||||
AC_TRY_COMPILE([
|
||||
#include <sys/types.h>
|
12
net-mgmt/net-snmp/files/patch-am
Normal file
12
net-mgmt/net-snmp/files/patch-am
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/vmstat_freebsd2.c~ Sat Dec 18 08:41:14 1999
|
||||
+++ agent/mibgroup/ucd-snmp/vmstat_freebsd2.c Wed May 17 11:18:59 2000
|
||||
@@ -9,6 +9,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
12
net-mgmt/net-snmp/files/patch-an
Normal file
12
net-mgmt/net-snmp/files/patch-an
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/memory_freebsd2.c~ Tue Mar 14 06:27:00 2000
|
||||
+++ agent/mibgroup/ucd-snmp/memory_freebsd2.c Wed May 17 11:19:23 2000
|
||||
@@ -10,6 +10,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
|
@ -14,7 +14,7 @@ MASTER_SITES= ftp://ucd-snmp.ucdavis.edu/ \
|
|||
|
||||
MAINTAINER= billf@FreeBSD.org
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_AUTOCONF= YES
|
||||
CONFIGURE_ARGS+= --enable-shared
|
||||
.if defined(BATCH)
|
||||
CONFIGURE_ARGS+= --with-defaults --with-sys-contact=nobody@no.where
|
||||
|
@ -71,5 +71,4 @@ post-install:
|
|||
fi
|
||||
${SETENV} OBJFORMAT="${PORTOBJFORMAT}" ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
29
net-mgmt/net-snmp4/files/patch-al
Normal file
29
net-mgmt/net-snmp4/files/patch-al
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- configure.in~ Sat May 6 01:46:26 2000
|
||||
+++ configure.in Wed May 17 11:09:08 2000
|
||||
@@ -1286,6 +1286,26 @@
|
||||
AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
|
||||
[
|
||||
|
||||
+dnl 4.4 compatible but renamed on FreeBSD
|
||||
+AC_TRY_COMPILE([
|
||||
+#include <sys/types.h>
|
||||
+#define KERNEL
|
||||
+#define _KERNEL
|
||||
+#include <sys/socket.h>
|
||||
+#undef KERNEL
|
||||
+#undef _KERNEL
|
||||
+#include <net/route.h>
|
||||
+],[
|
||||
+
|
||||
+#ifndef STRUCT_RTENTRY_HAS_RT_DST
|
||||
+#define rt_dst rt_nodes->rn_key
|
||||
+#endif
|
||||
+
|
||||
+ struct rtentry rt;
|
||||
+ rt.rt_nodes[0].rn_bit = 1;
|
||||
+ rt.rt_dst;
|
||||
+ ], ac_cv_RTENTRY_TYPE="BSD-4.4")
|
||||
+
|
||||
dnl 4.4 compat
|
||||
AC_TRY_COMPILE([
|
||||
#include <sys/types.h>
|
12
net-mgmt/net-snmp4/files/patch-am
Normal file
12
net-mgmt/net-snmp4/files/patch-am
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/vmstat_freebsd2.c~ Sat Dec 18 08:41:14 1999
|
||||
+++ agent/mibgroup/ucd-snmp/vmstat_freebsd2.c Wed May 17 11:18:59 2000
|
||||
@@ -9,6 +9,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
12
net-mgmt/net-snmp4/files/patch-an
Normal file
12
net-mgmt/net-snmp4/files/patch-an
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/memory_freebsd2.c~ Tue Mar 14 06:27:00 2000
|
||||
+++ agent/mibgroup/ucd-snmp/memory_freebsd2.c Wed May 17 11:19:23 2000
|
||||
@@ -10,6 +10,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
|
@ -14,7 +14,7 @@ MASTER_SITES= ftp://ucd-snmp.ucdavis.edu/ \
|
|||
|
||||
MAINTAINER= billf@FreeBSD.org
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_AUTOCONF= YES
|
||||
CONFIGURE_ARGS+= --enable-shared
|
||||
.if defined(BATCH)
|
||||
CONFIGURE_ARGS+= --with-defaults --with-sys-contact=nobody@no.where
|
||||
|
@ -71,5 +71,4 @@ post-install:
|
|||
fi
|
||||
${SETENV} OBJFORMAT="${PORTOBJFORMAT}" ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
29
net-mgmt/net-snmp53/files/patch-al
Normal file
29
net-mgmt/net-snmp53/files/patch-al
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- configure.in~ Sat May 6 01:46:26 2000
|
||||
+++ configure.in Wed May 17 11:09:08 2000
|
||||
@@ -1286,6 +1286,26 @@
|
||||
AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
|
||||
[
|
||||
|
||||
+dnl 4.4 compatible but renamed on FreeBSD
|
||||
+AC_TRY_COMPILE([
|
||||
+#include <sys/types.h>
|
||||
+#define KERNEL
|
||||
+#define _KERNEL
|
||||
+#include <sys/socket.h>
|
||||
+#undef KERNEL
|
||||
+#undef _KERNEL
|
||||
+#include <net/route.h>
|
||||
+],[
|
||||
+
|
||||
+#ifndef STRUCT_RTENTRY_HAS_RT_DST
|
||||
+#define rt_dst rt_nodes->rn_key
|
||||
+#endif
|
||||
+
|
||||
+ struct rtentry rt;
|
||||
+ rt.rt_nodes[0].rn_bit = 1;
|
||||
+ rt.rt_dst;
|
||||
+ ], ac_cv_RTENTRY_TYPE="BSD-4.4")
|
||||
+
|
||||
dnl 4.4 compat
|
||||
AC_TRY_COMPILE([
|
||||
#include <sys/types.h>
|
12
net-mgmt/net-snmp53/files/patch-am
Normal file
12
net-mgmt/net-snmp53/files/patch-am
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/vmstat_freebsd2.c~ Sat Dec 18 08:41:14 1999
|
||||
+++ agent/mibgroup/ucd-snmp/vmstat_freebsd2.c Wed May 17 11:18:59 2000
|
||||
@@ -9,6 +9,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
12
net-mgmt/net-snmp53/files/patch-an
Normal file
12
net-mgmt/net-snmp53/files/patch-an
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/memory_freebsd2.c~ Tue Mar 14 06:27:00 2000
|
||||
+++ agent/mibgroup/ucd-snmp/memory_freebsd2.c Wed May 17 11:19:23 2000
|
||||
@@ -10,6 +10,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
|
@ -14,7 +14,7 @@ MASTER_SITES= ftp://ucd-snmp.ucdavis.edu/ \
|
|||
|
||||
MAINTAINER= billf@FreeBSD.org
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_AUTOCONF= YES
|
||||
CONFIGURE_ARGS+= --enable-shared
|
||||
.if defined(BATCH)
|
||||
CONFIGURE_ARGS+= --with-defaults --with-sys-contact=nobody@no.where
|
||||
|
@ -71,5 +71,4 @@ post-install:
|
|||
fi
|
||||
${SETENV} OBJFORMAT="${PORTOBJFORMAT}" ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
29
net/net-snmp/files/patch-al
Normal file
29
net/net-snmp/files/patch-al
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- configure.in~ Sat May 6 01:46:26 2000
|
||||
+++ configure.in Wed May 17 11:09:08 2000
|
||||
@@ -1286,6 +1286,26 @@
|
||||
AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
|
||||
[
|
||||
|
||||
+dnl 4.4 compatible but renamed on FreeBSD
|
||||
+AC_TRY_COMPILE([
|
||||
+#include <sys/types.h>
|
||||
+#define KERNEL
|
||||
+#define _KERNEL
|
||||
+#include <sys/socket.h>
|
||||
+#undef KERNEL
|
||||
+#undef _KERNEL
|
||||
+#include <net/route.h>
|
||||
+],[
|
||||
+
|
||||
+#ifndef STRUCT_RTENTRY_HAS_RT_DST
|
||||
+#define rt_dst rt_nodes->rn_key
|
||||
+#endif
|
||||
+
|
||||
+ struct rtentry rt;
|
||||
+ rt.rt_nodes[0].rn_bit = 1;
|
||||
+ rt.rt_dst;
|
||||
+ ], ac_cv_RTENTRY_TYPE="BSD-4.4")
|
||||
+
|
||||
dnl 4.4 compat
|
||||
AC_TRY_COMPILE([
|
||||
#include <sys/types.h>
|
12
net/net-snmp/files/patch-am
Normal file
12
net/net-snmp/files/patch-am
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/vmstat_freebsd2.c~ Sat Dec 18 08:41:14 1999
|
||||
+++ agent/mibgroup/ucd-snmp/vmstat_freebsd2.c Wed May 17 11:18:59 2000
|
||||
@@ -9,6 +9,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
12
net/net-snmp/files/patch-an
Normal file
12
net/net-snmp/files/patch-an
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/memory_freebsd2.c~ Tue Mar 14 06:27:00 2000
|
||||
+++ agent/mibgroup/ucd-snmp/memory_freebsd2.c Wed May 17 11:19:23 2000
|
||||
@@ -10,6 +10,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
|
@ -14,7 +14,7 @@ MASTER_SITES= ftp://ucd-snmp.ucdavis.edu/ \
|
|||
|
||||
MAINTAINER= billf@FreeBSD.org
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_AUTOCONF= YES
|
||||
CONFIGURE_ARGS+= --enable-shared
|
||||
.if defined(BATCH)
|
||||
CONFIGURE_ARGS+= --with-defaults --with-sys-contact=nobody@no.where
|
||||
|
@ -71,5 +71,4 @@ post-install:
|
|||
fi
|
||||
${SETENV} OBJFORMAT="${PORTOBJFORMAT}" ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
29
net/net-snmp4/files/patch-al
Normal file
29
net/net-snmp4/files/patch-al
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- configure.in~ Sat May 6 01:46:26 2000
|
||||
+++ configure.in Wed May 17 11:09:08 2000
|
||||
@@ -1286,6 +1286,26 @@
|
||||
AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
|
||||
[
|
||||
|
||||
+dnl 4.4 compatible but renamed on FreeBSD
|
||||
+AC_TRY_COMPILE([
|
||||
+#include <sys/types.h>
|
||||
+#define KERNEL
|
||||
+#define _KERNEL
|
||||
+#include <sys/socket.h>
|
||||
+#undef KERNEL
|
||||
+#undef _KERNEL
|
||||
+#include <net/route.h>
|
||||
+],[
|
||||
+
|
||||
+#ifndef STRUCT_RTENTRY_HAS_RT_DST
|
||||
+#define rt_dst rt_nodes->rn_key
|
||||
+#endif
|
||||
+
|
||||
+ struct rtentry rt;
|
||||
+ rt.rt_nodes[0].rn_bit = 1;
|
||||
+ rt.rt_dst;
|
||||
+ ], ac_cv_RTENTRY_TYPE="BSD-4.4")
|
||||
+
|
||||
dnl 4.4 compat
|
||||
AC_TRY_COMPILE([
|
||||
#include <sys/types.h>
|
12
net/net-snmp4/files/patch-am
Normal file
12
net/net-snmp4/files/patch-am
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/vmstat_freebsd2.c~ Sat Dec 18 08:41:14 1999
|
||||
+++ agent/mibgroup/ucd-snmp/vmstat_freebsd2.c Wed May 17 11:18:59 2000
|
||||
@@ -9,6 +9,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
12
net/net-snmp4/files/patch-an
Normal file
12
net/net-snmp4/files/patch-an
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/memory_freebsd2.c~ Tue Mar 14 06:27:00 2000
|
||||
+++ agent/mibgroup/ucd-snmp/memory_freebsd2.c Wed May 17 11:19:23 2000
|
||||
@@ -10,6 +10,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
|
@ -14,7 +14,7 @@ MASTER_SITES= ftp://ucd-snmp.ucdavis.edu/ \
|
|||
|
||||
MAINTAINER= billf@FreeBSD.org
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_AUTOCONF= YES
|
||||
CONFIGURE_ARGS+= --enable-shared
|
||||
.if defined(BATCH)
|
||||
CONFIGURE_ARGS+= --with-defaults --with-sys-contact=nobody@no.where
|
||||
|
@ -71,5 +71,4 @@ post-install:
|
|||
fi
|
||||
${SETENV} OBJFORMAT="${PORTOBJFORMAT}" ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
29
net/ucd-snmp/files/patch-al
Normal file
29
net/ucd-snmp/files/patch-al
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- configure.in~ Sat May 6 01:46:26 2000
|
||||
+++ configure.in Wed May 17 11:09:08 2000
|
||||
@@ -1286,6 +1286,26 @@
|
||||
AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
|
||||
[
|
||||
|
||||
+dnl 4.4 compatible but renamed on FreeBSD
|
||||
+AC_TRY_COMPILE([
|
||||
+#include <sys/types.h>
|
||||
+#define KERNEL
|
||||
+#define _KERNEL
|
||||
+#include <sys/socket.h>
|
||||
+#undef KERNEL
|
||||
+#undef _KERNEL
|
||||
+#include <net/route.h>
|
||||
+],[
|
||||
+
|
||||
+#ifndef STRUCT_RTENTRY_HAS_RT_DST
|
||||
+#define rt_dst rt_nodes->rn_key
|
||||
+#endif
|
||||
+
|
||||
+ struct rtentry rt;
|
||||
+ rt.rt_nodes[0].rn_bit = 1;
|
||||
+ rt.rt_dst;
|
||||
+ ], ac_cv_RTENTRY_TYPE="BSD-4.4")
|
||||
+
|
||||
dnl 4.4 compat
|
||||
AC_TRY_COMPILE([
|
||||
#include <sys/types.h>
|
12
net/ucd-snmp/files/patch-am
Normal file
12
net/ucd-snmp/files/patch-am
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/vmstat_freebsd2.c~ Sat Dec 18 08:41:14 1999
|
||||
+++ agent/mibgroup/ucd-snmp/vmstat_freebsd2.c Wed May 17 11:18:59 2000
|
||||
@@ -9,6 +9,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
12
net/ucd-snmp/files/patch-an
Normal file
12
net/ucd-snmp/files/patch-an
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- agent/mibgroup/ucd-snmp/memory_freebsd2.c~ Tue Mar 14 06:27:00 2000
|
||||
+++ agent/mibgroup/ucd-snmp/memory_freebsd2.c Wed May 17 11:19:23 2000
|
||||
@@ -10,6 +10,9 @@
|
||||
#include <sys/time.h>
|
||||
#include <sys/proc.h>
|
||||
#include <sys/dkstat.h>
|
||||
+#ifdef freebsd5
|
||||
+#include <sys/bio.h>
|
||||
+#endif
|
||||
#include <sys/buf.h>
|
||||
#include <sys/uio.h>
|
||||
#include <sys/namei.h>
|
Loading…
Reference in a new issue