Update to 3.3.0 release.
This commit is contained in:
parent
070cb2804d
commit
9849983627
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=114857
4 changed files with 20 additions and 35 deletions
|
@ -6,20 +6,25 @@
|
|||
#
|
||||
|
||||
PORTNAME= motor
|
||||
PORTVERSION= 3.2.4
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 3.3.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://konst.org.ua/download/
|
||||
|
||||
MAINTAINER= ale@FreeBSD.org
|
||||
COMMENT= A powerful text mode based programming IDE
|
||||
|
||||
USE_GETTEXT= yes
|
||||
USE_GMAKE= yes
|
||||
USE_ICONV= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -lintl"
|
||||
USE_REINPLACE= yes
|
||||
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}
|
||||
.if !defined(WITHOUT_NLS)
|
||||
USE_GETTEXT= yes
|
||||
CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE}
|
||||
PLIST_SUB= NLS=""
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-nls
|
||||
PLIST_SUB= NLS="@comment "
|
||||
.endif
|
||||
|
||||
MAN1= motor.1
|
||||
|
||||
|
@ -29,12 +34,6 @@ MAN1= motor.1
|
|||
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/_G_config.h/d' \
|
||||
${WRKSRC}/kkstrtext/conf.h \
|
||||
${WRKSRC}/kksystr/include/conf.h \
|
||||
${WRKSRC}/kkconsui/include/conf.h
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
post-install:
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (motor-3.2.4.tar.gz) = cb24eba00be62ff3fab2a1a4c03e1cb3
|
||||
SIZE (motor-3.2.4.tar.gz) = 473412
|
||||
MD5 (motor-3.3.0.tar.gz) = 257d63a33c511266ae0ff56c4274af76
|
||||
SIZE (motor-3.3.0.tar.gz) = 570704
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/debugger/Makefile.in 2002/05/16 10:52:11 1.1
|
||||
+++ src/debugger/Makefile.in 2002/05/16 10:52:28
|
||||
@@ -108,7 +108,7 @@
|
||||
libdebugger_a_OBJECTS = breakpoint.o debuggercommand.o \
|
||||
debuggermessage.o watch.o motordebugger.o stackitem.o
|
||||
AR = ar
|
||||
-CXXFLAGS = @CXXFLAGS@
|
||||
+CXXFLAGS = @CXXFLAGS@ -fpermissive
|
||||
CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
|
||||
CXXLD = $(CXX)
|
||||
CXXLINK = $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@
|
|
@ -1,9 +1,9 @@
|
|||
bin/motor
|
||||
bin/motorsync
|
||||
share/locale/de/LC_MESSAGES/motor.mo
|
||||
share/locale/pl/LC_MESSAGES/motor.mo
|
||||
share/locale/ru/LC_MESSAGES/motor.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/motor.mo
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/motor.mo
|
||||
%%NLS%%share/locale/pl/LC_MESSAGES/motor.mo
|
||||
%%NLS%%share/locale/ru/LC_MESSAGES/motor.mo
|
||||
%%NLS%%share/locale/zh_CN/LC_MESSAGES/motor.mo
|
||||
share/motor/CVS.vcsrc
|
||||
share/motor/external
|
||||
share/motor/syntax
|
||||
|
@ -56,6 +56,6 @@ share/motor/themes
|
|||
@dirrm share/motor/templates/library
|
||||
@dirrm share/motor/templates
|
||||
@dirrm share/motor
|
||||
%%PORTDOCS%%share/doc/motor/FAQ
|
||||
%%PORTDOCS%%share/doc/motor/README
|
||||
%%PORTDOCS%%@dirrm share/doc/motor
|
||||
%%PORTDOCS%%%%DOCSDIR%%/FAQ
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/
|
||||
|
|
Loading…
Reference in a new issue