x11/deforaos-keyboard: allow staging
- Allow staging - Bump port revision for libdesktop update - Convert lib depends to new format PR: ports/183633 Submitted by: Olivier Cochard-Labbe <olivier cochard.me> (maintainer)
This commit is contained in:
parent
57734edbdb
commit
986bc82e69
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=332765
3 changed files with 16 additions and 5 deletions
|
@ -3,23 +3,22 @@
|
|||
|
||||
PORTNAME= keyboard
|
||||
PORTVERSION= 0.2.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://www.defora.org/os/download/download/3696/
|
||||
DISTNAME= Keyboard-${PORTVERSION}
|
||||
PKGNAMEPREFIX= deforaos-
|
||||
DISTNAME= Keyboard-${PORTVERSION}
|
||||
|
||||
MAINTAINER= olivier@cochard.me
|
||||
COMMENT= DeforaOS desktop virtual keyboardr
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
LIB_DEPENDS= Desktop:${PORTSDIR}/x11/deforaos-libdesktop
|
||||
LIB_DEPENDS= libDesktop.so:${PORTSDIR}/x11/deforaos-libdesktop
|
||||
|
||||
USE_GNOME= gtk20
|
||||
USES= pkgconfig gettext
|
||||
USES= desktop-file-utils gettext pkgconfig
|
||||
USE_XORG= xtst
|
||||
MAKE_ARGS+= PREFIX=${PREFIX}
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.mk>
|
||||
|
|
11
x11/deforaos-keyboard/files/patch-keyboard.c.diff
Normal file
11
x11/deforaos-keyboard/files/patch-keyboard.c.diff
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/keyboard.c.orig 2013-10-30 12:04:38.512854430 +0100
|
||||
+++ src/keyboard.c 2013-10-30 12:04:53.198851447 +0100
|
||||
@@ -437,7 +437,7 @@
|
||||
keyboard_set_layout(keyboard, KLS_LETTERS);
|
||||
pango_font_description_free(bold);
|
||||
/* messages */
|
||||
- desktop_message_register(KEYBOARD_CLIENT_MESSAGE, on_keyboard_message,
|
||||
+ desktop_message_register(keyboard->window,KEYBOARD_CLIENT_MESSAGE, on_keyboard_message,
|
||||
keyboard);
|
||||
return keyboard;
|
||||
}
|
|
@ -3,3 +3,4 @@ bin/keyboard
|
|||
include/Desktop/Keyboard.h
|
||||
share/applications/keyboard.desktop
|
||||
share/locale/fr/LC_MESSAGES/Keyboard.mo
|
||||
@dirrm include/Desktop
|
||||
|
|
Loading…
Reference in a new issue