- Update to 0.3.14
- Take maintainship
This commit is contained in:
parent
d0383e1ee9
commit
98b78d20b0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=214176
4 changed files with 29 additions and 10 deletions
|
@ -1,3 +1,4 @@
|
|||
# ex: ts=8
|
||||
# New ports collection makefile for: dclib
|
||||
# Date created: Wed 10 Jul 2002
|
||||
# Whom: Sverrir Valgeirsson <e96sv@yahoo.se> and
|
||||
|
@ -7,10 +8,11 @@
|
|||
#
|
||||
|
||||
PORTNAME= dclib
|
||||
PORTVERSION= 0.3.13
|
||||
PORTVERSION= 0.3.14
|
||||
CATEGORIES= net-p2p
|
||||
MASTER_SITES= SF
|
||||
MASTER_SITE_SUBDIR= wxdcgui
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}a
|
||||
|
||||
MAINTAINER= gahr@FreeBSD.org
|
||||
COMMENT= Direct connect interface library for valknut
|
||||
|
@ -18,6 +20,8 @@ COMMENT= Direct connect interface library for valknut
|
|||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
xml2.5:${PORTSDIR}/textproc/libxml2
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
@ -25,10 +29,15 @@ USE_OPENSSL= yes
|
|||
USE_LDCONFIG= yes
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
post-extract:
|
||||
${CHMOD} 0755 ${WRKSRC}/admin/install-sh
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's/-O2//g; s/-pedantic //g' \
|
||||
${REINPLACE_CMD} -e 's/-O2//g; s/-pedantic //g' \
|
||||
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
@${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
|
||||
${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
|
||||
${WRKSRC}/Makefile.in
|
||||
${FIND} ${WRKSRC} -name "Makefile.*" | ${XARGS} \
|
||||
${REINPLACE_CMD} -e 's|dclib-0.3/||g'
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (dclib-0.3.13.tar.bz2) = d0802777ab7555309debd64f71397faf
|
||||
SHA256 (dclib-0.3.13.tar.bz2) = 47653f4672e266f0ee963b2ef728874dcce6e26be30d14774b4cfa1250d260ea
|
||||
SIZE (dclib-0.3.13.tar.bz2) = 644180
|
||||
MD5 (dclib-0.3.14a.tar.bz2) = efdaab61c2b3af95aef381392d580f16
|
||||
SHA256 (dclib-0.3.14a.tar.bz2) = 48839c77bc00842350dc1d5bebb28d10dcf8a9e2fa02084919aeb6b54e14e5a1
|
||||
SIZE (dclib-0.3.14a.tar.bz2) = 563006
|
||||
|
|
11
net-p2p/dclib/files/patch-dclib-core_ciconv.cpp
Normal file
11
net-p2p/dclib/files/patch-dclib-core_ciconv.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- dclib/core/ciconv.cpp.orig 2008-06-02 12:58:22.000000000 +0200
|
||||
+++ dclib/core/ciconv.cpp 2008-06-02 12:59:00.000000000 +0200
|
||||
@@ -20,7 +20,7 @@
|
||||
#endif
|
||||
|
||||
#ifndef ICONV_CONST
|
||||
-#define ICONV_CONST
|
||||
+#define ICONV_CONST const
|
||||
#endif
|
||||
|
||||
#include <stdio.h>
|
|
@ -6,6 +6,7 @@ include/dclib/cdcproto.h
|
|||
include/dclib/cdownloadmanager.h
|
||||
include/dclib/cdownloadqueue.h
|
||||
include/dclib/cencrypt.h
|
||||
include/dclib/cfilehasher.h
|
||||
include/dclib/cfilemanager.h
|
||||
include/dclib/chttp.h
|
||||
include/dclib/chublistmanager.h
|
||||
|
@ -26,7 +27,6 @@ include/dclib/core/clist.h
|
|||
include/dclib/core/clisten.h
|
||||
include/dclib/core/clogfile.h
|
||||
include/dclib/core/cmanager.h
|
||||
include/dclib/core/cmd5.h
|
||||
include/dclib/core/cobject.h
|
||||
include/dclib/core/cplugin.h
|
||||
include/dclib/core/csingleton.h
|
||||
|
@ -49,6 +49,7 @@ include/dclib/csharelist.h
|
|||
include/dclib/ctransfer.h
|
||||
include/dclib/cuserlist.h
|
||||
include/dclib/cutils.h
|
||||
include/dclib/dclib-ssl-use.h
|
||||
include/dclib/dclib.h
|
||||
include/dclib/dcobject.h
|
||||
include/dclib/dcos.h
|
||||
|
@ -62,8 +63,6 @@ lib/libdc.la
|
|||
lib/libdc.so
|
||||
lib/libdc.so.0
|
||||
libdata/pkgconfig/dclib.pc
|
||||
@dirrm share/dclib/plugin
|
||||
@dirrm share/dclib
|
||||
@dirrm include/dclib/hash
|
||||
@dirrm include/dclib/core
|
||||
@dirrm include/dclib/hash
|
||||
@dirrm include/dclib
|
||||
|
|
Loading…
Reference in a new issue