New port: didentd

This is a new port for didentd, an RfC1423 (identd) server for FreeBSD and
Linux written with security and privacy in mind.

PR: ports/31349
Submitted by: D. T. Tzeck <drt@un.brewaff.net>
This commit is contained in:
Clive Lin 2001-10-20 14:32:35 +00:00
parent e1b6983dda
commit 99436422e8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48994
6 changed files with 105 additions and 0 deletions

36
security/didentd/Makefile Normal file
View file

@ -0,0 +1,36 @@
# New ports collection makefile for: publicfile
# Date created: 15 Oct 2001
# Whom: Doobee R. Tzeck
#
# $FreeBSD$
#
PORTNAME= didentd
PORTVERSION= 0.2
CATEGORIES= security
MASTER_SITES= http://untergrund.bewaff.net/~drt/c0re.jp/c0de/didentd/ http://c0re.jp/c0de/didentd/
MAINTAINER= drt@un.bewaff.net
RUN_DEPENDS= tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
ALL_TARGET= all
INSTALL_TARGET= install
post-patch:
${PERL} -pi -e 's,%%LOCALBASE%%,${LOCALBASE},g' ${WRKSRC}/Makefile
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/didentd
${INSTALL_MAN} ${WRKSRC}/BLURB ${PREFIX}/share/doc/didentd
${INSTALL_MAN} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/didentd
${INSTALL_MAN} ${WRKSRC}/INTERNALS ${PREFIX}/share/doc/didentd
${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/didentd
${INSTALL_MAN} ${WRKSRC}/THANKS ${PREFIX}/share/doc/didentd
${INSTALL_MAN} ${WRKSRC}/TODO ${PREFIX}/share/doc/didentd
${INSTALL_MAN} ${WRKSRC}/WHY-ENCRYPT ${PREFIX}/share/doc/didentd
${INSTALL_MAN} ${WRKSRC}/WHY-TAP ${PREFIX}/share/doc/didentd
.endif
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (didentd-0.2.tar.gz) = 57dcf69b4a3dce6324e14aa29938ba13

View file

@ -0,0 +1,26 @@
--- Makefile.orig Sun Oct 14 13:58:33 2001
+++ Makefile Sat Oct 20 22:24:04 2001
@@ -2,7 +2,7 @@
PROGS = didentd didentd-decrypt didentd-name didentd-static didentd-conf didentd-name-conf didentd-static-conf
-CFLAGS = -g -Wall -Idjblib
+CFLAGS = -Wall -Idjblib
all: djblib.a $(PROGS)
@@ -64,10 +64,10 @@
ranlib djblib.a
install: $(PROGS)
- install -m 755 -s didentd didentd-name didentd-static /usr/local/bin
- install -m 755 -s didentd-conf didentd-name-conf didentd-static-conf /usr/local/bin
- install -m 755 -s didentd-decrypt /usr/local/bin
- install -m 644 didentd.8 didentd-name.8 didentd-decrypt.8 /usr/local/man/man8
+ install -m 755 -s didentd didentd-name didentd-static %%LOCALBASE%%/bin
+ install -m 755 -s didentd-conf didentd-name-conf didentd-static-conf %%LOCALBASE%%/bin
+ install -m 755 -s didentd-decrypt %%LOCALBASE%%/bin
+ install -m 644 didentd.8 didentd-name.8 didentd-decrypt.8 %%LOCALBASE%%/man/man8
clean:
rm -f $(PROGS) *.o

View file

@ -0,0 +1 @@
Modular RfC1423 (identd) server sending encrypted audit tokens.

View file

@ -0,0 +1,22 @@
didentd is a modular RfC1423 (identd) server for FreeBSD and Linux written
with security in mind. The Server normally runs chrooted under /proc/net on
an unprivileged id.
Normally didentd does not send an username but an encrypted audit token to
the client. This token contains all information about the requested
connection: userid owning the connection, source ip:port, destination ip:port,
a timestamp.
If a remote admin has a complaint about something from your machine he can
send this audit token back to you, you can pipe it through didentd-decrypt
and find out which user did the connection. didentd-decrypt outputs all the
information from the audit token. So you can have the benefit of ident
without revealing internal information from your system.
There is also didentd-name which is a server returning the username of the
uid owning the requested connection. This is the classic ident approach.
didentd-static is a server which delivers a fixed reply defined by the
administrator to every request.
WWW: http://c0re.jp/c0de/didentd/

View file

@ -0,0 +1,19 @@
bin/didentd
bin/didentd-name
bin/didentd-static
bin/didentd-conf
bin/didentd-name-conf
bin/didentd-static-conf
bin/didentd-decrypt
man/man8/didentd.8
man/man8/didentd-name.8
man/man8/didentd-decrypt.8
%%PORTDOCS%%share/doc/didentd/BLURB
%%PORTDOCS%%share/doc/didentd/INSTALL
%%PORTDOCS%%share/doc/didentd/INTERNALS
%%PORTDOCS%%share/doc/didentd/README
%%PORTDOCS%%share/doc/didentd/THANKS
%%PORTDOCS%%share/doc/didentd/TODO
%%PORTDOCS%%share/doc/didentd/WHY-ENCRYPT
%%PORTDOCS%%share/doc/didentd/WHY-TAP
%%PORTDOCS%%@dirrm share/doc/didentd