New port
"libvmime is a MIME manipulation library." PR: ports/86300 Submitted by: Xin LI <delphij@freebsd.org> Approved by: pav (mentor)
This commit is contained in:
parent
1faaed765a
commit
9984aa2815
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=143205
7 changed files with 232 additions and 0 deletions
|
@ -160,6 +160,7 @@
|
|||
SUBDIR += libspf2-10
|
||||
SUBDIR += libsrs
|
||||
SUBDIR += libsrs2
|
||||
SUBDIR += libvmime
|
||||
SUBDIR += listmanager
|
||||
SUBDIR += lmtp2nntp
|
||||
SUBDIR += lmtpd
|
||||
|
|
29
mail/libvmime/Makefile
Normal file
29
mail/libvmime/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# New ports collection makefile for: libvmime
|
||||
# Date created: September 17, 2005
|
||||
# Whom: delphij@FreeBSD.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libvmime
|
||||
PORTVERSION= 0.7.1
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= vmime
|
||||
|
||||
MAINTAINER= delphij@FreeBSD.org
|
||||
COMMENT= An all-in-one Internet mail library
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_ICONV= yes
|
||||
USE_GCC= 3.3+
|
||||
USE_LIBTOOL_VER=15
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
CONFIGURE_ARGS= --disable-debug
|
||||
|
||||
DOCSDIR= ${PREFIX}/share/doc/vmime
|
||||
|
||||
.include <bsd.port.mk>
|
2
mail/libvmime/distinfo
Normal file
2
mail/libvmime/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (libvmime-0.7.1.tar.bz2) = 81f06a771d2de01d5982635838eb5f6a
|
||||
SIZE (libvmime-0.7.1.tar.bz2) = 418302
|
11
mail/libvmime/files/patch-Makefile.in
Normal file
11
mail/libvmime/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.in.orig Sun Sep 18 22:07:16 2005
|
||||
+++ Makefile.in Sun Sep 18 22:08:38 2005
|
||||
@@ -206,7 +206,7 @@
|
||||
|
||||
#AUTOMAKE_OPTIONS = dist-bzip2
|
||||
AUTOMAKE_OPTIONS = no-dist
|
||||
-pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfigdir = $(prefix)/libdata/pkgconfig
|
||||
pkgconfig_DATA = $(GENERIC_VERSIONED_LIBRARY_NAME).pc
|
||||
EXTRA_DIST = SConstruct bootstrap
|
||||
doc_DATA = AUTHORS ChangeLog COPYING INSTALL NEWS README
|
36
mail/libvmime/files/patch-src__Makefile.in
Normal file
36
mail/libvmime/files/patch-src__Makefile.in
Normal file
|
@ -0,0 +1,36 @@
|
|||
--- src/Makefile.in.orig Tue Jun 21 19:11:35 2005
|
||||
+++ src/Makefile.in Mon Sep 19 12:28:03 2005
|
||||
@@ -212,11 +212,11 @@
|
||||
am__depfiles_maybe =
|
||||
CXXCOMPILE = $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
|
||||
$(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
|
||||
-LTCXXCOMPILE = $(LIBTOOL) --mode=compile $(CXX) $(DEFS) \
|
||||
+LTCXXCOMPILE = $(LIBTOOL) --tag=CXX --mode=compile $(CXX) $(DEFS) \
|
||||
$(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
|
||||
$(AM_CXXFLAGS) $(CXXFLAGS)
|
||||
CXXLD = $(CXX)
|
||||
-CXXLINK = $(LIBTOOL) --mode=link $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) \
|
||||
+CXXLINK = $(LIBTOOL) --tag=CXX --mode=link $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) \
|
||||
$(AM_LDFLAGS) $(LDFLAGS) -o $@
|
||||
SOURCES = $(libvmime_la_SOURCES)
|
||||
DIST_SOURCES = $(am__libvmime_la_SOURCES_DIST)
|
||||
@@ -356,7 +356,7 @@
|
||||
target_vendor = @target_vendor@
|
||||
AUTOMAKE_OPTIONS = no-dependencies foreign
|
||||
INTERNALS =
|
||||
-INCLUDES = -I$(top_srcdir) -I$(srcdir) @PKGCONFIG_CFLAGS@ @EXTRA_CFLAGS@
|
||||
+INCLUDES = -I$(prefix)/include -I$(top_srcdir) -I$(srcdir) @PKGCONFIG_CFLAGS@ @EXTRA_CFLAGS@
|
||||
lib_LTLIBRARIES = libvmime.la
|
||||
libvmime_la_LDFLAGS = -export-dynamic -version-info @LIBRARY_VERSION@ @PKGCONFIG_LIBS@ @EXTRA_LIBS@
|
||||
libvmime_la_SOURCES = address.cpp \
|
||||
@@ -473,8 +473,8 @@
|
||||
@list='$(lib_LTLIBRARIES)'; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
f="`echo $$p | sed -e 's|^.*/||'`"; \
|
||||
- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
|
||||
- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(libdir)/$$f"; \
|
||||
+ echo " $(LIBTOOL) --tag=CXX --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
|
||||
+ $(LIBTOOL) --tag=CXX --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(libdir)/$$f"; \
|
||||
else :; fi; \
|
||||
done
|
||||
|
3
mail/libvmime/pkg-descr
Normal file
3
mail/libvmime/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
libvmime is a MIME manipulation library.
|
||||
|
||||
WWW: http://www.vmime.org
|
150
mail/libvmime/pkg-plist
Normal file
150
mail/libvmime/pkg-plist
Normal file
|
@ -0,0 +1,150 @@
|
|||
include/vmime/address.hpp
|
||||
include/vmime/addressList.hpp
|
||||
include/vmime/attachment.hpp
|
||||
include/vmime/base.hpp
|
||||
include/vmime/body.hpp
|
||||
include/vmime/bodyPart.hpp
|
||||
include/vmime/charset.hpp
|
||||
include/vmime/component.hpp
|
||||
include/vmime/config.hpp
|
||||
include/vmime/constants.hpp
|
||||
include/vmime/contentDisposition.hpp
|
||||
include/vmime/contentDispositionField.hpp
|
||||
include/vmime/contentHandler.hpp
|
||||
include/vmime/contentTypeField.hpp
|
||||
include/vmime/dateTime.hpp
|
||||
include/vmime/defaultAttachment.hpp
|
||||
include/vmime/defaultParameter.hpp
|
||||
include/vmime/disposition.hpp
|
||||
include/vmime/emptyContentHandler.hpp
|
||||
include/vmime/encoder.hpp
|
||||
include/vmime/encoder7bit.hpp
|
||||
include/vmime/encoder8bit.hpp
|
||||
include/vmime/encoderB64.hpp
|
||||
include/vmime/encoderBinary.hpp
|
||||
include/vmime/encoderDefault.hpp
|
||||
include/vmime/encoderFactory.hpp
|
||||
include/vmime/encoderQP.hpp
|
||||
include/vmime/encoderUUE.hpp
|
||||
include/vmime/encoding.hpp
|
||||
include/vmime/exception.hpp
|
||||
include/vmime/fileAttachment.hpp
|
||||
include/vmime/genericField.hpp
|
||||
include/vmime/genericParameter.hpp
|
||||
include/vmime/header.hpp
|
||||
include/vmime/headerField.hpp
|
||||
include/vmime/headerFieldFactory.hpp
|
||||
include/vmime/htmlTextPart.hpp
|
||||
include/vmime/mailbox.hpp
|
||||
include/vmime/mailboxField.hpp
|
||||
include/vmime/mailboxGroup.hpp
|
||||
include/vmime/mailboxList.hpp
|
||||
include/vmime/mdn/MDNHelper.hpp
|
||||
include/vmime/mdn/MDNInfos.hpp
|
||||
include/vmime/mdn/receivedMDNInfos.hpp
|
||||
include/vmime/mdn/sendableMDNInfos.hpp
|
||||
include/vmime/mediaType.hpp
|
||||
include/vmime/message.hpp
|
||||
include/vmime/messageBuilder.hpp
|
||||
include/vmime/messageId.hpp
|
||||
include/vmime/messageIdSequence.hpp
|
||||
include/vmime/messageParser.hpp
|
||||
include/vmime/messaging/authHelper.hpp
|
||||
include/vmime/messaging/authenticationInfos.hpp
|
||||
include/vmime/messaging/authenticator.hpp
|
||||
include/vmime/messaging/defaultAuthenticator.hpp
|
||||
include/vmime/messaging/events.hpp
|
||||
include/vmime/messaging/folder.hpp
|
||||
include/vmime/messaging/imap/IMAPConnection.hpp
|
||||
include/vmime/messaging/imap/IMAPFolder.hpp
|
||||
include/vmime/messaging/imap/IMAPMessage.hpp
|
||||
include/vmime/messaging/imap/IMAPParser.hpp
|
||||
include/vmime/messaging/imap/IMAPStore.hpp
|
||||
include/vmime/messaging/imap/IMAPTag.hpp
|
||||
include/vmime/messaging/imap/IMAPUtils.hpp
|
||||
include/vmime/messaging/maildir/maildirFolder.hpp
|
||||
include/vmime/messaging/maildir/maildirMessage.hpp
|
||||
include/vmime/messaging/maildir/maildirStore.hpp
|
||||
include/vmime/messaging/maildir/maildirUtils.hpp
|
||||
include/vmime/messaging/message.hpp
|
||||
include/vmime/messaging/pop3/POP3Folder.hpp
|
||||
include/vmime/messaging/pop3/POP3Message.hpp
|
||||
include/vmime/messaging/pop3/POP3Store.hpp
|
||||
include/vmime/messaging/sendmail/sendmailTransport.hpp
|
||||
include/vmime/messaging/service.hpp
|
||||
include/vmime/messaging/serviceFactory.hpp
|
||||
include/vmime/messaging/serviceInfos.hpp
|
||||
include/vmime/messaging/session.hpp
|
||||
include/vmime/messaging/simpleAuthenticator.hpp
|
||||
include/vmime/messaging/smtp/SMTPTransport.hpp
|
||||
include/vmime/messaging/socket.hpp
|
||||
include/vmime/messaging/store.hpp
|
||||
include/vmime/messaging/timeoutHandler.hpp
|
||||
include/vmime/messaging/transport.hpp
|
||||
include/vmime/misc/importanceHelper.hpp
|
||||
include/vmime/options.hpp
|
||||
include/vmime/parameter.hpp
|
||||
include/vmime/parameterFactory.hpp
|
||||
include/vmime/parameterizedHeaderField.hpp
|
||||
include/vmime/parserHelpers.hpp
|
||||
include/vmime/path.hpp
|
||||
include/vmime/plainTextPart.hpp
|
||||
include/vmime/platformDependant.hpp
|
||||
include/vmime/platforms/posix/posixChildProcess.hpp
|
||||
include/vmime/platforms/posix/posixFile.hpp
|
||||
include/vmime/platforms/posix/posixHandler.hpp
|
||||
include/vmime/platforms/posix/posixSocket.hpp
|
||||
include/vmime/platforms/windows/windowsFile.hpp
|
||||
include/vmime/platforms/windows/windowsHandler.hpp
|
||||
include/vmime/platforms/windows/windowsSocket.hpp
|
||||
include/vmime/propertySet.hpp
|
||||
include/vmime/relay.hpp
|
||||
include/vmime/standardFields.hpp
|
||||
include/vmime/standardParams.hpp
|
||||
include/vmime/streamContentHandler.hpp
|
||||
include/vmime/stringContentHandler.hpp
|
||||
include/vmime/text.hpp
|
||||
include/vmime/textPart.hpp
|
||||
include/vmime/textPartFactory.hpp
|
||||
include/vmime/typeAdapter.hpp
|
||||
include/vmime/types.hpp
|
||||
include/vmime/utility/childProcess.hpp
|
||||
include/vmime/utility/datetimeUtils.hpp
|
||||
include/vmime/utility/file.hpp
|
||||
include/vmime/utility/filteredStream.hpp
|
||||
include/vmime/utility/md5.hpp
|
||||
include/vmime/utility/path.hpp
|
||||
include/vmime/utility/progressionListener.hpp
|
||||
include/vmime/utility/random.hpp
|
||||
include/vmime/utility/smartPtr.hpp
|
||||
include/vmime/utility/stream.hpp
|
||||
include/vmime/utility/stringProxy.hpp
|
||||
include/vmime/utility/stringUtils.hpp
|
||||
include/vmime/utility/url.hpp
|
||||
include/vmime/utility/urlUtils.hpp
|
||||
include/vmime/vmime.hpp
|
||||
include/vmime/word.hpp
|
||||
lib/libvmime.a
|
||||
lib/libvmime.so
|
||||
lib/libvmime.so.7
|
||||
libdata/pkgconfig/vmime.pc
|
||||
%%DOCSDIR%%/AUTHORS
|
||||
%%DOCSDIR%%/COPYING
|
||||
%%DOCSDIR%%/ChangeLog
|
||||
%%DOCSDIR%%/INSTALL
|
||||
%%DOCSDIR%%/NEWS
|
||||
%%DOCSDIR%%/README
|
||||
@dirrm %%DOCSDIR%%
|
||||
@dirrm include/vmime/utility
|
||||
@dirrm include/vmime/platforms/windows
|
||||
@dirrm include/vmime/platforms/posix
|
||||
@dirrm include/vmime/platforms
|
||||
@dirrm include/vmime/misc
|
||||
@dirrm include/vmime/messaging/smtp
|
||||
@dirrm include/vmime/messaging/sendmail
|
||||
@dirrm include/vmime/messaging/pop3
|
||||
@dirrm include/vmime/messaging/maildir
|
||||
@dirrm include/vmime/messaging/imap
|
||||
@dirrm include/vmime/messaging
|
||||
@dirrm include/vmime/mdn
|
||||
@dirrm include/vmime
|
Loading…
Reference in a new issue