Relay is a very simple proxy that can be used for building simple firewalls.

telnet, ftp, and finger client rappers are provided.
This commit is contained in:
David E. O'Brien 1998-12-30 04:30:48 +00:00
parent 9002cc6d80
commit 99a4b96b35
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=15721
7 changed files with 76 additions and 0 deletions

28
net/relay/Makefile Normal file
View file

@ -0,0 +1,28 @@
# ex:ts=8
# Ports collection makefile for: relay
# Version required: 1.10
# Date created: Mon Dec 23, 1998
# Whom: David O'Brien (obrien@NUXI.com)
#
# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
#
DISTNAME= relay
PKGNAME= relay-1.10
CATEGORIES= net security
MASTER_SITES= http://www.eleves.ens.fr:8080/home/espel/ \
http://www.freebsd.org/~obrien/Distfiles/
MAINTAINER= obrien@FreeBSD.org
IS_INTERACTIVE= 'must set server hostname in relay.h'
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/relay ${PREFIX}/libexec
@cd ${WRKSRC} ; ${INSTALL_PROGRAM} rtelnet rftp rfinger ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/relay
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/relay
.endif
.include <bsd.port.mk>

1
net/relay/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (relay.tar.gz) = f0bddae0bc594b42a2a56d38305de7f9

13
net/relay/files/patch-01 Normal file
View file

@ -0,0 +1,13 @@
--- relay.c.orig Fri Nov 10 21:18:37 1995
+++ relay.c Sat Dec 26 12:29:01 1998
@@ -51,8 +51,8 @@
char sbuf[16384], cbuf[16384];
struct hostent *myself;
char mynumber[100];
-extern int errno;
-extern char *sys_errlist[];
+/* extern int errno;
+extern char *sys_errlist[]; */
int debug=0;
void sigchld() {

26
net/relay/files/patch-02 Normal file
View file

@ -0,0 +1,26 @@
--- relay.h.orig Wed Oct 25 20:28:45 1995
+++ relay.h Sat Dec 26 12:34:21 1998
@@ -22,7 +22,7 @@
by the clients
*/
-#define FINGER "/usr/ucb/finger"
+#define FINGER "/usr/bin/finger"
/* change this to the name of the finger client on the relay, if it's
something else
*/
@@ -30,12 +30,12 @@
#define SERV_TCP_PORT 19023
/* change this if you don't like this number */
-#define TELNET "/usr/ucb/telnet"
+#define TELNET "/usr/bin/telnet"
/* change this to the name of the telnet client on the client machine if it's
something else
*/
-#define FTP "/usr/local/bin/ftp"
+#define FTP "/usr/bin/ftp"
/* change this to the name of the ftp client on the client machine, if it's
something else
*/

1
net/relay/pkg-comment Normal file
View file

@ -0,0 +1 @@
very simple TCP proxy server + telnet,ftp,finger client rappers.

2
net/relay/pkg-descr Normal file
View file

@ -0,0 +1,2 @@
Relay is a very simple proxy that can be used for building simple firewalls.
telnet, ftp, and finger client rappers are provided.

5
net/relay/pkg-plist Normal file
View file

@ -0,0 +1,5 @@
bin/rtelnet
bin/rfinger
bin/rftp
libexec/relay
share/doc/relay/README