Remove phoenix now that it is mozilla-firebird.

This commit is contained in:
Joe Marcus Clarke 2003-06-02 18:32:07 +00:00
parent ed564c5560
commit 99ba1da147
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82038
9 changed files with 0 additions and 616 deletions

View file

@ -1,165 +0,0 @@
# ex:ts=8 -*-mode: makefile-*-
#
# New ports collection makefile for: phoenix
# Date created: 2002/10/21
# Whom: Alan Eldridge <alane@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= phoenix
PORTVERSION= 0.5
PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_LOCAL} ${BSD_WEBDIR}
MASTER_SITE_SUBDIR= alane
MAINTAINER= gnome@freebsd.org
COMMENT= Phoenix is a fast, low-overhead browser from the Mozilla project
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
freetype.9:${PORTSDIR}/print/freetype2 \
IDL.2:${PORTSDIR}/devel/ORBit \
iconv.3:${PORTSDIR}/converters/libiconv \
nspr4.1:${PORTSDIR}/devel/nspr
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
freetype-config:${PORTSDIR}/print/freetype2
BSD_WEBDIR=http://people.freebsd.org/~${MASTER_SITE_SUBDIR}/
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
USE_REINPLACE= yes
HAS_CONFIGURE= yes
USE_GNOME= gtk12 orbit
NO_MTREE= yes
WRKSRC= ${WRKDIR}/mozilla
LOCAL_SUBDIR= lib/${PORTNAME}
LOCAL_PREFIX= ${PREFIX}/${LOCAL_SUBDIR}
JREDIR= ${LOCALBASE}/jdk1.3.1/jre
MOZVER= 1.3a
PLUGINSDIR= ${LOCAL_PREFIX}/lib/mozilla-${MOZVER}/plugins/
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500601
.undef NO_IGNORE
BROKEN= Phoenix only supports the ports versions of Perl.
BROKEN+=If you have installed a Perl port, and are getting this message,
BROKEN+=please make sure you have given the command \'use.perl port\'.
.endif # ${PERL_LEVEL} < 500601
SORT?=/usr/bin/sort
PLIST=${WRKDIR}/plist
.if defined(WITH_DEBUG)
WITH_LOGGING= yes
WITHOUT_OPTIMIZE= yes
CONFIGURE_ENV+= WITH_DEBUG=yes
.endif # defined(WITH_DEBUG)
.if !defined(WITHOUT_OPTIMIZE)
CFLAGS+= -O2
.endif # defined(WITH_OPTIMIZE)
.if defined(WITH_LOGGING)
CONFIGURE_ENV+= WITH_LOGGING=yes
.endif # defined(WITH_LOGGING)
.if defined(WITHOUT_XFT)
CONFIGURE_ENV+= WITHOUT_XFT=yes
.else
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/Xft
.endif # !defined(WITHOUT_XFT)
CPPFLAGS+= -I${X11BASE}/include
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= -L${X11BASE}/lib
LIBS+= ${PTHREAD_LIBS}
EXTRA_SCRIPTS= phoenix.rb
pre-extract::
@${ECHO_MSG}
@${ECHO_MSG} "Extracting source (this takes a while) ..."
@${ECHO_MSG}
post-extract::
@${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
-e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LDFLAGS@|${LDFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
-e 's|@X11BASE@|${X11BASE}|' \
-e 's|@LOCALBASE@|${LOCALBASE}|' \
-e 's|@PREFIX@|${LOCAL_PREFIX}|' \
<${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
post-build:
${RM} -f ${PLIST}
${TOUCH} ${PLIST}
pre-install:
${RM} -fr ${LOCAL_PREFIX}
install-extra:
.for i in ${EXTRA_SCRIPTS}
${INSTALL_SCRIPT} ${FILESDIR}/${i} ${PREFIX}/bin
.endfor # i in ${EXTRA_SCRIPTS}
link-bins:
${RM} -f ${PREFIX}/bin/phoenix
${LN} -s ${LOCAL_PREFIX}/bin/phoenix \
${PREFIX}/bin/phoenix
${RM} -f ${PREFIX}/bin/phoenix-config
${LN} -s ${LOCAL_PREFIX}/bin/mozilla-config \
${PREFIX}/bin/phoenix-config
# not used because of undefined symbol errors
link-java:
-${RM} -f ${PLUGINSDIR}/libjavaplugin_oji.so
-${LN} -sf \
${JREDIR}/plugin/i386/ns600/libjavaplugin_oji.so \
${PLUGINSDIR}/libjavaplugin_oji.so
cleanup-install:
${RM} -fr ${LOCAL_PREFIX}/share/idl
${RM} -fr ${LOCAL_PREFIX}/include
cons-plist:
-${RM} -f ${PLIST}
${ECHO_CMD} bin/phoenix >>${PLIST}
${ECHO_CMD} bin/phoenix-config >>${PLIST}
.for i in ${EXTRA_SCRIPTS}
${ECHO_CMD} bin/${i} >>${PLIST}
.endfor # i in ${EXTRA_SCRIPTS}
cd ${PREFIX}; \
${FIND} ${LOCAL_SUBDIR} ! -type d | ${SORT} >>${PLIST}; \
${FIND} ${LOCAL_SUBDIR} -type d -empty | ${SORT} \
| ${SED} -e "s:^:@exec ${MKDIR} %D/:" -e "s:$$: || true:" \
>> ${PLIST}; \
${FIND} ${LOCAL_SUBDIR} -type d -empty | ${SORT} -r \
| ${SED} -e "s:^:@unexec ${RMDIR} %D/:" -e "s:$$: || true:" \
>> ${PLIST}; \
${FIND} ${LOCAL_SUBDIR} -type d ! -empty | ${SORT} -r \
| ${SED} -e "s:^:@dirrm :" >> ${PLIST}
.PHONY: install-extra link-bins link-java cleanup-install cons-plist
.include <bsd.port.post.mk>
# <alane>
# Under normal circumstances, you should not put anything after
# the above line. However, this is the only way I can state the
# dependency without trashing the actual code of the generate-plist
# target. This is a limitation of the make(1) program itself.
# </alane>
generate-plist: install-extra link-bins cleanup-install cons-plist
#EOF

View file

@ -1 +0,0 @@
MD5 (phoenix-0.5.tar.bz2) = fb99a5a866a99fbb15269699a1022b47

View file

@ -1,171 +0,0 @@
#!/bin/sh
# -*-shell-script-*-
#
# mkdistfile -- maintainer's utility to make a phoenix distfile
#
# Copyright (c) 2002, Alan Eldridge
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions
# are met:
#
# * Redistributions of source code must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# * Redistributions in binary form must reproduce the above copyright
# notice, this list of conditions and the following disclaimer in the
# documentation and/or other materials provided with the distribution.
#
# * Neither the name of the copyright owner nor the names of its
# contributors may be used to endorse or promote products derived
# from this software without specific prior written permission.
#
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
# ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
# LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
# CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
# SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
# POSSIBILITY OF SUCH DAMAGE.
#
# $FreeBSD$
#
# 2002/10/21 alane@geeksrus.net
#
ORIGDIR=$(/bin/pwd); export ORIGDIR
APPNAME=${0##*/};APPNAME=${APPNAME#-}; export APPNAME
test -z "$TMPDIR" && TMPDIR=/tmp; export TMPDIR
test -z "$HOSTNAME" && HOSTNAME=$(hostname); export HOSTNAME
warn() { echo "[$APPNAME:$$]" "****" "$@";}
status() { echo "[$APPNAME:$$]" "===>" "$@";}
error() { echo "[$APPNAME:$$]" "ERROR:" "$@";}
die() { echo "[$APPNAME:$$]" "FATAL:" "$@"; exit 1;}
unset echo_n; test "X`echo -n`" = "X-n" \
&& echo_n() { echo "$@\c"; } || echo_n() { echo -n "$@"; }
status_n() { echo_n "[$APPNAME:$$]" "===>" "$@";}
log() { local cmd=$1;shift;echo_n $(date "+%Y%m%d.%T") "";$cmd "$@";}
qexpr() { expr "$@" >/dev/null 2>&1;}
qw() { echo \""$@"\"; }
listfiles() { ls -1 ${1:+"$@"} 2>/dev/null; }
whichre() { local n=$#; local s="$1"; shift; while test $# -ge 1; do
qexpr "$s" : "$1"&& echo $(($n - $#)) && return 0; shift; done;
echo 0; return 1;}
matchre() { test $(whichre "$@") -gt 0; }
streq() { local s="$1"; shift; while test $# -ge 1; do
test "X$s" = "X$1" && return 0; shift; done; return 1;}
strupper() {
echo "$@"|tr abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ
}
strlower() {
echo "$@"|tr ABCDEFGHIJKLMNOPQRSTUVWXYZ abcdefghijklmnopqrstuvwxyz
}
chdir() { cd "$1" || die cd $(qw $1) failed; }
absdir() { chdir "$1" && pwd; }
abspath() { local p=''; case "$1" in /*);; *)p="$(pwd)/";; esac; echo "$p$1"; }
tmpfile() { mktemp -t .$APPNAME ${1:+"$@"}; }
############################################################
# show usage and exit
############################################################
usage() {
cat <<EOF
Usage: $APPNAME [options] [--] rev[.yyyymmdd]
Options:
-h,--help Show this help.
-V,--version Show version number.
-v,--verbose Produce more verbose output.
-x,--debug Turn on shell command tracing.
-- Stop option processing.
EOF
exit $1
}
############################################################
# show version and exit
############################################################
VERSION='$Revision$'
VERSION=${VERSION#* }; VERSION=${VERSION% *}
version() { echo "$APPNAME $VERSION" \
"Copyright (c) 2002 Alan Eldridge"; exit $1;}
############################################################
# set default vars here
############################################################
DEBUG=0
VERBOSE=0; VFLG=''
DATETIME=$(date +%Y%m%d.%H%M)
DATE=${DATETIME%.*}
TIME=${DATETIME#*.}
############################################################
# do command line options
############################################################
while test $# -gt 0; do
n=1; case "$1" in
-h|--help) usage 0;;
-V|--version) version 0;;
-v|--verbose) VERBOSE=1;VFLG='-v';;
-x|--debug) set -x;DEBUG=1;;
--) shift; break;; -*) usage 1;; *) break;;
esac; shift $n
done
############################################################
# main(): script execution begins here
############################################################
test $# -eq 1 || usage 1
REV=$1
test ${REV##*.} = today && REV=${REV%.*}.$DATE
status "pruning tree..."
exfile=$(tmpfile)
cat >>$exfile <<'EOF'
^.*/CVS($|/)
^.*/macbuild($|/)
^.*/package($|/)
^.*/.cvsignore($|/)
^.*/windows($|/)
^.*/activex($|/)
^.*/os2($|/)
^.*/solaris($|/)
^.*/gc($|/)
^mozilla/apache($|/)
^mozilla/calendar($|/)
^mozilla/cck($|/)
^mozilla/chimera($|/)
^mozilla/ef($|/)
^mozilla/embed.mak($|/)
^mozilla/embed.mk($|/)
^mozilla/gconfig($|/)
^mozilla/gfx2($|/)
^mozilla/grendel($|/)
^mozilla/java($|/)
^mozilla/js2($|/)
^mozilla/mail($|/)
^mozilla/mailnews($|/)
^mozilla/mozilla($|/)
^mozilla/mozilla.kdevprj($|/)
^mozilla/mozilla.lsm($|/)
^mozilla/msgsdk($|/)
^mozilla/mstone($|/)
^mozilla/nglayout.mac($|/)
^mozilla/nunet($|/)
^mozilla/other-licenses($|/)
^mozilla/privacy($|/)
^mozilla/silentdl($|/)
^mozilla/timer($|/)
^mozilla/trex.mak($|/)
^mozilla/trex.mk($|/)
^mozilla/webtools($|/)
EOF
test -d mozilla || die "No mozilla dir here."
find mozilla 2>/dev/null | egrep -f $exfile | xargs rm -fr
rm -f $exfile
status "making phoenix-$REV.tar.bz2 ..."
tar -cjpf phoenix-$REV.tar.bz2 mozilla
status "done."
#EOF

View file

@ -1,66 +0,0 @@
# .mozconfig.in -*-shell-script-*-
# $FreeBSD$
######################################################################
# standard opts from README
export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1
ac_add_options --enable-crypto
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-mailnews
ac_add_options --disable-composer
######################################################################
# FBSD specific
export CPPFLAGS="@CPPFLAGS@"
export CFLAGS="@CFLAGS@"
export LIBS="@LIBS@"
export LDFLAGS="@LDFLAGS@"
export CONFIG_SH=/bin/sh
export XP_UNIX=1
mk_add_options XP_UNIX=1
export PERL=/usr/local/bin/perl
mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
mk_add_options GLIB_CONFIG=$GLIB_CONFIG
# Configure options for installation
ac_add_options --prefix=@PREFIX@
######################################################################
# Use ports for these libraries
ac_add_options --with-system-jpeg=@LOCALBASE@
ac_add_options --with-system-zlib
ac_add_options --with-system-png=@LOCALBASE@
ac_add_options --with-system-mng=@LOCALBASE@
######################################################################
# set compile/link features
ac_add_options --with-pthreads
ac_add_options --enable-reorder
ac_add_options --enable-strip
######################################################################
# disable unneeded/unavailable
ac_add_options --disable-auto-deps
ac_add_options --disable-bidi
ac_add_options --disable-dtd-debug
ac_add_options --disable-jsd
ac_add_options --disable-ldap
ac_add_options --disable-pedantic
ac_add_options --disable-xinerama
######################################################################
# conditional from port Makefile
if test -n "$WITH_DEBUG"; then
ac_add_options --enable-debug
else
ac_add_options --disable-debug
fi # test -n "$WITH_DEBUG"
if test -n "$WITH_LOGGING"; then
ac_add_options --enable-logging
else
ac_add_options --disable-logging
fi # test -n "$WITH_LOGGING"
if test -z "$WITHOUT_XFT"; then
ac_add_options --enable-xft
else
ac_add_options --disable-xft
fi # test -z "$WITHOUT_XFT"
######################################################################

View file

@ -1,18 +0,0 @@
--- nsprpub/pr/src/misc/prtime.c.orig Sun Mar 31 12:17:46 2002
+++ nsprpub/pr/src/misc/prtime.c Tue Dec 17 21:30:30 2002
@@ -1666,12 +1666,13 @@
* values for these two fields.
*/
-#if defined(SUNOS4) || (__GLIBC__ >= 2) || defined(XP_BEOS)
+#if defined(__FreeBSD__)|| defined(SUNOS4) \
+ || (__GLIBC__ >= 2) || defined(XP_BEOS)
if (mktime(&a) == -1) {
PR_snprintf(buf, buflen, "can't get timezone");
return 0;
}
-#endif
+#endif /* check for __FreeBSD__, too <alane@freebsd.org> */
return strftime(buf, buflen, fmt, &a);
}

View file

@ -1,22 +0,0 @@
Index: nsprpub/pr/src/pthreads/ptio.c
diff -u nsprpub/pr/src/pthreads/ptio.c.orig nsprpub/pr/src/pthreads/ptio.c
--- nsprpub/pr/src/pthreads/ptio.c.orig Fri Apr 12 03:14:39 2002
+++ nsprpub/pr/src/pthreads/ptio.c Tue Jul 30 18:52:11 2002
@@ -3414,6 +3414,17 @@
if (osfd == -1) pt_MapError(_PR_MD_MAP_SOCKET_ERROR, errno);
else
{
+#if (defined(_PR_INET6_PROBE) || defined(_PR_INET6)) && \
+ defined(__FreeBSD__) && defined(IPV6_V6ONLY)
+ if (domain == PR_AF_INET6) {
+ int opt = 0;
+ if (setsockopt(osfd, IPPROTO_IPV6, IPV6_V6ONLY,
+ &opt, sizeof(opt))) {
+ close(osfd);
+ return NULL;
+ }
+ }
+#endif
fd = pt_SetMethods(osfd, ftype, PR_FALSE, PR_FALSE);
if (fd == NULL) close(osfd);
}

View file

@ -1,95 +0,0 @@
#!/usr/bin/env ruby
=begin -*-mode: ruby-*-
MoZiLLa.in
Copyright (c) 2002, Alan Eldridge
All rights reserved.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions
are met:
* Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the distribution.
* Neither the name of the copyright owner nor the names of its
contributors may be used to endorse or promote products derived
from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
$Id: MoZiLLa.in,v 1.18 2002/12/18 02:40:58 alane Exp $
2002-12-16 Alan Eldridge <alane@geeksrus.net>
=end
X11BIN = "/usr/X11R6/bin"
NAME = File::basename($0, ".rb")
APP_PATH = File::join(X11BIN, NAME)
if !File::executable?(APP_PATH)
raise "File '#{APP_PATH}' not found. Giving up."
elsif ($display = ENV["DISPLAY"]) == nil
raise "Environment variable DISPLAY not found. Giving up."
end
if ARGV.size > 0
if ARGV[0] == "--debug"
ARGV.shift
else
$stdin.reopen(File::open("/dev/null", "r"))
$stdout.reopen(File::open("/dev/null", "w"))
$stderr.reopen(File::open("/dev/null", "w"))
end
end
if ARGV.size < 1
$url = nil
else
$url = ARGV.pop
$url.sub!(/^ghelp:/, "file:")
end
IO::popen("xwininfo -display #{$display} -root -tree") {
|io|
if NAME != "phoenix"
$windows = io.grep(%r<"Mozilla"\s+"navigator:\s*browser">)
else
$windows = io.grep(%r<Phoenix.*"Mozilla"\s+"navigator:\s*browser">)
end
}
if $windows.size > 0
$id = $windows.map {
|s| s.strip.split.first
}.sort.first
$args = [ "-id", $id, "-raise", "-remote" ]
$args.push($url ? "\"openURL(#{$url},new-window)\"" :
"\"xfeDoCommand(openBrowser)\"")
else
$args = ARGV
$args.push("\"#{$url}\"") if $url
end
fork {
exec(([APP_PATH] + $args).join(" "))
}
exit!
#EOF

View file

@ -1,6 +0,0 @@
Phoenix is a fast, low-overhead browser from the Mozilla project. See the
phoenix project page for more details.
WWW: http://www.mozilla.org/projects/phoenix/
-- AlanE <alane@freebsd.org>

View file

@ -1,72 +0,0 @@
======================================================================
As of version 0.4_7, this port appears to be stable *again*. It will work
with either of the port versions of perl, provided you do "use.perl port".
It will NOT work with the -STABLE base-system versions of Perl.
If you use the lang/perl5.8 port, please remove the File::Spec package with
the command "pkg_deinstall -f p5-File-Spec". If you are updating to the 5.8
version of perl, please do this *first*.
Any bug reports should be addressed to the maintainers at:
phoenix@freebsd.org
You may also Cc: freebsd-ports@freebsd.org. Please do not send
bug reports to any other addresses.
Please include the following information with any bug report:
* Output from 'uname -a'.
* Date/time stamp from www/phoenix/Makefile.
* Perl version used (/usr/bin/perl --version or
/usr/local/bin/perl --version for -current).
* Where/when did the problem occur: configuring, building, or
running phoenix?
* How can you reproduce the problem?
Thank you for your help in testing and reporting bugs, and we hope you
enjoy using Phoenix.
The Maintainers (alane@ & trevor@)
Additional notes:
0.4_8:
Add patch to fix network ops on -CURRENT.
0.4_9:
Install link to java plugin.
Build plist after install using find/sed.
0.4_10:
Backdown after failed 0.5 from nonofficial tree. Makefile modifications
to generate plist done right this time.
0.5_1
Official 0.5 release port.
****WARNING! DANGER, WILL ROBINSON!**** You must delete your old .phoenix
dir! Save your bookmarks.html somewhere and then let it create a new
directory. You can import your old bookmark file. Bug reports from people
who did not do this are going to be taken at extremely low priority.
Also, please see the nifty new phoenix themes and extensions at the new
website http://texturizer.net/phoenix/index.html.
Finally make portlint STFU about the Makefile.
The distfile is on my distfiles dir this time, so I have mirrored it on my
html page until the distfiles dir gets mirrored in 24-48 hours.
I had to disable Xinerama since it was breaking the build.
0.5_4
Patch to hopefully fix crash when formatting time string at end of download.
Thanks to Greg Rumple and Joe Marcus Clarke for the fantastic work debugging
this one.
Added /usr/X11R6/bin/phoenix.rb. If you have ruby installed, you can run
this instead of 'phoenix' and it takes care of the 'profile in use' errors
by automatically using an existing phoenix if one is running. I didn't put
a dependency because I don't want to require ruby + ruby-shim to run the
browser.
-- AlanE <phoenix@freebsd.org>
======================================================================