Fix on perl-5.10.

This commit is contained in:
Sergey Skvortsov 2009-03-14 13:46:24 +00:00
parent d47f511eff
commit 9a0e3b3098
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=230052
3 changed files with 25 additions and 20 deletions

View file

@ -7,7 +7,7 @@
PORTNAME= XML-SAX-Machines
PORTVERSION= 0.41
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@ -27,6 +27,12 @@ MAN3= XML::Filter::Distributor.3 XML::Filter::DocSplitter.3 \
XML::SAX::Machines.3 XML::SAX::Machines::ConfigHelper.3 \
XML::SAX::Manifold.3 XML::SAX::Pipeline.3 XML::SAX::Tap.3
regression-test: build
${MAKE} -C ${WRKSRC} test
post-patch:
${RM} -f ${WRKSRC}/lib/XML/SAX/Machine.pm.orig
post-install:
.ifndef(NOPORTEXAMPLES)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
@ -34,10 +40,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
EXTRA_PATCHES= ${PATCHDIR}/500503-Makefile.PL
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,12 +0,0 @@
--- Makefile.PL.orig Wed Dec 29 20:16:15 2004
+++ Makefile.PL Wed Dec 29 20:18:39 2004
@@ -49,3 +49,9 @@
install_site_config:
$(PERL) -I$(PERL_ARCHLIB) -I$(PERL_LIB) -I$(INST_LIB) -I$(INSTALLSITELIB) -MXML::SAX::Machines::ConfigHelper -we 'XML::SAX::Machines::ConfigHelper::_write_site_config_if_absent(shift)' $(INSTALLSITELIB)
POSTAMBLE_END
+
+sub MY::manifypods {
+ package MY; my $self=shift;
+ $self->{MAN3PODS}->{'lib/XML/SAX/Machines/ConfigHelper.pm'}='$(INST_MAN3DIR)/XML::SAX::Machines::ConfigHelper.$(MAN3EXT)';
+ $self->SUPER::manifypods(@_);
+}

View file

@ -0,0 +1,17 @@
--- lib/XML/SAX/Machine.pm
+++ lib/XML/SAX/Machine.pm
@@ -1468,13 +1468,7 @@
my $proto = shift;
my $class = ref $proto || $proto;
- my $self = do {
- no strict 'refs';
- bless [ \%{ "${class}::FIELDS" } ];
- };
-
- ## Pseudo hashes are badly borken in older Perls. Should use something
- ## else, really.
+ my $self = fields::new( $class );
my %options = @_ ;
$self->{$_} = $options{$_} for keys %options;