- Fix pear pkg-plist
- Increase pear memory limit (requested by amd64)
This commit is contained in:
parent
730fa70418
commit
9a201016ae
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=148440
12 changed files with 82 additions and 42 deletions
|
@ -1,4 +1,4 @@
|
|||
PORTREVISION= 0
|
||||
PORTREVISION= 1
|
||||
|
||||
USE_GNOME= libxml2
|
||||
|
||||
|
|
|
@ -1,12 +1,11 @@
|
|||
--- Zend/zend.h.orig Mon Dec 6 15:42:56 2004
|
||||
+++ Zend/zend.h Mon Dec 6 15:46:40 2004
|
||||
@@ -176,7 +176,7 @@
|
||||
--- Zend/zend.h.orig Thu Aug 25 19:41:08 2005
|
||||
+++ Zend/zend.h Wed Nov 16 09:30:03 2005
|
||||
@@ -178,7 +178,7 @@
|
||||
#endif
|
||||
|
||||
|
||||
|
||||
|
||||
-#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__)
|
||||
+#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__) && !(defined(ZTS) && defined(__FreeBSD__))
|
||||
# define do_alloca(p) alloca(p)
|
||||
# define free_alloca(p)
|
||||
#else
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- acinclude.m4.orig Tue Jan 25 14:02:45 2005
|
||||
+++ acinclude.m4 Mon Apr 4 11:09:25 2005
|
||||
@@ -1681,9 +1681,9 @@
|
||||
unset OPENSSL_LIBDIR
|
||||
--- acinclude.m4.orig Tue Jul 26 00:31:07 2005
|
||||
+++ acinclude.m4 Wed Nov 16 09:30:03 2005
|
||||
@@ -1707,9 +1707,9 @@
|
||||
test -z "$PHP_IMAP_SSL" && PHP_IMAP_SSL=no
|
||||
|
||||
dnl Fallbacks for different configure options
|
||||
- if test "$PHP_OPENSSL" != "no"; then
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- main/php_config.h.in.orig Mon Jul 12 16:30:37 2004
|
||||
+++ main/php_config.h.in Mon Jul 12 16:31:38 2004
|
||||
@@ -2362,6 +2362,9 @@
|
||||
/* */
|
||||
#undef SOLARIS_YP
|
||||
--- main/php_config.h.in.orig Mon Sep 5 13:16:27 2005
|
||||
+++ main/php_config.h.in Wed Nov 16 09:30:03 2005
|
||||
@@ -2454,6 +2454,9 @@
|
||||
/* Define if uint32_t type is present. */
|
||||
#undef HAVE_UINT32_T
|
||||
|
||||
+/* Include external shared modules configurations */
|
||||
+#include "ext/php_config.h"
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- pear/scripts/pearcmd.php.orig Sun Jun 6 17:52:41 2004
|
||||
+++ pear/scripts/pearcmd.php Mon Jul 12 16:22:50 2004
|
||||
--- pear/scripts/pearcmd.php.orig Mon Mar 28 18:46:06 2005
|
||||
+++ pear/scripts/pearcmd.php Wed Nov 16 09:30:03 2005
|
||||
@@ -1,3 +1,4 @@
|
||||
+#!%%PREFIX%%/bin/php -nq
|
||||
<?php
|
||||
//
|
||||
// +----------------------------------------------------------------------+
|
||||
@@ -24,9 +25,9 @@
|
||||
@@ -24,9 +25,10 @@
|
||||
/**
|
||||
* @nodep Gtk
|
||||
*/
|
||||
|
@ -15,6 +15,7 @@
|
|||
+dl('pcre.so');
|
||||
+dl('xml.so');
|
||||
+ini_set('include_path', '%%PREFIX%%/share/pear:%%PREFIX%%/share/pear/bootstrap');
|
||||
+ini_set('memory_limit', '16M');
|
||||
ini_set('allow_url_fopen', true);
|
||||
if (!ini_get('safe_mode')) {
|
||||
set_time_limit(0);
|
||||
@set_time_limit(0);
|
||||
|
|
|
@ -1,5 +1,14 @@
|
|||
bin/pear
|
||||
@exec mkdir -p %D/lib/php/pear/.registry
|
||||
@exec mkdir -p %D/lib/php/pear/.channels/.alias
|
||||
@exec mkdir -p %D/lib/php/pear/.registry/.channel.__uri
|
||||
@exec mkdir -p %D/lib/php/pear/.registry/.channel.pecl.php.net
|
||||
@exec touch %D/lib/php/pear/.channels/.alias/pear.txt
|
||||
@exec touch %D/lib/php/pear/.channels/.alias/pecl.txt
|
||||
@exec touch %D/lib/php/pear/.channels/__uri.reg
|
||||
@exec touch %D/lib/php/pear/.channels/pear.php.net.reg
|
||||
@exec touch %D/lib/php/pear/.channels/pecl.php.net.reg
|
||||
@exec touch %D/lib/php/pear/.depdb
|
||||
@exec touch %D/lib/php/pear/.depdblock
|
||||
@exec touch %D/lib/php/pear/.filemap
|
||||
@exec touch %D/lib/php/pear/.lock
|
||||
share/pear/bootstrap/Archive/Tar.php
|
||||
|
@ -34,8 +43,19 @@ share/pear/bootstrap/PEAR/Remote.php
|
|||
share/pear/bootstrap/PEAR/RunTest.php
|
||||
share/pear/bootstrap/XML/RPC.php
|
||||
share/pear/bootstrap/XML/RPC/Server.php
|
||||
@unexec rm %D/lib/php/pear/.channels/.alias/pear.txt 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.channels/.alias/pecl.txt 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.channels/__uri.reg 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.channels/pear.php.net.reg 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.channels/pecl.php.net.reg 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.depdb 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.depdblock 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.filemap 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.lock 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php/pear/.channels/.alias 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php/pear/.channels 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php/pear/.registry/.channel.__uri 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php/pear/.registry/.channel.pecl.php.net 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php/pear/.registry 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php/pear 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php 2> /dev/null || true
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
PORTREVISION= 0
|
||||
PORTREVISION= 1
|
||||
|
||||
USE_GNOME= libxml2
|
||||
|
||||
|
|
|
@ -1,12 +1,11 @@
|
|||
--- Zend/zend.h.orig Mon Dec 6 15:42:56 2004
|
||||
+++ Zend/zend.h Mon Dec 6 15:46:40 2004
|
||||
@@ -176,7 +176,7 @@
|
||||
--- Zend/zend.h.orig Thu Aug 25 19:41:08 2005
|
||||
+++ Zend/zend.h Wed Nov 16 09:30:03 2005
|
||||
@@ -178,7 +178,7 @@
|
||||
#endif
|
||||
|
||||
|
||||
|
||||
|
||||
-#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__)
|
||||
+#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__) && !(defined(ZTS) && defined(__FreeBSD__))
|
||||
# define do_alloca(p) alloca(p)
|
||||
# define free_alloca(p)
|
||||
#else
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- acinclude.m4.orig Tue Jan 25 14:02:45 2005
|
||||
+++ acinclude.m4 Mon Apr 4 11:09:25 2005
|
||||
@@ -1681,9 +1681,9 @@
|
||||
unset OPENSSL_LIBDIR
|
||||
--- acinclude.m4.orig Tue Jul 26 00:31:07 2005
|
||||
+++ acinclude.m4 Wed Nov 16 09:30:03 2005
|
||||
@@ -1707,9 +1707,9 @@
|
||||
test -z "$PHP_IMAP_SSL" && PHP_IMAP_SSL=no
|
||||
|
||||
dnl Fallbacks for different configure options
|
||||
- if test "$PHP_OPENSSL" != "no"; then
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- main/php_config.h.in.orig Mon Jul 12 16:30:37 2004
|
||||
+++ main/php_config.h.in Mon Jul 12 16:31:38 2004
|
||||
@@ -2362,6 +2362,9 @@
|
||||
/* */
|
||||
#undef SOLARIS_YP
|
||||
--- main/php_config.h.in.orig Mon Sep 5 13:16:27 2005
|
||||
+++ main/php_config.h.in Wed Nov 16 09:30:03 2005
|
||||
@@ -2454,6 +2454,9 @@
|
||||
/* Define if uint32_t type is present. */
|
||||
#undef HAVE_UINT32_T
|
||||
|
||||
+/* Include external shared modules configurations */
|
||||
+#include "ext/php_config.h"
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- pear/scripts/pearcmd.php.orig Sun Jun 6 17:52:41 2004
|
||||
+++ pear/scripts/pearcmd.php Mon Jul 12 16:22:50 2004
|
||||
--- pear/scripts/pearcmd.php.orig Mon Mar 28 18:46:06 2005
|
||||
+++ pear/scripts/pearcmd.php Wed Nov 16 09:30:03 2005
|
||||
@@ -1,3 +1,4 @@
|
||||
+#!%%PREFIX%%/bin/php -nq
|
||||
<?php
|
||||
//
|
||||
// +----------------------------------------------------------------------+
|
||||
@@ -24,9 +25,9 @@
|
||||
@@ -24,9 +25,10 @@
|
||||
/**
|
||||
* @nodep Gtk
|
||||
*/
|
||||
|
@ -15,6 +15,7 @@
|
|||
+dl('pcre.so');
|
||||
+dl('xml.so');
|
||||
+ini_set('include_path', '%%PREFIX%%/share/pear:%%PREFIX%%/share/pear/bootstrap');
|
||||
+ini_set('memory_limit', '16M');
|
||||
ini_set('allow_url_fopen', true);
|
||||
if (!ini_get('safe_mode')) {
|
||||
set_time_limit(0);
|
||||
@set_time_limit(0);
|
||||
|
|
|
@ -1,5 +1,14 @@
|
|||
bin/pear
|
||||
@exec mkdir -p %D/lib/php/pear/.registry
|
||||
@exec mkdir -p %D/lib/php/pear/.channels/.alias
|
||||
@exec mkdir -p %D/lib/php/pear/.registry/.channel.__uri
|
||||
@exec mkdir -p %D/lib/php/pear/.registry/.channel.pecl.php.net
|
||||
@exec touch %D/lib/php/pear/.channels/.alias/pear.txt
|
||||
@exec touch %D/lib/php/pear/.channels/.alias/pecl.txt
|
||||
@exec touch %D/lib/php/pear/.channels/__uri.reg
|
||||
@exec touch %D/lib/php/pear/.channels/pear.php.net.reg
|
||||
@exec touch %D/lib/php/pear/.channels/pecl.php.net.reg
|
||||
@exec touch %D/lib/php/pear/.depdb
|
||||
@exec touch %D/lib/php/pear/.depdblock
|
||||
@exec touch %D/lib/php/pear/.filemap
|
||||
@exec touch %D/lib/php/pear/.lock
|
||||
share/pear/bootstrap/Archive/Tar.php
|
||||
|
@ -34,8 +43,19 @@ share/pear/bootstrap/PEAR/Remote.php
|
|||
share/pear/bootstrap/PEAR/RunTest.php
|
||||
share/pear/bootstrap/XML/RPC.php
|
||||
share/pear/bootstrap/XML/RPC/Server.php
|
||||
@unexec rm %D/lib/php/pear/.channels/.alias/pear.txt 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.channels/.alias/pecl.txt 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.channels/__uri.reg 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.channels/pear.php.net.reg 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.channels/pecl.php.net.reg 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.depdb 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.depdblock 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.filemap 2> /dev/null || true
|
||||
@unexec rm %D/lib/php/pear/.lock 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php/pear/.channels/.alias 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php/pear/.channels 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php/pear/.registry/.channel.__uri 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php/pear/.registry/.channel.pecl.php.net 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php/pear/.registry 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php/pear 2> /dev/null || true
|
||||
@unexec rmdir %D/lib/php 2> /dev/null || true
|
||||
|
|
Loading…
Reference in a new issue