Update to 0.1.1.

This commit is contained in:
Pete Fritchman 2002-07-13 04:25:21 +00:00
parent f172aa6926
commit 9ae37e5938
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62889
5 changed files with 56 additions and 13 deletions

View file

@ -6,17 +6,14 @@
#
PORTNAME= libcapsinetwork
PORTVERSION= 0.0.13
PORTVERSION= 0.1.1
CATEGORIES= devel net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= petef@FreeBSD.org
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
post-patch:
@${PERL} -pi -e 's!CC!CXX!g; s!CXX=!CXX?=!; s!CFLAGS=!CFLAGS+=!; \
s!/usr/local!${PREFIX}!' ${WRKSRC}/Makefile
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (libcapsinetwork-0.0.13.tar.gz) = 9180719a119d79fe5f6b0deefa0ac8da
MD5 (libcapsinetwork-0.1.1.tar.gz) = 828a0cb9ceb7c8d6ad3d29371942c4c6

View file

@ -0,0 +1,12 @@
$FreeBSD$
--- listener.cc.orig Sat Jul 13 00:06:34 2002
+++ listener.cc Sat Jul 13 00:06:36 2002
@@ -14,6 +14,7 @@
// the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
// Boston, MA 02111-1307, USA.
+#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>

View file

@ -0,0 +1,35 @@
$FreeBSD$
--- ltmain.sh.orig Thu Nov 22 05:43:58 2001
+++ ltmain.sh Fri Dec 7 07:18:03 2001
@@ -944,6 +944,7 @@
;;
-avoid-version)
+ build_old_libs=no
avoid_version=yes
continue
;;
@@ -2408,6 +2409,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test $build_libtool_need_lc = "yes"; then
@@ -4175,10 +4179,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false ; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -1,7 +1,6 @@
include/libcapsi_network/listener.h
include/libcapsi_network/server.h
include/libcapsi_network/socket.h
lib/libcapsi_network.so
lib/libcapsi_network.so.0
lib/libcapsi_network.so.0.0.13
@dirrm include/libcapsi_network
include/libcapsinetwork/listener.h
include/libcapsinetwork/socket.h
lib/libcapsinetwork.a
lib/libcapsinetwork.so
lib/libcapsinetwork.so.0
@dirrm include/libcapsinetwork