net/ecal: Allow build with tinyxml2 with meson
This commit is contained in:
parent
9e1564bdc2
commit
9b1d0a8492
3 changed files with 43 additions and 1 deletions
|
@ -28,7 +28,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
|
|||
libyaml-cpp.so:devel/yaml-cpp
|
||||
# binaries aren't linked with libfineftp-server.so, see https://github.com/continental/ecal/issues/381; same with libcurl.so
|
||||
|
||||
USES= cmake compiler:c++17-lang desktop-file-utils localbase:ldflags qt:5 shared-mime-info
|
||||
USES= cmake compiler:c++17-lang desktop-file-utils localbase:ldflags pkgconfig qt:5 shared-mime-info
|
||||
USE_QT= core gui widgets buildtools:build qmake:build
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
|
|
|
@ -0,0 +1,21 @@
|
|||
--- app/rec/rec_server_core/CMakeLists.txt.orig 2023-10-27 08:38:06 UTC
|
||||
+++ app/rec/rec_server_core/CMakeLists.txt
|
||||
@@ -20,7 +20,8 @@ find_package(fineftp REQUIRED)
|
||||
find_package(Protobuf REQUIRED)
|
||||
find_package(spdlog REQUIRED)
|
||||
find_package(fineftp REQUIRED)
|
||||
-find_package(tinyxml2 REQUIRED)
|
||||
+find_package(PkgConfig REQUIRED)
|
||||
+pkg_check_modules(tinyxml2 REQUIRED IMPORTED_TARGET tinyxml2)
|
||||
|
||||
set(PROJECT_NAME rec_server_core)
|
||||
|
||||
@@ -66,7 +66,7 @@ target_link_libraries(${PROJECT_NAME}
|
||||
|
||||
target_link_libraries(${PROJECT_NAME}
|
||||
PRIVATE
|
||||
- tinyxml2::tinyxml2
|
||||
+ PkgConfig::tinyxml2
|
||||
protobuf::libprotobuf
|
||||
eCAL::core
|
||||
eCAL::app_pb
|
21
net/ecal/files/patch-app_sys_sys__core_CMakeLists.txt
Normal file
21
net/ecal/files/patch-app_sys_sys__core_CMakeLists.txt
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- app/sys/sys_core/CMakeLists.txt.orig 2023-10-27 08:38:06 UTC
|
||||
+++ app/sys/sys_core/CMakeLists.txt
|
||||
@@ -21,7 +21,8 @@ find_package(spdlog REQUIRED)
|
||||
find_package(Threads REQUIRED)
|
||||
find_package(Protobuf REQUIRED)
|
||||
find_package(spdlog REQUIRED)
|
||||
-find_package(tinyxml2 REQUIRED)
|
||||
+find_package(PkgConfig REQUIRED)
|
||||
+pkg_check_modules(tinyxml2 REQUIRED IMPORTED_TARGET tinyxml2)
|
||||
|
||||
set(ecalsyscore_src
|
||||
include/ecalsys/ecal_sys.h
|
||||
@@ -88,7 +88,7 @@ target_link_libraries(${PROJECT_NAME}
|
||||
|
||||
target_link_libraries(${PROJECT_NAME}
|
||||
Threads::Threads
|
||||
- tinyxml2::tinyxml2
|
||||
+ PkgConfig::tinyxml2
|
||||
spdlog::spdlog
|
||||
protobuf::libprotobuf
|
||||
eCAL::core
|
Loading…
Reference in a new issue