- Update to 0.8.90

- Change my email
- Use new WX framework
This commit is contained in:
Stanislav Sedov 2006-11-15 17:32:37 +00:00
parent 696dde0848
commit 9b2cddd874
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=177325
3 changed files with 19 additions and 15 deletions

View file

@ -6,19 +6,19 @@
#
PORTNAME= gspiceui
PORTVERSION= 0.8.55
PORTVERSION= 0.8.90
CATEGORIES= cad
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= ssedov@mbsd.msk.ru
MAINTAINER= stas@FreeBSD.org
COMMENT= GUI frontend for gnucap/ng-spice circuit simulators
LIB_DEPENDS= wx_gtk2u_core-2.6:${PORTSDIR}/x11-toolkits/wxgtk26-unicode
RUN_DEPENDS= gwave:${PORTSDIR}/cad/gwave
USE_X_PREFIX= yes
USE_WX= 2.6
WX_UNICODE= yes
USE_GMAKE= yes
OPTIONS= NGSPICE "Use ng-spice as backend" on \
@ -36,6 +36,10 @@ COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -E -e "s,%%WX_CONFIG%%,${WX_CONFIG},g" \
${WRKSRC}/src/Makefile
.if !defined(WITHOUT_NGSPICE)
RUN_DEPENDS+= ngspice:${PORTSDIR}/cad/ngspice_rework
.endif

View file

@ -1,3 +1,3 @@
MD5 (gspiceui-v0.8.55.tar.gz) = 7a52d50456d21f259281350d88a926d3
SHA256 (gspiceui-v0.8.55.tar.gz) = 31d39cfafc9af48139cb29b303eca76a082f1dd25cbb91b04c30a292d3effb48
SIZE (gspiceui-v0.8.55.tar.gz) = 419458
MD5 (gspiceui-v0.8.90.tar.gz) = 6e0de5b02a5b4707d197bd8648b2d8df
SHA256 (gspiceui-v0.8.90.tar.gz) = 9618ba20a80baf054b5e0c25a75a6a5a6b54078e6e40ce196d0101a78b16d4d5
SIZE (gspiceui-v0.8.90.tar.gz) = 438270

View file

@ -1,24 +1,24 @@
--- src/Makefile.orig Wed Jan 11 23:09:15 2006
+++ src/Makefile Sat Apr 29 19:29:09 2006
--- src/Makefile.orig Tue Oct 17 12:17:20 2006
+++ src/Makefile Wed Nov 15 19:14:19 2006
@@ -23,7 +23,7 @@
PROG = gspiceui
# wxWidgets configuration utility
-WXCFG = wx-config
+WXCFG = wxgtk2u-2.6-config
+WXCFG = %%WX_CONFIG%%
# Directories
#ROOT := $(shell cd .. ; pwd)
@@ -45,10 +45,10 @@
endif
# Includes
INCLUDES =-I/usr/include -I/usr/X11R6/include -I. -Ibase -Imain -Inetlist \
--Ignucap -Ingspice -Iprocess -Iutility
+-Ignucap -Ingspice -Iprocess -Iutility $(shell wxgtk2u-2.6-config --cxxflags)
-INCLUDES =-I/usr/include -I/usr/X11R6/include -I.
+INCLUDES =-I/usr/include -I/usr/X11R6/include -I. $(shell %%WX_CONFIG%% --cxxflags)
# Libraries
-LIB := $(shell wx-config --libs)
+LIB := $(shell wxgtk2u-2.6-config --libs)
-LIB := $(shell wx-config --libs) $(shell pkg-config --libs pangox)
+LIB := $(shell %%WX_CONFIG%% --libs) $(shell pkg-config --libs pangox)
# Sources & headers
SRCS = *.cpp