graphics/glslang: update to 12.3.0
Changes: https://github.com/KhronosGroup/glslang/releases/tag/12.3.0 Reported by: GitHub (watch releases)
This commit is contained in:
parent
2ef79dee3d
commit
9b2d20ffc5
4 changed files with 17 additions and 5 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= glslang
|
||||
DISTVERSION= 12.2.0
|
||||
DISTVERSION= 12.3.0
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1684356476
|
||||
SHA256 (KhronosGroup-glslang-12.2.0_GH0.tar.gz) = 870d17030fda7308c1521fb2e01a9e93cbe4b130bc8274e90d00e127432ab6f6
|
||||
SIZE (KhronosGroup-glslang-12.2.0_GH0.tar.gz) = 3706316
|
||||
TIMESTAMP = 1689793027
|
||||
SHA256 (KhronosGroup-glslang-12.3.0_GH0.tar.gz) = 45e0c7efad184206495aa1888c9008e168628fd1d3867a6975a7cd61dd11f53f
|
||||
SIZE (KhronosGroup-glslang-12.3.0_GH0.tar.gz) = 3718594
|
||||
|
|
11
graphics/glslang/files/patch-StandAlone_CMakeLists.txt
Normal file
11
graphics/glslang/files/patch-StandAlone_CMakeLists.txt
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- StandAlone/CMakeLists.txt.orig 2023-07-19 18:57:07 UTC
|
||||
+++ StandAlone/CMakeLists.txt
|
||||
@@ -117,7 +117,7 @@ if(ENABLE_GLSLANG_INSTALL)
|
||||
# Create the same symlink at install time
|
||||
install(CODE "execute_process( \
|
||||
COMMAND ${CMAKE_COMMAND} -E create_symlink $<TARGET_FILE_NAME:glslang-standalone> ${legacy_glslang_name} \
|
||||
- WORKING_DIRECTORY ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_BINDIR})")
|
||||
+ WORKING_DIRECTORY \$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_BINDIR})")
|
||||
|
||||
if(ENABLE_SPVREMAPPER)
|
||||
install(TARGETS spirv-remap EXPORT glslang-targets)
|
|
@ -1,3 +1,4 @@
|
|||
bin/glslang
|
||||
bin/glslangValidator
|
||||
bin/spirv-remap
|
||||
include/glslang/HLSL/hlslAttributes.h
|
||||
|
@ -69,12 +70,12 @@ lib/cmake/OSDependentTargets.cmake
|
|||
lib/cmake/SPIRVTargets.cmake
|
||||
lib/cmake/SPVRemapperTargets.cmake
|
||||
lib/cmake/glslang-default-resource-limitsTargets.cmake
|
||||
lib/cmake/glslang-standaloneTargets.cmake
|
||||
lib/cmake/glslang/glslang-config-version.cmake
|
||||
lib/cmake/glslang/glslang-config.cmake
|
||||
lib/cmake/glslang/glslang-targets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
lib/cmake/glslang/glslang-targets.cmake
|
||||
lib/cmake/glslangTargets.cmake
|
||||
lib/cmake/glslangValidatorTargets.cmake
|
||||
lib/cmake/spirv-remapTargets.cmake
|
||||
lib/libGenericCodeGen.a
|
||||
lib/libHLSL.a
|
||||
|
|
Loading…
Reference in a new issue