Fix mistake with ossp-uuid: don't use --with-ossp-uuid, since it will need

the ossp library present, and then we never use it.
This commit is contained in:
Palle Girgensohn 2014-03-21 08:15:26 +00:00
parent 1992bca13e
commit 9b588a49ff
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=348732
10 changed files with 55 additions and 5 deletions

View file

@ -23,7 +23,7 @@ INSTALL_DIRS= contrib
SLAVE_ONLY= yes
COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --with-ossp-uuid
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl
post-install:
@- ${INSTALL_DATA} ${WRKSRC}/contrib/README ${STAGEDIR}${DOCSDIR}/contrib/README

View file

@ -369,3 +369,13 @@
+ return internal_uuid_create(5, (unsigned char *)ns,
+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
}
--- contrib/Makefile.orig 2014-03-21 09:09:12.000000000 +0100
+++ contrib/Makefile 2014-03-21 09:09:28.000000000 +0100
@@ -39,6 +39,7 @@
tablefunc \
test_parser \
tsearch2 \
+ uuid-ossp \
vacuumlo
ifeq ($(with_openssl),yes)

View file

@ -23,7 +23,7 @@ INSTALL_DIRS= contrib
SLAVE_ONLY= yes
COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --with-ossp-uuid
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
post-install:

View file

@ -369,3 +369,13 @@
+ return internal_uuid_create(5, (unsigned char *)ns,
+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
}
--- contrib/Makefile.orig 2014-03-21 08:54:03.000000000 +0100
+++ contrib/Makefile 2014-03-21 08:54:08.000000000 +0100
@@ -43,6 +43,7 @@
tablefunc \
test_parser \
tsearch2 \
+ uuid-ossp \
unaccent \
vacuumlo

View file

@ -22,7 +22,7 @@ INSTALL_DIRS= contrib
SLAVE_ONLY= yes
COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --with-ossp-uuid
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
post-install:

View file

@ -391,3 +391,13 @@
+ return internal_uuid_create(5, (unsigned char *)ns,
+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
}
--- contrib/Makefile.orig 2014-03-21 09:05:11.000000000 +0100
+++ contrib/Makefile 2014-03-21 09:05:29.000000000 +0100
@@ -48,6 +48,7 @@
test_parser \
tsearch2 \
unaccent \
+ uuid-ossp \
vacuumlo
ifeq ($(with_openssl),yes)

View file

@ -22,7 +22,7 @@ INSTALL_DIRS= contrib
SLAVE_ONLY= yes
COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-ossp-uuid --with-openssl
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
post-install:

View file

@ -391,3 +391,13 @@
+ return internal_uuid_create(5, (unsigned char *)ns,
+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
}
--- contrib/Makefile.orig 2014-03-21 09:01:58.000000000 +0100
+++ contrib/Makefile 2014-03-21 09:02:16.000000000 +0100
@@ -50,6 +50,7 @@
test_parser \
tsearch2 \
unaccent \
+ uuid-ossp \
vacuumlo
ifeq ($(with_openssl),yes)

View file

@ -23,7 +23,7 @@ INSTALL_DIRS= contrib
SLAVE_ONLY= yes
COMPONENT= -contrib
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --with-ossp-uuid --disable-nls
CONFIGURE_ARGS+=--with-libxslt --with-libxml --with-openssl --disable-nls
LDFLAGS+= ${PTHREAD_LIBS} -L${PREFIX}/lib
post-install:

View file

@ -397,3 +397,13 @@
+ return internal_uuid_create(5, (unsigned char *)ns,
+ VARDATA(name), VARSIZE(name) - VARHDRSZ);
}
--- contrib/Makefile.orig 2014-03-21 08:58:32.000000000 +0100
+++ contrib/Makefile 2014-03-21 08:59:13.000000000 +0100
@@ -52,6 +52,7 @@
test_parser \
tsearch2 \
unaccent \
+ uuid-ossp \
vacuumlo \
worker_spi