Add lang/mono-basic 2.4, VisualBasic.NET support for Mono.
PR: ports/135928 Submitted by: Romain Tartiere
This commit is contained in:
parent
bcc4367439
commit
9b5ea55ce4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=236512
6 changed files with 65 additions and 0 deletions
|
@ -175,6 +175,7 @@
|
|||
SUBDIR += mlton
|
||||
SUBDIR += mmix
|
||||
SUBDIR += mono
|
||||
SUBDIR += mono-basic
|
||||
SUBDIR += moscow_ml
|
||||
SUBDIR += mosh
|
||||
SUBDIR += mozart
|
||||
|
|
30
lang/mono-basic/Makefile
Normal file
30
lang/mono-basic/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# New ports collection makefile for: mono-basic
|
||||
# Date created: 2008-12-20
|
||||
# Whom: Romain Tartiere <romain@blogreen.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= mono-basic
|
||||
PORTVERSION= 2.4
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
|
||||
|
||||
MAINTAINER= mono@FreeBSD.org
|
||||
COMMENT= VisualBasic.NET support for Mono
|
||||
|
||||
BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
|
||||
RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
|
||||
|
||||
MAN1= vbnc.1
|
||||
|
||||
USE_BZIP2= yes
|
||||
HAS_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
tests: build
|
||||
@${ECHO_MSG} "===> Running ${PORTNAME} regression tests"
|
||||
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} \
|
||||
${MAKE_FLAGS} Makefile ${MAKE_ARGS} test)
|
||||
|
||||
.include <bsd.port.mk>
|
3
lang/mono-basic/distinfo
Normal file
3
lang/mono-basic/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (mono-basic-2.4.tar.bz2) = ee15480cfc667d514c958313ee980572
|
||||
SHA256 (mono-basic-2.4.tar.bz2) = 0964b5bbc2f6731f469e39a98ed2f212eed0886865fbbf24880d947e87a94416
|
||||
SIZE (mono-basic-2.4.tar.bz2) = 1207415
|
14
lang/mono-basic/files/patch-configure
Normal file
14
lang/mono-basic/files/patch-configure
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig
|
||||
+++ configure
|
||||
@@ -19,7 +19,7 @@
|
||||
echo "prefix=$prefix" > build/config.make
|
||||
echo "exec_prefix=\${prefix}" >> build/config.make
|
||||
echo "mono_libdir=\${exec_prefix}/lib" >> build/config.make
|
||||
-echo "man_dir=\${exec_prefix}/share/man" >> build/config.make
|
||||
+echo "man_dir=\${exec_prefix}/man" >> build/config.make
|
||||
echo "man1_dir=\${man_dir}/man1" >> build/config.make
|
||||
echo "MCS_FLAGS=-debug+" >> build/config.make
|
||||
echo "RUNTIME=mono" >> build/config.make
|
14
lang/mono-basic/files/patch-vbruntime_Test_Makefile
Normal file
14
lang/mono-basic/files/patch-vbruntime_Test_Makefile
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- vbruntime/Test/Makefile.orig
|
||||
+++ vbruntime/Test/Makefile
|
||||
@@ -62,7 +62,7 @@
|
||||
MONO_PATH=$(MONO_VB_PATH) mono ../../tools/extract-source/extract-source.exe -s:2005VB_test_CS.csproj -d:2005VB_test_CS.dll.sources.win -m:w
|
||||
|
||||
test-first:
|
||||
- cd ../Microsoft.VisualBasic && make && cp ../../class/lib/vbnc/Microsoft.VisualBasic.dll* ../Test/bin
|
||||
+ cd ../Microsoft.VisualBasic && ${MAKE} && cp ../../class/lib/vbnc/Microsoft.VisualBasic.dll* ../Test/bin
|
||||
|
||||
test-cs: test-first 2005VB_test_CS.dll.sources
|
||||
$(CSCOMPILER) "-out:bin/2005VB_test_CS.dll" @2005VB_test_CS.dll.rsp @2005VB_test_CS.dll.sources -lib:bin $(CSDEFINES)
|
3
lang/mono-basic/pkg-descr
Normal file
3
lang/mono-basic/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
Mono Basic: Visual Basic Compiler and Runtime.
|
||||
|
||||
WWW: http://www.mono-project.com/VisualBasic.NET
|
Loading…
Reference in a new issue