New port utserver version 436: Unreal Tournament Dedicated Server
for Linux Submitted by: Martin Matuska <matuska@wu-wien.ac.at> Reviewed by: Patrick Li <pat@databits.net>
This commit is contained in:
parent
203a7b96e5
commit
9b7914fbe7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48857
8 changed files with 624 additions and 0 deletions
|
@ -257,6 +257,7 @@
|
|||
SUBDIR += twitch
|
||||
SUBDIR += uclient
|
||||
SUBDIR += uox3
|
||||
SUBDIR += utserver
|
||||
SUBDIR += virt
|
||||
SUBDIR += wmeyes
|
||||
SUBDIR += wmminichess
|
||||
|
|
88
games/utserver/Makefile
Normal file
88
games/utserver/Makefile
Normal file
|
@ -0,0 +1,88 @@
|
|||
# New ports collection makefile for: Unreal Tournament Dedicated Server
|
||||
# Date created: Thu Oct 4 23:38:00 CEST 2001
|
||||
# Whom: Martin Matuska <matuska@wu-wien.ac.at> et al
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= utserver
|
||||
PORTVERSION= 436
|
||||
CATEGORIES= games linux
|
||||
MASTER_SITES= ftp://utservers:idspispopd@ftp.lokigames.com/ \
|
||||
http://arcadia.inf.udec.cl/ftp/pub/linux/ut-server/
|
||||
DISTNAME= ut-server-${PORTVERSION}
|
||||
|
||||
MAINTAINER= matuska@wu-wien.ac.at
|
||||
|
||||
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
USE_LINUX_PREFIX= yes
|
||||
NO_CDROM= "Size; the data set is much too big"
|
||||
NO_BUILD= yes
|
||||
WRKSRC= ${WRKDIR}/ut-server
|
||||
|
||||
UTDIR= usr/games/ut-server/
|
||||
PLIST_SUB= UTDIR="${UTDIR}"
|
||||
EXTRA_PATCHES= ${WRKDIR}/patch-ngstatsut
|
||||
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}
|
||||
SORT?= /usr/bin/sort
|
||||
|
||||
# files which should be installed with executable perms
|
||||
EXECUTABLES= ucc ucc-bin
|
||||
|
||||
pre-patch:
|
||||
# remove trailing ^M
|
||||
@find -E ${WRKSRC} -type f \
|
||||
-iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|int|lst|pl|pm|sc|sh|scr|txt|url|uhtm)" \
|
||||
-exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
|
||||
@${SED} -e "s!%%LOCALBASE%%!${LOCALBASE}!" \
|
||||
-e "s!%%LINUXBASE%%!${LINUXBASE}!" \
|
||||
-e "s!%%UTDIR%%!${UTDIR}!" \
|
||||
${FILESDIR}/template-patch-ngstatsut > \
|
||||
${WRKDIR}/patch-ngstatsut
|
||||
|
||||
do-install: install-parse-plist install-run-scripts
|
||||
|
||||
# Contributed by <lioux@FreeBSD.org>
|
||||
install-parse-plist: generate-plist
|
||||
@${PERL} -e 'open(FHANDLER,"${TMPPLIST}");' \
|
||||
-e 'open(FDIR,">${WRKDIR}/dirs.sh.tmp");' \
|
||||
-e 'open(FFILES,">${WRKDIR}/files.sh");' \
|
||||
-e 'while (!eof(FHANDLER)) {' \
|
||||
-e 'chop($$file = <FHANDLER>);' \
|
||||
-e '$$dir = $$file_partial = $$file;' \
|
||||
-e '$$file_partial =~ s!^${UTDIR}!!;' \
|
||||
-e 'print FDIR "${INSTALL_DIR}", \
|
||||
" ", "\"${PREFIX}/$$dir\"", \
|
||||
"\n" if $$dir =~ s!(^\@dirrm\s+)!!;' \
|
||||
-e 'if ($$file !~ m!^\@!) {' \
|
||||
-e '$$program_flag = 0;' \
|
||||
-e 'if ("${EXECUTABLES}" ne "") {' \
|
||||
-e 'foreach $$program_pattern \
|
||||
(split (/\s+/,"${EXECUTABLES}")) {' \
|
||||
-e '($$program_flag = 1 , break) \
|
||||
if ($$file =~ /$$program_pattern$$/);' \
|
||||
-e '}' \
|
||||
-e '}' \
|
||||
-e 'print FFILES ($$program_flag == 0) ? \
|
||||
"${INSTALL_DATA}" : "${INSTALL_SCRIPT}", \
|
||||
" ", "\"${WRKSRC}/$$file_partial\"", \
|
||||
" ", "\"${PREFIX}/$$file\"", \
|
||||
"\n";' \
|
||||
-e '}' \
|
||||
-e '}' \
|
||||
-e 'close(FFILES);' \
|
||||
-e 'close(FDIR);' \
|
||||
-e 'close(FHANDLER);'
|
||||
@${SORT} ${WRKDIR}/dirs.sh.tmp > ${WRKDIR}/dirs.sh
|
||||
|
||||
install-run-scripts:
|
||||
.for script in dirs files
|
||||
@${SH} ${WRKDIR}/${script}.sh
|
||||
.endfor
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
1
games/utserver/distinfo
Normal file
1
games/utserver/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (ut-server-436.tar.gz) = 875ad8c6d97a32f896e4ab8190075baf
|
21
games/utserver/files/template-patch-ngstatsut
Normal file
21
games/utserver/files/template-patch-ngstatsut
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- NetGamesUSA.com/ngStats/ngStatsUT Tue Aug 7 15:24:12 2001
|
||||
+++ NetGamesUSA.com/ngStats/ngStatsUT Tue Aug 7 15:32:36 2001
|
||||
@@ -5,13 +5,16 @@
|
||||
## to ensure that the files are actually found
|
||||
## this has not really been tested, hence the debug.
|
||||
## modified by abfackeln, 2000-10-10
|
||||
+##
|
||||
+## FreeBSD directories added by RebuM, 2001-08-07
|
||||
+##
|
||||
#######
|
||||
|
||||
-INSTALL_DIR=`cat $HOME/.loki/ut/install_dir`
|
||||
+INSTALL_DIR="%%LINUXBASE%%/%%UTDIR%%"
|
||||
|
||||
JAVA1=`which java`
|
||||
JAVA2="/usr/local/java/bin/java"
|
||||
-JAVA3="/usr/jdk1.2/bin/java"
|
||||
+JAVA3="%%LOCALBASE%%/linux-jdk1.2.2/bin/java"
|
||||
NGHOME1="../NetGamesUSA.com/ngStats"
|
||||
NGHOME2="$INSTALL_DIR/../NetGamesUSA.com/ngStats"
|
||||
NGHOME3="$HOME/UnrealTournament/NetGamesUSA.com/ngStats"
|
1
games/utserver/pkg-comment
Normal file
1
games/utserver/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Unreal Tournament Dedicated Server for Linux
|
14
games/utserver/pkg-descr
Normal file
14
games/utserver/pkg-descr
Normal file
|
@ -0,0 +1,14 @@
|
|||
This package contains all of the items you'll need to run a
|
||||
Unreal Tournament Dedicated Server under FreeBSD (with Linux
|
||||
emulation).
|
||||
|
||||
Dedicated server of the very popular first person shooter game.
|
||||
- default install points to '/compat/linux/usr/games/ut-server/'
|
||||
|
||||
WWW: http://ut.abfackeln.com/installer.html?page=dedicated
|
||||
|
||||
For more information about UT visit:
|
||||
http://www.unrealtournament.com/
|
||||
|
||||
For more information about configuring Linux UT servers visit:
|
||||
http://www.planetunreal.com/TheAdminPage/TheLinuxServer.htm
|
11
games/utserver/pkg-message
Normal file
11
games/utserver/pkg-message
Normal file
|
@ -0,0 +1,11 @@
|
|||
|
||||
*WARNING* *WARNING* *WARNING* *WARNING* *WARNING* *WARNING*
|
||||
------------------------------------------------------------
|
||||
It is highly recommended to run the UT server in a non-root
|
||||
environment. There is a zombie-process bug if running UT as
|
||||
user root.
|
||||
|
||||
If you want to use ngStats and/or ngWorldStats
|
||||
install linux-jdk-1.2.2 from /usr/ports/java/linux-jdk
|
||||
------------------------------------------------------------
|
||||
|
487
games/utserver/pkg-plist
Normal file
487
games/utserver/pkg-plist
Normal file
|
@ -0,0 +1,487 @@
|
|||
%%PORTDOCS%%%%UTDIR%%Help/Logo.bmp
|
||||
%%PORTDOCS%%%%UTDIR%%Help/ReadMe.htm
|
||||
%%PORTDOCS%%%%UTDIR%%Help/Unreal.ico
|
||||
%%PORTDOCS%%%%UTDIR%%Help/UnrealTournamentSetupLogo.bmp
|
||||
%%PORTDOCS%%%%UTDIR%%Help/UnrealTournamentSetupLogo.gif
|
||||
%%UTDIR%%Logs/delete_me.txt
|
||||
%%UTDIR%%Maps/AS-Frigate.unr
|
||||
%%UTDIR%%Maps/AS-Guardia.unr
|
||||
%%UTDIR%%Maps/AS-HiSpeed.unr
|
||||
%%UTDIR%%Maps/AS-Mazon.unr
|
||||
%%UTDIR%%Maps/AS-OceanFloor.unr
|
||||
%%UTDIR%%Maps/AS-Overlord.unr
|
||||
%%UTDIR%%Maps/AS-Rook.unr
|
||||
%%UTDIR%%Maps/CTF-Command.unr
|
||||
%%UTDIR%%Maps/CTF-Coret.unr
|
||||
%%UTDIR%%Maps/CTF-Dreary.unr
|
||||
%%UTDIR%%Maps/CTF-EternalCave.unr
|
||||
%%UTDIR%%Maps/CTF-Face.unr
|
||||
%%UTDIR%%Maps/CTF-Gauntlet.unr
|
||||
%%UTDIR%%Maps/CTF-LavaGiant.unr
|
||||
%%UTDIR%%Maps/CTF-Niven.unr
|
||||
%%UTDIR%%Maps/CTF-November.unr
|
||||
%%UTDIR%%Maps/DM-Barricade.unr
|
||||
%%UTDIR%%Maps/DM-Codex.unr
|
||||
%%UTDIR%%Maps/DM-Conveyor.unr
|
||||
%%UTDIR%%Maps/DM-Curse][.unr
|
||||
%%UTDIR%%Maps/DM-Deck16][.unr
|
||||
%%UTDIR%%Maps/DM-Fetid.unr
|
||||
%%UTDIR%%Maps/DM-Fractal.unr
|
||||
%%UTDIR%%Maps/DM-Gothic.unr
|
||||
%%UTDIR%%Maps/DM-Grinder.unr
|
||||
%%UTDIR%%Maps/DM-HyperBlast.unr
|
||||
%%UTDIR%%Maps/DM-KGalleon.unr
|
||||
%%UTDIR%%Maps/DM-Liandri.unr
|
||||
%%UTDIR%%Maps/DM-Morbias][.unr
|
||||
%%UTDIR%%Maps/DM-Morpheus.unr
|
||||
%%UTDIR%%Maps/DM-Oblivion.unr
|
||||
%%UTDIR%%Maps/DM-Peak.unr
|
||||
%%UTDIR%%Maps/DM-Phobos.unr
|
||||
%%UTDIR%%Maps/DM-Pressure.unr
|
||||
%%UTDIR%%Maps/DM-Pyramid.unr
|
||||
%%UTDIR%%Maps/DM-Stalwart.unr
|
||||
%%UTDIR%%Maps/DM-StalwartXL.unr
|
||||
%%UTDIR%%Maps/DM-Tempest.unr
|
||||
%%UTDIR%%Maps/DM-Turbine.unr
|
||||
%%UTDIR%%Maps/DM-Zeto.unr
|
||||
%%UTDIR%%Maps/DOM-Cinder.unr
|
||||
%%UTDIR%%Maps/DOM-Condemned.unr
|
||||
%%UTDIR%%Maps/DOM-Cryptic.unr
|
||||
%%UTDIR%%Maps/DOM-Gearbolt.unr
|
||||
%%UTDIR%%Maps/DOM-Ghardhen.unr
|
||||
%%UTDIR%%Maps/DOM-Lament.unr
|
||||
%%UTDIR%%Maps/DOM-Leadworks.unr
|
||||
%%UTDIR%%Maps/DOM-MetalDream.unr
|
||||
%%UTDIR%%Maps/DOM-Olden.unr
|
||||
%%UTDIR%%Maps/DOM-Sesmar.unr
|
||||
%%UTDIR%%Maps/Entry.unr
|
||||
%%UTDIR%%Music/Botmca9.umx
|
||||
%%UTDIR%%Music/Botpck10.umx
|
||||
%%UTDIR%%Music/Cannon.umx
|
||||
%%UTDIR%%Music/Colossus.umx
|
||||
%%UTDIR%%Music/Course.umx
|
||||
%%UTDIR%%Music/Credits.umx
|
||||
%%UTDIR%%Music/Ending.umx
|
||||
%%UTDIR%%Music/Enigma.umx
|
||||
%%UTDIR%%Music/Foregone.umx
|
||||
%%UTDIR%%Music/Godown.umx
|
||||
%%UTDIR%%Music/Lock.umx
|
||||
%%UTDIR%%Music/Mech8.umx
|
||||
%%UTDIR%%Music/Mission.umx
|
||||
%%UTDIR%%Music/Nether.umx
|
||||
%%UTDIR%%Music/Organic.umx
|
||||
%%UTDIR%%Music/Phantom.umx
|
||||
%%UTDIR%%Music/Razor-ub.umx
|
||||
%%UTDIR%%Music/Run.umx
|
||||
%%UTDIR%%Music/SaveMe.umx
|
||||
%%UTDIR%%Music/Savemeg.umx
|
||||
%%UTDIR%%Music/Seeker.umx
|
||||
%%UTDIR%%Music/Seeker2.umx
|
||||
%%UTDIR%%Music/Skyward.umx
|
||||
%%UTDIR%%Music/Strider.umx
|
||||
%%UTDIR%%Music/Suprfist.umx
|
||||
%%UTDIR%%Music/UnWorld2.umx
|
||||
%%UTDIR%%Music/Uttitle.umx
|
||||
%%UTDIR%%Music/Wheels.umx
|
||||
%%UTDIR%%Music/firebr.umx
|
||||
%%UTDIR%%Music/utmenu23.umx
|
||||
%%UTDIR%%NetGamesUSA.com/About_NetGames_USA.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/Readme-Help_Using_ngStats.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/data/db.ver
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/history.txt
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/About_Epic_Games.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/About_NetGames_USA.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/About_ngTCS.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/About_ngWorldStats.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/Help_Using_ngStats.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/Individual_Game_Stats/Highest_Score/index.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/Individual_Game_Stats/Last_Game/index.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/Individual_Game_Stats/Recent_Index.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/Legal_Terms.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/Total_Game_Stats/All_Totals.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/Total_Game_Stats/Bot_Totals.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/Total_Game_Stats/Human_Totals.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/Total_Game_Stats/Player_Index.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/Total_Game_Stats/Rankings.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/Total_Game_Stats/Total_Index.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/Change_ngWorldStats_Password.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/Confirm_Password.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/UT_Logo_Large_Button.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/UT_Logo_Small_Button.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/View_ngStats.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/View_ngWorldStats.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/blue_white.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/flags_279.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g1.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g10.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g11.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g12.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g13.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g14.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g15.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g16.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g17.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g18.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g19.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g2.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g20.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g21.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g22.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g23.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g24.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g25.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g26.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g27.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g28.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g29.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g3.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g30.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g31.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g32.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g4.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g5.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g6.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g7.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g8.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g9.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g_legend.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/g_no.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/graph_back_ngStats.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/graph_back_ngStats_big.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngStats.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngStats_106_Wide.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngStats_Processing.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngTCS_129x114.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngTCS_Lite_129x114.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngTCS_Pro_129x114.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngUSA_Logo.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngUSA_Logo_106_wide.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngWorldStats.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngWorldStats_500x83.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngWorldStats_ENABLED_240x70.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngWorldStats_ENABLED_88x31.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngWorldStats_Enabled_234x46.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/ngWorldStats_Password.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/unreallogo.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/graphics/white.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/ngStats_Main.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/processing.html
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin/README.txt
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin/custom_graphics/background.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin/custom_graphics/sidebar_120x90.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin/custom_graphics/skin_credit_88x31.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin/skin.css
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/skins/custom_graphics/background.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/skins/custom_graphics/sidebar_120x90.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/skins/custom_graphics/skin_credit_88x31.gif
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/html/skins/skin.css
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/ngStats End User License Agreement (EULA).txt
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/ngStatsUT
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/ngStatsUT.cfg
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/ngStatsUT.exe
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/ngusa.jar
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/processedLogs/_tmp
|
||||
%%UTDIR%%NetGamesUSA.com/ngStats/spawnBrowser.exe
|
||||
%%UTDIR%%NetGamesUSA.com/ngWorldStats/bin/ngWS.ver
|
||||
%%UTDIR%%NetGamesUSA.com/ngWorldStats/bin/ngWorldStats
|
||||
%%UTDIR%%NetGamesUSA.com/ngWorldStats/bin/ngWorldStats End User License Agreement (EULA).txt
|
||||
%%UTDIR%%NetGamesUSA.com/ngWorldStats/bin/ngWorldStats.exe
|
||||
%%UTDIR%%NetGamesUSA.com/ngWorldStats/logs/New_Install.log
|
||||
%%UTDIR%%Sounds/Activates.uax
|
||||
%%UTDIR%%Sounds/Addon1.uax
|
||||
%%UTDIR%%Sounds/AmbAncient.uax
|
||||
%%UTDIR%%Sounds/AmbCity.uax
|
||||
%%UTDIR%%Sounds/AmbModern.uax
|
||||
%%UTDIR%%Sounds/AmbOutside.uax
|
||||
%%UTDIR%%Sounds/Announcer.uax
|
||||
%%UTDIR%%Sounds/BossVoice.uax
|
||||
%%UTDIR%%Sounds/DDay.uax
|
||||
%%UTDIR%%Sounds/DMatch.uax
|
||||
%%UTDIR%%Sounds/DoorsAnc.uax
|
||||
%%UTDIR%%Sounds/DoorsMod.uax
|
||||
%%UTDIR%%Sounds/Extro.uax
|
||||
%%UTDIR%%Sounds/Female1Voice.uax
|
||||
%%UTDIR%%Sounds/Female2Voice.uax
|
||||
%%UTDIR%%Sounds/FemaleSounds.uax
|
||||
%%UTDIR%%Sounds/LadderSounds.uax
|
||||
%%UTDIR%%Sounds/Male1Voice.uax
|
||||
%%UTDIR%%Sounds/Male2Voice.uax
|
||||
%%UTDIR%%Sounds/MaleSounds.uax
|
||||
%%UTDIR%%Sounds/Pan1.uax
|
||||
%%UTDIR%%Sounds/TutVoiceAS.uax
|
||||
%%UTDIR%%Sounds/TutVoiceCTF.uax
|
||||
%%UTDIR%%Sounds/TutVoiceDM.uax
|
||||
%%UTDIR%%Sounds/TutVoiceDOM.uax
|
||||
%%UTDIR%%Sounds/VRikers.uax
|
||||
%%UTDIR%%Sounds/noxxsnd.uax
|
||||
%%UTDIR%%Sounds/openingwave.uax
|
||||
%%UTDIR%%Sounds/rain.uax
|
||||
%%UTDIR%%System/BossSkins.int
|
||||
%%UTDIR%%System/BotPack.u
|
||||
%%UTDIR%%System/Botpack.int
|
||||
%%UTDIR%%System/CommandoSkins.int
|
||||
%%UTDIR%%System/Core.int
|
||||
%%UTDIR%%System/Core.so
|
||||
%%UTDIR%%System/Core.u
|
||||
%%UTDIR%%System/DefUser.ini
|
||||
%%UTDIR%%System/Default.ini
|
||||
%%UTDIR%%System/Editor.int
|
||||
%%UTDIR%%System/Editor.so
|
||||
%%UTDIR%%System/Engine.int
|
||||
%%UTDIR%%System/Engine.so
|
||||
%%UTDIR%%System/Engine.u
|
||||
%%UTDIR%%System/FCommandoSkins.int
|
||||
%%UTDIR%%System/Female1Skins.int
|
||||
%%UTDIR%%System/Female2Skins.int
|
||||
%%UTDIR%%System/Fire.so
|
||||
%%UTDIR%%System/Fire.u
|
||||
%%UTDIR%%System/GlideDrv.int
|
||||
%%UTDIR%%System/GlobalStatsWeb.url
|
||||
%%UTDIR%%System/IpDrv.int
|
||||
%%UTDIR%%System/IpDrv.so
|
||||
%%UTDIR%%System/IpDrv.u
|
||||
%%UTDIR%%System/IpServer.int
|
||||
%%UTDIR%%System/IpServer.u
|
||||
%%UTDIR%%System/License.int
|
||||
%%UTDIR%%System/Male1Skins.int
|
||||
%%UTDIR%%System/Male2Skins.int
|
||||
%%UTDIR%%System/Male3Skins.int
|
||||
%%UTDIR%%System/Manifest.ini
|
||||
%%UTDIR%%System/Manifest.int
|
||||
%%UTDIR%%System/NetGamesUsaWeb.url
|
||||
%%UTDIR%%System/RunServer.bat
|
||||
%%UTDIR%%System/SDLDrv.so
|
||||
%%UTDIR%%System/SGirlSkins.int
|
||||
%%UTDIR%%System/Setup.int
|
||||
%%UTDIR%%System/SkTrooperSkins.int
|
||||
%%UTDIR%%System/SoldierSkins.int
|
||||
%%UTDIR%%System/Startup.int
|
||||
%%UTDIR%%System/UBrowser.int
|
||||
%%UTDIR%%System/UBrowser.u
|
||||
%%UTDIR%%System/UMenu.int
|
||||
%%UTDIR%%System/UMenu.u
|
||||
%%UTDIR%%System/UTBrowser.u
|
||||
%%UTDIR%%System/UTMenu.int
|
||||
%%UTDIR%%System/UTMenu.u
|
||||
%%UTDIR%%System/UTServerAdmin.int
|
||||
%%UTDIR%%System/UTServerAdmin.u
|
||||
%%UTDIR%%System/UWeb.int
|
||||
%%UTDIR%%System/UWeb.so
|
||||
%%UTDIR%%System/UWeb.u
|
||||
%%UTDIR%%System/UWindow.u
|
||||
%%UTDIR%%System/Unreal.int
|
||||
%%UTDIR%%System/UnrealEd.int
|
||||
%%UTDIR%%System/UnrealI.int
|
||||
%%UTDIR%%System/UnrealI.u
|
||||
%%UTDIR%%System/UnrealIOrder.int
|
||||
%%UTDIR%%System/UnrealShare.int
|
||||
%%UTDIR%%System/UnrealShare.u
|
||||
%%UTDIR%%System/UnrealTournament.ini
|
||||
%%UTDIR%%System/UnrealTournament.ini.PATCH
|
||||
%%UTDIR%%System/UnrealTournament.int
|
||||
%%UTDIR%%System/UnrealTournamentRemoteAdmin.url
|
||||
%%UTDIR%%System/UnrealTournamentWeb.url
|
||||
%%UTDIR%%System/User.ini
|
||||
%%UTDIR%%System/Window.int
|
||||
%%UTDIR%%System/de.int
|
||||
%%UTDIR%%System/de.u
|
||||
%%UTDIR%%System/ucc-bin
|
||||
%%UTDIR%%Textures/AlfaFX.utx
|
||||
%%UTDIR%%Textures/Ancient.utx
|
||||
%%UTDIR%%Textures/ArenaTex.utx
|
||||
%%UTDIR%%Textures/Belt_fx.utx
|
||||
%%UTDIR%%Textures/BluffFX.utx
|
||||
%%UTDIR%%Textures/BossSkins.utx
|
||||
%%UTDIR%%Textures/CTF.utx
|
||||
%%UTDIR%%Textures/ChizraEFX.utx
|
||||
%%UTDIR%%Textures/Coret_FX.utx
|
||||
%%UTDIR%%Textures/Creative.utx
|
||||
%%UTDIR%%Textures/Crypt.utx
|
||||
%%UTDIR%%Textures/Crypt2.utx
|
||||
%%UTDIR%%Textures/Crypt_FX.utx
|
||||
%%UTDIR%%Textures/DDayFX.utx
|
||||
%%UTDIR%%Textures/DMeffects.utx
|
||||
%%UTDIR%%Textures/DacomaFem.utx
|
||||
%%UTDIR%%Textures/DacomaSkins.utx
|
||||
%%UTDIR%%Textures/DecayedS.utx
|
||||
%%UTDIR%%Textures/Detail.utx
|
||||
%%UTDIR%%Textures/Egypt.utx
|
||||
%%UTDIR%%Textures/EgyptPan.utx
|
||||
%%UTDIR%%Textures/FCommandoSkins.utx
|
||||
%%UTDIR%%Textures/Faces.utx
|
||||
%%UTDIR%%Textures/Female1Skins.utx
|
||||
%%UTDIR%%Textures/Female2Skins.utx
|
||||
%%UTDIR%%Textures/FireEng.utx
|
||||
%%UTDIR%%Textures/FlareFX.utx
|
||||
%%UTDIR%%Textures/FractalFX.utx
|
||||
%%UTDIR%%Textures/GenEarth.utx
|
||||
%%UTDIR%%Textures/GenFX.utx
|
||||
%%UTDIR%%Textures/GenFluid.utx
|
||||
%%UTDIR%%Textures/GenIn.utx
|
||||
%%UTDIR%%Textures/GenTerra.utx
|
||||
%%UTDIR%%Textures/GenWarp.utx
|
||||
%%UTDIR%%Textures/GothFem.utx
|
||||
%%UTDIR%%Textures/GothSkins.utx
|
||||
%%UTDIR%%Textures/GreatFire.utx
|
||||
%%UTDIR%%Textures/GreatFire2.utx
|
||||
%%UTDIR%%Textures/HubEffects.utx
|
||||
%%UTDIR%%Textures/ISVFX.utx
|
||||
%%UTDIR%%Textures/Indus1.utx
|
||||
%%UTDIR%%Textures/Indus2.utx
|
||||
%%UTDIR%%Textures/Indus3.utx
|
||||
%%UTDIR%%Textures/Indus4.utx
|
||||
%%UTDIR%%Textures/Indus5.utx
|
||||
%%UTDIR%%Textures/Indus6.utx
|
||||
%%UTDIR%%Textures/Indus7.utx
|
||||
%%UTDIR%%Textures/JWSky.utx
|
||||
%%UTDIR%%Textures/LadderFonts.utx
|
||||
%%UTDIR%%Textures/LadrArrow.utx
|
||||
%%UTDIR%%Textures/LadrStatic.utx
|
||||
%%UTDIR%%Textures/LavaFX.utx
|
||||
%%UTDIR%%Textures/Lian-X.utx
|
||||
%%UTDIR%%Textures/Liquids.utx
|
||||
%%UTDIR%%Textures/Logo.utx
|
||||
%%UTDIR%%Textures/Male1Skins.utx
|
||||
%%UTDIR%%Textures/Male2Skins.utx
|
||||
%%UTDIR%%Textures/Male3Skins.utx
|
||||
%%UTDIR%%Textures/MenuGr.utx
|
||||
%%UTDIR%%Textures/Metalmys.utx
|
||||
%%UTDIR%%Textures/Mine.utx
|
||||
%%UTDIR%%Textures/NaliCast.utx
|
||||
%%UTDIR%%Textures/NaliFX.utx
|
||||
%%UTDIR%%Textures/NivenFX.utx
|
||||
%%UTDIR%%Textures/Old_FX.utx
|
||||
%%UTDIR%%Textures/Palettes.utx
|
||||
%%UTDIR%%Textures/PhraelFx.utx
|
||||
%%UTDIR%%Textures/PlayrShp.utx
|
||||
%%UTDIR%%Textures/Queen.utx
|
||||
%%UTDIR%%Textures/RainFX.utx
|
||||
%%UTDIR%%Textures/Render.utx
|
||||
%%UTDIR%%Textures/RotatingU.utx
|
||||
%%UTDIR%%Textures/SGirlSkins.utx
|
||||
%%UTDIR%%Textures/Scripted.utx
|
||||
%%UTDIR%%Textures/ShaneChurch.utx
|
||||
%%UTDIR%%Textures/ShaneDay.utx
|
||||
%%UTDIR%%Textures/ShaneSky.utx
|
||||
%%UTDIR%%Textures/SkTrooperSkins.utx
|
||||
%%UTDIR%%Textures/Skaarj.utx
|
||||
%%UTDIR%%Textures/SkyBox.utx
|
||||
%%UTDIR%%Textures/SkyCity.utx
|
||||
%%UTDIR%%Textures/Slums.utx
|
||||
%%UTDIR%%Textures/Soldierskins.utx
|
||||
%%UTDIR%%Textures/SpaceFX.utx
|
||||
%%UTDIR%%Textures/Starship.utx
|
||||
%%UTDIR%%Textures/TCrystal.utx
|
||||
%%UTDIR%%Textures/Terranius.utx
|
||||
%%UTDIR%%Textures/TrenchesFX.utx
|
||||
%%UTDIR%%Textures/UT.utx
|
||||
%%UTDIR%%Textures/UT_ArtFX.utx
|
||||
%%UTDIR%%Textures/UTbase1.utx
|
||||
%%UTDIR%%Textures/UTcrypt.utx
|
||||
%%UTDIR%%Textures/UTtech1.utx
|
||||
%%UTDIR%%Textures/UTtech2.utx
|
||||
%%UTDIR%%Textures/UTtech3.utx
|
||||
%%UTDIR%%Textures/UWindowFonts.utx
|
||||
%%UTDIR%%Textures/XFX.utx
|
||||
%%UTDIR%%Textures/XbpFX.utx
|
||||
%%UTDIR%%Textures/Xtortion.utx
|
||||
%%UTDIR%%Textures/castle1.utx
|
||||
%%UTDIR%%Textures/city.utx
|
||||
%%UTDIR%%Textures/commandoskins.utx
|
||||
%%UTDIR%%Textures/credits.utx
|
||||
%%UTDIR%%Textures/eol.utx
|
||||
%%UTDIR%%Textures/of1.utx
|
||||
%%UTDIR%%Web/current.uhtm
|
||||
%%UTDIR%%Web/current_console.uhtm
|
||||
%%UTDIR%%Web/current_console_log.uhtm
|
||||
%%UTDIR%%Web/current_console_send.uhtm
|
||||
%%UTDIR%%Web/current_game.uhtm
|
||||
%%UTDIR%%Web/current_menu.uhtm
|
||||
%%UTDIR%%Web/current_mutators.uhtm
|
||||
%%UTDIR%%Web/current_players.uhtm
|
||||
%%UTDIR%%Web/defaults.uhtm
|
||||
%%UTDIR%%Web/defaults_bots.uhtm
|
||||
%%UTDIR%%Web/defaults_ippolicy-d.uhtm
|
||||
%%UTDIR%%Web/defaults_ippolicy-f.uhtm
|
||||
%%UTDIR%%Web/defaults_ippolicy-h.uhtm
|
||||
%%UTDIR%%Web/defaults_maps.uhtm
|
||||
%%UTDIR%%Web/defaults_menu.uhtm
|
||||
%%UTDIR%%Web/defaults_rules.uhtm
|
||||
%%UTDIR%%Web/defaults_server.uhtm
|
||||
%%UTDIR%%Web/defaults_settings.uhtm
|
||||
%%UTDIR%%Web/images/1-1.gif
|
||||
%%UTDIR%%Web/images/1-2.gif
|
||||
%%UTDIR%%Web/images/1.gif
|
||||
%%UTDIR%%Web/images/2-1.gif
|
||||
%%UTDIR%%Web/images/2-2.gif
|
||||
%%UTDIR%%Web/images/3-1.gif
|
||||
%%UTDIR%%Web/images/3-2.gif
|
||||
%%UTDIR%%Web/images/4-1.gif
|
||||
%%UTDIR%%Web/images/4-2.gif
|
||||
%%UTDIR%%Web/images/5-1.gif
|
||||
%%UTDIR%%Web/images/5-2.gif
|
||||
%%UTDIR%%Web/images/6-1.gif
|
||||
%%UTDIR%%Web/images/6-2.gif
|
||||
%%UTDIR%%Web/images/7-1.gif
|
||||
%%UTDIR%%Web/images/7-2.gif
|
||||
%%UTDIR%%Web/images/7-3.gif
|
||||
%%UTDIR%%Web/images/image.gif
|
||||
%%UTDIR%%Web/images/logo.gif
|
||||
%%UTDIR%%Web/images/m1-1.gif
|
||||
%%UTDIR%%Web/images/m1-2.gif
|
||||
%%UTDIR%%Web/images/m3-1.gif
|
||||
%%UTDIR%%Web/images/m3-2.gif
|
||||
%%UTDIR%%Web/images/right.gif
|
||||
%%UTDIR%%Web/menu.uhtm
|
||||
%%UTDIR%%Web/message.uhtm
|
||||
%%UTDIR%%Web/plaintext/current.uhtm
|
||||
%%UTDIR%%Web/plaintext/current_console.uhtm
|
||||
%%UTDIR%%Web/plaintext/current_console_log.uhtm
|
||||
%%UTDIR%%Web/plaintext/current_console_send.uhtm
|
||||
%%UTDIR%%Web/plaintext/current_game.uhtm
|
||||
%%UTDIR%%Web/plaintext/current_menu.uhtm
|
||||
%%UTDIR%%Web/plaintext/current_mutators.uhtm
|
||||
%%UTDIR%%Web/plaintext/current_players.uhtm
|
||||
%%UTDIR%%Web/plaintext/defaults.uhtm
|
||||
%%UTDIR%%Web/plaintext/defaults_bots.uhtm
|
||||
%%UTDIR%%Web/plaintext/defaults_ippolicy-d.uhtm
|
||||
%%UTDIR%%Web/plaintext/defaults_ippolicy-f.uhtm
|
||||
%%UTDIR%%Web/plaintext/defaults_ippolicy-h.uhtm
|
||||
%%UTDIR%%Web/plaintext/defaults_maps.uhtm
|
||||
%%UTDIR%%Web/plaintext/defaults_menu.uhtm
|
||||
%%UTDIR%%Web/plaintext/defaults_rules.uhtm
|
||||
%%UTDIR%%Web/plaintext/defaults_server.uhtm
|
||||
%%UTDIR%%Web/plaintext/defaults_settings.uhtm
|
||||
%%UTDIR%%Web/plaintext/menu.uhtm
|
||||
%%UTDIR%%Web/plaintext/message.uhtm
|
||||
%%UTDIR%%Web/plaintext/root.uhtm
|
||||
%%UTDIR%%Web/root.uhtm
|
||||
%%UTDIR%%ucc
|
||||
@dirrm %%UTDIR%%Web/plaintext
|
||||
@dirrm %%UTDIR%%Web/images
|
||||
@dirrm %%UTDIR%%Web
|
||||
@dirrm %%UTDIR%%Textures
|
||||
@dirrm %%UTDIR%%System
|
||||
@dirrm %%UTDIR%%Sounds
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngWorldStats/logs
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngWorldStats/bin
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngWorldStats
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats/processedLogs
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats/html/skins/custom_graphics
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin/custom_graphics
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats/html/skins/Default NetGamesUSA Skin
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats/html/skins
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats/html/graphics
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats/html/Total_Game_Stats
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats/html/Individual_Game_Stats/Last_Game
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats/html/Individual_Game_Stats/Highest_Score
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats/html/Individual_Game_Stats
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats/html
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats/data
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com/ngStats
|
||||
@dirrm %%UTDIR%%NetGamesUSA.com
|
||||
@dirrm %%UTDIR%%Music
|
||||
@dirrm %%UTDIR%%Maps
|
||||
@dirrm %%UTDIR%%Logs
|
||||
%%PORTDOCS%%@dirrm %%UTDIR%%Help
|
||||
@unexec rmdir %D/%%UTDIR%% 2>/dev/null || echo "If you are permanently removing this port, you should do a ``rm -rf ${PKG_PREFIX}/%%UTDIR%%`` to remove any configuration files and logs left." | fmt
|
Loading…
Reference in a new issue