Update to 5.5.2
PR: ports/80770 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
parent
552137bf98
commit
9b844bc2fc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=134899
5 changed files with 55 additions and 30 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= plplot
|
||||
PORTVERSION= 5.3.1
|
||||
PORTVERSION= 5.5.2
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -15,7 +15,9 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= A scientific plotting package
|
||||
|
||||
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
|
||||
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
|
||||
LIB_DEPENDS= unicode.0:${PORTSDIR}/devel/libunicode \
|
||||
gd.4:${PORTSDIR}/graphics/gd \
|
||||
qhull.5:${PORTSDIR}/math/qhull
|
||||
|
||||
USE_LIBLTDL= yes
|
||||
USE_REINPLACE= yes
|
||||
|
@ -23,11 +25,12 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib" \
|
||||
GDINCDIR="${LOCALBASE}/include" \
|
||||
GDLIBDIR="${LOCALBASE}/lib" \
|
||||
M4="${LOCALBASE}/bin/gm4"
|
||||
CONFIGURE_ARGS= --disable-cgm --disable-java --disable-octave \
|
||||
--with-ltdlsystem --without-qhull
|
||||
--with-ltdlsystem \
|
||||
--with-gd-incdir=${LOCALBASE}/include \
|
||||
--with-gd-libdir=${LOCALBASE}/lib \
|
||||
--with-freetype-font-dir=${LOCALBASE}
|
||||
INSTALLS_SHLIB= yes
|
||||
PLIST_SUB= VERSION="${PORTVERSION}"
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (plplot-5.3.1.tar.gz) = 3487a6b2a78a064188a80f244b341d33
|
||||
SIZE (plplot-5.3.1.tar.gz) = 5543320
|
||||
MD5 (plplot-5.5.2.tar.gz) = bef62f05b317005fbf36c2fc3c191338
|
||||
SIZE (plplot-5.5.2.tar.gz) = 5891255
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- bindings/tcl/Makefile.in.orig Mon Feb 2 20:40:59 2004
|
||||
+++ bindings/tcl/Makefile.in Tue Feb 10 01:10:30 2004
|
||||
@@ -932,7 +932,7 @@
|
||||
|
||||
info-am:
|
||||
|
||||
-install-data-am: install-pkgincludeHEADERS install-tclDATA
|
||||
+install-data-am: @enable_tcl_TRUE@install-pkgincludeHEADERS install-tclDATA
|
||||
|
||||
install-exec-am: install-libLTLIBRARIES
|
||||
|
||||
--- bindings/tcl/Makefile.in.orig Thu Apr 21 05:35:22 2005
|
||||
+++ bindings/tcl/Makefile.in Sun May 8 12:18:36 2005
|
||||
@@ -482,7 +482,7 @@
|
||||
with_qhull_TRUE = @with_qhull_TRUE@
|
||||
with_rpath_FALSE = @with_rpath_FALSE@
|
||||
with_rpath_TRUE = @with_rpath_TRUE@
|
||||
-tcldir = $(TCL_DIR)
|
||||
+@enable_tcl_TRUE@tcldir = $(TCL_DIR)
|
||||
libplplot = $(top_builddir)/src/libplplot$(LIB_TAG).la
|
||||
libmatrix = libtclmatrix$(LIB_TAG).la
|
||||
@enable_tcl_TRUE@generated_scripts = plplot.tcl
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- bindings/tk/Makefile.in.orig Mon Feb 2 20:40:59 2004
|
||||
+++ bindings/tk/Makefile.in Tue Feb 10 01:12:09 2004
|
||||
@@ -744,7 +744,7 @@
|
||||
|
||||
info-am:
|
||||
|
||||
-install-data-am: install-pkgincludeHEADERS install-tclDATA
|
||||
+install-data-am: @enable_tk_TRUE@install-pkgincludeHEADERS install-tclDATA
|
||||
|
||||
install-exec-am: install-binPROGRAMS
|
||||
--- bindings/tk/Makefile.in.orig Thu Apr 21 05:35:23 2005
|
||||
+++ bindings/tk/Makefile.in Sun May 8 12:19:29 2005
|
||||
@@ -467,7 +467,7 @@
|
||||
with_qhull_TRUE = @with_qhull_TRUE@
|
||||
with_rpath_FALSE = @with_rpath_FALSE@
|
||||
with_rpath_TRUE = @with_rpath_TRUE@
|
||||
-tcldir = $(TCL_DIR)
|
||||
+@enable_tk_TRUE@tcldir = $(TCL_DIR)
|
||||
libplplottcltk = $(top_builddir)/bindings/tcl/libplplottcltk$(LIB_TAG).la
|
||||
libplplot = $(top_builddir)/src/libplplot$(LIB_TAG).la
|
||||
|
||||
|
|
|
@ -9,6 +9,7 @@ bin/pltek
|
|||
bin/pstex2eps
|
||||
include/plplot/disptab.h
|
||||
include/plplot/drivers.h
|
||||
include/plplot/gcw.h
|
||||
include/plplot/pdf.h
|
||||
include/plplot/plConfig.h
|
||||
include/plplot/plDevs.h
|
||||
|
@ -16,16 +17,21 @@ include/plplot/pldebug.h
|
|||
include/plplot/plevent.h
|
||||
include/plplot/plplot.h
|
||||
include/plplot/plplotP.h
|
||||
include/plplot/plplotcanvas.h
|
||||
include/plplot/plstream.h
|
||||
include/plplot/plstrm.h
|
||||
%%TCLTK%%include/plplot/pltcl.h
|
||||
include/plplot/pltcl.h
|
||||
%%TCLTK%%include/plplot/pltk.h
|
||||
include/plplot/plxwd.h
|
||||
%%TCLTK%%include/plplot/tclMatrix.h
|
||||
include/plplot/tclMatrix.h
|
||||
lib/libcsirocsa.a
|
||||
lib/libcsirocsa.la
|
||||
lib/libcsirocsa.so
|
||||
lib/libcsirocsa.so.0
|
||||
lib/libcsironn.a
|
||||
lib/libcsironn.la
|
||||
lib/libcsironn.so
|
||||
lib/libcsironn.so.0
|
||||
lib/libplplotcxxd.a
|
||||
lib/libplplotcxxd.la
|
||||
lib/libplplotcxxd.so
|
||||
|
@ -101,13 +107,18 @@ lib/plplot%%VERSION%%/driversd/xfig.so
|
|||
%%PORTDOCS%%%%DOCSDIR%%/PROBLEMS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.1st.csa
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.1st.nn
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.csa
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.drivers
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.nn
|
||||
%%DATADIR%%%%VERSION%%/cglobe.map
|
||||
%%DATADIR%%%%VERSION%%/examples/Makefile
|
||||
%%DATADIR%%%%VERSION%%/examples/c/Makefile
|
||||
%%DATADIR%%%%VERSION%%/examples/c/README.plplotcanvas
|
||||
%%DATADIR%%%%VERSION%%/examples/c/lena.pgm
|
||||
%%DATADIR%%%%VERSION%%/examples/c/plcdemos.h
|
||||
%%DATADIR%%%%VERSION%%/examples/c/plplotcanvas_animation.c
|
||||
%%DATADIR%%%%VERSION%%/examples/c/plplotcanvas_demo.c
|
||||
%%DATADIR%%%%VERSION%%/examples/c/tutor.c
|
||||
%%DATADIR%%%%VERSION%%/examples/c/x01c.c
|
||||
%%DATADIR%%%%VERSION%%/examples/c/x02c.c
|
||||
|
@ -131,6 +142,8 @@ lib/plplot%%VERSION%%/driversd/xfig.so
|
|||
%%DATADIR%%%%VERSION%%/examples/c/x20c.c
|
||||
%%DATADIR%%%%VERSION%%/examples/c/x21c.c
|
||||
%%DATADIR%%%%VERSION%%/examples/c/x22c.c
|
||||
%%DATADIR%%%%VERSION%%/examples/c/x23c.c
|
||||
%%DATADIR%%%%VERSION%%/examples/c/x24c.c
|
||||
%%DATADIR%%%%VERSION%%/examples/c++/Makefile
|
||||
%%DATADIR%%%%VERSION%%/examples/c++/lena.pgm
|
||||
%%DATADIR%%%%VERSION%%/examples/c++/x01.cc
|
||||
|
@ -156,6 +169,8 @@ lib/plplot%%VERSION%%/driversd/xfig.so
|
|||
%%DATADIR%%%%VERSION%%/examples/c++/x20.cc
|
||||
%%DATADIR%%%%VERSION%%/examples/c++/x21.cc
|
||||
%%DATADIR%%%%VERSION%%/examples/c++/x22.cc
|
||||
%%DATADIR%%%%VERSION%%/examples/c++/x23.cc
|
||||
%%DATADIR%%%%VERSION%%/examples/c++/x24.cc
|
||||
%%DATADIR%%%%VERSION%%/examples/f77/Makefile
|
||||
%%DATADIR%%%%VERSION%%/examples/f77/x01f.f
|
||||
%%DATADIR%%%%VERSION%%/examples/f77/x02f.f
|
||||
|
@ -200,9 +215,14 @@ lib/plplot%%VERSION%%/driversd/xfig.so
|
|||
%%DATADIR%%%%VERSION%%/examples/perl/x20.pl
|
||||
%%DATADIR%%%%VERSION%%/examples/perl/x21.pl
|
||||
%%DATADIR%%%%VERSION%%/examples/perl/x22.pl
|
||||
%%DATADIR%%%%VERSION%%/examples/perl/x23.pl
|
||||
%%DATADIR%%%%VERSION%%/examples/perl/x24.pl
|
||||
%%DATADIR%%%%VERSION%%/examples/plplot-test.sh
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/README.plplotcanvas
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/README.pythondemos
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/plplot_python_start.py
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/plplotcanvas_animation.py
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/plplotcanvas_demo.py
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/prova.py
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/pythondemos.py
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/qplplot.py
|
||||
|
@ -225,6 +245,7 @@ lib/plplot%%VERSION%%/driversd/xfig.so
|
|||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/x17
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/x18
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/x22
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/x23
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/xw01.py
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/xw02.py
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/xw03.py
|
||||
|
@ -245,6 +266,7 @@ lib/plplot%%VERSION%%/driversd/xfig.so
|
|||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/xw18.py
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/xw19.py
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/xw22.py
|
||||
%%PYTHON%%%%DATADIR%%%%VERSION%%/examples/python/xw23.py
|
||||
%%TCLTK%%%%DATADIR%%%%VERSION%%/examples/tcl/README.tcldemos
|
||||
%%TCLTK%%%%DATADIR%%%%VERSION%%/examples/tcl/plgrid.tcl
|
||||
%%TCLTK%%%%DATADIR%%%%VERSION%%/examples/tcl/plot.dat
|
||||
|
|
Loading…
Reference in a new issue