o) Update to version 4.50.91
o) Change package name from xbae to Xbae o) Add CONFIGURE_TARGET (new autoconf) o) Fix compile error of ner version on FreeBSD 4 PR: ports/67359 Submitted by: Roman Neuhauser <neuhauser@chello.cz>
This commit is contained in:
parent
5984367937
commit
9b93f5197d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=110407
5 changed files with 153 additions and 454 deletions
|
@ -7,8 +7,8 @@
|
|||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= xbae
|
||||
PORTVERSION= 4.50.0
|
||||
PORTNAME= Xbae
|
||||
PORTVERSION= 4.50.91
|
||||
CATEGORIES= x11-toolkits math
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= xbae
|
||||
|
@ -19,6 +19,7 @@ COMMENT= A Motif-based widget which displays a grid of cells as a spreadsheet
|
|||
|
||||
USE_LIBTOOL_VER=13
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
USE_MOTIF= yes
|
||||
USE_X_PREFIX= yes
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (Xbae-4.50.0.tar.gz) = 8233877eae34f114f6f05590543af4ad
|
||||
SIZE (Xbae-4.50.0.tar.gz) = 1270772
|
||||
MD5 (Xbae-4.50.91.tar.gz) = 7580353e86ca452b481608b67586fc3c
|
||||
SIZE (Xbae-4.50.91.tar.gz) = 1413828
|
||||
|
|
|
@ -1,357 +1,36 @@
|
|||
diff -bru acconfig.h acconfig.h
|
||||
--- acconfig.h Thu Aug 16 12:35:43 2001
|
||||
+++ acconfig.h Sat Nov 23 15:52:20 2002
|
||||
@@ -6,3 +6,6 @@
|
||||
#undef HAVE_LIB_XP
|
||||
|
||||
#undef HAVE_MOTIF
|
||||
+
|
||||
+/* Build a production version of the library */
|
||||
+#undef XBAE_PRODUCTION
|
||||
diff -bru configure configure
|
||||
--- configure Wed Oct 16 13:56:36 2002
|
||||
+++ configure Sat Nov 23 15:52:48 2002
|
||||
@@ -1002,6 +1002,7 @@
|
||||
--disable-libtool-lock avoid locking (might break parallel builds)
|
||||
--enable-maintainer-mode enable make rules and dependencies not useful
|
||||
(and sometimes confusing) to the casual installer
|
||||
+ --enable-production build a production version
|
||||
|
||||
Optional Packages:
|
||||
--with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
|
||||
@@ -4694,7 +4695,7 @@
|
||||
case $host in
|
||||
*-*-irix6*)
|
||||
# Find out which ABI we are using.
|
||||
- echo '#line 4697 "configure"' > conftest.$ac_ext
|
||||
+ echo '#line 4698 "configure"' > conftest.$ac_ext
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
||||
(eval $ac_compile) 2>&5
|
||||
ac_status=$?
|
||||
@@ -5230,7 +5231,7 @@
|
||||
save_CFLAGS="$CFLAGS"
|
||||
CFLAGS="$CFLAGS -o out/conftest2.$ac_objext"
|
||||
compiler_c_o=no
|
||||
-if { (eval echo configure:5233: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>out/conftest.err; } && test -s out/conftest2.$ac_objext; then
|
||||
+if { (eval echo configure:5234: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>out/conftest.err; } && test -s out/conftest2.$ac_objext; then
|
||||
# The compiler can only warn and ignore the option if not recognized
|
||||
# So say no if there are warnings
|
||||
if test -s out/conftest.err; then
|
||||
@@ -7023,7 +7024,7 @@
|
||||
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
|
||||
lt_status=$lt_dlunknown
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
-#line 7026 "configure"
|
||||
+#line 7027 "configure"
|
||||
#include "confdefs.h"
|
||||
|
||||
#if HAVE_DLFCN_H
|
||||
@@ -7121,7 +7122,7 @@
|
||||
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
|
||||
lt_status=$lt_dlunknown
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
-#line 7124 "configure"
|
||||
+#line 7125 "configure"
|
||||
#include "confdefs.h"
|
||||
|
||||
#if HAVE_DLFCN_H
|
||||
@@ -9611,6 +9612,19 @@
|
||||
echo "$as_me:$LINENO: result: libraries $motif_libraries_result, headers $motif_includes_result" >&5
|
||||
echo "${ECHO_T}libraries $motif_libraries_result, headers $motif_includes_result" >&6
|
||||
|
||||
+
|
||||
+# Check whether --enable-production or --disable-production was given.
|
||||
+if test "${enable_production+set}" = set; then
|
||||
+ enableval="$enable_production"
|
||||
+
|
||||
+fi;
|
||||
+
|
||||
+if test "x$enable_production" = "xyes" ; then
|
||||
+ cat >>confdefs.h <<\_ACEOF
|
||||
+#define XBAE_PRODUCTION 1
|
||||
+_ACEOF
|
||||
+
|
||||
+fi
|
||||
|
||||
if (aclocal --print-ac-dir) </dev/null >/dev/null 2>&1 && test -w `aclocal --print-ac-dir`; then
|
||||
ACLOCALDIR=`aclocal --print-ac-dir`
|
||||
diff -bru configure.in configure.in
|
||||
--- configure.in Wed Oct 16 13:44:30 2002
|
||||
+++ configure.in Sat Nov 23 15:52:20 2002
|
||||
@@ -98,6 +98,20 @@
|
||||
dnl
|
||||
AC_FIND_MOTIF
|
||||
|
||||
+dnl
|
||||
+dnl Build a production version of the library
|
||||
+dnl This will compile out XdbDebug statements
|
||||
+dnl (the libraries itself remain binary compatible, you can
|
||||
+dnl link against a debug version, run with a production version
|
||||
+dnl and vice versa!)
|
||||
+dnl
|
||||
+AC_ARG_ENABLE(production,
|
||||
+[ --enable-production build a production version])
|
||||
+
|
||||
+if test "x$enable_production" = "xyes" ; then
|
||||
+ AC_DEFINE(XBAE_PRODUCTION)
|
||||
+fi
|
||||
+
|
||||
dnl Run test in a subshell; some versions of sh will print an error if
|
||||
dnl an executable is not found, even if stderr is redirected.
|
||||
dnl Redirect stdin to placate older versions of autoconf. Sigh.
|
||||
diff -bru include/XbaeDebug.h include/XbaeDebug.h
|
||||
--- include/XbaeDebug.h Sat Apr 6 10:01:19 2002
|
||||
+++ include/XbaeDebug.h Sat Nov 23 15:52:20 2002
|
||||
@@ -136,7 +136,7 @@
|
||||
void _XbaeDebugAction(const char *fn, Widget w, const String action,
|
||||
const String *params, const Cardinal *num_params);
|
||||
|
||||
-#ifdef LESSTIF_PRODUCTION
|
||||
+#ifdef XBAE_PRODUCTION
|
||||
#define _XbaeDebugInDebug(x, y) False
|
||||
#define DEBUGOUT(x)
|
||||
|
||||
@@ -146,7 +146,7 @@
|
||||
#else
|
||||
Boolean _XbaeDebugInDebug(const char *fn, Widget w);
|
||||
#define DEBUGOUT(x) x
|
||||
-#endif /* LESSTIF_PRODUCTION */
|
||||
+#endif /* XBAE_PRODUCTION */
|
||||
|
||||
/*
|
||||
* Some stuff to produce sensible tracing with dmalloc.
|
||||
diff -bru src/DebugUtil.c src/DebugUtil.c
|
||||
--- src/DebugUtil.c Thu Jul 25 16:37:10 2002
|
||||
+++ src/DebugUtil.c Sat Nov 23 15:52:20 2002
|
||||
@@ -77,7 +77,7 @@
|
||||
Boolean _XbaeDebugInDebug(const char *fn, Widget w);
|
||||
|
||||
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
/* All external interfaces need to be in place for both,
|
||||
debug and production build. We may just reduce them
|
||||
to empty stubs ... */
|
||||
@@ -130,16 +130,16 @@
|
||||
* enabled or disabled upon program start. Valid Values are on/off.
|
||||
* e.g. XBAE_DEBUG_TOGGLE=off
|
||||
*
|
||||
- * If the C macro LESSTIF_PRODUCTION is defined, then _XbaeDebug etc. don't
|
||||
+ * If the C macro XBAE_PRODUCTION is defined, then _XbaeDebug etc. don't
|
||||
* work. Note: this is a compile time option.
|
||||
* To have maximum performance, sequences of _XbaeDebug statements should be
|
||||
* surrounded by an if (_XbaeDebugInDebug(__FILE__, w)) statement.
|
||||
- * _XbaeDebugInDebug is False when LESSTIF_PRODUCTION is defined.
|
||||
+ * _XbaeDebugInDebug is False when XBAE_PRODUCTION is defined.
|
||||
*/
|
||||
|
||||
|
||||
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
static Boolean _XbaeDebugFlag = True;
|
||||
static FILE *_XbaeDebugFile = NULL;
|
||||
typedef void (*sighandler_t)(int);
|
||||
@@ -638,7 +638,7 @@
|
||||
|
||||
|
||||
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
/* catches the signal defined by XBAE_DEBUG_SIGNAL and toggles the
|
||||
global debugging flag.
|
||||
Avoid calling C-runtime functions from within here if possible
|
||||
@@ -719,7 +719,7 @@
|
||||
return True;
|
||||
} /* signo != NOSIG */
|
||||
} /* siginstall() */
|
||||
-#endif /* LESSTIF_PRODUCTION */
|
||||
+#endif /* XBAE_PRODUCTION */
|
||||
|
||||
|
||||
/* some initialization.
|
||||
@@ -727,7 +727,7 @@
|
||||
is en- or disabled currently */
|
||||
extern Boolean
|
||||
_XbaeDebugInit(void) {
|
||||
-#ifdef LESSTIF_PRODUCTION
|
||||
+#ifdef XBAE_PRODUCTION
|
||||
return False;
|
||||
#else
|
||||
static Boolean init=False;
|
||||
@@ -751,7 +751,7 @@
|
||||
#endif
|
||||
}
|
||||
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
static void
|
||||
_XbaeDebugOpenFile(void)
|
||||
*** src/ScrollMgr.c.orig Mon Apr 12 07:49:28 2004
|
||||
--- src/ScrollMgr.c Sun May 30 14:37:57 2004
|
||||
***************
|
||||
*** 951,957 ****
|
||||
xbaeRedrawCells(XbaeMatrixWidget mw, Rectangle *expose)
|
||||
{
|
||||
@@ -1009,13 +1009,13 @@
|
||||
}
|
||||
} /* ValidateSource() */
|
||||
int startCol, endCol, startRow, endRow, i, j;
|
||||
! Rectangle rect;
|
||||
Boolean set_mask = False;
|
||||
|
||||
-#endif /* !LESSTIF_PRODUCTION */
|
||||
+#endif /* !XBAE_PRODUCTION */
|
||||
|
||||
|
||||
extern void
|
||||
_XbaeDebug(const char *fn, Widget w, const char *fmt, ...)
|
||||
DEBUGOUT(_XbaeDebug(__FILE__, (Widget)mw,
|
||||
--- 951,957 ----
|
||||
xbaeRedrawCells(XbaeMatrixWidget mw, Rectangle *expose)
|
||||
{
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
va_list ap;
|
||||
int startCol, endCol, startRow, endRow, i, j;
|
||||
! Rectangle rect, matrix_expose;
|
||||
Boolean set_mask = False;
|
||||
|
||||
#ifdef DEBUGVALIDATE
|
||||
@@ -1049,14 +1049,14 @@
|
||||
DEBUGOUT(_XbaeDebug(__FILE__, (Widget)mw,
|
||||
***************
|
||||
*** 963,969 ****
|
||||
return;
|
||||
|
||||
fflush(_XbaeDebugFile);
|
||||
}
|
||||
-#endif /* !LESSTIF_PRODUCTION */
|
||||
+#endif /* !XBAE_PRODUCTION */
|
||||
}
|
||||
#if 1
|
||||
! Rectangle matrix_expose;
|
||||
SETRECT(matrix_expose,
|
||||
expose->x1 + FIXED_COLUMN_LABEL_OFFSET(mw),
|
||||
expose->y1 + FIXED_ROW_LABEL_OFFSET(mw),
|
||||
--- 963,969 ----
|
||||
return;
|
||||
|
||||
|
||||
extern void
|
||||
_XbaeDebug2(const char *fn, Widget w, Widget c, const char *fmt, ...)
|
||||
{
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
va_list ap;
|
||||
|
||||
if (_XbaeDebugInit() && ValidateSource(fn))
|
||||
@@ -1100,14 +1100,14 @@
|
||||
vfprintf(_XbaeDebugFile, fmt, ap);
|
||||
va_end(ap);
|
||||
}
|
||||
-#endif /* !LESSTIF_PRODUCTION */
|
||||
+#endif /* !XBAE_PRODUCTION */
|
||||
}
|
||||
|
||||
|
||||
extern void
|
||||
_XbaeDebug0(const char *fn, Widget w, const char *fmt, ...)
|
||||
{
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
va_list ap;
|
||||
|
||||
if (_XbaeDebugInit() && ValidateSource(fn))
|
||||
@@ -1116,7 +1116,7 @@
|
||||
vfprintf(_XbaeDebugFile, fmt, ap);
|
||||
va_end(ap);
|
||||
}
|
||||
-#endif /* !LESSTIF_PRODUCTION */
|
||||
+#endif /* !XBAE_PRODUCTION */
|
||||
}
|
||||
|
||||
|
||||
@@ -1125,7 +1125,7 @@
|
||||
extern Boolean
|
||||
_XbaeDebugInDebug(const char *fn, Widget w)
|
||||
{
|
||||
-#ifdef LESSTIF_PRODUCTION
|
||||
+#ifdef XBAE_PRODUCTION
|
||||
return False;
|
||||
#else
|
||||
return ValidateSource(fn);
|
||||
@@ -1165,7 +1165,7 @@
|
||||
extern void
|
||||
_XbaeDebugSet(Boolean flag)
|
||||
{
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
if (flag)
|
||||
_XbaeDebugFlag = True;
|
||||
else
|
||||
@@ -1180,7 +1180,7 @@
|
||||
extern void
|
||||
_XbaeDebugToggle(void)
|
||||
{
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
_XbaeDebugFlag = !_XbaeDebugFlag;
|
||||
#endif
|
||||
}
|
||||
@@ -1190,7 +1190,7 @@
|
||||
extern Boolean
|
||||
_XbaeDebugQueryState(void)
|
||||
{
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
return _XbaeDebugFlag;
|
||||
#else
|
||||
return False;
|
||||
@@ -1198,7 +1198,7 @@
|
||||
}
|
||||
|
||||
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
static Boolean
|
||||
__XbaeDebugPrintWidgetID(void)
|
||||
{
|
||||
@@ -1263,7 +1263,7 @@
|
||||
extern void
|
||||
_XbaeDebugPrintTree(Widget w)
|
||||
{
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
__XbaeDebugPrintTree(w, 0);
|
||||
#endif
|
||||
}
|
||||
@@ -1272,7 +1272,7 @@
|
||||
extern void
|
||||
_XbaeDebugPrintCompleteTree(Widget w)
|
||||
{
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
Widget ww = w;
|
||||
|
||||
while (ww)
|
||||
@@ -1303,7 +1303,7 @@
|
||||
extern void
|
||||
_XbaeDebugPrintArgList(const char *fn, Widget w, ArgList al, int n, Boolean Get)
|
||||
{
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
int i;
|
||||
unsigned num;
|
||||
|
||||
@@ -1483,7 +1483,7 @@
|
||||
}
|
||||
}
|
||||
}
|
||||
-#endif/* !LESSTIF_PRODUCTION */
|
||||
+#endif/* !XBAE_PRODUCTION */
|
||||
}
|
||||
|
||||
|
||||
@@ -1493,7 +1493,7 @@
|
||||
extern void
|
||||
_XbaeDebugPrintString(const char *s)
|
||||
{
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
_XbaeDebugOpenFile();
|
||||
fprintf(_XbaeDebugFile, "%s", s);
|
||||
#endif
|
||||
@@ -2382,7 +2382,7 @@
|
||||
_XbaeDebugAction(const char *fn, Widget w, const String action,
|
||||
const String *params, const Cardinal *num_params)
|
||||
{
|
||||
-#ifndef LESSTIF_PRODUCTION
|
||||
+#ifndef XBAE_PRODUCTION
|
||||
|
||||
if (_XbaeDebugInit() && ValidateSource(fn)) {
|
||||
int i;
|
||||
@@ -2411,7 +2411,7 @@
|
||||
|
||||
fflush(_XbaeDebugFile);
|
||||
}
|
||||
-#endif /* !LESSTIF_PRODUCTION */
|
||||
+#endif /* !XBAE_PRODUCTION */
|
||||
}
|
||||
|
||||
/*
|
||||
#if 1
|
||||
! /* Rectangle matrix_expose;*/
|
||||
SETRECT(matrix_expose,
|
||||
expose->x1 + FIXED_COLUMN_LABEL_OFFSET(mw),
|
||||
expose->y1 + FIXED_ROW_LABEL_OFFSET(mw),
|
||||
|
|
|
@ -1,25 +1,25 @@
|
|||
--- doc/Makefile.am.orig Sun Oct 6 13:19:58 2002
|
||||
+++ doc/Makefile.am Sat Nov 23 16:20:46 2002
|
||||
--- doc/Makefile.am.orig Sat May 29 23:24:50 2004
|
||||
+++ doc/Makefile.am Sat May 29 23:24:57 2004
|
||||
@@ -15,7 +15,7 @@
|
||||
# Lets put the informational stuff in a sub directory to avoid
|
||||
# polluting /usr/local for default installs.
|
||||
#
|
||||
-docdir= $(prefix)/Xbae
|
||||
+docdir= $(datadir)/Xbae
|
||||
-docdir= $(datadir)/Xbae
|
||||
+docdir= $(datadir)/doc/Xbae
|
||||
|
||||
doc_DATA= \
|
||||
contents.html coverplus.html difffonts.html \
|
||||
--- doc/Makefile.in.orig Wed Oct 16 14:00:35 2002
|
||||
+++ doc/Makefile.in Sat Nov 23 16:21:05 2002
|
||||
@@ -127,7 +127,7 @@
|
||||
--- doc/Makefile.in.orig Sat May 29 23:25:16 2004
|
||||
+++ doc/Makefile.in Sat May 29 23:25:18 2004
|
||||
@@ -214,7 +214,7 @@
|
||||
# Lets put the informational stuff in a sub directory to avoid
|
||||
# polluting /usr/local for default installs.
|
||||
#
|
||||
-docdir = $(prefix)/Xbae
|
||||
+docdir = $(datadir)/Xbae
|
||||
|
||||
-docdir = $(datadir)/Xbae
|
||||
+docdir = $(datadir)/doc/Xbae
|
||||
doc_DATA = \
|
||||
contents.html coverplus.html difffonts.html \
|
||||
index.html main.html morelines.html \
|
||||
--- Makefile.am.orig Tue Aug 20 12:03:13 2002
|
||||
+++ Makefile.am Sat Nov 23 16:28:21 2002
|
||||
@@ -16,7 +16,7 @@
|
||||
|
@ -27,62 +27,82 @@
|
|||
endif
|
||||
|
||||
-docdir= $(prefix)/Xbae
|
||||
+docdir= $(datadir)/Xbae
|
||||
doc_DATA= NEWS README INSTALL
|
||||
+docdir= $(datadir)/doc/Xbae
|
||||
doc_DATA= NEWS README
|
||||
|
||||
.PHONY: changelog UpdateCheck
|
||||
--- Makefile.in.orig Wed Oct 16 13:56:23 2002
|
||||
+++ Makefile.in Sat Nov 23 16:28:17 2002
|
||||
@@ -125,7 +125,7 @@
|
||||
--- Makefile.in.orig Sat May 29 22:51:17 2004
|
||||
+++ Makefile.in Sat May 29 23:03:58 2004
|
||||
@@ -226,7 +226,7 @@
|
||||
|
||||
aclocaldir = @ACLOCALDIR@
|
||||
@Aclocal_TRUE@aclocal_DATA = ac_find_xbae.m4
|
||||
|
||||
-docdir = $(prefix)/Xbae
|
||||
+docdir = $(datadir)/Xbae
|
||||
doc_DATA = NEWS README INSTALL
|
||||
+docdir = $(datadir)/doc/Xbae
|
||||
doc_DATA = NEWS README
|
||||
|
||||
#
|
||||
--- examples/builderXcessory/Makefile.am.orig Tue Jan 25 17:39:52 2000
|
||||
+++ examples/builderXcessory/Makefile.am Sat Nov 23 16:27:50 2002
|
||||
@@ -627,7 +627,7 @@
|
||||
|
||||
info-am:
|
||||
|
||||
-install-data-am: install-aclocalDATA install-docDATA
|
||||
+install-data-am: install-docDATA
|
||||
|
||||
install-exec-am:
|
||||
|
||||
--- examples/builderXcessory/Makefile.am.orig Sat May 29 23:20:22 2004
|
||||
+++ examples/builderXcessory/Makefile.am Sat May 29 23:20:26 2004
|
||||
@@ -9,7 +9,7 @@
|
||||
xbae.wml \
|
||||
xbae_ctrl.tcl
|
||||
|
||||
-examplesdir = $(prefix)/Xbae/examples/builderXcessory
|
||||
+examplesdir = $(datadir)/Xbae/examples/builderXcessory
|
||||
-examplesdir = $(datadir)/Xbae/examples/builderXcessory
|
||||
+examplesdir = $(datadir)/examples/Xbae/builderXcessory
|
||||
examples_DATA = \
|
||||
XbaeCaption.col XbaeInput.col XbaeMatrix.col \
|
||||
XbaeCaption.pix XbaeInput.pix XbaeMatrix.pix \
|
||||
--- examples/builderXcessory/Makefile.in.orig Wed Oct 16 14:00:28 2002
|
||||
+++ examples/builderXcessory/Makefile.in Sat Nov 23 16:27:46 2002
|
||||
@@ -122,7 +122,7 @@
|
||||
--- examples/builderXcessory/Makefile.in.orig Sat May 29 23:23:48 2004
|
||||
+++ examples/builderXcessory/Makefile.in Sat May 29 23:23:52 2004
|
||||
@@ -203,7 +203,7 @@
|
||||
xbae.wml \
|
||||
xbae_ctrl.tcl
|
||||
|
||||
|
||||
-examplesdir = $(prefix)/Xbae/examples/builderXcessory
|
||||
+examplesdir = $(datadir)/Xbae/examples/builderXcessory
|
||||
-examplesdir = $(datadir)/Xbae/examples/builderXcessory
|
||||
+examplesdir = $(datadir)/examples/Xbae/builderXcessory
|
||||
examples_DATA = \
|
||||
XbaeCaption.col XbaeInput.col XbaeMatrix.col \
|
||||
XbaeCaption.pix XbaeInput.pix XbaeMatrix.pix \
|
||||
--- doc/images/Makefile.am.orig Tue Aug 20 14:11:11 2002
|
||||
+++ doc/images/Makefile.am Sat Nov 23 16:27:21 2002
|
||||
--- src/Makefile.in.orig Sat May 29 23:37:07 2004
|
||||
+++ src/Makefile.in Sat May 29 23:37:10 2004
|
||||
@@ -525,7 +525,7 @@
|
||||
|
||||
info-am:
|
||||
|
||||
-install-data-am: install-htmlDATA install-man
|
||||
+install-data-am: install-man
|
||||
|
||||
install-exec-am: install-libLTLIBRARIES
|
||||
|
||||
--- doc/images/Makefile.am.orig Sat May 29 23:25:49 2004
|
||||
+++ doc/images/Makefile.am Sat May 29 23:25:53 2004
|
||||
@@ -10,7 +10,7 @@
|
||||
# Lets put the informational stuff in a sub directory to avoid
|
||||
# polluting /usr/local for default installs.
|
||||
#
|
||||
-imagedir= $(exec_prefix)/Xbae/images
|
||||
+imagedir= $(datadir)/Xbae/images
|
||||
-imagedir= $(datadir)/Xbae/images
|
||||
+imagedir= $(datadir)/doc/Xbae/images
|
||||
|
||||
|
||||
|
||||
--- doc/images/Makefile.in.orig Wed Oct 16 14:00:42 2002
|
||||
+++ doc/images/Makefile.in Sat Nov 23 16:27:15 2002
|
||||
@@ -122,7 +122,7 @@
|
||||
--- doc/images/Makefile.in.orig Sat May 29 23:26:09 2004
|
||||
+++ doc/images/Makefile.in Sat May 29 23:26:14 2004
|
||||
@@ -203,7 +203,7 @@
|
||||
# Lets put the informational stuff in a sub directory to avoid
|
||||
# polluting /usr/local for default installs.
|
||||
#
|
||||
-imagedir = $(exec_prefix)/Xbae/images
|
||||
+imagedir = $(datadir)/Xbae/images
|
||||
-imagedir = $(datadir)/Xbae/images
|
||||
+imagedir = $(datadir)/doc/Xbae/images
|
||||
|
||||
#
|
||||
# Cut the distribution size, don't distribute these in a source
|
||||
|
|
|
@ -10,60 +10,59 @@ include/Xbae/patchlevel.h
|
|||
lib/libXbae.la
|
||||
lib/libXbae.so
|
||||
lib/libXbae.so.4
|
||||
share/Xbae/FAQ.html
|
||||
share/Xbae/INSTALL
|
||||
share/Xbae/NEWS
|
||||
share/Xbae/README
|
||||
share/Xbae/contents.html
|
||||
share/Xbae/coverplus.html
|
||||
share/Xbae/difffonts.html
|
||||
share/Xbae/examples/builderXcessory/XbaeCaption.col
|
||||
share/Xbae/examples/builderXcessory/XbaeCaption.pix
|
||||
share/Xbae/examples/builderXcessory/XbaeInput.col
|
||||
share/Xbae/examples/builderXcessory/XbaeInput.pix
|
||||
share/Xbae/examples/builderXcessory/XbaeMatrix.col
|
||||
share/Xbae/examples/builderXcessory/XbaeMatrix.pix
|
||||
share/Xbae/examples/builderXcessory/local.cat
|
||||
share/Xbae/examples/builderXcessory/xbae.wml
|
||||
share/Xbae/examples/builderXcessory/xbae_ctrl.tcl
|
||||
share/Xbae/images/LDO.jpg
|
||||
share/Xbae/images/add.jpg
|
||||
share/Xbae/images/bg.png
|
||||
share/Xbae/images/capfloor1.png
|
||||
share/Xbae/images/capfloor3.png
|
||||
share/Xbae/images/caption.png
|
||||
share/Xbae/images/choice.png
|
||||
share/Xbae/images/colors.jpg
|
||||
share/Xbae/images/coverplus.png
|
||||
share/Xbae/images/draw.png
|
||||
share/Xbae/images/fifteen.jpg
|
||||
share/Xbae/images/input.png
|
||||
share/Xbae/images/lesstif.png
|
||||
share/Xbae/images/list.jpg
|
||||
share/Xbae/images/mailbox.png
|
||||
share/Xbae/images/matrix.jpg
|
||||
share/Xbae/images/multifixed.jpg
|
||||
share/Xbae/images/new.png
|
||||
share/Xbae/images/organize.jpg
|
||||
share/Xbae/images/pricing.jpg
|
||||
share/Xbae/images/risk.jpg
|
||||
share/Xbae/images/select-push.jpg
|
||||
share/Xbae/images/taam.png
|
||||
share/Xbae/images/updated.png
|
||||
share/Xbae/images/xbasket.png
|
||||
share/Xbae/images/xbill2-2.png
|
||||
share/Xbae/images/xbum1-2.png
|
||||
share/Xbae/index.html
|
||||
share/Xbae/main.html
|
||||
share/Xbae/morelines.html
|
||||
share/Xbae/psdriver.html
|
||||
share/Xbae/scrolling.html
|
||||
share/Xbae/sites.html
|
||||
share/Xbae/spancells.html
|
||||
share/Xbae/title.html
|
||||
share/Xbae/users.html
|
||||
@dirrm share/Xbae/images
|
||||
@dirrm share/Xbae/examples/builderXcessory
|
||||
@dirrm share/Xbae/examples
|
||||
@dirrm share/Xbae
|
||||
%%DOCSDIR%%/FAQ.html
|
||||
%%DOCSDIR%%/NEWS
|
||||
%%DOCSDIR%%/README
|
||||
%%DOCSDIR%%/contents.html
|
||||
%%DOCSDIR%%/coverplus.html
|
||||
%%DOCSDIR%%/difffonts.html
|
||||
%%DOCSDIR%%/images/LDO.jpg
|
||||
%%DOCSDIR%%/images/add.jpg
|
||||
%%DOCSDIR%%/images/bg.png
|
||||
%%DOCSDIR%%/images/capfloor1.png
|
||||
%%DOCSDIR%%/images/capfloor3.png
|
||||
%%DOCSDIR%%/images/caption.png
|
||||
%%DOCSDIR%%/images/choice.png
|
||||
%%DOCSDIR%%/images/colors.jpg
|
||||
%%DOCSDIR%%/images/coverplus.png
|
||||
%%DOCSDIR%%/images/draw.png
|
||||
%%DOCSDIR%%/images/fifteen.jpg
|
||||
%%DOCSDIR%%/images/input.png
|
||||
%%DOCSDIR%%/images/lesstif.png
|
||||
%%DOCSDIR%%/images/list.jpg
|
||||
%%DOCSDIR%%/images/mailbox.png
|
||||
%%DOCSDIR%%/images/matrix.jpg
|
||||
%%DOCSDIR%%/images/multifixed.jpg
|
||||
%%DOCSDIR%%/images/new.png
|
||||
%%DOCSDIR%%/images/organize.jpg
|
||||
%%DOCSDIR%%/images/pricing.jpg
|
||||
%%DOCSDIR%%/images/risk.jpg
|
||||
%%DOCSDIR%%/images/select-push.jpg
|
||||
%%DOCSDIR%%/images/taam.png
|
||||
%%DOCSDIR%%/images/updated.png
|
||||
%%DOCSDIR%%/images/xbasket.png
|
||||
%%DOCSDIR%%/images/xbill2-2.png
|
||||
%%DOCSDIR%%/images/xbum1-2.png
|
||||
%%DOCSDIR%%/index.html
|
||||
%%DOCSDIR%%/main.html
|
||||
%%DOCSDIR%%/morelines.html
|
||||
%%DOCSDIR%%/psdriver.html
|
||||
%%DOCSDIR%%/scrolling.html
|
||||
%%DOCSDIR%%/sites.html
|
||||
%%DOCSDIR%%/spancells.html
|
||||
%%DOCSDIR%%/title.html
|
||||
%%DOCSDIR%%/users.html
|
||||
%%EXAMPLESDIR%%/builderXcessory/XbaeCaption.col
|
||||
%%EXAMPLESDIR%%/builderXcessory/XbaeCaption.pix
|
||||
%%EXAMPLESDIR%%/builderXcessory/XbaeInput.col
|
||||
%%EXAMPLESDIR%%/builderXcessory/XbaeInput.pix
|
||||
%%EXAMPLESDIR%%/builderXcessory/XbaeMatrix.col
|
||||
%%EXAMPLESDIR%%/builderXcessory/XbaeMatrix.pix
|
||||
%%EXAMPLESDIR%%/builderXcessory/local.cat
|
||||
%%EXAMPLESDIR%%/builderXcessory/xbae.wml
|
||||
%%EXAMPLESDIR%%/builderXcessory/xbae_ctrl.tcl
|
||||
@dirrm %%DOCSDIR%%/images
|
||||
@dirrm %%DOCSDIR%%
|
||||
@dirrm share/examples/Xbae/builderXcessory
|
||||
@dirrm share/examples/Xbae
|
||||
@dirrm include/Xbae
|
||||
|
|
Loading…
Reference in a new issue