Add glurp, a Gtk2 client to musicpd.

PR:		ports/67757
Submitted by:	Mark Daniel Reidel <ports@mark.reidel.info>
This commit is contained in:
Pav Lucistnik 2004-06-11 14:35:22 +00:00
parent 40b7698be1
commit 9b9cbc596d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=111279
6 changed files with 59 additions and 0 deletions

View file

@ -116,6 +116,7 @@
SUBDIR += gkrellmvolume SUBDIR += gkrellmvolume
SUBDIR += gkrellmvolume2 SUBDIR += gkrellmvolume2
SUBDIR += glame SUBDIR += glame
SUBDIR += glurp
SUBDIR += gmixer SUBDIR += gmixer
SUBDIR += gmpc SUBDIR += gmpc
SUBDIR += gnapster SUBDIR += gnapster

22
audio/glurp/Makefile Normal file
View file

@ -0,0 +1,22 @@
# New ports collection makefile for: glurp
# Date created: Jun 9 2004
# Whom: Mark Reidel <ports@mark.reidel.info>
#
# $FreeBSD$
#
PORTNAME= glurp
PORTVERSION= 0.3.1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@mark.reidel.info
COMMENT= Nice and clean GTK+-2.x based graphical client for musicpd
GNU_CONFIGURE= yes
USE_GNOME= libglade2
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
.include <bsd.port.mk>

2
audio/glurp/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (glurp-0.3.1.tar.gz) = 5e576b54f1bea9593d2361edd69eceb2
SIZE (glurp-0.3.1.tar.gz) = 80252

View file

@ -0,0 +1,10 @@
--- src/includes.h.orig Wed Jun 9 16:41:28 2004
+++ src/includes.h Sat Jun 5 21:01:51 2004
@@ -11,6 +11,7 @@
#define N_(str) str
#endif
+#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <netinet/tcp.h>

11
audio/glurp/pkg-descr Normal file
View file

@ -0,0 +1,11 @@
A GTK2 based graphical client with simple and clean interface.
Features
* Support for loading/saving playlists
* File Browser
* Playlist Quicksearch
* Supports streams in MPD (MPD 0.11.0 and higher)
* ID3 Information
* Single window interface, with possibility to hide the playlist
WWW: http://www.musicpd.org/?page=glurp

13
audio/glurp/pkg-plist Normal file
View file

@ -0,0 +1,13 @@
bin/glurp
share/glurp/pixmaps/media-audiofile.png
share/glurp/pixmaps/media-stream.png
share/glurp/pixmaps/player-prev.png
share/glurp/pixmaps/player-play.png
share/glurp/pixmaps/player-pause.png
share/glurp/pixmaps/player-stop.png
share/glurp/pixmaps/player-next.png
share/glurp/pixmaps/player-repeat.png
share/glurp/pixmaps/player-shuffle.png
share/glurp/glurp.glade
@dirrm share/glurp/pixmaps
@dirrm share/glurp