Fix build at 10.x.
While here: . use stage phase; . use MKDIR macro instead of INSTALL -d one to create a directory; . unmute install command. PR: ports/182315 Submitted by: Sergio Mangialardi <sergio@softshark.org> (maintainer)
This commit is contained in:
parent
784f47daef
commit
9bb1215a34
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=328032
3 changed files with 15 additions and 7 deletions
|
@ -23,7 +23,6 @@ CONFIGURE_ARGS= --with-motif-libraries="${LIBXMDIR}" \
|
|||
|
||||
PLIST_SUB= VERSION=${PORTVERSION}
|
||||
|
||||
MAN1= ddd.1
|
||||
DOCS= AUTHORS INSTALL PROBLEMS README TIPS TODO \
|
||||
doc/html/ddd.html doc/ddd-paper.ps \
|
||||
doc/ddd-themes.pdf doc/ddd.pdf
|
||||
|
@ -39,7 +38,6 @@ LIBXMDIR!= ${ECHO_CMD} ${MOTIFLIB} | ${SED} -e 's/-L//g' | ${AWK} '{print $$1}'
|
|||
LIBXMDIR= ${LOCALBASE}
|
||||
.endif
|
||||
|
||||
NO_STAGE= yes
|
||||
pre-patch:
|
||||
@${RM} -fv ${WRKSRC}/ddd/ddd.info*
|
||||
@${RM} -fv ${WRKSRC}/ddd/ddd-themes.info*
|
||||
|
@ -52,13 +50,11 @@ post-configure:
|
|||
@${ECHO_CMD} "LIBXM = ${MOTIFLIB}" >> ${WRKSRC}/ddd/Makefile
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${INSTALL} -d -o ${DOCOWN} -g ${DOCGRP} ${DOCSDIR}
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for file in ${DOCS}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
@${GZIP_CMD} ${DOCSDIR}/*.ps
|
||||
.endif
|
||||
${GZIP_CMD} ${STAGEDIR}${DOCSDIR}/*.ps
|
||||
|
||||
check:
|
||||
(cd ${WRKSRC} ; ${GMAKE} check)
|
||||
|
|
11
devel/ddd/files/patch-ddd-VSLDefList.C
Normal file
11
devel/ddd/files/patch-ddd-VSLDefList.C
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ddd/VSLDefList.C.orig 2013-09-23 10:38:30.000000000 +0200
|
||||
+++ ddd/VSLDefList.C 2013-09-23 10:39:12.000000000 +0200
|
||||
@@ -60,7 +60,7 @@
|
||||
{
|
||||
std::ostringstream s;
|
||||
s << *arg;
|
||||
- VSLLib::eval_error("no suiting definition for " + f_name() + s);
|
||||
+ VSLLib::eval_error("no suiting definition for " + f_name() + s.str().c_str());
|
||||
}
|
||||
|
||||
return d ? d->eval(arg) : 0;
|
|
@ -1,4 +1,5 @@
|
|||
bin/ddd
|
||||
man/man1/ddd.1.gz
|
||||
share/applications/ddd.desktop
|
||||
share/ddd-%%VERSION%%/COPYING
|
||||
share/ddd-%%VERSION%%/NEWS
|
||||
|
|
Loading…
Reference in a new issue