Upgrade to 0.4.3.
PR: ports/81652 Submitted by: Johan van Selst <johans@stack.nl>
This commit is contained in:
parent
4cd1623bc9
commit
9bcafa753b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=136461
4 changed files with 19 additions and 27 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= hpl
|
||||
PORTVERSION= 0.3.3
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.4.3
|
||||
CATEGORIES= devel haskell
|
||||
MASTER_SITES= http://www.cse.unsw.edu.au/~chak/haskell/ports/
|
||||
PKGNAMEPREFIX= hs-
|
||||
|
@ -16,12 +15,14 @@ DISTNAME= ports-${PORTVERSION}
|
|||
MAINTAINER= haskell@FreeBSD.org
|
||||
COMMENT= Haskell Ports Library provides ports in Haskell
|
||||
|
||||
BUILD_DEPENDS= ghc-5.04.3:${PORTSDIR}/lang/ghc5
|
||||
RUN_DEPENDS= ghc-5.04.3:${PORTSDIR}/lang/ghc5
|
||||
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
|
||||
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
CONFIGURE_ARGS+= --prefix=${PREFIX}
|
||||
|
||||
PLIST_SUB+= PORTVERSION=${PORTVERSION}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (ports-0.3.3.tar.gz) = b5d13ff5456b7b80fada58aefcb1957b
|
||||
SIZE (ports-0.3.3.tar.gz) = 62882
|
||||
MD5 (ports-0.4.3.tar.gz) = b2c79b885475397176897ccba3bf266e
|
||||
SIZE (ports-0.4.3.tar.gz) = 67528
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.orig Sun Sep 15 17:27:44 2002
|
||||
+++ configure Sun Sep 15 17:28:09 2002
|
||||
@@ -1224,7 +1224,7 @@
|
||||
else
|
||||
${GHC-ghc} --version > conftestghc 2>&1
|
||||
cat conftestghc >&5
|
||||
- ports_cv_ghc_version=`cat conftestghc | sed -n -e 's/, patchlevel *\([0-9]\)/.\1/;s/.* version \([0-9.]\+\).*/\1/p'`
|
||||
+ ports_cv_ghc_version=`cat conftestghc | sed -n -e 's/, patchlevel *\([0-9]\)/.\1/;s/.* version \([0-9.][0-9.]*\).*/\1/p'`
|
||||
rm -fr conftest*
|
||||
if test "$ports_cv_ghc_version" = ""
|
||||
then
|
|
@ -1,11 +1,13 @@
|
|||
bin/ports-config
|
||||
lib/ports-0.3.3/ghc5/import/HPL.hi
|
||||
lib/ports-0.3.3/ghc5/import/Ports.hi
|
||||
lib/ports-0.3.3/ghc5/import/PortsConfig.hi
|
||||
lib/ports-0.3.3/ghc5/import/PortsVersion.hi
|
||||
lib/ports-0.3.3/ghc5/import/Processes.hi
|
||||
lib/ports-0.3.3/ghc5/import/SVars.hi
|
||||
lib/ports-0.3.3/ghc5/libportsHS.a
|
||||
@dirrm lib/ports-0.3.3/ghc5/import
|
||||
@dirrm lib/ports-0.3.3/ghc5
|
||||
@dirrm lib/ports-0.3.3
|
||||
lib/ports-%%PORTVERSION%%/ghc6/import/HPL.hi
|
||||
lib/ports-%%PORTVERSION%%/ghc6/import/PortThreads.hi
|
||||
lib/ports-%%PORTVERSION%%/ghc6/import/Ports.hi
|
||||
lib/ports-%%PORTVERSION%%/ghc6/import/PortsConfig.hi
|
||||
lib/ports-%%PORTVERSION%%/ghc6/import/PortsVersion.hi
|
||||
lib/ports-%%PORTVERSION%%/ghc6/import/Processes.hi
|
||||
lib/ports-%%PORTVERSION%%/ghc6/import/SVars.hi
|
||||
lib/ports-%%PORTVERSION%%/ghc6/import/ThreadUtils.hi
|
||||
lib/ports-%%PORTVERSION%%/ghc6/libportsHS.a
|
||||
@dirrm lib/ports-%%PORTVERSION%%/ghc6/import
|
||||
@dirrm lib/ports-%%PORTVERSION%%/ghc6
|
||||
@dirrm lib/ports-%%PORTVERSION%%
|
||||
|
|
Loading…
Reference in a new issue