Despite the name, it has nothing to do with apricots. It's a game

where you fly a little plane around the screen and shoot things and
drop bombs on enemy targets, and it's meant to be quick and fun.

There can be up to 6 planes, at most two human-controlled. All
others will be computer-controlled. Network support is in to do
list.

You must shoot at another's planes, destroy others' base and try
to keep alive. You may return to your base to refill your ammo. The
scenery is randomly generated.

WWW: http://www.fishies.org.uk/apricots.html

PR:		ports/119439
Submitted by:	Dmitry Marakasov <amdmi3 at amdmi3.ru>
This commit is contained in:
Martin Wilke 2008-01-12 16:44:45 +00:00
parent 74ad3aafd5
commit 9bd60fbb22
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=205555
6 changed files with 114 additions and 0 deletions

View file

@ -47,6 +47,7 @@
SUBDIR += antrix
SUBDIR += aop
SUBDIR += apoolGL
SUBDIR += apricots
SUBDIR += aqbubble
SUBDIR += armagetron
SUBDIR += asc

52
games/apricots/Makefile Normal file
View file

@ -0,0 +1,52 @@
# New ports collection makefile for: apricots
# Date created: 07 Jan 2008
# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
#
# $FreeBSD$
#
PORTNAME= apricots
PORTVERSION= 0.2.6
CATEGORIES= games
MASTER_SITES= http://www.fishies.org.uk/ \
http://www.amdmi3.ru/distfiles/
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= Fly a little plane around and shoot things and drop bombs
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SDL= sdl
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
PORTDOCS= README
OPTIONS= OPENAL "Enable OpenAL audio" on
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_OPENAL)
LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal \
alut.1:${PORTSDIR}/audio/freealut
.endif
post-patch:
.if defined(WITHOUT_OPENAL)
@${REINPLACE_CMD} -e 's|-DAP_AUDIO_OPENAL||' ${WRKSRC}/configure
.else
@${REINPLACE_CMD} -e '/^LIBS = / s|$$| -lopenal -lalut|' \
${WRKSRC}/apricots/Makefile.in
.endif
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.post.mk>

3
games/apricots/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (apricots-0.2.6.tar.gz) = 910828d717e46d8cbd9c24f702d09fbc
SHA256 (apricots-0.2.6.tar.gz) = 9c408722abbb0cb925384f12a65fe4f6e2b3373d5ce5d0e5afe3aeb738b9cd8f
SIZE (apricots-0.2.6.tar.gz) = 768568

View file

@ -0,0 +1,19 @@
--- apricots/sampleio.cpp.orig 2003-08-06 03:21:22.000000000 +0400
+++ apricots/sampleio.cpp 2008-01-08 02:12:27.000000000 +0300
@@ -81,16 +81,10 @@
ALsizei freq;
ALboolean fileok;
// Evil OpenAL portability fix done here
-#ifdef _WIN32
ALenum format;
ALboolean trash;
alutLoadWAVFile(filenames[i],&format,&data,&filelen,&freq,&trash);
fileok = (alGetError() == AL_NO_ERROR);
-#else
- ALsizei format;
- ALsizei trash;
- fileok = alutLoadWAV(filenames[i],&data,&format,&filelen,&trash,&freq);
-#endif
if (!fileok){
cerr << "sampleio: could not open " << filenames[i] << endl;
exit(1);

20
games/apricots/pkg-descr Normal file
View file

@ -0,0 +1,20 @@
Despite the name, it has nothing to do with apricots. It's a game
where you fly a little plane around the screen and shoot things and
drop bombs on enemy targets, and it's meant to be quick and fun.
There can be up to 6 planes, at most two human-controlled. All
others will be computer-controlled. Network support is in to do
list.
You must shoot at another's planes, destroy others' base and try
to keep alive. You may return to your base to refill your ammo. The
scenery is randomly generated.
Currently the game has no menus. You run it, play it, and it exits
at end. To fix this is also in to do list.
Please take a look at apricots.cfg file. You will found some good
options there. (currently this is the only way of changing game
options)
WWW: http://www.fishies.org.uk/apricots.html

19
games/apricots/pkg-plist Normal file
View file

@ -0,0 +1,19 @@
bin/apricots
%%DATADIR%%/afterburner.wav
%%DATADIR%%/alt-8x16.psf
%%DATADIR%%/apricots.cfg
%%DATADIR%%/apricots.shapes
%%DATADIR%%/bomb.wav
%%DATADIR%%/engine.wav
%%DATADIR%%/explode.wav
%%DATADIR%%/finish.wav
%%DATADIR%%/fuelexplode.wav
%%DATADIR%%/groundhit.wav
%%DATADIR%%/gunshot.wav
%%DATADIR%%/gunshot2.wav
%%DATADIR%%/jet.wav
%%DATADIR%%/laser.wav
%%DATADIR%%/shot.wav
%%DATADIR%%/splash.wav
%%DATADIR%%/stall.wav
@dirrm %%DATADIR%%