Scrap pine4-ssl port as a separate entity. Shortly the pine4 port will
get a WITH_SSL=yes option, hopefully.
This commit is contained in:
parent
74d418c094
commit
9be2fdaa67
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40851
11 changed files with 0 additions and 208 deletions
|
@ -1,47 +0,0 @@
|
|||
# New ports collection makefile for: pine4-ssl
|
||||
# Date created: 29 Jul 1999
|
||||
# Whom: Nick Sayer <nsayer@freebsd.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
# I spent a <strong>very frustrating</strong> half hour with portlint
|
||||
# on this one and could never get it to fewer than 8 frigging warnings.
|
||||
# A bit more work got it down to 2 frigging warnings.
|
||||
# The warnings are getting harder to fix.
|
||||
# Good luck to you. :-P
|
||||
|
||||
PORTNAME= pine4-ssl
|
||||
PORTVERSION= 4.21.1.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= mail news
|
||||
MASTER_SITES= ftp://ftp.cac.washington.edu/pine/ \
|
||||
http://www.kfu.com/~nsayer/encryption/software/
|
||||
DISTNAME= pine4+ssl-1.4
|
||||
DISTFILES= pine4.21${EXTRACT_SUFX}
|
||||
|
||||
PATCH_SITES= http://www.kfu.com/~nsayer/encryption/software/
|
||||
PATCHFILES= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= nsayer@freebsd.org
|
||||
|
||||
BROKEN= "The c-client library is no longer built in the pine port, and that's where the SSL hacking needs to happen"
|
||||
|
||||
EXTRACT_ONLY= pine4.21${EXTRACT_SUFX}
|
||||
|
||||
WRKSRC= ${WRKDIR}/pine4.21
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../pine4
|
||||
|
||||
FILESDIR= ${.CURDIR}/files
|
||||
|
||||
EXTRA_PATCHES= ${FILESDIR}/extrapatch-*
|
||||
|
||||
USE_OPENSSL= YES
|
||||
|
||||
post-extract:
|
||||
( cd ${WRKSRC} ; tar xfz ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} )
|
||||
|
||||
do-build:
|
||||
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ./build bsf EXTRAAUTHENTICATORS=ssl)
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
|
@ -1,2 +0,0 @@
|
|||
MD5 (pine4+ssl-1.4.tar.gz) = 1ab8368bda76cea8418fcc9be74f75fb
|
||||
MD5 (pine4.21.tar.gz) = 9252a061387de806f8aa1ced885d41f6
|
|
@ -1,18 +0,0 @@
|
|||
--- imap/src/osdep/unix/Makefile.ssl.orig Fri Jan 14 20:56:16 2000
|
||||
+++ imap/src/osdep/unix/Makefile.ssl Tue Feb 1 00:34:17 2000
|
||||
@@ -1,12 +1,11 @@
|
||||
|
||||
# Extended flags needed for additional authenticators. You may need to modify.
|
||||
|
||||
-SSLDIR=/usr/local
|
||||
-SSLCFLAGS= -I$(SSLDIR)/include
|
||||
-SSLLDFLAGS= -L$(SSLDIR)/lib -lssl -lcrypto
|
||||
+SSLCFLAGS= -I$(OPENSSLINC)
|
||||
+SSLLDFLAGS= -L$(OPENSSLLIB) -lssl -lcrypto $(EXTRA_SSL_LIBS)
|
||||
|
||||
.ifdef RSAREF
|
||||
-SSLLDFLAGS+= -lRSAglue -lrsaref
|
||||
+SSLLDFLAGS+= -lRSAglue -L${LOCALBASE}/lib -lrsaref
|
||||
.endif
|
||||
|
||||
ssl: # SSL flags
|
|
@ -1,12 +0,0 @@
|
|||
--- imap/Makefile.orig Tue Feb 1 00:45:16 2000
|
||||
+++ imap/Makefile Tue Feb 1 00:46:24 2000
|
||||
@@ -274,7 +274,8 @@
|
||||
|
||||
BUILDOPTIONS= EXTRACFLAGS='$(EXTRACFLAGS)' EXTRALDFLAGS='$(EXTRALDFLAGS)'\
|
||||
EXTRADRIVERS='$(EXTRADRIVERS)' EXTRAAUTHENTICATORS='$(EXTRAAUTHENTICATORS)'\
|
||||
- PASSWDTYPE=$(PASSWDTYPE) SPECIALAUTHENTICATORS='$(SPECIALAUTHENTICATORS)'
|
||||
+ PASSWDTYPE=$(PASSWDTYPE) SPECIALAUTHENTICATORS='$(SPECIALAUTHENTICATORS)'\
|
||||
+ OPENSSLLIB=$(OPENSSLLIB) OPENSSLINC=$(OPENSSLINC)
|
||||
#BUILD=$(MAKE) build $(BUILDOPTIONS)
|
||||
# *** TEMPORARY FOR PINE 4.10 BUILD ***
|
||||
BUILD=$(MAKE) build $(BUILDOPTIONS) GSSDIR=$(GSSDIR)
|
|
@ -1,51 +0,0 @@
|
|||
#! /bin/sh
|
||||
# ---------- pgpdecode ---------
|
||||
# 21.03.96 Roland Rosenfeld <roland@spinnaker.rhein.de>
|
||||
#
|
||||
# Sun Mar 24 12:01:21 MET 1996 Andreas Klemm <andreas@knobel.gun.de>
|
||||
# The tmp files in the original version were world readable for
|
||||
# the short time of unpacking, setting suitable umask prevents this
|
||||
#
|
||||
# Wed Sep 16 21:35:43 WST 1997 Anthony Di Pietro <anthony@dino.omen.com.au>
|
||||
# Modified to work with both PGP v2 and PGP v5.
|
||||
# Now uses mktemp to prevent symlink attack and tmp races.
|
||||
|
||||
umask 077
|
||||
|
||||
MYNAME=`basename $0`
|
||||
|
||||
STDOUT=`mktemp -q /tmp/${MYNAME}.XXXXXX`
|
||||
if [ $? -ne 0 ]
|
||||
then
|
||||
echo "$0: Can't create temporary file to decode message."
|
||||
exit 1
|
||||
fi
|
||||
|
||||
trap "rm -f $STDOUT ; exit" 0 1 2 15
|
||||
|
||||
STDERR=`mktemp -q /tmp/${MYNAME}.XXXXXX`
|
||||
if [ $? -ne 0 ]
|
||||
then
|
||||
echo "$0: Can't create temporary file to decode message."
|
||||
exit 1
|
||||
fi
|
||||
|
||||
trap "rm -f $STDOUT $STDERR; exit" 0 1 2 15
|
||||
|
||||
if [ -x /usr/local/bin/pgpv ]
|
||||
then
|
||||
pgpv 2>&1 > $STDOUT |tee $STDERR > /dev/tty
|
||||
else
|
||||
pgp -f 2>&1 > $STDOUT |tee $STDERR > /dev/tty
|
||||
fi
|
||||
|
||||
cat $STDERR | \
|
||||
grep -v '^No files specified. Using stdin.$' | \
|
||||
grep -v '^Opening file \"stdout\" type text.$' | \
|
||||
grep -v '^Opening file \"stdout\" type binary.$' | \
|
||||
grep -v '^Opening file \"/dev/null\" type text.$' | \
|
||||
grep -v '^Opening file \"/dev/null\" type binary.$' | \
|
||||
grep -v '^$'| \
|
||||
sed -e 's/^/| /'
|
||||
echo ""
|
||||
cat $STDOUT
|
|
@ -1,11 +0,0 @@
|
|||
#!/bin/sh
|
||||
# ---------- pgpencrypt ---------
|
||||
# 21.03.96 Roland Rosenfeld <roland@spinnaker.rhein.de>
|
||||
# Wed 16 Sep 1998 23:46:43 WST Anthony Di Pietro <anthony@dino.omen.com.au>
|
||||
# Modified to work with both PGP v2 and PGP v5.
|
||||
if [ -x /usr/local/bin/pgpe ]
|
||||
then
|
||||
pgpe -s -a -r $*
|
||||
else
|
||||
pgp -feast $*
|
||||
fi
|
|
@ -1,11 +0,0 @@
|
|||
#!/bin/sh
|
||||
# ---------- pgpsign ---------
|
||||
# 21.03.96 Roland Rosenfeld <roland@spinnaker.rhein.de>
|
||||
# Wed 16 Sep 1998 23:48:51 WST Anthony Di Pietro <anthony@dino.omen.com.au>
|
||||
# Modified to work with both PGP v2 and PGP v5.
|
||||
if [ -x /usr/local/bin/pgps ]
|
||||
then
|
||||
pgps -a -t
|
||||
else
|
||||
pgp -fast
|
||||
fi
|
|
@ -1 +0,0 @@
|
|||
Program for Internet News & Email, with SSL add-on
|
|
@ -1,24 +0,0 @@
|
|||
This version of pine includes add-on code to use SSL to connect to
|
||||
servers. This is sort of equivalent to clicking on the 'server requires
|
||||
SSL' button in Netscape or Outlook or the like.
|
||||
|
||||
Pine (Program for Internet News & Email) is a tool for reading, sending,
|
||||
and managing electronic messages. It was designed specifically with
|
||||
novice computer users in mind, but can be tailored to accommodate the
|
||||
needs of "power users" as well. Pine uses Internet message protocols
|
||||
(e.g. RFC-822, SMTP, MIME, IMAP, NNTP) and runs on Unix and PCs.
|
||||
|
||||
Besides Pine this package includes the Pico editor, the Pilot file browser.
|
||||
|
||||
An optional set of configuration files can be put into /usr/local/etc
|
||||
to set system wide defaults. Have a look at the documentation installed
|
||||
in /usr/local/share/doc/pine/ for more details.
|
||||
|
||||
Also included in dot.pinerc.pgp.sample are example entries needed to
|
||||
add to your .pinerc to activate the pgp add on scripts pgpdecode,
|
||||
pgpencode, and pgpsign.
|
||||
|
||||
WWW: http://www.washington.edu/pine/
|
||||
|
||||
Adrian Penisoara (Ady)
|
||||
pine@freebsd.ady.ro
|
|
@ -1,9 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
if [ "$2" = "POST-INSTALL" -o -n "${PACKAGE_BUILDING}" ]; then
|
||||
exit 0
|
||||
fi
|
||||
|
||||
/usr/bin/dialog --yesno "SECURITY NOTE: The pine software has had several remote vulnerabilities discovered in the past, which allowed remote attackers to execute arbitrary code as you on your local system, by the action of sending a specially-prepared email. All such KNOWN problems have been fixed, but the pine code is written in a very insecure style and the FreeBSD Security Officer believes there are likely to be other undiscovered vulnerabilities. Do you wish to proceed with the installation of pine anyway?" 12 70 || /usr/bin/false
|
||||
|
||||
|
|
@ -1,22 +0,0 @@
|
|||
bin/pico
|
||||
bin/pilot
|
||||
bin/pine
|
||||
bin/pgpencrypt
|
||||
bin/pgpdecode
|
||||
bin/pgpsign
|
||||
etc/dot.pinerc.pgp.sample
|
||||
@exec %D/bin/pine -P %D/etc/pine.conf -conf >%D/etc/pine.conf.tmp
|
||||
@exec /bin/mv %D/etc/pine.conf.tmp %D/etc/pine.conf
|
||||
share/doc/pine/brochure.txt
|
||||
share/doc/pine/tech-notes.txt
|
||||
share/doc/pine/tech-notes/background.html
|
||||
share/doc/pine/tech-notes/cmd-line.html
|
||||
share/doc/pine/tech-notes/config-notes.html
|
||||
share/doc/pine/tech-notes/config.html
|
||||
share/doc/pine/tech-notes/index.html
|
||||
share/doc/pine/tech-notes/installation.html
|
||||
share/doc/pine/tech-notes/introduction.html
|
||||
share/doc/pine/tech-notes/low-level.html
|
||||
share/doc/pine/tech-notes/porting.html
|
||||
@dirrm share/doc/pine/tech-notes
|
||||
@dirrm share/doc/pine
|
Loading…
Reference in a new issue