Updated to kde3.
Submitted by: Michael Collette
This commit is contained in:
parent
cd05b71edd
commit
9bece8de93
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=66941
33 changed files with 13605 additions and 5832 deletions
|
@ -6,11 +6,12 @@
|
|||
#
|
||||
|
||||
PORTNAME= quanta
|
||||
PORTVERSION= 2.0.1
|
||||
PORTVERSION= 3.0pr2a
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= www kde
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DIST_SUBDIR= ${PORTNAME}
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
|
||||
|
@ -24,28 +25,19 @@ MAINTAINER= jeremy@external.org
|
|||
|
||||
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
|
||||
|
||||
USE_KDELIBS_VER=2
|
||||
USE_KDELIBS_VER=3
|
||||
USE_XPM= yes
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET=
|
||||
CONFIGURE_ARGS+= --with-extra-includes=${LOCALBASE}/include \
|
||||
--disable-closure
|
||||
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
|
||||
CONFIGURE_ARGS+=--disable-debug
|
||||
.endif
|
||||
--disable-closure \
|
||||
--enable-threads \
|
||||
--disable-debug
|
||||
USE_GMAKE= yes
|
||||
|
||||
DOCS= css html javascript php
|
||||
|
||||
pre-configure:
|
||||
@${PERL} -pi -e "s#lqt #lqt2 #g" ${WRKSRC}/quanta/Makefile.in
|
||||
@${PERL} -pi -e "s@automake@automake14@g" ${WRKSRC}/configure
|
||||
|
||||
|
||||
post-configure:
|
||||
@${PERL} -pi -e "s@autoconf@autoconf213@g" ${WRKSRC}/Makefile
|
||||
@${PERL} -pi -e "s@moc@moc2@g" ${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
.for doc in ${DOCS}
|
||||
|
@ -55,5 +47,5 @@ post-install:
|
|||
${CHOWN} -R root:wheel ${PREFIX}/share/apps/quanta/doc
|
||||
find ${PREFIX}/share/apps/quanta/doc -type f | xargs ${CHMOD} 444
|
||||
.endif
|
||||
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
MD5 (quanta-2.0.1.tar.bz2) = c2ea4c4a01fdc751375d033ada59a1dd
|
||||
MD5 (css.tar.bz2) = 9134a94af4c783c740cc0ad5806e4b51
|
||||
MD5 (html.tar.bz2) = 0cc3234c4b3df88d4115340ce05e0053
|
||||
MD5 (javascript.tar.bz2) = eea6e25a1c25af1f5a0c33e32e52c136
|
||||
MD5 (php.tar.bz2) = 8ae86e900874549c3749ee5940756817
|
||||
MD5 (quanta/quanta-3.0pr2a.tar.bz2) = 79aea6b9c13065a09da98cb07960d1e2
|
||||
MD5 (quanta/css.tar.bz2) = 9134a94af4c783c740cc0ad5806e4b51
|
||||
MD5 (quanta/html.tar.bz2) = 0cc3234c4b3df88d4115340ce05e0053
|
||||
MD5 (quanta/javascript.tar.bz2) = eea6e25a1c25af1f5a0c33e32e52c136
|
||||
MD5 (quanta/php.tar.bz2) = 8ae86e900874549c3749ee5940756817
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
--- Makefile.in.orig Wed Dec 5 11:04:46 2001
|
||||
+++ Makefile.in Thu Jan 24 16:34:24 2002
|
||||
@@ -251,17 +251,14 @@
|
||||
cd $(top_srcdir) && $(AUTOMAKE) --gnu ./Makefile
|
||||
cd $(top_srcdir) && perl admin/am_edit Makefile.in
|
||||
|
||||
-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status $(BUILT_SOURCES)
|
||||
- cd $(top_builddir) \
|
||||
- && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
|
||||
+Makefile:
|
||||
+ ${ECHO} ""
|
||||
|
||||
$(ACLOCAL_M4): configure.in acinclude.m4
|
||||
cd $(srcdir) && $(ACLOCAL)
|
||||
|
||||
-config.status: $(srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
|
||||
- $(SHELL) ./config.status --recheck
|
||||
-$(srcdir)/configure: $(srcdir)/configure.in $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
|
||||
- cd $(srcdir) && $(AUTOCONF)
|
||||
+config.status:
|
||||
+ @{ECHO} config.status patched
|
||||
|
||||
config.h: stamp-h
|
||||
@if test ! -f $@; then \
|
|
@ -1,10 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/DbgSite.h.orig Thu Jan 24 17:01:33 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/DbgSite.h Thu Jan 24 17:01:48 2002
|
||||
@@ -14,6 +14,7 @@
|
||||
#ifndef _DBGSITE_H_
|
||||
#define _DBGSITE_H_
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <qobject.h>
|
||||
#include "ListenerGlobals.h"
|
||||
#include "RequestorBase.h"
|
|
@ -1,18 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/ListenerBase.cpp.orig Thu Jan 24 17:09:23 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/ListenerBase.cpp Thu Jan 24 17:09:52 2002
|
||||
@@ -11,11 +11,13 @@
|
||||
the world-wide-web at http://dd.cron.ru/license
|
||||
***************************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
+#include <stdio.h>
|
||||
+#include <assert.h>
|
||||
#include "dbg_core.h"
|
||||
#include "ListenerBase.h"
|
||||
#include "ThreadBase.h"
|
||||
-#include <stdio.h>
|
||||
-#include <assert.h>
|
||||
+
|
||||
|
||||
ListenerBase::~ListenerBase() {
|
||||
DBGTRACE("ListenerBase::~ListenerBase\n");
|
|
@ -1,19 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/ListenerGlobals.cpp.orig Thu Jan 24 16:50:10 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/ListenerGlobals.cpp Thu Jan 24 16:51:58 2002
|
||||
@@ -11,6 +11,7 @@
|
||||
the world-wide-web at http://dd.cron.ru/license
|
||||
***************************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <stdarg.h>
|
||||
#include <stdio.h>
|
||||
#include "ListenerGlobals.h"
|
||||
@@ -344,7 +345,7 @@
|
||||
ret_val = select(listen_socket + 1, &rset, NULL, NULL, &timeout);
|
||||
if (ret_val>0) {
|
||||
siz = sizeof(laddr);
|
||||
- ret_val = accept(listen_socket, &laddr, &siz);
|
||||
+ ret_val = accept(listen_socket, &laddr,(socklen_t *) &siz);
|
||||
}
|
||||
if (ret_val <= 0) {
|
||||
return (ret_val) ? (-1) : (0);
|
|
@ -1,10 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/ThreadBase.cpp.orig Thu Jan 24 16:52:35 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/ThreadBase.cpp Thu Jan 24 16:52:44 2002
|
||||
@@ -11,6 +11,7 @@
|
||||
the world-wide-web at http://dd.cron.ru/license
|
||||
***************************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include "ThreadBase.h"
|
||||
#include "ListenerGlobals.h"
|
||||
#include "dbg_core.h"
|
|
@ -1,13 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/dbg_core.c.orig Thu Jan 24 16:53:35 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/dbg_core.c Thu Jan 24 16:53:42 2002
|
||||
@@ -11,9 +11,9 @@
|
||||
the world-wide-web at http://dd.cron.ru/license
|
||||
***************************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include "dbg_core.h"
|
||||
#include <string.h>
|
||||
-#include <malloc.h>
|
||||
#include <stdlib.h>
|
||||
|
||||
#ifdef DBG_USE_STDALLOCA
|
|
@ -1,10 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/debugger.h.orig Thu Jan 24 17:22:31 2002
|
||||
+++ quanta/plugins/php4dbg/debugger.h Thu Jan 24 17:22:47 2002
|
||||
@@ -6,6 +6,7 @@
|
||||
#endif
|
||||
|
||||
#include <qobject.h>
|
||||
+#include <sys/types.h>
|
||||
|
||||
class Listener;
|
||||
class QSocketNotifier;
|
|
@ -1,8 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/listener.cpp.orig Thu Jan 24 17:27:25 2002
|
||||
+++ quanta/plugins/php4dbg/listener.cpp Thu Jan 24 17:27:41 2002
|
||||
@@ -1,4 +1,4 @@
|
||||
-
|
||||
+#include <sys/types.h>
|
||||
#include "listener.h"
|
||||
|
||||
#include <stdarg.h>
|
File diff suppressed because it is too large
Load diff
|
@ -6,11 +6,12 @@
|
|||
#
|
||||
|
||||
PORTNAME= quanta
|
||||
PORTVERSION= 2.0.1
|
||||
PORTVERSION= 3.0pr2a
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= www kde
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DIST_SUBDIR= ${PORTNAME}
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
|
||||
|
@ -24,28 +25,19 @@ MAINTAINER= jeremy@external.org
|
|||
|
||||
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
|
||||
|
||||
USE_KDELIBS_VER=2
|
||||
USE_KDELIBS_VER=3
|
||||
USE_XPM= yes
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET=
|
||||
CONFIGURE_ARGS+= --with-extra-includes=${LOCALBASE}/include \
|
||||
--disable-closure
|
||||
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
|
||||
CONFIGURE_ARGS+=--disable-debug
|
||||
.endif
|
||||
--disable-closure \
|
||||
--enable-threads \
|
||||
--disable-debug
|
||||
USE_GMAKE= yes
|
||||
|
||||
DOCS= css html javascript php
|
||||
|
||||
pre-configure:
|
||||
@${PERL} -pi -e "s#lqt #lqt2 #g" ${WRKSRC}/quanta/Makefile.in
|
||||
@${PERL} -pi -e "s@automake@automake14@g" ${WRKSRC}/configure
|
||||
|
||||
|
||||
post-configure:
|
||||
@${PERL} -pi -e "s@autoconf@autoconf213@g" ${WRKSRC}/Makefile
|
||||
@${PERL} -pi -e "s@moc@moc2@g" ${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
.for doc in ${DOCS}
|
||||
|
@ -55,5 +47,5 @@ post-install:
|
|||
${CHOWN} -R root:wheel ${PREFIX}/share/apps/quanta/doc
|
||||
find ${PREFIX}/share/apps/quanta/doc -type f | xargs ${CHMOD} 444
|
||||
.endif
|
||||
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
MD5 (quanta-2.0.1.tar.bz2) = c2ea4c4a01fdc751375d033ada59a1dd
|
||||
MD5 (css.tar.bz2) = 9134a94af4c783c740cc0ad5806e4b51
|
||||
MD5 (html.tar.bz2) = 0cc3234c4b3df88d4115340ce05e0053
|
||||
MD5 (javascript.tar.bz2) = eea6e25a1c25af1f5a0c33e32e52c136
|
||||
MD5 (php.tar.bz2) = 8ae86e900874549c3749ee5940756817
|
||||
MD5 (quanta/quanta-3.0pr2a.tar.bz2) = 79aea6b9c13065a09da98cb07960d1e2
|
||||
MD5 (quanta/css.tar.bz2) = 9134a94af4c783c740cc0ad5806e4b51
|
||||
MD5 (quanta/html.tar.bz2) = 0cc3234c4b3df88d4115340ce05e0053
|
||||
MD5 (quanta/javascript.tar.bz2) = eea6e25a1c25af1f5a0c33e32e52c136
|
||||
MD5 (quanta/php.tar.bz2) = 8ae86e900874549c3749ee5940756817
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
--- Makefile.in.orig Wed Dec 5 11:04:46 2001
|
||||
+++ Makefile.in Thu Jan 24 16:34:24 2002
|
||||
@@ -251,17 +251,14 @@
|
||||
cd $(top_srcdir) && $(AUTOMAKE) --gnu ./Makefile
|
||||
cd $(top_srcdir) && perl admin/am_edit Makefile.in
|
||||
|
||||
-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status $(BUILT_SOURCES)
|
||||
- cd $(top_builddir) \
|
||||
- && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
|
||||
+Makefile:
|
||||
+ ${ECHO} ""
|
||||
|
||||
$(ACLOCAL_M4): configure.in acinclude.m4
|
||||
cd $(srcdir) && $(ACLOCAL)
|
||||
|
||||
-config.status: $(srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
|
||||
- $(SHELL) ./config.status --recheck
|
||||
-$(srcdir)/configure: $(srcdir)/configure.in $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
|
||||
- cd $(srcdir) && $(AUTOCONF)
|
||||
+config.status:
|
||||
+ @{ECHO} config.status patched
|
||||
|
||||
config.h: stamp-h
|
||||
@if test ! -f $@; then \
|
|
@ -1,10 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/DbgSite.h.orig Thu Jan 24 17:01:33 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/DbgSite.h Thu Jan 24 17:01:48 2002
|
||||
@@ -14,6 +14,7 @@
|
||||
#ifndef _DBGSITE_H_
|
||||
#define _DBGSITE_H_
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <qobject.h>
|
||||
#include "ListenerGlobals.h"
|
||||
#include "RequestorBase.h"
|
|
@ -1,18 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/ListenerBase.cpp.orig Thu Jan 24 17:09:23 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/ListenerBase.cpp Thu Jan 24 17:09:52 2002
|
||||
@@ -11,11 +11,13 @@
|
||||
the world-wide-web at http://dd.cron.ru/license
|
||||
***************************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
+#include <stdio.h>
|
||||
+#include <assert.h>
|
||||
#include "dbg_core.h"
|
||||
#include "ListenerBase.h"
|
||||
#include "ThreadBase.h"
|
||||
-#include <stdio.h>
|
||||
-#include <assert.h>
|
||||
+
|
||||
|
||||
ListenerBase::~ListenerBase() {
|
||||
DBGTRACE("ListenerBase::~ListenerBase\n");
|
|
@ -1,19 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/ListenerGlobals.cpp.orig Thu Jan 24 16:50:10 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/ListenerGlobals.cpp Thu Jan 24 16:51:58 2002
|
||||
@@ -11,6 +11,7 @@
|
||||
the world-wide-web at http://dd.cron.ru/license
|
||||
***************************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <stdarg.h>
|
||||
#include <stdio.h>
|
||||
#include "ListenerGlobals.h"
|
||||
@@ -344,7 +345,7 @@
|
||||
ret_val = select(listen_socket + 1, &rset, NULL, NULL, &timeout);
|
||||
if (ret_val>0) {
|
||||
siz = sizeof(laddr);
|
||||
- ret_val = accept(listen_socket, &laddr, &siz);
|
||||
+ ret_val = accept(listen_socket, &laddr,(socklen_t *) &siz);
|
||||
}
|
||||
if (ret_val <= 0) {
|
||||
return (ret_val) ? (-1) : (0);
|
|
@ -1,10 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/ThreadBase.cpp.orig Thu Jan 24 16:52:35 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/ThreadBase.cpp Thu Jan 24 16:52:44 2002
|
||||
@@ -11,6 +11,7 @@
|
||||
the world-wide-web at http://dd.cron.ru/license
|
||||
***************************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include "ThreadBase.h"
|
||||
#include "ListenerGlobals.h"
|
||||
#include "dbg_core.h"
|
|
@ -1,13 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/dbg_core.c.orig Thu Jan 24 16:53:35 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/dbg_core.c Thu Jan 24 16:53:42 2002
|
||||
@@ -11,9 +11,9 @@
|
||||
the world-wide-web at http://dd.cron.ru/license
|
||||
***************************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include "dbg_core.h"
|
||||
#include <string.h>
|
||||
-#include <malloc.h>
|
||||
#include <stdlib.h>
|
||||
|
||||
#ifdef DBG_USE_STDALLOCA
|
|
@ -1,10 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/debugger.h.orig Thu Jan 24 17:22:31 2002
|
||||
+++ quanta/plugins/php4dbg/debugger.h Thu Jan 24 17:22:47 2002
|
||||
@@ -6,6 +6,7 @@
|
||||
#endif
|
||||
|
||||
#include <qobject.h>
|
||||
+#include <sys/types.h>
|
||||
|
||||
class Listener;
|
||||
class QSocketNotifier;
|
|
@ -1,8 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/listener.cpp.orig Thu Jan 24 17:27:25 2002
|
||||
+++ quanta/plugins/php4dbg/listener.cpp Thu Jan 24 17:27:41 2002
|
||||
@@ -1,4 +1,4 @@
|
||||
-
|
||||
+#include <sys/types.h>
|
||||
#include "listener.h"
|
||||
|
||||
#include <stdarg.h>
|
File diff suppressed because it is too large
Load diff
|
@ -6,11 +6,12 @@
|
|||
#
|
||||
|
||||
PORTNAME= quanta
|
||||
PORTVERSION= 2.0.1
|
||||
PORTVERSION= 3.0pr2a
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= www kde
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DIST_SUBDIR= ${PORTNAME}
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
|
||||
|
@ -24,28 +25,19 @@ MAINTAINER= jeremy@external.org
|
|||
|
||||
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
|
||||
|
||||
USE_KDELIBS_VER=2
|
||||
USE_KDELIBS_VER=3
|
||||
USE_XPM= yes
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET=
|
||||
CONFIGURE_ARGS+= --with-extra-includes=${LOCALBASE}/include \
|
||||
--disable-closure
|
||||
.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
|
||||
CONFIGURE_ARGS+=--disable-debug
|
||||
.endif
|
||||
--disable-closure \
|
||||
--enable-threads \
|
||||
--disable-debug
|
||||
USE_GMAKE= yes
|
||||
|
||||
DOCS= css html javascript php
|
||||
|
||||
pre-configure:
|
||||
@${PERL} -pi -e "s#lqt #lqt2 #g" ${WRKSRC}/quanta/Makefile.in
|
||||
@${PERL} -pi -e "s@automake@automake14@g" ${WRKSRC}/configure
|
||||
|
||||
|
||||
post-configure:
|
||||
@${PERL} -pi -e "s@autoconf@autoconf213@g" ${WRKSRC}/Makefile
|
||||
@${PERL} -pi -e "s@moc@moc2@g" ${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
.for doc in ${DOCS}
|
||||
|
@ -55,5 +47,5 @@ post-install:
|
|||
${CHOWN} -R root:wheel ${PREFIX}/share/apps/quanta/doc
|
||||
find ${PREFIX}/share/apps/quanta/doc -type f | xargs ${CHMOD} 444
|
||||
.endif
|
||||
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
MD5 (quanta-2.0.1.tar.bz2) = c2ea4c4a01fdc751375d033ada59a1dd
|
||||
MD5 (css.tar.bz2) = 9134a94af4c783c740cc0ad5806e4b51
|
||||
MD5 (html.tar.bz2) = 0cc3234c4b3df88d4115340ce05e0053
|
||||
MD5 (javascript.tar.bz2) = eea6e25a1c25af1f5a0c33e32e52c136
|
||||
MD5 (php.tar.bz2) = 8ae86e900874549c3749ee5940756817
|
||||
MD5 (quanta/quanta-3.0pr2a.tar.bz2) = 79aea6b9c13065a09da98cb07960d1e2
|
||||
MD5 (quanta/css.tar.bz2) = 9134a94af4c783c740cc0ad5806e4b51
|
||||
MD5 (quanta/html.tar.bz2) = 0cc3234c4b3df88d4115340ce05e0053
|
||||
MD5 (quanta/javascript.tar.bz2) = eea6e25a1c25af1f5a0c33e32e52c136
|
||||
MD5 (quanta/php.tar.bz2) = 8ae86e900874549c3749ee5940756817
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
--- Makefile.in.orig Wed Dec 5 11:04:46 2001
|
||||
+++ Makefile.in Thu Jan 24 16:34:24 2002
|
||||
@@ -251,17 +251,14 @@
|
||||
cd $(top_srcdir) && $(AUTOMAKE) --gnu ./Makefile
|
||||
cd $(top_srcdir) && perl admin/am_edit Makefile.in
|
||||
|
||||
-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status $(BUILT_SOURCES)
|
||||
- cd $(top_builddir) \
|
||||
- && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
|
||||
+Makefile:
|
||||
+ ${ECHO} ""
|
||||
|
||||
$(ACLOCAL_M4): configure.in acinclude.m4
|
||||
cd $(srcdir) && $(ACLOCAL)
|
||||
|
||||
-config.status: $(srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
|
||||
- $(SHELL) ./config.status --recheck
|
||||
-$(srcdir)/configure: $(srcdir)/configure.in $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
|
||||
- cd $(srcdir) && $(AUTOCONF)
|
||||
+config.status:
|
||||
+ @{ECHO} config.status patched
|
||||
|
||||
config.h: stamp-h
|
||||
@if test ! -f $@; then \
|
|
@ -1,10 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/DbgSite.h.orig Thu Jan 24 17:01:33 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/DbgSite.h Thu Jan 24 17:01:48 2002
|
||||
@@ -14,6 +14,7 @@
|
||||
#ifndef _DBGSITE_H_
|
||||
#define _DBGSITE_H_
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <qobject.h>
|
||||
#include "ListenerGlobals.h"
|
||||
#include "RequestorBase.h"
|
|
@ -1,18 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/ListenerBase.cpp.orig Thu Jan 24 17:09:23 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/ListenerBase.cpp Thu Jan 24 17:09:52 2002
|
||||
@@ -11,11 +11,13 @@
|
||||
the world-wide-web at http://dd.cron.ru/license
|
||||
***************************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
+#include <stdio.h>
|
||||
+#include <assert.h>
|
||||
#include "dbg_core.h"
|
||||
#include "ListenerBase.h"
|
||||
#include "ThreadBase.h"
|
||||
-#include <stdio.h>
|
||||
-#include <assert.h>
|
||||
+
|
||||
|
||||
ListenerBase::~ListenerBase() {
|
||||
DBGTRACE("ListenerBase::~ListenerBase\n");
|
|
@ -1,19 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/ListenerGlobals.cpp.orig Thu Jan 24 16:50:10 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/ListenerGlobals.cpp Thu Jan 24 16:51:58 2002
|
||||
@@ -11,6 +11,7 @@
|
||||
the world-wide-web at http://dd.cron.ru/license
|
||||
***************************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <stdarg.h>
|
||||
#include <stdio.h>
|
||||
#include "ListenerGlobals.h"
|
||||
@@ -344,7 +345,7 @@
|
||||
ret_val = select(listen_socket + 1, &rset, NULL, NULL, &timeout);
|
||||
if (ret_val>0) {
|
||||
siz = sizeof(laddr);
|
||||
- ret_val = accept(listen_socket, &laddr, &siz);
|
||||
+ ret_val = accept(listen_socket, &laddr,(socklen_t *) &siz);
|
||||
}
|
||||
if (ret_val <= 0) {
|
||||
return (ret_val) ? (-1) : (0);
|
|
@ -1,10 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/ThreadBase.cpp.orig Thu Jan 24 16:52:35 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/ThreadBase.cpp Thu Jan 24 16:52:44 2002
|
||||
@@ -11,6 +11,7 @@
|
||||
the world-wide-web at http://dd.cron.ru/license
|
||||
***************************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include "ThreadBase.h"
|
||||
#include "ListenerGlobals.h"
|
||||
#include "dbg_core.h"
|
|
@ -1,13 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/dbgbase/dbg_core.c.orig Thu Jan 24 16:53:35 2002
|
||||
+++ quanta/plugins/php4dbg/dbgbase/dbg_core.c Thu Jan 24 16:53:42 2002
|
||||
@@ -11,9 +11,9 @@
|
||||
the world-wide-web at http://dd.cron.ru/license
|
||||
***************************************************************************/
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include "dbg_core.h"
|
||||
#include <string.h>
|
||||
-#include <malloc.h>
|
||||
#include <stdlib.h>
|
||||
|
||||
#ifdef DBG_USE_STDALLOCA
|
|
@ -1,10 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/debugger.h.orig Thu Jan 24 17:22:31 2002
|
||||
+++ quanta/plugins/php4dbg/debugger.h Thu Jan 24 17:22:47 2002
|
||||
@@ -6,6 +6,7 @@
|
||||
#endif
|
||||
|
||||
#include <qobject.h>
|
||||
+#include <sys/types.h>
|
||||
|
||||
class Listener;
|
||||
class QSocketNotifier;
|
|
@ -1,8 +0,0 @@
|
|||
--- quanta/plugins/php4dbg/listener.cpp.orig Thu Jan 24 17:27:25 2002
|
||||
+++ quanta/plugins/php4dbg/listener.cpp Thu Jan 24 17:27:41 2002
|
||||
@@ -1,4 +1,4 @@
|
||||
-
|
||||
+#include <sys/types.h>
|
||||
#include "listener.h"
|
||||
|
||||
#include <stdarg.h>
|
6333
www/quanta/pkg-plist
6333
www/quanta/pkg-plist
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue