Add www/elixir-httpoison, an HTTP client for Elixir based on HTTPotion.

This commit is contained in:
Jimmy Olgeni 2015-07-05 09:04:39 +00:00
parent 321afb931f
commit 9bfb6ed3ad
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=391355
6 changed files with 49 additions and 0 deletions

View file

@ -161,6 +161,7 @@
SUBDIR += elgg
SUBDIR += elinks
SUBDIR += eliom
SUBDIR += elixir-httpoison
SUBDIR += elixir-maru
SUBDIR += elixir-phoenix
SUBDIR += elixir-phoenix_ecto

View file

@ -0,0 +1,20 @@
# $FreeBSD$
PORTNAME= httpoison
PORTVERSION= 0.7.0
CATEGORIES= www
PKGNAMEPREFIX= elixir-
MAINTAINER= olgeni@FreeBSD.org
COMMENT= HTTP client for Elixir powered by hackney
LICENSE= MIT
USES= elixir
USE_GITHUB= yes
GH_ACCOUNT= edgurgel
MIX_BUILD_DEPS= www/erlang-hackney
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (edgurgel-httpoison-0.7.0_GH0.tar.gz) = 2d326a5549f937cfa23f9ae26ca116272e43f12058db18e9bb2d1135ae2ee3d1
SIZE (edgurgel-httpoison-0.7.0_GH0.tar.gz) = 13426

View file

@ -0,0 +1,10 @@
--- mix.exs.orig 2015-07-05 09:01:37 UTC
+++ mix.exs
@@ -12,7 +12,6 @@ defmodule HTTPoison.Mixfile do
name: "HTTPoison",
description: @description,
package: package,
- deps: deps,
source_url: "https://github.com/edgurgel/httpoison" ]
end

View file

@ -0,0 +1,3 @@
HTTP client for Elixir, based on HTTPotion.
WWW: https://github.com/edgurgel/httpoison

View file

@ -0,0 +1,13 @@
lib/elixir/lib/httpoison/ebin/Elixir.HTTPoison.AsyncChunk.beam
lib/elixir/lib/httpoison/ebin/Elixir.HTTPoison.AsyncEnd.beam
lib/elixir/lib/httpoison/ebin/Elixir.HTTPoison.AsyncHeaders.beam
lib/elixir/lib/httpoison/ebin/Elixir.HTTPoison.AsyncResponse.beam
lib/elixir/lib/httpoison/ebin/Elixir.HTTPoison.AsyncStatus.beam
lib/elixir/lib/httpoison/ebin/Elixir.HTTPoison.Base.beam
lib/elixir/lib/httpoison/ebin/Elixir.HTTPoison.Error.beam
lib/elixir/lib/httpoison/ebin/Elixir.HTTPoison.Response.beam
lib/elixir/lib/httpoison/ebin/Elixir.HTTPoison.beam
lib/elixir/lib/httpoison/ebin/httpoison.app
lib/elixir/lib/httpoison/lib/httpoison.ex
lib/elixir/lib/httpoison/lib/httpoison/base.ex
%%PORTDOCS%%%%DOCSDIR%%/README.md