- Update to 0.49.10.3
PR: ports/67354 Submitted by: Andrey Slusar <vasallia@ukr.net>, Denis Shaposhnikov <dsh@neva.vlink.ru> (maintainer)
This commit is contained in:
parent
f8c9e1e5db
commit
9c033e68b6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=110494
10 changed files with 20 additions and 178 deletions
|
@ -6,25 +6,26 @@
|
|||
#
|
||||
|
||||
PORTNAME= qico
|
||||
PORTVERSION= 0.48.5
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.49.10.3
|
||||
CATEGORIES= comms
|
||||
MASTER_SITES= http://lev.serebryakov.spb.ru/download/0.48/
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}-0.49.10-p3
|
||||
|
||||
MAINTAINER= dsh@vlink.ru
|
||||
COMMENT= An FidoNet Technology Network (FTN) compatible mailer for Unix systems
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAKE_ENV+= SH=${SH} AWK=${AWK} MORDA="${MORDA}" DEFS="${DEFS}"
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
.if defined(WITH_QICO_AMIGA4D)
|
||||
DEFS+= -DAMIGA4D
|
||||
CONFIGURE_ARGS+= --enable-aso
|
||||
.endif
|
||||
|
||||
.if defined(WITH_QICO_MORDA)
|
||||
MORDA= 1
|
||||
PLIST_SUB+= WITH_QICO_MORDA=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-qcc
|
||||
PLIST_SUB+= WITH_QICO_MORDA="@comment "
|
||||
.endif
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (qico-0.48.5.tar.gz) = 0879986b7e1794c2ec5afa9cf6646904
|
||||
SIZE (qico-0.48.5.tar.gz) = 103893
|
||||
MD5 (qico-0.49.10-p3.tar.bz2) = 1fd5a72976c5d8f71a762b1243513093
|
||||
SIZE (qico-0.49.10-p3.tar.bz2) = 229434
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
--- CONFIG.orig Sat Oct 28 00:02:38 2000
|
||||
+++ CONFIG Fri Nov 3 20:39:19 2000
|
||||
@@ -6,7 +6,7 @@
|
||||
BINDIR = /usr/local/bin
|
||||
|
||||
# default config (can be overridden with -I)
|
||||
-CONF = /etc/ftn/qico.conf
|
||||
+CONF = ${PREFIX}/etc/qico.conf
|
||||
# non-binary file permissions
|
||||
PERM = 00600
|
||||
|
||||
@@ -19,14 +19,14 @@
|
||||
#############################################################################
|
||||
|
||||
# qcc features (for building this you must have ncurses-4.2+)
|
||||
-MORDA = 1
|
||||
+#MORDA = 1
|
||||
|
||||
# Please, set it under FreeBSD
|
||||
-#FREE_BSD=1
|
||||
+FREE_BSD=1
|
||||
|
||||
|
||||
# lock dir
|
||||
-DEFS += -DLOCK_DIR=\"/var/lock\"
|
||||
+DEFS += -DLOCK_DIR=\"/var/spool/lock\"
|
||||
|
||||
# communication socket
|
||||
DEFS += -DQIPC_SOCKET=\"/tmp/qlog\"
|
||||
@@ -59,13 +59,13 @@
|
||||
### OS depended settings #####################################################
|
||||
##############################################################################
|
||||
|
||||
-SHELL = /bin/sh
|
||||
-CC = gcc
|
||||
-AWK = awk
|
||||
-INSTALL = install
|
||||
-LEX = lex
|
||||
+SHELL ?= /bin/sh
|
||||
+CC ?= gcc
|
||||
+AWK ?= awk
|
||||
+INSTALL ?= install
|
||||
+LEX ?= lex
|
||||
#YACC = bison -y
|
||||
-YACC = yacc
|
||||
+YACC ?= yacc
|
||||
|
||||
# required for linux glibc2 systems
|
||||
#LIBS=-lresolv
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.orig Tue Jul 18 18:41:42 2000
|
||||
+++ Makefile Thu Jul 20 19:51:32 2000
|
||||
@@ -5,8 +5,6 @@
|
||||
|
||||
DIRS = src
|
||||
|
||||
-CC = gcc
|
||||
-AWK = awk
|
||||
INSTALL = install
|
||||
|
||||
DIST = qico-$(VERSION).tar.gz
|
|
@ -1,20 +0,0 @@
|
|||
--- src/Makefile.orig Tue Aug 15 20:53:42 2000
|
||||
+++ src/Makefile Sat Oct 7 19:06:08 2000
|
||||
@@ -14,7 +14,7 @@
|
||||
#DEFS += -DY_DEBUG #-DYYERROR_VERBOSE=1 -DYYDEBUG=100
|
||||
|
||||
DEFS += -DSHELL=\"$(SHELL)\" -DCONFIG=\"$(CONF)\"
|
||||
-CFLAGS = $(DEFS) -Wall -m486 -O2 -D_GNU_SOURCE=1 -D_BSD_SOURCE=1 -I/usr/local/include
|
||||
+CFLAGS += $(DEFS)
|
||||
ifeq (1,$(STRIP))
|
||||
IFLAGS = -s
|
||||
else
|
||||
@@ -23,7 +23,7 @@
|
||||
endif
|
||||
#DLIBS = -lccmalloc -ldl
|
||||
ifeq (1,$(FREE_BSD))
|
||||
-LIBS += -lutil
|
||||
+#LIBS += -lutil
|
||||
DEFS += -DFREE_BSD=1
|
||||
else
|
||||
LIBS +=
|
|
@ -6,25 +6,26 @@
|
|||
#
|
||||
|
||||
PORTNAME= qico
|
||||
PORTVERSION= 0.48.5
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.49.10.3
|
||||
CATEGORIES= comms
|
||||
MASTER_SITES= http://lev.serebryakov.spb.ru/download/0.48/
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}-0.49.10-p3
|
||||
|
||||
MAINTAINER= dsh@vlink.ru
|
||||
COMMENT= An FidoNet Technology Network (FTN) compatible mailer for Unix systems
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAKE_ENV+= SH=${SH} AWK=${AWK} MORDA="${MORDA}" DEFS="${DEFS}"
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
.if defined(WITH_QICO_AMIGA4D)
|
||||
DEFS+= -DAMIGA4D
|
||||
CONFIGURE_ARGS+= --enable-aso
|
||||
.endif
|
||||
|
||||
.if defined(WITH_QICO_MORDA)
|
||||
MORDA= 1
|
||||
PLIST_SUB+= WITH_QICO_MORDA=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-qcc
|
||||
PLIST_SUB+= WITH_QICO_MORDA="@comment "
|
||||
.endif
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (qico-0.48.5.tar.gz) = 0879986b7e1794c2ec5afa9cf6646904
|
||||
SIZE (qico-0.48.5.tar.gz) = 103893
|
||||
MD5 (qico-0.49.10-p3.tar.bz2) = 1fd5a72976c5d8f71a762b1243513093
|
||||
SIZE (qico-0.49.10-p3.tar.bz2) = 229434
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
--- CONFIG.orig Sat Oct 28 00:02:38 2000
|
||||
+++ CONFIG Fri Nov 3 20:39:19 2000
|
||||
@@ -6,7 +6,7 @@
|
||||
BINDIR = /usr/local/bin
|
||||
|
||||
# default config (can be overridden with -I)
|
||||
-CONF = /etc/ftn/qico.conf
|
||||
+CONF = ${PREFIX}/etc/qico.conf
|
||||
# non-binary file permissions
|
||||
PERM = 00600
|
||||
|
||||
@@ -19,14 +19,14 @@
|
||||
#############################################################################
|
||||
|
||||
# qcc features (for building this you must have ncurses-4.2+)
|
||||
-MORDA = 1
|
||||
+#MORDA = 1
|
||||
|
||||
# Please, set it under FreeBSD
|
||||
-#FREE_BSD=1
|
||||
+FREE_BSD=1
|
||||
|
||||
|
||||
# lock dir
|
||||
-DEFS += -DLOCK_DIR=\"/var/lock\"
|
||||
+DEFS += -DLOCK_DIR=\"/var/spool/lock\"
|
||||
|
||||
# communication socket
|
||||
DEFS += -DQIPC_SOCKET=\"/tmp/qlog\"
|
||||
@@ -59,13 +59,13 @@
|
||||
### OS depended settings #####################################################
|
||||
##############################################################################
|
||||
|
||||
-SHELL = /bin/sh
|
||||
-CC = gcc
|
||||
-AWK = awk
|
||||
-INSTALL = install
|
||||
-LEX = lex
|
||||
+SHELL ?= /bin/sh
|
||||
+CC ?= gcc
|
||||
+AWK ?= awk
|
||||
+INSTALL ?= install
|
||||
+LEX ?= lex
|
||||
#YACC = bison -y
|
||||
-YACC = yacc
|
||||
+YACC ?= yacc
|
||||
|
||||
# required for linux glibc2 systems
|
||||
#LIBS=-lresolv
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.orig Tue Jul 18 18:41:42 2000
|
||||
+++ Makefile Thu Jul 20 19:51:32 2000
|
||||
@@ -5,8 +5,6 @@
|
||||
|
||||
DIRS = src
|
||||
|
||||
-CC = gcc
|
||||
-AWK = awk
|
||||
INSTALL = install
|
||||
|
||||
DIST = qico-$(VERSION).tar.gz
|
|
@ -1,20 +0,0 @@
|
|||
--- src/Makefile.orig Tue Aug 15 20:53:42 2000
|
||||
+++ src/Makefile Sat Oct 7 19:06:08 2000
|
||||
@@ -14,7 +14,7 @@
|
||||
#DEFS += -DY_DEBUG #-DYYERROR_VERBOSE=1 -DYYDEBUG=100
|
||||
|
||||
DEFS += -DSHELL=\"$(SHELL)\" -DCONFIG=\"$(CONF)\"
|
||||
-CFLAGS = $(DEFS) -Wall -m486 -O2 -D_GNU_SOURCE=1 -D_BSD_SOURCE=1 -I/usr/local/include
|
||||
+CFLAGS += $(DEFS)
|
||||
ifeq (1,$(STRIP))
|
||||
IFLAGS = -s
|
||||
else
|
||||
@@ -23,7 +23,7 @@
|
||||
endif
|
||||
#DLIBS = -lccmalloc -ldl
|
||||
ifeq (1,$(FREE_BSD))
|
||||
-LIBS += -lutil
|
||||
+#LIBS += -lutil
|
||||
DEFS += -DFREE_BSD=1
|
||||
else
|
||||
LIBS +=
|
Loading…
Reference in a new issue