- Add another MASTER_SITE

- Fix detection of libGL

PR:		78512
Submitted by:	Ulrich Spoerlein <q@uni.de>
This commit is contained in:
Tilman Keskinoz 2005-03-06 21:39:44 +00:00
parent 6524edf83c
commit 9c048dad92
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=130474
2 changed files with 20 additions and 2 deletions

View file

@ -8,7 +8,8 @@
PORTNAME= quake2forge
PORTVERSION= 0.3
CATEGORIES= games
MASTER_SITES= ftp://ftp.quakeforge.net/quake2forge/
MASTER_SITES= ftp://ftp.quakeforge.net/quake2forge/ \
http://www.galgenberg.net/~q/
DISTNAME= quake2-${PORTVERSION}
MAINTAINER= q@uni.de

View file

@ -1,5 +1,5 @@
--- configure.in.orig Tue Mar 16 11:07:38 2004
+++ configure.in Thu Aug 5 09:59:56 2004
+++ configure.in Fri Mar 4 14:30:46 2005
@@ -109,6 +109,7 @@
# test for the library first, for people who may have the libs
# installed but no headers
@ -16,3 +16,20 @@
AC_SUBST(SVGALIB_CFLAGS)
AC_SUBST(SVGALIB_LIBS)
else
@@ -221,7 +221,7 @@
# --with-opengl was explicitly given, so look in that directory
if test "x${ac_with_opengl}" != xauto ; then
OPENGL_CFLAGS="$OPENGL_CFLAGS -I$withval/include"
- OPENGL_LIBS="$OPENGL_CFLAGS -L$withval/lib"
+ OPENGL_LIBS="$OPENGL_LIBS -L$withval/lib"
fi
# save and set CPPFLAGS for coming tests
save_CPPFLAGS="$CPPFLAGS"
@@ -263,7 +263,6 @@
if test "x$HAVE_OPENGL" = xyes; then
AC_DEFINE(HAVE_OPENGL, 1, [Define this if you have OpenGL])
- OPENGL_LIBS="-lGL"
AC_SUBST(OPENGL_CFLAGS)
AC_SUBST(OPENGL_LIBS)
else