comms/wsjtx: Update to 2.5.2

- Repair a  longstanding regression  that caused signal  reports from
  tail-ended Tx2 messages to be omitted from logged information

- Parse   "dx-call-1 RR73; dx-call-2 <de-call> +nn"  messages  (i3=0,
  n3=1 DXpedition mode) in regular 77-bit modes

- Repair a regression  associated with setting the  main window width
  on program startup.

- Repair a problem with Q65 decodes  of type 'q3' for messages of the
  form "<Call_1> Call_2"

- Execute code associated with Q65 decodes of type 'q5' only when the
  Max   Drift   control   is   set  to   50.    This   fix   prevents
  double-incrementing of  the message averaging counter  on the first
  decoding sequence.

- Polarization offset 'Dpol' from the astronomical data window is now
  written    to    file     azel.dat    if    environment    variable
  WSJT_AZEL_EXTRA_LINES has  been defined as  1 or greater.   Dpol is
  especially useful for EME on the higher microwave bands.

- The Auto  Log QSO option  in "Settings->Reporting" now  behaves the
  same  as  the Prompt  to  log  QSO option  when  not  in a  special
  operating context mode.

- The Fast/Normal/Deep  setting in  Q65 mode is  now a sticky setting
  and is no longer reset to Fast on program startup or  when Settings
  has  been opened. The user selection is used for automatic decodes,
  but Deep is used for any subsequent manual decode attempts.

- New hamlib code to correct minor flaws in controlling several rigs.

- Update  the  Chinese  and  Hong   Kong  translations  of  the  user
  interface.

PR:		ports/260618
Reported by:	hellocodebsd@gmail.com
This commit is contained in:
Diane Bruce 2021-12-31 09:34:57 -05:00
parent 2b4cfc8ff3
commit 9c3c365902
6 changed files with 255 additions and 129 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= wsjtx
DISTVERSION= 2.1.2
PORTREVISION= 3
DISTVERSION= 2.5.2
CATEGORIES= comms hamradio
MASTER_SITES= SF/wsjt/${PORTNAME}-${PORTVERSION}${DISTVERSIONSUFFIX}
@ -13,21 +12,21 @@ BUILD_DEPENDS= asciidoctor:textproc/rubygem-asciidoctor \
autoconf>=2.69:devel/autoconf \
automake>=1.16.1:devel/automake \
a2x:textproc/asciidoc \
git:devel/git \
libtool:devel/libtool \
${LOCALBASE}/share/xsl/docbook:textproc/docbook-xsl
LIB_DEPENDS= libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
libboost_log_setup.so:devel/boost-libs \
libxslt.so:textproc/libxslt
USES= cmake compiler:c++11-lib fortran gl \
makeinfo pkgconfig qt:5 tar:tgz
USES= cmake:noninja compiler:c++11-lang fortran gl libedit \
makeinfo pkgconfig qt:5 readline tar:tgz
USE_GL= glu
USE_QT= core gui network widgets \
multimedia concurrent printsupport serialport sql sql-sqlite3 \
buildtools_build linguisttools_build qmake_build
buildtools_build linguisttools_build qmake_build testlib
CMAKE_ARGS+= -DCMAKE_PREFIX_PATH+=${LOCALBASE}/wsjtx/lib \
-DLOCALBASE::STRING="${LOCALBASE}"
# for detailed debugging uncomment the next line
#CMAKE_ARGS+= --debug-output --trace
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
@ -41,6 +40,23 @@ _PATCHES= wsjtx.patch hamlib.patch
FFLAGS+= -fallow-argument-mismatch
.endif
_HAMLIB_PATCHES= configure.ac hamlib.pc.in tests/rigtestlibusb.c
make-hamlib-patch:
${MV} ${FILESDIR}/hamlib.patch ${FILESDIR}/hamlib.patch.old
. for f in ${_HAMLIB_PATCHES}
(cd ${WRKDIR}/.build/hamlib-prefix/src;diff -u hamlib/$f.orig hamlib/$f >> ${FILESDIR}/hamlib.patch || true)
. endfor
_WSJTX_PATCHES= CMakeLists.txt Radio.cpp widgets/FrequencyLineEdit.cpp \
widgets/FrequencyDeltaLineEdit.cpp \
CMake/Modules/FindUsb.cmake \
CMake/Modules/FindHamlib.cmake
make-wsjtx-patch:
${MV} ${FILESDIR}/wsjtx.patch ${FILESDIR}/wsjtx.patch.old
. for f in ${_WSJTX_PATCHES}
(cd ${WRKDIR}/.build/wsjtx-prefix/src;diff -u wsjtx/$f.orig wsjtx/$f >> ${FILESDIR}/wsjtx.patch || true)
. endfor
post-patch:
. for _patch in ${_PATCHES}
# Keep a copy of the blank patch for the post-build target below
@ -60,8 +76,10 @@ do-install:
(cd ${CONFIGURE_WRKSRC};${MAKE} -f Makefile DESTDIR=${STAGEDIR} install)
post-install:
.for f in fcal fmeasure fmtave ft8code jt4code jt65code jt9 jt9code \
message_aggregator msk144code qra64code qra64sim udp_daemon wsjtx wsprd
.for f in fcal fmeasure fmtave fst4sim ft8code jt4code jt65code jt9 jt9code \
message_aggregator msk144code rigctld-wsjtx rigctlcom-wsjtx \
rigctl-wsjtx udp_daemon q65code q65sim \
wsjtx wsjtx_app_version wsprd
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
.endfor

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1578066901
SHA256 (wsjtx-2.1.2.tgz) = d4af8703abc0295bd1242a0707013708f3f2543841656af8961c4bd9cbe3432a
SIZE (wsjtx-2.1.2.tgz) = 44928980
TIMESTAMP = 1640351546
SHA256 (wsjtx-2.5.2.tgz) = e0a4896217d4c9af271f5293b19ec94608742a729daab8127e87ec8d6697eff3
SIZE (wsjtx-2.5.2.tgz) = 25246974

View file

@ -1,28 +1,62 @@
--- hamlib/configure.ac.orig 2019-02-24 18:41:47.000000000 -0500
+++ hamlib/configure.ac 2019-04-15 12:40:39.767084000 -0400
@@ -270,7 +270,7 @@
--- hamlib/configure.ac.orig 2021-11-03 20:39:16.000000000 -0400
+++ hamlib/configure.ac 2021-12-28 12:12:44.629890000 -0500
@@ -269,7 +269,7 @@
dnl The host_os variable is set by the AC_CANONICAL_HOST macro above.
AS_CASE(["$host_os"],
[freebsd*], [
- AM_CPPFLAGS="-I/usr/local/include ${AM_CPPFLAGS}"
+ AM_CPPFLAGS="${AM_CPPFLAGS} -I/usr/local/include"
AM_LDFLAGS="${AM_LDFLAGS} -L/usr/local/lib"
AC_SUBST([AM_LDFLAGS])],
- AM_CPPFLAGS="-I/usr/local/include ${AM_CPPFLAGS}"
+ AM_CPPFLAGS="${AM_CPPFLAGS} -I/usr/local/include"
AM_LDFLAGS="${AM_LDFLAGS} -L/usr/local/lib"
AC_SUBST([AM_LDFLAGS])],
@@ -317,6 +317,7 @@
AC_MSG_RESULT([$cf_with_libusb])
AM_CONDITIONAL([HAVE_LIBUSB], [test x"${cf_with_libusb}" = "xyes"])
+LIBUSB_LIBS="-lusb"
LIBUSB=""
AC_ARG_VAR([LIBUSB_CFLAGS], [C compiler flags for libusb, overriding configure defaults])
AC_ARG_VAR([LIBUSB_LIBS], [linker flags for libusb, overriding configure check (useful for specifying static libusb-1.0.a (see INSTALL))])
--- hamlib/hamlib.pc.in.orig 2019-04-15 13:06:46.078042000 -0400
+++ hamlib/hamlib.pc.in 2019-04-15 13:06:59.695694000 -0400
@@ -9,5 +9,5 @@
--- hamlib/hamlib.pc.in.orig 2021-11-03 20:39:16.000000000 -0400
+++ hamlib/hamlib.pc.in 2021-12-28 12:19:09.120541000 -0500
@@ -7,7 +7,6 @@
Description: Library to control radio and rotator equipment.
URL: @PACKAGE_URL@
Version: @PACKAGE_VERSION@
Requires.private: @LIBUSB@
-Requires.private: @LIBUSB@
Cflags: -I${includedir} @PTHREAD_CFLAGS@
-Libs: -L${libdir} -lhamlib
-Libs.private: @MATH_LIBS@ @DL_LIBS@ @NET_LIBS@ @PTHREAD_LIBS@
+Libs: -L${libdir} ${libdir}/libhamlib.a
Libs.private: @MATH_LIBS@ @DL_LIBS@ @NET_LIBS@ @PTHREAD_LIBS@
+Libs.private: @MATH_LIBS@ @DL_LIBS@ @NET_LIBS@ @PTHREAD_LIBS@ -lusb
--- hamlib/tests/rigtestlibusb.c.orig 2021-11-03 20:39:16.000000000 -0400
+++ hamlib/tests/rigtestlibusb.c 2021-12-28 12:12:44.630778000 -0500
@@ -115,7 +115,10 @@
printf(" wSpeedSupported: %u\n", ss_usb_cap->wSpeedSupported);
printf(" bFunctionalitySupport: %u\n", ss_usb_cap->bFunctionalitySupport);
printf(" bU1devExitLat: %u\n", ss_usb_cap->bU1DevExitLat);
- printf(" bU2devExitLat: %u\n", ss_usb_cap->bU2DevExitLat);
+/*
+ * does not exist on FreeBSD libusb.h yet
+ * printf(" bU2devExitLat: %u\n", ss_usb_cap->bU2DevExitLat);
+ */
}
static void print_bos(libusb_device_handle *handle)
@@ -133,6 +136,7 @@
printf(" Binary Object Store (BOS):\n");
printf(" wTotalLength: %u\n", bos->wTotalLength);
+#if 0
printf(" bNumDeviceCaps: %u\n", bos->bNumDeviceCaps);
for (i = 0; i < bos->bNumDeviceCaps; i++)
@@ -170,7 +174,7 @@
libusb_free_ss_usb_device_capability_descriptor(ss_dev_cap);
}
}
-
+#endif
libusb_free_bos_descriptor(bos);
}

View file

@ -1,20 +0,0 @@
--- CMakeLists.txt.orig 2019-02-25 04:11:18 UTC
+++ CMakeLists.txt
@@ -23,7 +23,7 @@ source tarball." )
#
# Find_library (USB_LIBRARY NAMES libusb.a usb)
Find_program (PATCH_EXECUTABLE patch REQUIRED)
-Find_package (Git REQUIRED)
+#Find_package (Git REQUIRED)
#
# extra C flags to minimize hamlib excutable sizes
@@ -91,7 +91,7 @@ ExternalProject_Add (hamlib
URL_HASH MD5=${hamlib_md5sum}
UPDATE_COMMAND ./bootstrap
PATCH_COMMAND ${PATCH_EXECUTABLE} -p1 -N < ${CMAKE_CURRENT_SOURCE_DIR}/hamlib.patch
- CONFIGURE_COMMAND <SOURCE_DIR>/configure --prefix=<INSTALL_DIR> --disable-shared --enable-static --without-cxx-binding ${EXTRA_FLAGS} # LIBUSB_LIBS=${USB_LIBRARY}
+ CONFIGURE_COMMAND <SOURCE_DIR>/configure --prefix=<INSTALL_DIR> --disable-shared --enable-static --without-cxx-binding --without-readline ${EXTRA_FLAGS} # LIBUSB_LIBS=${USB_LIBRARY}
BUILD_COMMAND $(MAKE) all V=1 # $(MAKE) is ExternalProject_Add() magic to do recursive make
INSTALL_COMMAND $(MAKE) install-strip V=1 DESTDIR=""
STEP_TARGETS update install

View file

@ -1,88 +1,172 @@
--- wsjtx/CMakeLists.txt.orig 2019-11-26 09:22:32.000000000 -0500
+++ wsjtx/CMakeLists.txt 2020-01-03 11:52:01.553241000 -0500
@@ -1,5 +1,4 @@
cmake_minimum_required (VERSION 2.8.10 FATAL_ERROR)
-
if (APPLE)
#
# The following variables define the portability and compatability attributes of the Mac OS X build
@@ -136,7 +135,13 @@
set (is_debug_build 1)
--- wsjtx/CMakeLists.txt.orig 2021-11-03 19:53:01.000000000 -0400
+++ wsjtx/CMakeLists.txt 2021-12-31 07:53:05.900792000 -0500
@@ -41,7 +41,7 @@
endif ()
+if (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+ set (FREEBSD TRUE)
+ link_directories("/usr/lib" "${LOCALBASE}/lib")
+ include_directories("/usr/include" "${LOCALBASE}/include")
+endif()
if (POLICY CMP0075)
- cmake_policy (SET CMP0075 NEW) # honour CMAKE_REQUIRED_LIBRARIES in config checks
+ cmake_policy (SET CMP0075 NEW) # honour CMAKE_REQUIRED_LIBRARIES in config che,cks
endif ()
+
#
# Options & features
#
@@ -859,8 +864,20 @@
#
project (wsjtx
@@ -867,7 +867,7 @@
# OpenMP
#
-find_package (OpenMP)
+# OpenMP_C_FLAGS - flags to add to the C compiler for OpenMP support
+# OpenMP_CXX_FLAGS - flags to add to the CXX compiler for OpenMP support
+# OpenMP_Fortran_FLAGS - flags to add to the Fortran compiler for OpenMP support
+# OPENMP_FOUND - true if openmp is detected
+if (FREEBSD)
+ set (OpenMP_C_FLAGS "-openmp")
+ set (OpenMP_CXX_FLAGS "-openmp")
+ set (OpenMP_Fortran_FLAGS "-openmp")
+ set (OPENMP_FOUND TRUE)
+else()
+ find_package (OpenMP)
+endif()
+
find_package (OpenMP)
-
+set (OpenMP_C_FLAGS "-fopenmp")
#
# fftw3 single precision library
#
@@ -1325,6 +1342,13 @@
target_link_libraries (record_time_signal wsjt_cxx wsjt_qtmm wsjt_qt)
@@ -884,7 +884,7 @@
check_type_size (CACHE_ALL HAMLIB_OLD_CACHING)
check_symbol_exists (rig_set_cache_timeout_ms "hamlib/rig.h" HAVE_HAMLIB_CACHING)
endif(WSJT_BUILD_UTILS)
+
+if(FREEBSD)
+ set (extraLIBS "ltdl" "usb")
+ else()
+ set (extraLIBS "")
+endif()
+
-find_package (Usb REQUIRED)
+#find_package (Usb REQUIRED)
# build the main application
add_executable (wsjtx MACOSX_BUNDLE
--- wsjtx/qt_helpers.hpp.orig 2020-04-04 19:19:54.667679000 +0200
+++ wsjtx/qt_helpers.hpp 2020-04-04 19:20:37.899375000 +0200
@@ -78,6 +78,7 @@
}
};
#
# Qt5 setup
@@ -914,7 +914,7 @@
#
set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra")
+#if (QT_VERSION < QT_VERSION_CHECK(5, 14, 0))
namespace std
-set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Wall -Wextra -fexceptions -frtti")
+set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -fexceptions -frtti")
if (NOT APPLE)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-pragmas")
@@ -1160,7 +1160,7 @@
target_link_libraries (encode77 wsjt_fort wsjt_cxx)
add_executable (wsprsim ${wsprsim_CSRCS})
-target_link_libraries (wsprsim ${LIBM_LIBRARIES})
+target_link_libraries (wsprsim "-lm")
add_executable (jt4code lib/jt4code.f90)
target_link_libraries (jt4code wsjt_fort wsjt_cxx)
--- wsjtx/Radio.cpp.orig 2021-11-03 19:53:01.000000000 -0400
+++ wsjtx/Radio.cpp 2021-12-31 07:48:03.411318000 -0500
@@ -54,7 +54,8 @@
value *= std::pow (10., scale);
if (ok)
{
- if (value < 0. || value > std::numeric_limits<Frequency>::max ())
+#define MAXDOUBLEFREQUENCY 18446744073709551616.0
+ if (value < 0. || value > MAXDOUBLEFREQUENCY)
{
value = 0.;
*ok = false;
@@ -92,7 +93,7 @@
if (ok)
{
if (value < -std::numeric_limits<Frequency>::max ()
- || value > std::numeric_limits<Frequency>::max ())
+ || value > MAXDOUBLEFREQUENCY)
{
value = 0.;
*ok = false;
--- wsjtx/widgets/FrequencyLineEdit.cpp.orig 2021-11-03 19:53:01.000000000 -0400
+++ wsjtx/widgets/FrequencyLineEdit.cpp 2021-12-31 07:48:03.411740000 -0500
@@ -39,7 +39,8 @@
FrequencyLineEdit::FrequencyLineEdit (QWidget * parent)
: QLineEdit (parent)
{
// std::hash<> specialization for QString based on the dbj2
@@ -97,6 +98,7 @@
}
};
- setValidator (new MHzValidator {0., std::numeric_limits<Radio::Frequency>::max () / 10.e6, this});
+#define MAXDOUBLEFREQUENCY 18446744073709551616.0
+ setValidator (new MHzValidator {0., MAXDOUBLEFREQUENCY / 10.e6, this});
}
+#endif
// Register some useful Qt types with QMetaType
Q_DECLARE_METATYPE (QHostAddress);
--- wsjtx/lib/wsprd/jelinek.h.orig 2020-08-23 10:47:23.539369000 -0400
+++ wsjtx/lib/wsprd/jelinek.h 2020-08-23 10:40:31.539503000 -0400
@@ -10,7 +10,7 @@
unsigned int jpointer;
};
auto FrequencyLineEdit::frequency () const -> Frequency
--- wsjtx/widgets/FrequencyDeltaLineEdit.cpp.orig 2021-11-03 19:53:01.000000000 -0400
+++ wsjtx/widgets/FrequencyDeltaLineEdit.cpp 2021-12-31 07:48:03.412129000 -0500
@@ -39,8 +39,8 @@
FrequencyDeltaLineEdit::FrequencyDeltaLineEdit (QWidget * parent)
: QLineEdit (parent)
{
- setValidator (new MHzValidator {-std::numeric_limits<FrequencyDelta>::max () / 10.e6,
- std::numeric_limits<FrequencyDelta>::max () / 10.e6, this});
+ setValidator (new MHzValidator {(-(std::numeric_limits<FrequencyDelta>::max ())&-0xF) / 10.e6,
+ (std::numeric_limits<FrequencyDelta>::max ()&~0xF) / 10.e6, this});
}
-struct snode *stack;
+static struct snode *stack;
auto FrequencyDeltaLineEdit::frequency_delta () const -> FrequencyDelta
--- wsjtx/CMake/Modules/FindUsb.cmake.orig 2021-11-03 19:53:01.000000000 -0400
+++ wsjtx/CMake/Modules/FindUsb.cmake 2021-12-31 07:48:03.412537000 -0500
@@ -13,25 +13,35 @@
# Usb::Usb - The libusb library
#
+if ( CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" )
+ message ( Status "FreeBSD libusb is built in")
+ set (Usb_FOUND True)
+ set(Usb_LIBRARY "usb")
+ set(Usb_INCLUDE_DIR "/usr/include")
+ set(Usb_LIBRARIES "")
+ add_library (Usb "usb")
+else()
include (LibFindMacros)
-if (WIN32)
- # Use path suffixes on MS Windows as we probably shouldn't
- # trust the PATH envvar. PATH will still be searched to find the
- # library as last resort.
- if (CMAKE_SIZEOF_VOID_P MATCHES "8")
- set (_library_options PATH_SUFFIXES MinGW64/dll MinGW64/static)
- else ()
- set (_library_options PATH_SUFFIXES MinGW32/dll MinGW32/static)
- endif ()
-endif ()
-libfind_pkg_detect (Usb usb-1.0
- FIND_PATH libusb.h PATH_SUFFIXES libusb-1.0
- FIND_LIBRARY usb-1.0 ${_library_options}
- )
+ if (WIN32)
+ # Use path suffixes on MS Windows as we probably shouldn't
+ # trust the PATH envvar. PATH will still be searched to find the
+ # library as last resort.
+ if (CMAKE_SIZEOF_VOID_P MATCHES "8")
+ set (_library_options PATH_SUFFIXES MinGW64/dll MinGW64/static)
+ else ()
+ set (_library_options PATH_SUFFIXES MinGW32/dll MinGW32/static)
+ endif ()
+ endif ()
-libfind_process (Usb)
+ libfind_pkg_detect (Usb usb-1.0
+ FIND_PATH libusb.h PATH_SUFFIXES libusb-1.0
+ FIND_LIBRARY usb-1.0 ${_library_options}
+ )
+ libfind_process (Usb)
+endif()
+
if (Usb_FOUND AND NOT TARGET Usb::Usb)
add_library (Usb::Usb UNKNOWN IMPORTED)
set_target_properties (Usb::Usb PROPERTIES
@@ -40,10 +50,12 @@
INTERFACE_INCLUDE_DIRECTORIES "${Usb_INCLUDE_DIRS}"
INTERFACE_LINK_LIBRARIES "${Usb_LIBRARIES}"
)
-endif ()
+endif()
+if ( NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" )
mark_as_advanced (
Usb_INCLUDE_DIR
Usb_LIBRARY
Usb_LIBRARIES
)
+endif()
--- wsjtx/CMake/Modules/FindHamlib.cmake.orig 2021-11-03 19:53:01.000000000 -0400
+++ wsjtx/CMake/Modules/FindHamlib.cmake 2021-12-31 07:48:03.412916000 -0500
@@ -18,7 +18,9 @@
FIND_LIBRARY hamlib
)
+if ( NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" )
libfind_package (Hamlib Usb)
+endif()
libfind_process (Hamlib)
int jelinek(unsigned int *metric,
unsigned int *cycles,

View file

@ -1,6 +1,7 @@
bin/fcal
bin/fmeasure
bin/fmtave
bin/fst4sim
bin/ft8code
bin/jt4code
bin/jt65code
@ -8,19 +9,28 @@ bin/jt9
bin/jt9code
bin/message_aggregator
bin/msk144code
bin/qra64code
bin/qra64sim
bin/q65code
bin/q65sim
bin/rigctl-wsjtx
bin/rigctlcom-wsjtx
bin/rigctld-wsjtx
bin/udp_daemon
bin/wsjtx
bin/wsjtx_app_version
bin/wsprd
man/man1/fcal.1.gz
man/man1/fmeasure.1.gz
man/man1/fmtave.1.gz
man/man1/fst4sim.1.gz
man/man1/ft8code.1.gz
man/man1/jt4code.1.gz
man/man1/jt65code.1.gz
man/man1/jt9.1.gz
man/man1/jt9code.1.gz
man/man1/message_aggregator.1.gz
man/man1/msk144code.1.gz
man/man1/qra64code.1.gz
man/man1/qra64sim.1.gz
man/man1/rigctl-wsjtx.1.gz
man/man1/rigctlcom-wsjtx.1.gz
man/man1/rigctld-wsjtx.1.gz
@ -29,15 +39,15 @@ man/man1/wsjtx.1.gz
man/man1/wsprd.1.gz
share/applications/message_aggregator.desktop
share/applications/wsjtx.desktop
share/doc/WSJT-X/AUTHORS
share/doc/WSJT-X/BUGS
share/doc/WSJT-X/COPYING
share/doc/WSJT-X/INSTALL
share/doc/WSJT-X/NEWS
share/doc/WSJT-X/README
share/doc/WSJT-X/THANKS
share/doc/WSJT-X/changelog.Debian.gz
share/doc/WSJT-X/copyright
share/doc/WSJT-X/wsjtx-main-%%PORTVERSION%%.html
share/doc/wsjtx/AUTHORS
share/doc/wsjtx/BUGS
share/doc/wsjtx/COPYING
share/doc/wsjtx/NEWS
share/doc/wsjtx/README
share/doc/wsjtx/THANKS
share/doc/wsjtx/copyright
share/doc/wsjtx/wsjtx-main-%%PORTVERSION%%.html
share/pixmaps/wsjtx_icon.png
%%DATADIR%%/JPLEPH
%%DATADIR%%/cty.dat
%%DATADIR%%/cty.dat_copyright.txt