Add KOTH (King of the Hill), a multiplayer tank artillery game similar to

Scorched Earth that uses libggi.

PR:		ports/72725
Submitted by:	Travis Poppe <tlp@LiquidX.org>
This commit is contained in:
Pav Lucistnik 2004-10-16 18:46:41 +00:00
parent b4133861d2
commit 9c596717a1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=119616
7 changed files with 92 additions and 0 deletions

View file

@ -248,6 +248,7 @@
SUBDIR += klondike
SUBDIR += knights
SUBDIR += kobodeluxe
SUBDIR += koth
SUBDIR += kpacman
SUBDIR += kpicframer
SUBDIR += kpictorial

28
games/koth/Makefile Normal file
View file

@ -0,0 +1,28 @@
# New ports collection makefile for: koth
# Date created: 15 Oct 2004
# Whom: Travis Poppe <tlp@liquidx.org>
#
# $FreeBSD$
#
PORTNAME= koth
PORTVERSION= 0.8.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR=games/multiplayer
MAINTAINER= tlp@liquidx.org
COMMENT= Multiplayer tank artillery game similar to Scorched Earth
LIB_DEPENDS= ggi.2:${PORTSDIR}/graphics/libggi
USE_BZIP2= yes
USE_GMAKE= yes
PLIST_FILES= bin/kclever-ai bin/kmoron-ai bin/koth bin/koths
MAN6= kclever-ai.6 kmoron-ai.6 koth.6 koths.6
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>

2
games/koth/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (koth-0.8.0.tar.bz2) = 72aa370ea30b94ff2f5e3ed5b8674c75
SIZE (koth-0.8.0.tar.bz2) = 140569

View file

@ -0,0 +1,19 @@
--- src/ballistics.c.orig Wed Jan 15 05:12:43 2003
+++ src/ballistics.c Sat Oct 16 20:33:24 2004
@@ -92,6 +92,7 @@
break;
case WALL_LAST:
/* just to satisfy gcc -Wall */
+ ;
}
}
@@ -210,7 +211,7 @@
break;
case WALL_RANDOM: /* both of this can't happen, */
case WALL_LAST: /* so they are here to satisfy gcc -Wall */
-
+ ;
}
}
return FLYING;

View file

@ -0,0 +1,18 @@
--- src/kserver.c.orig Wed Feb 5 03:39:03 2003
+++ src/kserver.c Sat Oct 16 20:42:55 2004
@@ -21,6 +21,7 @@
#include <string.h>
#include <time.h>
#include <stdlib.h>
+#include <sys/types.h>
#include <netinet/in.h>
#include <signal.h>
#include <assert.h>
@@ -31,7 +32,6 @@
# include <sys/select.h>
#else
# include <sys/time.h>
-# include <sys/types.h>
#endif
#include "player.h"
#include "relay.h"

View file

@ -0,0 +1,10 @@
--- src/relay.c.orig Mon Feb 3 01:34:54 2003
+++ src/relay.c Sat Oct 16 20:29:42 2004
@@ -260,6 +260,7 @@
else goto bail;
goto nextpkt;
bail:
+ ;
}
}
}

14
games/koth/pkg-descr Normal file
View file

@ -0,0 +1,14 @@
King of the Hill (KOTH) is a multiplayer, networked artillery game of
little tanks with really big weapons set out to destroy one another.
Best-known games of this type include the classic DOS game "Scorched
Earth: The Mother of All Games" and "Scorched Tanks" for the Amiga, but
the concept has been implemented on everything from the TI-85 graphing
calculator on up. KOTH seeks to build on the best ideas from these games
while also taking a fresh approach including an open, network-centric
architecture and concurrent progressive event modeling.
WWW: http://www.nongnu.org/koth/index.html
- Travis Poppe
tlp@liquidx.org