textproc/py-sphinx-inline-tabs: Update to 2022.1.2b11

Changes:	https://github.com/pradyunsg/sphinx-inline-tabs/commits/main
This commit is contained in:
Po-Chuan Hsieh 2022-02-28 17:37:17 +08:00
parent f28db96561
commit 9c7ef501b4
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
4 changed files with 42 additions and 14 deletions

View file

@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= sphinx-inline-tabs
PORTVERSION= 2021.8.17b10
PORTVERSION= 2022.1.2b11
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=3,1:textproc/py-sphinx@${PY_FLAVOR}
USES= python:3.6+
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
@ -26,4 +26,7 @@ NO_ARCH= yes
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extensions@${PY_FLAVOR}
.endif
post-patch:
@${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1632664376
SHA256 (sphinx_inline_tabs-2021.8.17b10.tar.gz) = 6e37b4aa5f2baa8d946d7da95b87775f70023d8d0719c77c414fc168ff22c636
SIZE (sphinx_inline_tabs-2021.8.17b10.tar.gz) = 42848
TIMESTAMP = 1643971134
SHA256 (sphinx_inline_tabs-2022.1.2b11.tar.gz) = afb9142772ec05ccb07f05d8181b518188fc55631b26ee803c694e812b3fdd73
SIZE (sphinx_inline_tabs-2022.1.2b11.tar.gz) = 42520

View file

@ -1,9 +0,0 @@
--- setup.py.orig 1970-01-01 00:00:00 UTC
+++ setup.py
@@ -30,5 +30,5 @@ setup(name='sphinx_inline_tabs',
package_dir=package_dir,
install_requires=install_requires,
extras_require=extras_require,
- python_requires='>=3.8',
+ python_requires='>=3.6',
)

View file

@ -0,0 +1,34 @@
#!/usr/bin/env python
# setup.py generated by flit for tools that don't yet use PEP 517
from distutils.core import setup
packages = \
['sphinx_inline_tabs']
package_data = \
{'': ['*'], 'sphinx_inline_tabs': ['static/*']}
package_dir = \
{'': 'src'}
install_requires = \
['sphinx >= 3']
extras_require = \
{'doc': ['myst-parser', 'furo'],
'test': ['pytest', 'pytest-cov', 'pytest-xdist']}
setup(name='sphinx_inline_tabs',
version='%%PORTVERSION%%',
description='Add inline tabbed content to your Sphinx documentation.',
author='Pradyun Gedam',
author_email='mail@pradyunsg.me',
url='https://github.com/pradyunsg/sphinx-inline-tabs',
packages=packages,
package_data=package_data,
package_dir=package_dir,
install_requires=install_requires,
extras_require=extras_require,
python_requires='>=3.7',
)