Update to 1.6 and some clean-up.
PR: 54664 Submitted by: KATO Tsuguru <tkato@prontomail.com> aka Ports fury
This commit is contained in:
parent
aea1dce716
commit
9cb0da02b0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=85259
7 changed files with 63 additions and 104 deletions
|
@ -5,7 +5,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= chemtool
|
||||
PORTVERSION= 1.5
|
||||
PORTVERSION= 1.6
|
||||
CATEGORIES= science
|
||||
MASTER_SITES= http://ruby.chemie.uni-freiburg.de/~martin/chemtool/
|
||||
|
||||
|
@ -15,13 +15,28 @@ COMMENT= Draw organic molecules easily and store them
|
|||
RUN_DEPENDS= transfig:${PORTSDIR}/print/transfig
|
||||
|
||||
USE_GNOME= gtk12
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
MAN1= chemtool.1 cht.1
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${PREFIX}/share/examples/chemtool
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/* ${PREFIX}/share/examples/chemtool
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/chemtool ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src-cht/cht ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/chemtool.1 ${MANPREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/cht.1 ${MANPREFIX}/man/man1
|
||||
.for lang in cs de fr pl pt_BR ru
|
||||
@${MKDIR} ${PREFIX}/share/locale/${lang}/LC_MESSAGES
|
||||
${INSTALL_DATA} ${WRKSRC}/locales/${lang}/chemtool.mo \
|
||||
${PREFIX}/share/locale/${lang}/LC_MESSAGES
|
||||
.endfor
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
cd ${WRKSRC}/examples && ${FIND} . | \
|
||||
cpio -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (chemtool-1.5.tar.gz) = 093b68e032b2c5611c2f83315764bd40
|
||||
MD5 (chemtool-1.6.tar.gz) = 1b7a1bde89517ef8a1b4a566bfbd9b3f
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.in.orig Thu Apr 11 21:41:37 2002
|
||||
+++ Makefile.in Fri Aug 30 01:25:01 2002
|
||||
--- Makefile.in.orig Sun May 11 22:02:15 2003
|
||||
+++ Makefile.in Sun Jul 20 22:49:21 2003
|
||||
@@ -5,7 +5,7 @@
|
||||
mandir=@mandir@
|
||||
kdedir=@kdemimedir@
|
||||
|
@ -13,11 +13,11 @@ $FreeBSD$
|
|||
CC=@CC@
|
||||
CP=/bin/cp
|
||||
@@ -16,7 +16,7 @@
|
||||
SRCS = main.c chemproc.c graph.c draw.c inout.c gtkfilesel.c undo.c
|
||||
OBJS = main.o chemproc.o graph.o draw.o inout.o gtkfilesel.o undo.o
|
||||
SRCS = main.c chemproc.c graph.c draw.c inout.c undo.c @MYGTKSRCS@
|
||||
OBJS = main.o chemproc.o graph.o draw.o inout.o undo.o @MYGTKOBJS@
|
||||
|
||||
-SYS_LIBRARIES = `gtk-config --libs` -lm
|
||||
+SYS_LIBRARIES = `${GTK_CONFIG} --libs` -lm
|
||||
-SYS_LIBRARIES = `gtk-config --libs` @EMFLIBS@ -lm
|
||||
+SYS_LIBRARIES = `${GTK_CONFIG} --libs` @EMFLIBS@ -lm
|
||||
|
||||
|
||||
all: chemtool cht
|
||||
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- src-cht/Makefile.in.orig Fri Aug 30 01:23:49 2002
|
||||
+++ src-cht/Makefile.in Fri Aug 30 01:24:27 2002
|
||||
@@ -1,4 +1,7 @@
|
||||
+CC=@CC@
|
||||
+CFLAGS=@CFLAGS@
|
||||
+
|
||||
default: cht
|
||||
|
||||
cht: cht-2.1.c
|
||||
- gcc -O cht-2.1.c -o cht
|
||||
+ $(CC) $(CFLAGS) -o cht cht-2.1.c
|
|
@ -1,32 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- src-cht/cht-2.1.c.orig Fri Aug 30 01:25:46 2002
|
||||
+++ src-cht/cht-2.1.c Fri Aug 30 01:31:51 2002
|
||||
@@ -1431,7 +1431,7 @@
|
||||
{
|
||||
#ifndef NO_TIME
|
||||
struct tm *tm;
|
||||
- long clock;
|
||||
+ time_t clock;
|
||||
|
||||
time(&clock);
|
||||
tm = localtime(&clock);
|
||||
@@ -1449,7 +1449,7 @@
|
||||
Void VAXdate(s)
|
||||
char *s;
|
||||
{
|
||||
- long clock;
|
||||
+ time_t clock;
|
||||
char *c;
|
||||
int i;
|
||||
static int where[] = {8, 9, 0, 4, 5, 6, 0, 20, 21, 22, 23};
|
||||
@@ -1465,7 +1465,7 @@
|
||||
Void VAXtime(s)
|
||||
char *s;
|
||||
{
|
||||
- long clock;
|
||||
+ time_t clock;
|
||||
char *c;
|
||||
int i;
|
||||
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- undo.c.orig Sat Mar 9 17:27:32 2002
|
||||
+++ undo.c Fri Aug 30 00:12:23 2002
|
||||
@@ -61,7 +61,7 @@
|
||||
#define MAP_NEW_ANON_AT_FLAGS(pos, size, flags) \
|
||||
(mmap((pos), (size), \
|
||||
PROT_READ | PROT_WRITE | PROT_EXEC, \
|
||||
- MAP_PRIVATE | MAP_ANONYMOUS | (flags), 0, 0))
|
||||
+ MAP_PRIVATE | MAP_ANON | (flags), -1, 0))
|
||||
#define MAP_NEW_ANON(size) MAP_NEW_ANON_AT_FLAGS(0, (size), 0)
|
||||
#define MAP_NEW_ANON_AT(pos, size) \
|
||||
MAP_NEW_ANON_AT_FLAGS((pos), (size), MAP_FIXED)
|
|
@ -1,40 +1,44 @@
|
|||
@comment $FreeBSD$
|
||||
bin/chemtool
|
||||
bin/cht
|
||||
share/examples/chemtool/14263232.mol
|
||||
share/examples/chemtool/AMP.cht
|
||||
share/examples/chemtool/Adenosine.cht
|
||||
share/examples/chemtool/Dehydrotubifolin.cht
|
||||
share/examples/chemtool/G-host.pdb
|
||||
share/examples/chemtool/Indolizomycin.cht
|
||||
share/examples/chemtool/Lepicidin-A-Aglycon.cht
|
||||
share/examples/chemtool/Neu2
|
||||
share/examples/chemtool/amine.mol
|
||||
share/examples/chemtool/bcarotin.pdb
|
||||
share/examples/chemtool/breve.cht
|
||||
share/examples/chemtool/breve.mol
|
||||
share/examples/chemtool/byrostatin1.cht
|
||||
share/examples/chemtool/camphor
|
||||
share/examples/chemtool/claisen.cht
|
||||
share/examples/chemtool/example1
|
||||
share/examples/chemtool/example2
|
||||
share/examples/chemtool/example3
|
||||
share/examples/chemtool/example4
|
||||
share/examples/chemtool/example5
|
||||
share/examples/chemtool/example7
|
||||
share/examples/chemtool/indigo
|
||||
share/examples/chemtool/kdo
|
||||
share/examples/chemtool/krebs.cht
|
||||
share/examples/chemtool/penicillin_v.cht
|
||||
share/examples/chemtool/pteridin
|
||||
share/examples/chemtool/reaction.cht
|
||||
share/examples/chemtool/rutamycin_b.cht
|
||||
share/examples/chemtool/tcdd.cht
|
||||
share/examples/chemtool/viagra.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/14263232.mol
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/AMP.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Adenosine.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Dehydrotubifolin.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/G-host.pdb
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Indolizomycin.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Lepicidin-A-Aglycon.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/Neu2
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/amine.mol
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/anabsinthin
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/atp
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/bcarotin.pdb
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/breve.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/breve.mol
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/bufotalin
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/byrostatin1.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/c70.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/camphor
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/chlorophyll
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/claisen.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/dodecahedran.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/indigo
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/kdo
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/krebs.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/labeltest
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/pagodan.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/penicillin_v.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/pteridin
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/reaction.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/rutamycin_b.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/tbutylazulene
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/tcdd.cht
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/tetracyclin
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/viagra.cht
|
||||
share/locale/cs/LC_MESSAGES/chemtool.mo
|
||||
share/locale/de/LC_MESSAGES/chemtool.mo
|
||||
share/locale/fr/LC_MESSAGES/chemtool.mo
|
||||
share/locale/pl/LC_MESSAGES/chemtool.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/chemtool.mo
|
||||
share/locale/ru/LC_MESSAGES/chemtool.mo
|
||||
@dirrm share/examples/chemtool
|
||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
|
||||
|
|
Loading…
Reference in a new issue