Update gitg to 3.22.0.

Obtained from:	GNOME devel repo
This commit is contained in:
Koop Mast 2017-04-23 08:37:47 +00:00
parent 42f20fa8e7
commit 9cd9dbddeb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=439208
5 changed files with 13 additions and 40 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gitg
PORTVERSION= 3.19.6
PORTREVISION= 2
PORTVERSION= 3.22.0
CATEGORIES= devel deskutils gnome
MASTER_SITES= GNOME
@ -14,7 +13,9 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
libenchant.so:textproc/enchant \
libgee-0.8.so:devel/libgee \
libgit2.so:devel/libgit2 \
libgit2-glib-1.0.so:devel/libgit2-glib \
libpeas-1.0.so:devel/libpeas \
libgtkspell3-3.so:textproc/gtkspell3 \
@ -26,30 +27,25 @@ RUN_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
CONFLICTS= gitg0-[0-9]*
PORTSCOUT= limitw:1,even
USES= compiler:c11 desktop-file-utils gmake libtool pathfix pkgconfig tar:xz
USES= compiler:c11 desktop-file-utils gmake libtool localbase \
pathfix pkgconfig tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-maintainer-mode \
CONFIGURE_ARGS= --disable-silent-rules \
--disable-maintainer-mode \
--enable-compile-warnings=no
USE_GNOME= glib20 gtk30 gtksourceview3 intlhack introspection
USE_GNOME= cairo glib20 gtk30 gtksourceview3 intlhack introspection
INSTALL_TARGET= install-strip
INSTALLS_ICONS= yes
GLIB_SCHEMAS= org.gnome.gitg.gschema.xml
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DEBUG NLS PYTHON
OPTIONS_SUB= yes
DEBUG_CONFIGURE_ENABLE= debug
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
PYTHON_USES= python:3
PYTHON_USES= python:3.2+
PYTHON_CONFIGURE_ENABLE= python
PYTHON_USE= GNOME=py3gobject3
post-patch:
@${REINPLACE_CMD} -e 's|0.24.0|0.25.0|g' \
${WRKSRC}/configure
.include <bsd.port.mk>

View file

@ -1,2 +1,3 @@
SHA256 (gitg-3.19.6.tar.xz) = d84925c843d4bc81d031a543ce84e400f133310b32c238a7dfd7a67c6cf0ddd0
SIZE (gitg-3.19.6.tar.xz) = 1463724
TIMESTAMP = 1477240097
SHA256 (gitg-3.22.0.tar.xz) = ba6895f85c18748294075980a5e03e0936ad4e84534dbb0d8f9e29aa874ddeaf
SIZE (gitg-3.22.0.tar.xz) = 1507056

View file

@ -1,11 +0,0 @@
--- Makefile.in.orig 2016-02-24 20:05:48.691700000 +0100
+++ Makefile.in 2016-02-24 20:07:55.252920000 +0100
@@ -4591,7 +4591,7 @@
@if test -f $@; then :; else \
$(MAKE) $(AM_MAKEFLAGS) $(srcdir)/libgitg_ext_libgitg_ext_1_0_la_vala.stamp; \
fi
-$(srcdir)/GitgExt-1.0.gir: $(srcdir)/libgitg_ext_libgitg_ext_1_0_la_vala.stamp
+$(srcdir)/GitgExt-1.0.gir: Gitg-1.0.gir $(srcdir)/libgitg_ext_libgitg_ext_1_0_la_vala.stamp
@if test -f $@; then :; else rm -f $(srcdir)/libgitg_ext_libgitg_ext_1_0_la_vala.stamp; fi
@if test -f $@; then :; else \
$(MAKE) $(AM_MAKEFLAGS) $(srcdir)/libgitg_ext_libgitg_ext_1_0_la_vala.stamp; \

View file

@ -1,14 +0,0 @@
Upstream fix for building against libgit2 0.24.
Should be removed after updating to gitg 3.20.0
--- libgitg/gitg-remote.vala.orig 2015-12-15 14:12:13 UTC
+++ libgitg/gitg-remote.vala
@@ -247,7 +247,7 @@ public class Remote : Ggit.Remote
try
{
yield Async.thread(() => {
- base.connect(direction, new Callbacks(this, callbacks, null));
+ base.connect(direction, new Callbacks(this, callbacks, null), null);
});
}
catch (Error e)

View file

@ -32,6 +32,7 @@ share/icons/hicolor/32x32/apps/gitg.png
share/icons/hicolor/48x48/apps/gitg.png
share/icons/hicolor/scalable/apps/gitg-symbolic.svg
%%NLS%%share/locale/as/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/bg/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/bs/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/ca/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/ca@valencia/LC_MESSAGES/gitg.mo