add libnova 0.5.0
Astronomical Calculation Library
This commit is contained in:
parent
2c3144cb57
commit
9cf417c07a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=68642
8 changed files with 52 additions and 0 deletions
|
@ -17,6 +17,7 @@
|
|||
SUBDIR += ksetispy
|
||||
SUBDIR += ksetiwatch
|
||||
SUBDIR += kstars
|
||||
SUBDIR += libnova
|
||||
SUBDIR += linux-setiathome
|
||||
SUBDIR += luna
|
||||
SUBDIR += match
|
||||
|
|
20
astro/libnova/Makefile
Normal file
20
astro/libnova/Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: libnova
|
||||
# Date created: Oct 23, 2002
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libnova
|
||||
PORTVERSION= 0.5.0
|
||||
CATEGORIES= astro
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.mk>
|
1
astro/libnova/distinfo
Normal file
1
astro/libnova/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (libnova-0.5.0.tar.gz) = e04bfb5583da6d99023e3f3bba810b2f
|
9
astro/libnova/files/patch-Makefile.in
Normal file
9
astro/libnova/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,9 @@
|
|||
--- src/Makefile.in.orig Wed Oct 23 16:40:39 2002
|
||||
+++ src/Makefile.in Wed Oct 23 16:43:50 2002
|
||||
@@ -92,5 +92,5 @@
|
||||
|
||||
|
||||
-libnova_la_LDFLAGS = -version-info $(LT_VERSION) -release $(LT_RELEASE)
|
||||
+#libnova_la_LDFLAGS = -version-info $(LT_VERSION) -release $(LT_RELEASE)
|
||||
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
10
astro/libnova/files/patch-configure
Normal file
10
astro/libnova/files/patch-configure
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- configure.orig Wed Oct 23 16:35:47 2002
|
||||
+++ configure Wed Oct 23 16:36:13 2002
|
||||
@@ -6163,6 +6163,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
1
astro/libnova/pkg-comment
Normal file
1
astro/libnova/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Astronomical Calculation Library
|
5
astro/libnova/pkg-descr
Normal file
5
astro/libnova/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
libnova is a general purpose, double precision, astronomical calculation
|
||||
library. The intended audience of libnova is C / C++ programmers, astronomers
|
||||
and anyone else interested in calculating positions of astronomical objects.
|
||||
|
||||
WWW: http://libnova.sourceforge.net/
|
5
astro/libnova/pkg-plist
Normal file
5
astro/libnova/pkg-plist
Normal file
|
@ -0,0 +1,5 @@
|
|||
bin/libnovaconfig
|
||||
include/libnova.h
|
||||
lib/libnova.a
|
||||
lib/libnova.so
|
||||
lib/libnova.so.0
|
Loading…
Reference in a new issue