- Update to 0.9
This commit is contained in:
parent
cfa96923b6
commit
9d63e2f8e7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=260741
5 changed files with 39 additions and 60 deletions
|
@ -6,41 +6,40 @@
|
|||
#
|
||||
|
||||
PORTNAME= luabind
|
||||
PORTVERSION= 0.7
|
||||
PORTVERSION= 0.9
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Library that helps you create bindings between C++ and Lua
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/boost/python/detail/is_xxx.hpp:${PORTSDIR}/devel/boost-python-libs
|
||||
RUN_DEPENDS= ${LOCALBASE}/include/boost/python/detail/is_xxx.hpp:${PORTSDIR}/devel/boost-python-libs
|
||||
LIB_DEPENDS= boost_python.4:${PORTSDIR}/devel/boost-python-libs
|
||||
|
||||
USE_ZIP= yes
|
||||
USE_LUA= 5.0
|
||||
USE_GMAKE= yes
|
||||
USE_LUA= 5.1+
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
MAKE_ENV= BOOST_ROOT="${LOCALBASE}/include"
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
BUILD_WRKSRC= ${WRKSRC}/src
|
||||
|
||||
MAKEFILE= makefile
|
||||
CPPFLAGS= -I.. -I${LUA_INCDIR} -I${LOCALBASE}/include
|
||||
LDFLAGS= -L${LUA_LIBDIR}
|
||||
CXXFLAGS+= -fPIC
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
post-patch:
|
||||
${MKDIR} ${WRKSRC}/lib
|
||||
@${FIND} ${WRKSRC}/luabind -name "*.orig" -delete
|
||||
# If you manage to make boost_build build luabind with correct
|
||||
# includes/libraries/compiler/flags, please send a patch
|
||||
do-build:
|
||||
@cd ${WRKSRC}/src && ${ECHO_CMD} *.cpp | \
|
||||
${XARGS} -n1 -t ${_MAKE_JOBS:C/j/P/} \
|
||||
${CXX} ${CXXFLAGS} ${CPPFLAGS} -c
|
||||
cd ${WRKSRC}/src && ${CXX} -shared ${LDFLAGS} -llua -o libluabind.so *.o
|
||||
cd ${WRKSRC}/src && ${AR} -rcs libluabind.a *.o
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/lib/libluabind.a ${PREFIX}/lib
|
||||
(cd ${WRKSRC} && ${COPYTREE_SHARE} luabind ${PREFIX}/include)
|
||||
|
||||
${INSTALL_DATA} ${WRKSRC}/src/libluabind.a ${PREFIX}/lib
|
||||
${INSTALL_DATA} ${WRKSRC}/src/libluabind.so ${PREFIX}/lib
|
||||
cd ${WRKSRC} && ${COPYTREE_SHARE} luabind ${PREFIX}/include
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
|
||||
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (luabind-0.7.zip) = f3e8adf1d63785928b043ed377b0e94d
|
||||
SHA256 (luabind-0.7.zip) = 8a966b5a8b63e5d601eb16bef28bec3ea486bd1f29deb43c5f8fad36ced528f5
|
||||
SIZE (luabind-0.7.zip) = 320531
|
||||
MD5 (luabind-0.9.tar.gz) = cf7f0e9dc4c578d670d5b851e624c4d6
|
||||
SHA256 (luabind-0.9.tar.gz) = 44faa87e1af52bb46e78735341171c9dcc1389de72c0f412274301c1b638424e
|
||||
SIZE (luabind-0.9.tar.gz) = 190049
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- luabind/detail/policy.hpp.orig 2005-12-22 02:09:47.000000000 +0300
|
||||
+++ luabind/detail/policy.hpp 2009-03-20 18:52:45.000000000 +0300
|
||||
@@ -1276,7 +1276,8 @@
|
||||
|
||||
namespace luabind { namespace
|
||||
{
|
||||
-#if defined(__BORLANDC__) || (BOOST_VERSION >= 103400 && defined(__GNUC__))
|
||||
+#if defined(__GNUC__) && \
|
||||
+ (__GNUC__ * 100 + __GNUC_MINOR__ <= 400 || BOOST_VERSION <= 103401)
|
||||
static inline boost::arg<0> return_value()
|
||||
{
|
||||
return boost::arg<0>();
|
|
@ -1,17 +0,0 @@
|
|||
--- src/makefile.orig Mon Nov 28 23:55:34 2005
|
||||
+++ src/makefile Wed Jun 6 21:18:26 2007
|
||||
@@ -1,5 +1,3 @@
|
||||
-include ../config
|
||||
-
|
||||
SOURCES = \
|
||||
wrapper_base.cpp \
|
||||
pcall.cpp \
|
||||
@@ -37,7 +35,7 @@
|
||||
ranlib $@
|
||||
|
||||
%.o:%.cpp
|
||||
- $(CXX) -g -ftemplate-depth-100 -Wall -DLUABIND_BUILDING -c $? -o $@ -I$(LUA_PATH)/include -I- -I.. -I$(BOOST_ROOT) $(CONFIG)
|
||||
+ $(CXX) $(CXXFLAGS) -ftemplate-depth-100 -Wall -DLUABIND_BUILDING -c $? -o $@ -I$(LUA_INCDIR) -I.. -I$(BOOST_ROOT) -DNODEBUG
|
||||
|
||||
clean:
|
||||
rm -f $(OBJECTS) $(TARGET)
|
|
@ -15,21 +15,23 @@ include/luabind/detail/call_operator_iterate.hpp
|
|||
include/luabind/detail/class_cache.hpp
|
||||
include/luabind/detail/class_registry.hpp
|
||||
include/luabind/detail/class_rep.hpp
|
||||
include/luabind/detail/construct_rep.hpp
|
||||
include/luabind/detail/compute_score.hpp
|
||||
include/luabind/detail/constructor.hpp
|
||||
include/luabind/detail/conversion_storage.hpp
|
||||
include/luabind/detail/convert_to_lua.hpp
|
||||
include/luabind/detail/debug.hpp
|
||||
include/luabind/detail/decorate_type.hpp
|
||||
include/luabind/detail/deduce_signature.hpp
|
||||
include/luabind/detail/enum_maker.hpp
|
||||
include/luabind/detail/find_best_match.hpp
|
||||
include/luabind/detail/format_signature.hpp
|
||||
include/luabind/detail/garbage_collector.hpp
|
||||
include/luabind/detail/get_overload_signature.hpp
|
||||
include/luabind/detail/get_signature.hpp
|
||||
include/luabind/detail/has_get_pointer.hpp
|
||||
include/luabind/detail/implicit_cast.hpp
|
||||
include/luabind/detail/inheritance.hpp
|
||||
include/luabind/detail/instance_holder.hpp
|
||||
include/luabind/detail/is_indirect_const.hpp
|
||||
include/luabind/detail/link_compatibility.hpp
|
||||
include/luabind/detail/method_rep.hpp
|
||||
include/luabind/detail/make_instance.hpp
|
||||
include/luabind/detail/most_derived.hpp
|
||||
include/luabind/detail/object_call.hpp
|
||||
include/luabind/detail/object_funs.hpp
|
||||
|
@ -37,8 +39,6 @@ include/luabind/detail/object_rep.hpp
|
|||
include/luabind/detail/open.hpp
|
||||
include/luabind/detail/operator_id.hpp
|
||||
include/luabind/detail/other.hpp
|
||||
include/luabind/detail/overload_rep.hpp
|
||||
include/luabind/detail/overload_rep_base.hpp
|
||||
include/luabind/detail/pcall.hpp
|
||||
include/luabind/detail/pointee_sizeof.hpp
|
||||
include/luabind/detail/pointee_typeid.hpp
|
||||
|
@ -52,13 +52,17 @@ include/luabind/detail/typetraits.hpp
|
|||
include/luabind/detail/yes_no.hpp
|
||||
include/luabind/discard_result_policy.hpp
|
||||
include/luabind/error.hpp
|
||||
include/luabind/exception_handler.hpp
|
||||
include/luabind/from_stack.hpp
|
||||
include/luabind/function.hpp
|
||||
include/luabind/get_main_thread.hpp
|
||||
include/luabind/get_pointer.hpp
|
||||
include/luabind/handle.hpp
|
||||
include/luabind/iterator_policy.hpp
|
||||
include/luabind/lua_include.hpp
|
||||
include/luabind/luabind.hpp
|
||||
include/luabind/make_function.hpp
|
||||
include/luabind/nil.hpp
|
||||
include/luabind/object.hpp
|
||||
include/luabind/open.hpp
|
||||
include/luabind/operator.hpp
|
||||
|
@ -67,10 +71,15 @@ include/luabind/prefix.hpp
|
|||
include/luabind/raw_policy.hpp
|
||||
include/luabind/return_reference_to_policy.hpp
|
||||
include/luabind/scope.hpp
|
||||
include/luabind/shared_ptr_converter.hpp
|
||||
include/luabind/tag_function.hpp
|
||||
include/luabind/typeid.hpp
|
||||
include/luabind/value_wrapper.hpp
|
||||
include/luabind/version.hpp
|
||||
include/luabind/weak_ref.hpp
|
||||
include/luabind/wrapper_base.hpp
|
||||
include/luabind/yield_policy.hpp
|
||||
lib/libluabind.a
|
||||
lib/libluabind.so
|
||||
@dirrm include/luabind/detail
|
||||
@dirrm include/luabind
|
||||
|
|
Loading…
Reference in a new issue