- Update to 20120405

PR:		ports/167342
Submitted by:	jlaffaye, Grzegorz Blach <magik@roorback.net> (maintainer)
Approved by:	Grzegorz Blach <magik@roorback.net> (maintainer)
This commit is contained in:
Julien Laffaye 2012-05-14 22:01:25 +00:00
parent 6d356025c0
commit 9d779315cf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=296613
4 changed files with 23 additions and 30 deletions

View file

@ -6,17 +6,25 @@
#
PORTNAME= godis
PORTVERSION= 20110803
PORTREVISION= 3
PORTVERSION= 20120405
CATEGORIES= databases
MASTER_SITES= LOCAL/jlaffaye
MAINTAINER= magik@roorback.net
COMMENT= A Redis client library written in Go
PLIST_FILES= ${GO_LIBDIR}/godis.a
USE_GO= yes
GO_PKGNAME= ${SUBLIBDIR}/${PORTNAME}
SUBLIBDIR= github.com/simonz05
do-install:
${MKDIR} ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
${INSTALL_DATA} ${GO_WRKDIR_PKG}/${SUBLIBDIR}/godis.a ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
${MKDIR} ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}
.for f in godis.go commands.go conn.go
${INSTALL_DATA} ${GO_WRKSRC}/${f} ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}
.endfor
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/go/files/bsd.go.mk"

View file

@ -1,2 +1,2 @@
SHA256 (godis-20110803.tar.gz) = 24a3fb5e90983caa23163b33ed2d18d997747d5683f92fc1cbf335ad5bfed917
SIZE (godis-20110803.tar.gz) = 15584
SHA256 (godis-20120405.tar.gz) = 5be02502b07386085ac4ba6d92b749a7829fd694ad8bfee0d15b0960074b44b2
SIZE (godis-20120405.tar.gz) = 17712

View file

@ -1,24 +0,0 @@
--- conn.go.orig 2011-09-04 22:00:03.000000000 +0200
+++ conn.go 2012-01-18 21:31:25.000000000 +0100
@@ -342,8 +342,8 @@
}
func (cc *conn) configConn(db int, password string) os.Error {
- if db != 0 {
- buf := [][]byte{[]byte("SELECT"), []byte(strconv.Itoa(db))}
+ if password != "" {
+ buf := [][]byte{[]byte("AUTH"), []byte(password)}
_, err := cc.rwc.Write(buildCmd(buf))
if err != nil {
@@ -356,8 +356,8 @@
}
}
- if password != "" {
- buf := [][]byte{[]byte("AUTH"), []byte(password)}
+ if db != 0 {
+ buf := [][]byte{[]byte("SELECT"), []byte(strconv.Itoa(db))}
_, err := cc.rwc.Write(buildCmd(buf))
if err != nil {

View file

@ -0,0 +1,9 @@
%%GO_LIBDIR%%/github.com/simonz05/godis.a
%%GO_SRCDIR%%/%%GO_PKGNAME%%/godis.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/commands.go
%%GO_SRCDIR%%/%%GO_PKGNAME%%/conn.go
@dirrmtry %%GO_LIBDIR%%/github.com/simonz05
@dirrmtry %%GO_LIBDIR%%/github.com
@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%
@dirrmtry %%GO_SRCDIR%%/github.com/simonz05
@dirrmtry %%GO_SRCDIR%%/github.com