New port: audio/pianobooster: MIDI file player that teaches how to play the piano
This commit is contained in:
parent
61fdcc3a0b
commit
9da798285d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=531710
7 changed files with 130 additions and 0 deletions
|
@ -615,6 +615,7 @@
|
|||
SUBDIR += pear-Text_Spell_Audio
|
||||
SUBDIR += penguinsap
|
||||
SUBDIR += pianobar
|
||||
SUBDIR += pianobooster
|
||||
SUBDIR += pianod2
|
||||
SUBDIR += picard
|
||||
SUBDIR += picard-plugins
|
||||
|
|
37
audio/pianobooster/Makefile
Normal file
37
audio/pianobooster/Makefile
Normal file
|
@ -0,0 +1,37 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pianobooster
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.7.2b
|
||||
CATEGORIES= audio
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= MIDI file player that teaches how to play the piano
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/gplv3.txt
|
||||
|
||||
LIB_DEPENDS= libftgl.so:graphics/ftgl \
|
||||
libjack.so:audio/jack \
|
||||
librtmidi.so:audio/rtmidi
|
||||
|
||||
USES= cmake desktop-file-utils gl pkgconfig qt:5
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= captnfab
|
||||
GH_PROJECT= PianoBooster
|
||||
USE_QT= core gui opengl widgets xml buildtools_build linguisttools_build qmake_build
|
||||
USE_GL= gl glu
|
||||
|
||||
CMAKE_ON= USE_SYSTEM_RTMIDI USE_JACK
|
||||
CMAKE_ARGS= -DDATA_DIR:STRING=share/${PORTNAME}
|
||||
|
||||
OPTIONS_DEFINE= FLUIDSYNTH
|
||||
OPTIONS_DEFAULT= FLUIDSYNTH
|
||||
|
||||
FLUIDSYNTH_CMAKE_BOOL= EXPERIMENTAL_USE_FLUIDSYNTH
|
||||
FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
|
||||
|
||||
post-stage:
|
||||
@${RM} -r ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
3
audio/pianobooster/distinfo
Normal file
3
audio/pianobooster/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1586862081
|
||||
SHA256 (captnfab-PianoBooster-v0.7.2b_GH0.tar.gz) = fe331f9bebafda31444fa415a6594a91f8283ba9c3cf18066684072081490633
|
||||
SIZE (captnfab-PianoBooster-v0.7.2b_GH0.tar.gz) = 2542590
|
22
audio/pianobooster/files/patch-src_MidiDevice.cpp
Normal file
22
audio/pianobooster/files/patch-src_MidiDevice.cpp
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- src/MidiDevice.cpp.orig 2020-02-25 07:45:06 UTC
|
||||
+++ src/MidiDevice.cpp
|
||||
@@ -32,9 +32,9 @@
|
||||
#include "MidiDeviceFluidSynth.h"
|
||||
#endif
|
||||
|
||||
+#include <QDebug>
|
||||
|
||||
|
||||
-
|
||||
CMidiDevice::CMidiDevice()
|
||||
{
|
||||
m_rtMidiDevice = new CMidiDeviceRt();
|
||||
@@ -65,6 +65,8 @@ QStringList CMidiDevice::getMidiPortList(midiType_t ty
|
||||
QStringList list;
|
||||
#if EXPERIMENTAL_USE_FLUIDSYNTH
|
||||
list << m_fluidSynthMidiDevice->getMidiPortList(type);
|
||||
+ if (list.empty())
|
||||
+ qWarning() << "FluidSynth midi device didn't return any midi ports of midi type=" << type;
|
||||
#endif
|
||||
list << m_rtMidiDevice->getMidiPortList(type);
|
||||
|
33
audio/pianobooster/files/patch-src_MidiDeviceFluidSynth.cpp
Normal file
33
audio/pianobooster/files/patch-src_MidiDeviceFluidSynth.cpp
Normal file
|
@ -0,0 +1,33 @@
|
|||
--- src/MidiDeviceFluidSynth.cpp.orig 2019-07-09 08:30:16 UTC
|
||||
+++ src/MidiDeviceFluidSynth.cpp
|
||||
@@ -30,6 +30,7 @@
|
||||
|
||||
#include <QString>
|
||||
#include <QDir>
|
||||
+#include <QDebug>
|
||||
#include <string>
|
||||
|
||||
CMidiDeviceFluidSynth::CMidiDeviceFluidSynth()
|
||||
@@ -54,7 +55,7 @@ void CMidiDeviceFluidSynth::init()
|
||||
|
||||
QStringList CMidiDeviceFluidSynth::getMidiPortList(midiType_t type)
|
||||
{
|
||||
-
|
||||
+ qInfo() << "YURI CMidiDeviceFluidSynth::getMidiPortList type=" << type << " MIDI_OUTPUT=" << MIDI_OUTPUT;
|
||||
if (type != MIDI_OUTPUT) // Only has an output
|
||||
return QStringList();
|
||||
|
||||
@@ -62,11 +63,13 @@ QStringList CMidiDeviceFluidSynth::getMidiPortList(mid
|
||||
QDir dirSoundFont("soundfont");
|
||||
dirSoundFont.setFilter(QDir::Files);
|
||||
QStringList fileNames = dirSoundFont.entryList();
|
||||
+ qInfo() << "YURI CMidiDeviceFluidSynth::getMidiPortList numFileNames=" << fileNames.size() << " in dir=" << dirSoundFont;
|
||||
|
||||
QStringList portNames;
|
||||
|
||||
for (int i = 0; i < fileNames.size(); i++)
|
||||
{
|
||||
+ qInfo() << "YURI CMidiDeviceFluidSynth::getMidiPortList file[" << i << "]=" << fileNames.at(i);
|
||||
if ( fileNames.at(i).endsWith(".sf2", Qt::CaseInsensitive ) )
|
||||
{
|
||||
portNames += fileNames.at(i);
|
6
audio/pianobooster/pkg-descr
Normal file
6
audio/pianobooster/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
PianoBooster is a free (Open Source) program that plays regular midi files and
|
||||
allows you to change the speed of playback and transpose the music etc.
|
||||
There is a scrolling musical stave that shows the notes for just one part
|
||||
from all the parts in the complete musical arrangement.
|
||||
|
||||
WWW: http://pianobooster.sourceforge.net
|
28
audio/pianobooster/pkg-plist
Normal file
28
audio/pianobooster/pkg-plist
Normal file
|
@ -0,0 +1,28 @@
|
|||
bin/pianobooster
|
||||
share/applications/pianobooster.desktop
|
||||
share/icons/hicolor/32x32/apps/pianobooster.png
|
||||
share/icons/hicolor/48x48/apps/pianobooster.png
|
||||
share/icons/hicolor/64x64/apps/pianobooster.png
|
||||
%%DATADIR%%/fonts/DejaVuSans.ttf
|
||||
%%DATADIR%%/music/BoosterMusicBooks.zip
|
||||
%%DATADIR%%/translations/langs.json
|
||||
%%DATADIR%%/translations/music_ru.qm
|
||||
%%DATADIR%%/translations/music_uk.qm
|
||||
%%DATADIR%%/translations/pianobooster_ca.qm
|
||||
%%DATADIR%%/translations/pianobooster_cs.qm
|
||||
%%DATADIR%%/translations/pianobooster_da.qm
|
||||
%%DATADIR%%/translations/pianobooster_de.qm
|
||||
%%DATADIR%%/translations/pianobooster_es.qm
|
||||
%%DATADIR%%/translations/pianobooster_fr.qm
|
||||
%%DATADIR%%/translations/pianobooster_gl.qm
|
||||
%%DATADIR%%/translations/pianobooster_is.qm
|
||||
%%DATADIR%%/translations/pianobooster_it.qm
|
||||
%%DATADIR%%/translations/pianobooster_ja.qm
|
||||
%%DATADIR%%/translations/pianobooster_nb.qm
|
||||
%%DATADIR%%/translations/pianobooster_nl.qm
|
||||
%%DATADIR%%/translations/pianobooster_pl.qm
|
||||
%%DATADIR%%/translations/pianobooster_ru.qm
|
||||
%%DATADIR%%/translations/pianobooster_sk.qm
|
||||
%%DATADIR%%/translations/pianobooster_sv.qm
|
||||
%%DATADIR%%/translations/pianobooster_uk.qm
|
||||
%%DATADIR%%/translations/pianobooster_zh.qm
|
Loading…
Reference in a new issue