- Fixed build on 10-CURRENT where /usr/bin/cpp is supplied by clang. The
port now explicitly uses cpp46 which is supplied by the gcc dependency. PR: ports/177275 PR: ports/177974 Submitted by: Beeblebrox <zaphod@berentweb.com> Submitted by: Oliver Hartmann <ohartman@zedat.fu-berlin.de>
This commit is contained in:
parent
58059c7bf8
commit
9dac3b8f76
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=323303
2 changed files with 28 additions and 2 deletions
|
@ -9,10 +9,14 @@ MASTER_SITES= http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/ \
|
|||
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
|
||||
|
||||
MAINTAINER= glarkin@FreeBSD.org
|
||||
COMMENT= A simple tool for doing everyday things with PDF documents
|
||||
COMMENT= Simple tool for doing everyday things with PDF documents
|
||||
|
||||
USE_ZIP= yes
|
||||
|
||||
BUILD_DEPENDS= gcj${CSUFF}:${PORTSDIR}/lang/gcc${CSUFF} \
|
||||
gcjh${CSUFF}:${PORTSDIR}/lang/gcc${CSUFF} \
|
||||
cpp${CSUFF}:${PORTSDIR}/lang/gcc${CSUFF}
|
||||
|
||||
# Get gcc version suffix without the dot in USE_GCC
|
||||
CSUFF= ${_USE_GCC:S/.//}
|
||||
|
||||
|
@ -29,7 +33,8 @@ PATCH_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-dist
|
|||
WRKSRC= ${PATCH_WRKSRC}/${PORTNAME}
|
||||
|
||||
MAKEFILE= Makefile.FreeBSD
|
||||
MAKE_ENV= GCJ=gcj${CSUFF} GCJH=gcjh${CSUFF} OBJCOPY=${OBJCOPY} LANG=C
|
||||
MAKE_ENV= GCJ=gcj${CSUFF} GCJH=gcjh${CSUFF} GCPP=cpp${CSUFF} \
|
||||
OBJCOPY=${OBJCOPY} LANG=C LC_CTYPE=C
|
||||
|
||||
MAN1= ${PORTNAME}.1
|
||||
PLIST_FILES= bin/pdftk
|
||||
|
|
21
print/pdftk/files/patch-java__Makefile
Normal file
21
print/pdftk/files/patch-java__Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- ./java/Makefile.orig 2013-07-18 14:58:41.000000000 -0400
|
||||
+++ ./java/Makefile 2013-07-18 14:59:08.000000000 -0400
|
||||
@@ -21,9 +21,9 @@
|
||||
# preprocess this file so it might include our local copies of library objects: libgcj_local
|
||||
com/lowagie/text/pdf/PdfEncryption.java : com/lowagie/text/pdf/PdfEncryption.java.c
|
||||
ifdef USE_LOCAL_LIBGCJ
|
||||
- cpp -C -P -DPDFTK_JAVA_LOCAL com/lowagie/text/pdf/PdfEncryption.java.c com/lowagie/text/pdf/PdfEncryption.java
|
||||
+ ${GCPP} -C -P -DPDFTK_JAVA_LOCAL com/lowagie/text/pdf/PdfEncryption.java.c com/lowagie/text/pdf/PdfEncryption.java
|
||||
else
|
||||
- cpp -C -P com/lowagie/text/pdf/PdfEncryption.java.c com/lowagie/text/pdf/PdfEncryption.java
|
||||
+ ${GCPP} -C -P com/lowagie/text/pdf/PdfEncryption.java.c com/lowagie/text/pdf/PdfEncryption.java
|
||||
endif
|
||||
|
||||
#
|
||||
@@ -102,4 +102,4 @@
|
||||
libgcj_local_clean :
|
||||
$(MAKE) -iC "$(JAVALIBPATH)/gnu_local/java/security" clean;
|
||||
$(MAKE) -iC "$(JAVALIBPATH)/gnu_local/java/security/provider" clean;
|
||||
- $(MAKE) -iC "$(JAVALIBPATH)/java_local/security" clean;
|
||||
\ No newline at end of file
|
||||
+ $(MAKE) -iC "$(JAVALIBPATH)/java_local/security" clean;
|
Loading…
Reference in a new issue