archivers/py-borgbackup: avoid dependency on xxhash port

- Instead, use the xxhash library provided in the same port

PR:	265060
Author:	Jose G. Juanino <jjuanino@gmail.com>
This commit is contained in:
Jose G. Juanino 2022-08-13 17:23:51 +02:00 committed by Kurt Jaeger
parent 6b8d17bef0
commit 9db903a89b
2 changed files with 12 additions and 2 deletions

View file

@ -12,8 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.7:devel/py-setuptools_scm@${PY_FLAVOR}
LIB_DEPENDS= liblz4.so:archivers/liblz4 \
libzstd.so:archivers/zstd \
libxxhash.so:devel/xxhash
libzstd.so:archivers/zstd
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=19.0:devel/py-packaging@${PY_FLAVOR}
USES= python:3.5+ ssl

View file

@ -0,0 +1,11 @@
--- setup.py.orig 2022-07-16 16:20:52 UTC
+++ setup.py
@@ -23,7 +23,7 @@ prefer_system_libzstd = True
prefer_system_libb2 = True
# True: use the shared libxxhash (>= 0.6.5 [>= 0.7.2 on ARM]) from the system, False: use the bundled xxhash code
-prefer_system_libxxhash = True
+prefer_system_libxxhash = False
# prefer_system_msgpack is another option, but you need to set it in src/borg/helpers.py.