- Update to version 0.53.0
- Switch to optionsng PR: ports/169404 Submitted by: KATO Tsuguru <tkato432 _at_ yahoo.com> Approved by: beat (mentor)
This commit is contained in:
parent
5bf9c8d17e
commit
9df88a92a3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=301160
4 changed files with 65 additions and 15 deletions
|
@ -7,33 +7,39 @@
|
|||
#
|
||||
|
||||
PORTNAME= qfsm
|
||||
PORTVERSION= 0.52.0
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.53.0
|
||||
DISTVERSIONSUFFIX= -Source
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A graphical tool for designing finite state machines
|
||||
|
||||
LICENSE= GPLv3 # (or later)
|
||||
|
||||
OPTIONS_DEFINE= GRAPHVIZ DOCS EXAMPLES
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_XORG= xi
|
||||
USE_QT4= corelib gui qt3support svg xml \
|
||||
moc_build porting_build qmake_build \
|
||||
uic_build uic3_build rcc_build
|
||||
moc_build qmake_build rcc_build uic_build
|
||||
USE_GNOME= desktopfileutils
|
||||
USE_CMAKE= yes
|
||||
INSTALLS_ICONS= yes
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
.if !defined(WITH_DEBUG)
|
||||
CMAKE_ARGS+= -DCMAKE_CXX_FLAGS_RELEASE:STRING="-DNDEBUG"
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MGRAPHVIZ}
|
||||
BULID_DEPENDS+= graphviz>=2.22:${PORTSDIR}/graphics/graphviz
|
||||
RUN_DEPENDS+= graphviz>=2.22:${PORTSDIR}/graphics/graphviz
|
||||
.else
|
||||
CMAKE_ARGS+= -DQFSM_AVOID_GRAPHVIZ:BOOL=ON
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|(/usr/include/.*$$|(|g ; \
|
||||
/^\/usr\/include/d ; \
|
||||
/SET.*CMAKE_BUILD_TYPE/d ; \
|
||||
/SET.*CMAKE_INSTALL_PREFIX/d' ${WRKSRC}/CMakeLists.txt
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/\/usr\//d' ${WRKSRC}/FindGraphViz.cmake
|
||||
|
||||
do-install:
|
||||
(cd ${WRKSRC} && ${INSTALL_PROGRAM} qfsm ${PREFIX}/bin)
|
||||
|
@ -53,11 +59,11 @@ do-install:
|
|||
${PREFIX}/share/mimelnk/application)
|
||||
@${MKDIR} ${DATADIR}
|
||||
(cd ${WRKSRC}/po && ${INSTALL_DATA} *.qm ${DATADIR})
|
||||
.if !defined(NOPORTDOCS)
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@(cd ${WRKSRC}/doc/user && ${COPYTREE_SHARE} . ${DOCSDIR})
|
||||
.endif
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
|
||||
.endif
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (qfsm-0.52.0-Source.tar.bz2) = 9d2e03901338517b622771c1e4db4c3d7a50c3d8525cab9315d4b7a953e191b0
|
||||
SIZE (qfsm-0.52.0-Source.tar.bz2) = 2830833
|
||||
SHA256 (qfsm-0.53.0-Source.tar.bz2) = a47f2f85fc15992a41ae06560fdc0ddbd663488821af6a34d2f0a3a87c4ba9bb
|
||||
SIZE (qfsm-0.53.0-Source.tar.bz2) = 1498547
|
||||
|
|
41
cad/qfsm/files/patch-CMakeLists.txt
Normal file
41
cad/qfsm/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,41 @@
|
|||
--- CMakeLists.txt.orig 2012-05-30 18:36:12.000000000 +0900
|
||||
+++ CMakeLists.txt 2012-06-23 18:00:22.000000000 +0900
|
||||
@@ -35,6 +35,9 @@
|
||||
ENDIF ( WIN32 )
|
||||
|
||||
|
||||
+SET(QFSM_AVOID_GRAPHVIZ "" CACHE BOOL "Avoid linking against GraphViz")
|
||||
+
|
||||
+IF(NOT QFSM_AVOID_GRAPHVIZ)
|
||||
FIND_PACKAGE(GraphViz)
|
||||
IF(graphviz_FOUND)
|
||||
MESSAGE("Graphviz library found")
|
||||
@@ -45,13 +48,14 @@
|
||||
ELSE(graphviz_FOUND)
|
||||
MESSAGE("WARNING: Graphviz library not found")
|
||||
ENDIF(graphviz_FOUND)
|
||||
+ENDIF(NOT QFSM_AVOID_GRAPHVIZ)
|
||||
|
||||
FIND_PACKAGE(Qt4 REQUIRED)
|
||||
|
||||
ADD_DEFINITIONS(-DQT3_SUPPORT -DSVG)
|
||||
|
||||
#SET( CMAKE_BUILD_TYPE Debug )
|
||||
-SET( CMAKE_BUILD_TYPE Release )
|
||||
+#SET( CMAKE_BUILD_TYPE Release )
|
||||
|
||||
SET( QT_USE_QT3SUPPORT TRUE )
|
||||
SET( QT_USE_QTXML TRUE )
|
||||
@@ -405,9 +409,9 @@
|
||||
|
||||
|
||||
|
||||
-IF(UNIX AND NOT WIN32)
|
||||
- SET(CMAKE_INSTALL_PREFIX "/usr")
|
||||
-ENDIF(UNIX AND NOT WIN32)
|
||||
+#IF(UNIX AND NOT WIN32)
|
||||
+# SET(CMAKE_INSTALL_PREFIX "/usr")
|
||||
+#ENDIF(UNIX AND NOT WIN32)
|
||||
|
||||
IF(UNIX AND NOT WIN32)
|
||||
ADD_DEFINITIONS(-DQFSM_LANGUAGE_DIR="${CMAKE_INSTALL_PREFIX}/share/qfsm/")
|
|
@ -38,11 +38,14 @@ share/applications/qfsm.desktop
|
|||
%%PORTDOCS%%%%DOCSDIR%%/zoom.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/zoomin.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/zoomout.png
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ascii.gv
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ascii_example.fsm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bin.gv
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bin_example.fsm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datum.fsm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/float.fsm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/integer.fsm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/more_complex_nonsense.fsm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_example.fsm
|
||||
share/icons/hicolor/32x32/apps/qfsm.png
|
||||
share/icons/hicolor/32x32/mimetypes/x-qfsm.png
|
||||
|
|
Loading…
Reference in a new issue