- Update to 3.3.2
- Make portclippy/portfmt happy PR: 246507 Submitted by: Kevin Zheng <kevinz5000@gmail.com> (maintainer) Approved by: mentors (implicit) Changelog: https://github.com/quozl/netrek-client-cow/blob/3.3.2/ChangeLog
This commit is contained in:
parent
4da3978e17
commit
9e27176ac0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=538143
4 changed files with 16 additions and 37 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= netrek-client-cow
|
||||
PORTVERSION= 3.3.1
|
||||
PORTREVISION= 5
|
||||
PORTVERSION= 3.3.2
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://www.netrek.org/files/COW/ \
|
||||
http://quozl.us.netrek.org/netrek/
|
||||
|
@ -11,21 +10,17 @@ MASTER_SITES= http://www.netrek.org/files/COW/ \
|
|||
MAINTAINER= kevinz5000@gmail.com
|
||||
COMMENT= Multi-player battle simulation with a Star Trek theme
|
||||
|
||||
LIB_DEPENDS= libImlib2.so:graphics/imlib2
|
||||
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USES= gmake sdl
|
||||
USE_SDL= sdl mixer
|
||||
LIB_DEPENDS= libImlib2.so:graphics/imlib2
|
||||
|
||||
CONFIGURE_ARGS+= NORSA='\#'
|
||||
USES= gmake sdl xorg
|
||||
USE_SDL= mixer sdl
|
||||
USE_XORG= x11 xau xcb xdmcp xext xpm xxf86vm
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|ushort damage|unsigned short damage|' \
|
||||
${WRKSRC}/short.c
|
||||
${REINPLACE_CMD} -e 's|inline void|void|' \
|
||||
${WRKSRC}/local.[ch]
|
||||
${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' \
|
||||
${WRKSRC}/netrek-client-cow.desktop \
|
||||
${WRKSRC}/sound.c \
|
||||
|
@ -35,4 +30,7 @@ post-patch:
|
|||
${REINPLACE_CMD} -e 's|games|bin|' \
|
||||
${WRKSRC}/netrek-client-cow.desktop
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/netrek-client-cow
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (netrek-client-cow-3.3.1.tar.gz) = a9e969bc5aa2a884481f81e8997e725ca18eedba01c018d7e7d383e85f183ae2
|
||||
SIZE (netrek-client-cow-3.3.1.tar.gz) = 1793481
|
||||
TIMESTAMP = 1589646417
|
||||
SHA256 (netrek-client-cow-3.3.2.tar.gz) = cac219248d71033b62098c3da1ca6b4408974b22996da39eaba213b2253e6da3
|
||||
SIZE (netrek-client-cow-3.3.2.tar.gz) = 1791293
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- ./parsemeta.c.orig 2011-10-18 05:35:34.000000000 -0500
|
||||
+++ ./parsemeta.c 2012-04-27 15:57:56.000000000 -0500
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <arpa/inet.h>
|
||||
#include <netdb.h>
|
||||
#include <errno.h>
|
||||
+#include <signal.h>
|
||||
|
||||
#include "Wlib.h"
|
||||
#include "defs.h"
|
|
@ -1,21 +1,11 @@
|
|||
--- ./system.mk.in.orig 2011-10-18 05:35:35.000000000 -0500
|
||||
+++ ./system.mk.in 2012-04-27 15:59:00.000000000 -0500
|
||||
@@ -9,8 +9,7 @@
|
||||
--- system.mk.in.orig 2020-05-16 16:32:14 UTC
|
||||
+++ system.mk.in
|
||||
@@ -9,7 +9,7 @@ exec_prefix=@exec_prefix@
|
||||
datarootdir=@datarootdir@
|
||||
|
||||
DESTDIR=
|
||||
-BINDIR=${prefix}/games
|
||||
-DOCDIR=${datarootdir}/doc/${PACKAGE}
|
||||
+BINDIR=${prefix}/bin
|
||||
PIXMAPDIR=${datarootdir}/pixmaps/${PACKAGE}
|
||||
APPDIR=${datarootdir}/applications
|
||||
|
||||
@@ -200,8 +199,6 @@
|
||||
install: netrek-client-cow
|
||||
mkdir -p $(DESTDIR)$(BINDIR)
|
||||
install netrek-client-cow $(DESTDIR)$(BINDIR)
|
||||
- mkdir -p $(DESTDIR)$(DOCDIR)
|
||||
- cp $(KEYFILE) $(DESTDIR)$(DOCDIR)
|
||||
mkdir -p $(DESTDIR)$(PIXMAPDIR)
|
||||
cp -pr pixmaps/* $(DESTDIR)$(PIXMAPDIR)/
|
||||
mkdir -p $(DESTDIR)$(APPDIR)
|
||||
|
|
Loading…
Reference in a new issue