Update to version 3.17.
PR: ports/69812 Submitted by: Ports Fury
This commit is contained in:
parent
db95a8d61a
commit
9e5fc8dded
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=115110
9 changed files with 62 additions and 169 deletions
|
@ -6,38 +6,41 @@
|
|||
#
|
||||
|
||||
PORTNAME= cooledit
|
||||
PORTVERSION= 3.17.7
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 3.17.8
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= http://cooledit.sourceforge.net/
|
||||
MASTER_SITES= ${MASTER_SITE_SUNSITE}
|
||||
MASTER_SITE_SUBDIR= apps/editors/X/cooledit
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Suite of utilities, including a GUI editor
|
||||
|
||||
LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib
|
||||
|
||||
USE_GETTEXT= yes
|
||||
USE_XPM= yes
|
||||
USE_XLIB= yes
|
||||
USE_PYTHON= yes
|
||||
USE_GETTEXT= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL_VER= 15
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
CONFIGURE_ARGS= --with-libs='-lcrypt -lreadline -lvga -lintl' \
|
||||
--disable-mail-author
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
|
||||
AUTOMAKE="${TRUE}"
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= cooledit.1 coolicon.1 coolman.1 smalledit.1
|
||||
MAN1= cooledit.1 coolman.1 smalledit.1
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/pixmap/coolicon.config \
|
||||
${PREFIX}/etc/coolicon.config.dist
|
||||
.if !exists(${PREFIX}/etc/coolicon.config)
|
||||
${INSTALL_DATA} ${WRKSRC}/pixmap/coolicon.config \
|
||||
${PREFIX}/etc/coolicon.config
|
||||
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_GETTEXT ${PTHREAD_CFLAGS}
|
||||
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
|
||||
|
||||
.if defined(WITH_NEXT_LOOK)
|
||||
CONFIGURE_ARGS+= --enable-NeXT-look
|
||||
.endif
|
||||
@${LN} -sf ${PREFIX}/share/cooledit/global.py \
|
||||
${PREFIX}/share/coolicon/global.py
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|^PACKAGE_FORCE|#PACKAGE_FORGE|g ; \
|
||||
s|USE_INCLUDED_LIBINTL=yes|USE_INCLUDED_LIBINTL=no|g ; \
|
||||
s|\\$${top_builddir}/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|#undef HAVE_WCHAR_H||g ; \
|
||||
s|#undef HAVE_DCGETTEXT||g' ${WRKSRC}/config.h.in
|
||||
@${REINPLACE_CMD} -e 's|m4 intl rxvt|m4 rxvt|g' ${WRKSRC}/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (cooledit-3.17.7.tar.gz) = 06e16994ebc2108e04dc7c6bd29981de
|
||||
SIZE (cooledit-3.17.7.tar.gz) = 1705631
|
||||
MD5 (cooledit-3.17.8.tar.gz) = 7b55c892f5b90b9f4eedda6b68f2e15b
|
||||
SIZE (cooledit-3.17.8.tar.gz) = 1655037
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- config.h.in.orig Sat Aug 3 20:04:12 2002
|
||||
+++ config.h.in Thu May 1 00:37:22 2003
|
||||
@@ -330,7 +330,7 @@
|
||||
#undef HAVE_VPRINTF
|
||||
|
||||
/* Define to 1 if you have the <wchar.h> header file. */
|
||||
-#undef HAVE_WCHAR_H
|
||||
+/* #undef HAVE_WCHAR_H */
|
||||
|
||||
/* 0 */
|
||||
#undef HAVE_XPOINTER
|
|
@ -1,11 +0,0 @@
|
|||
--- icon/Makefile.in.orig Sat Aug 3 20:04:13 2002
|
||||
+++ icon/Makefile.in Thu May 1 00:44:36 2003
|
||||
@@ -158,7 +158,7 @@
|
||||
coolinput_LDADD = ../widget/libCw.la -lX11 @LIBINTL@
|
||||
localedir = $(datadir)/locale
|
||||
|
||||
-DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/share/coolicon\" @DEFS@
|
||||
+DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/share/coolicon\" -DSYSCONFDIR=\"$(sysconfdir)\" @DEFS@
|
||||
subdir = icon
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = $(top_builddir)/config.h
|
|
@ -1,11 +0,0 @@
|
|||
--- icon/coolicon.c.orig Mon Jun 7 11:23:06 1999
|
||||
+++ icon/coolicon.c Mon Jun 7 11:24:05 1999
|
||||
@@ -49,7 +49,7 @@
|
||||
void free_icon_elements (CPowerIcon * icon);
|
||||
void free_all_lists (void);
|
||||
|
||||
-#define SYSTEM_ICONS LIBDIR "/coolicon.config"
|
||||
+#define SYSTEM_ICONS SYSCONFDIR "/coolicon.config"
|
||||
#define E_DATA LIBDIR "/e.data"
|
||||
#define START_WIDTH size_of_e
|
||||
#define START_HEIGHT size_of_e
|
|
@ -1,11 +0,0 @@
|
|||
--- intl/Makefile.in.orig Sat Aug 3 20:04:13 2002
|
||||
+++ intl/Makefile.in Fri May 9 12:03:32 2003
|
||||
@@ -141,7 +141,7 @@
|
||||
# separate library.
|
||||
# If you want to use the one which comes with this version of the
|
||||
# package, you have to use `configure --with-included-gettext'.
|
||||
-install: install-exec install-data
|
||||
+install: # install-exec install-data
|
||||
install-exec: all
|
||||
if test "$(PACKAGE)" = "gettext" \
|
||||
&& test '@INTLOBJS@' = '$(GETTOBJS)'; then \
|
|
@ -1,33 +0,0 @@
|
|||
--- ltmain.sh.orig Sat Aug 3 20:03:26 2002
|
||||
+++ ltmain.sh Sat May 10 15:52:10 2003
|
||||
@@ -1043,7 +1043,7 @@
|
||||
# These systems don't actually have a C library (as such)
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
@@ -2441,7 +2441,7 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
*)
|
||||
@@ -4210,10 +4210,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
|
@ -9,7 +9,5 @@ Cooledit is a suite of programs consisting of the following:
|
|||
- coolicon - a utility to place icons directly on your desktop which runs
|
||||
under any window manager
|
||||
|
||||
WWW: http://cooledit.sourceforge.net/
|
||||
|
||||
- Brett Taylor
|
||||
brett@peloton.physics.montana.edu
|
||||
|
|
|
@ -1,75 +1,45 @@
|
|||
bin/coolbrowse
|
||||
bin/cooledit
|
||||
bin/cooledit-gdb
|
||||
bin/coolicon
|
||||
bin/coolinput
|
||||
bin/coollistbox
|
||||
bin/coolman
|
||||
bin/coolmessage
|
||||
bin/coolproject
|
||||
bin/coolquery
|
||||
bin/smalledit
|
||||
@unexec if cmp -s %D/etc/coolicon.config.dist %D/etc/coolicon.config; then rm -f %D/etc/coolicon.config; fi
|
||||
etc/coolicon.config.dist
|
||||
@exec if [ ! -f %D/etc/coolicon.config ]; then cp -p %D/%F %B/coolicon.config; fi
|
||||
lib/libCw.a
|
||||
lib/libCw.so
|
||||
lib/libCw.so.1
|
||||
share/cooledit/c_utils.py
|
||||
share/cooledit/global.py
|
||||
share/cooledit/sh_utils.py
|
||||
share/cooledit/syntax/ada95.syntax
|
||||
share/cooledit/syntax/bapc.syntax
|
||||
share/cooledit/syntax/c.syntax
|
||||
share/cooledit/syntax/css.syntax
|
||||
share/cooledit/syntax/changelog.syntax
|
||||
share/cooledit/syntax/diff.syntax
|
||||
share/cooledit/syntax/fortran.syntax
|
||||
share/cooledit/syntax/html.syntax
|
||||
share/cooledit/syntax/jasm.syntax
|
||||
share/cooledit/syntax/java.syntax
|
||||
share/cooledit/syntax/latex.syntax
|
||||
share/cooledit/syntax/lsm.syntax
|
||||
share/cooledit/syntax/lua.syntax
|
||||
share/cooledit/syntax/mail.syntax
|
||||
share/cooledit/syntax/makefile.syntax
|
||||
share/cooledit/syntax/mhtml.syntax
|
||||
share/cooledit/syntax/ml.syntax
|
||||
share/cooledit/syntax/mudela.syntax
|
||||
share/cooledit/syntax/nroff.syntax
|
||||
share/cooledit/syntax/pascal.syntax
|
||||
share/cooledit/syntax/perl.syntax
|
||||
share/cooledit/syntax/php.syntax
|
||||
share/cooledit/syntax/prolog.syntax
|
||||
share/cooledit/syntax/python.syntax
|
||||
share/cooledit/syntax/sh.syntax
|
||||
share/cooledit/syntax/sql.syntax
|
||||
share/cooledit/syntax/smalltalk.syntax
|
||||
share/cooledit/syntax/swig.syntax
|
||||
share/cooledit/syntax/texinfo.syntax
|
||||
share/cooledit/syntax/unknown.syntax
|
||||
share/cooledit/syntax/xml.syntax
|
||||
share/coolicon/browse.xpm
|
||||
share/coolicon/cdrom_eject.xpm
|
||||
share/coolicon/cdrom_view.xpm
|
||||
share/coolicon/cooledit.xpm
|
||||
share/coolicon/coolicon.config
|
||||
share/coolicon/dynamite.xpm
|
||||
share/coolicon/e.data
|
||||
share/coolicon/global.py
|
||||
share/coolicon/gmc.xpm
|
||||
share/coolicon/launch.xpm
|
||||
share/coolicon/lyx.xpm
|
||||
share/coolicon/manual.xpm
|
||||
share/coolicon/mc.xpm
|
||||
share/coolicon/netscape.xpm
|
||||
share/coolicon/nscape.xpm
|
||||
share/coolicon/phonedown.xpm
|
||||
share/coolicon/phoneup.xpm
|
||||
share/coolicon/printer.xpm
|
||||
share/coolicon/spanner.xpm
|
||||
share/coolicon/xterm.xpm
|
||||
share/coolicon/xv.xpm
|
||||
%%DATADIR%%/c_utils.py
|
||||
%%DATADIR%%/global.py
|
||||
%%DATADIR%%/sh_utils.py
|
||||
%%DATADIR%%/syntax/ada95.syntax
|
||||
%%DATADIR%%/syntax/bapc.syntax
|
||||
%%DATADIR%%/syntax/c.syntax
|
||||
%%DATADIR%%/syntax/changelog.syntax
|
||||
%%DATADIR%%/syntax/css.syntax
|
||||
%%DATADIR%%/syntax/diff.syntax
|
||||
%%DATADIR%%/syntax/fortran.syntax
|
||||
%%DATADIR%%/syntax/html.syntax
|
||||
%%DATADIR%%/syntax/jasm.syntax
|
||||
%%DATADIR%%/syntax/java.syntax
|
||||
%%DATADIR%%/syntax/latex.syntax
|
||||
%%DATADIR%%/syntax/lsm.syntax
|
||||
%%DATADIR%%/syntax/lua.syntax
|
||||
%%DATADIR%%/syntax/mail.syntax
|
||||
%%DATADIR%%/syntax/makefile.syntax
|
||||
%%DATADIR%%/syntax/mhtml.syntax
|
||||
%%DATADIR%%/syntax/ml.syntax
|
||||
%%DATADIR%%/syntax/mudela.syntax
|
||||
%%DATADIR%%/syntax/nroff.syntax
|
||||
%%DATADIR%%/syntax/pascal.syntax
|
||||
%%DATADIR%%/syntax/perl.syntax
|
||||
%%DATADIR%%/syntax/php.syntax
|
||||
%%DATADIR%%/syntax/prolog.syntax
|
||||
%%DATADIR%%/syntax/python.syntax
|
||||
%%DATADIR%%/syntax/sh.syntax
|
||||
%%DATADIR%%/syntax/smalltalk.syntax
|
||||
%%DATADIR%%/syntax/sql.syntax
|
||||
%%DATADIR%%/syntax/swig.syntax
|
||||
%%DATADIR%%/syntax/texinfo.syntax
|
||||
%%DATADIR%%/syntax/unknown.syntax
|
||||
%%DATADIR%%/syntax/xml.syntax
|
||||
share/locale/cs/LC_MESSAGES/cooledit.mo
|
||||
share/locale/da/LC_MESSAGES/cooledit.mo
|
||||
share/locale/de/LC_MESSAGES/cooledit.mo
|
||||
|
@ -86,6 +56,5 @@ share/locale/pt/LC_MESSAGES/cooledit.mo
|
|||
share/locale/ru/LC_MESSAGES/cooledit.mo
|
||||
share/locale/sl/LC_MESSAGES/cooledit.mo
|
||||
share/locale/sv/LC_MESSAGES/cooledit.mo
|
||||
@dirrm share/coolicon
|
||||
@dirrm share/cooledit/syntax
|
||||
@dirrm share/cooledit
|
||||
@dirrm %%DATADIR%%/syntax
|
||||
@dirrm %%DATADIR%%
|
||||
|
|
Loading…
Reference in a new issue