games/libretro-beetle_bsnes: rename to games/libretro-mednafen_bsnes

PR:		274647
This commit is contained in:
Stephane D'Alu 2023-10-27 12:23:48 +02:00 committed by Robert Clausecker
parent 60e76a9898
commit 9e6c40395f
6 changed files with 5 additions and 22 deletions

1
MOVED
View file

@ -7960,3 +7960,4 @@ www/sfnt2woff||2023-11-02|Has expired: Superseded by WOFF 2.0, please consider u
textproc/kibana7||2023-11-02|Has expired: Depends on EOL NodeJS 16
devel/electron22|devel/electron24|2023-11-02|Has expired: Depends on EOL NodeJS 16
www/hedgedoc||2023-11-02|Has expired: Depends on EOL NodeJS 16
games/libretro-beetle_bsnes|games/libretro-mednafen_bsnes|2023-10-26|Follow naming of libretro-super build script

View file

@ -497,7 +497,6 @@
SUBDIR += libretro
SUBDIR += libretro-2048
SUBDIR += libretro-a5200
SUBDIR += libretro-beetle_bsnes
SUBDIR += libretro-beetle_gba
SUBDIR += libretro-beetle_lynx
SUBDIR += libretro-beetle_ngp
@ -532,6 +531,7 @@
SUBDIR += libretro-mame2000
SUBDIR += libretro-mame2003
SUBDIR += libretro-mame2003_plus
SUBDIR += libretro-mednafen_bsnes
SUBDIR += libretro-melonds
SUBDIR += libretro-mgba
SUBDIR += libretro-mu

View file

@ -1,18 +0,0 @@
--- mednafen/snes/src/lib/libco/aarch64.c.orig 2022-04-07 09:05:20 UTC
+++ mednafen/snes/src/lib/libco/aarch64.c
@@ -15,6 +15,15 @@
#include <malloc.h>
#endif
+#ifndef __BSD__
+#include <sys/param.h>
+
+void *
+memalign(size_t align, size_t size)
+{
+ return (aligned_alloc(align, roundup(size, align)));
+}
+
#ifdef __cplusplus
extern "C" {
#endif

View file

@ -1,4 +1,4 @@
PORTNAME= libretro-beetle_bsnes
PORTNAME= libretro-mednafen_bsnes
PORTVERSION= 0.20220406
CATEGORIES= games
@ -19,7 +19,7 @@ GH_TAGNAME= d770563
PLIST_FILES= lib/libretro/mednafen_snes_libretro.so
do-install:
${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro;
${INSTALL_LIB} ${WRKSRC}/mednafen_snes_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro;
${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro
${INSTALL_LIB} ${WRKSRC}/mednafen_snes_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro
.include <bsd.port.mk>