Repocopy mail/qmHandle to mail/qmhandle to reflect correct project's name
PR: ports/115310 Submitted by: garga
This commit is contained in:
parent
f7548d9bc6
commit
9ea279b3a2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=197581
7 changed files with 4 additions and 100 deletions
1
MOVED
1
MOVED
|
@ -3152,3 +3152,4 @@ net/py-rrdtool_lgpl|databases/py-rrdtool_lgpl|2007-08-11|Moved to a more appropr
|
|||
games/gpuzzle|games/jigsaw|2007-08-11|Project renamed
|
||||
devel/upnp104||2007-08-12|Removed
|
||||
shells/perlsh|shells/psh|2007-08-13|Renamed to reflect correct project's name
|
||||
mail/qmHandle|mail/qmhandle|2007-08-13|Renamed to reflect correct project's name
|
||||
|
|
|
@ -479,7 +479,6 @@
|
|||
SUBDIR += pyzor
|
||||
SUBDIR += qar-bufo
|
||||
SUBDIR += qconfirm
|
||||
SUBDIR += qmHandle
|
||||
SUBDIR += qmail
|
||||
SUBDIR += qmail-activedir
|
||||
SUBDIR += qmail-auditor
|
||||
|
@ -500,6 +499,7 @@
|
|||
SUBDIR += qmailadmin
|
||||
SUBDIR += qmailanalog
|
||||
SUBDIR += qmailmrtg7
|
||||
SUBDIR += qmhandle
|
||||
SUBDIR += qmqtool
|
||||
SUBDIR += qmrtg
|
||||
SUBDIR += qpopper
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
# New ports collection makefile for: qmHandle
|
||||
# Date created: 17 August 2001
|
||||
# Whom: petef
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= qmHandle
|
||||
PORTVERSION= 1.3.0
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= qmhandle
|
||||
DISTNAME= qmhandle-${PORTVERSION}
|
||||
|
||||
MAINTAINER= garga@FreeBSD.org
|
||||
COMMENT= Tool to view and manage a qmail queue
|
||||
|
||||
USE_QMAIL_RUN= yes
|
||||
|
||||
NO_BUILD= yes
|
||||
USE_PERL5= yes
|
||||
USE_BZIP2= yes
|
||||
|
||||
PLIST_FILES= bin/qmHandle
|
||||
PORTDOCS= HISTORY README
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PERL_LEVEL} < 500601
|
||||
IGNORE= requires perl 5.6.1 or later. Install lang/perl5 then try again
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},; \
|
||||
s,%%LOCALBASE%%,${LOCALBASE},g' ${WRKSRC}/qmHandle
|
||||
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/qmHandle ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for file in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (qmhandle-1.3.0.tar.bz2) = 842a0541cd12b365403793aa08c6c3ac
|
||||
SHA256 (qmhandle-1.3.0.tar.bz2) = 1488f9fe4de3cdcdb1e1cb0a2f46bed379701bfc7c88b87ca8d8f37f9caa6c5d
|
||||
SIZE (qmhandle-1.3.0.tar.bz2) = 14415
|
|
@ -1,34 +0,0 @@
|
|||
--- qmHandle.old Tue Aug 7 17:32:57 2007
|
||||
+++ qmHandle Tue Aug 7 17:34:55 2007
|
||||
@@ -26,13 +26,17 @@
|
||||
# ### Be sure to uncomment only ONE of each variable declarations ###
|
||||
|
||||
# For instance, this is if you have DJB's daemontools
|
||||
-my ($stopqmail) = '/usr/local/bin/svc -d /service/qmail-deliver';
|
||||
-my ($startqmail) = '/usr/local/bin/svc -u /service/qmail-deliver';
|
||||
+#my ($stopqmail) = '/usr/local/bin/svc -d /service/qmail-deliver';
|
||||
+#my ($startqmail) = '/usr/local/bin/svc -u /service/qmail-deliver';
|
||||
|
||||
# While this is if you have a Debian GNU/Linux with its qmail package
|
||||
#my ($stopqmail) = '/etc/init.d/qmail stop';
|
||||
#my ($startqmail) = '/etc/init.d/qmail start';
|
||||
|
||||
+# This is if you have FreeBSD with its qmail package
|
||||
+my ($stopqmail) = '%%LOCALBASE%%/etc/rc.d/qmail.sh stop';
|
||||
+my ($startqmail) = '%%LOCALBASE%%/etc/rc.d/qmail.sh start';
|
||||
+
|
||||
# If you don't have scripts, leave $stopqmail blank (the process will
|
||||
# be hunted and killed by qmHandle):
|
||||
#my ($stopqmail) = '';
|
||||
@@ -47,7 +51,10 @@
|
||||
#####
|
||||
# Enter here the system command which returns qmail PID. The following
|
||||
# should work on most Unixes:
|
||||
-my ($pidcmd) = 'pidof qmail-send';
|
||||
+#my ($pidcmd) = 'pidof qmail-send';
|
||||
+# This is for FreeBSD with a standard qmail installation:
|
||||
+my ($pidcmd) = 'ps -U qmails | grep qmail-send | cut -s -d " " -f 1';
|
||||
+
|
||||
|
||||
#################### USER CONFIGURATION END ####################
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
qmHandle is a simple program which allows you to view and manage a qmail
|
||||
message queue.
|
||||
|
||||
The key features of qmHandle are:
|
||||
* You can read the qmail queue, like you do with the qmail-qread program.
|
||||
However, the output of this program is improved over qmail-qread, with
|
||||
the output of the message subjects and color capabilities;
|
||||
* You can print queue statistics, like qmail-qstat, with color capabilities;
|
||||
* You can view a message in the queue;
|
||||
* You can remove a message from the queue.
|
||||
|
||||
WWW: http://qmhandle.sourceforge.net/
|
|
@ -5,12 +5,10 @@
|
|||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= qmHandle
|
||||
PORTNAME= qmhandle
|
||||
PORTVERSION= 1.3.0
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= qmhandle
|
||||
DISTNAME= qmhandle-${PORTVERSION}
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= garga@FreeBSD.org
|
||||
COMMENT= Tool to view and manage a qmail queue
|
||||
|
|
Loading…
Reference in a new issue