games/corsix-th: Update to 0.67

This commit is contained in:
Guido Falsi 2023-08-13 14:23:11 +02:00
parent 164f817254
commit 9ed0c1c0dc
5 changed files with 56 additions and 72 deletions

View file

@ -1,7 +1,6 @@
PORTNAME= corsixth
PORTVERSION= 0.66
PORTVERSION= 0.67
DISTVERSIONPREFIX= v
PORTREVISION= 2
CATEGORIES= games
MAINTAINER= madpilot@FreeBSD.org
@ -16,40 +15,32 @@ RUN_DEPENDS= ${LUA_REFMODLIBDIR}/lfs.so:devel/luafilesystem@${LUA_FLAVOR} \
USES= cmake:insource compiler:c++11-lib desktop-file-utils dos2unix \
iconv lua pkgconfig sdl
USE_SDL= mixer2
DOS2UNIX_FILES= CMake/FindFFmpeg.cmake \
CorsixTH/CMakeLists.txt \
CorsixTH/Src/iso_fs.cpp
USE_GITHUB= yes
GH_ACCOUNT= CorsixTH
GH_PROJECT= CorsixTH
USE_SDL= mixer2
CMAKE_ARGS= -DWITH_LUAJIT=OFF
CFLAGS+= -I${ICONV_PREFIX}/include
DATADIR= ${PREFIX}/share/corsix-th
DESKTOP_ENTRIES= "CorsixTH" \
"${COMMENT}" \
"${PREFIX}/share/pixmaps/corsix-th.png" \
"${PREFIX}/bin/corsix-th" \
"Game;" \
""
OPTIONS_DEFINE= MOVIES TOOLS
OPTIONS_DEFAULT=MOVIES TOOLS
OPTIONS_SUB= yes
USE_GITHUB= yes
GH_ACCOUNT= CorsixTH
GH_PROJECT= CorsixTH
OPTIONS_DEFINE= MOVIES
OPTIONS_DEFAULT= MOVIES
MOVIES_DESC= Play in-game movies
TOOLS_DESC= Tools for decoding RNC files
MOVIES_LIB_DEPENDS= libswresample.so:multimedia/ffmpeg
MOVIES_CMAKE_ON= -DWITH_MOVIES=ON
MOVIES_CMAKE_OFF= -DWITH_MOVIES=OFF
MOVIES_LIB_DEPENDS= libswresample.so:multimedia/ffmpeg
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/CorsixTH/corsix-th ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/CorsixTH/CorsixTH.lua ${STAGEDIR}${DATADIR}
cd ${WRKSRC}/CorsixTH && ${COPYTREE_SHARE} "Bitmap Levels Lua" \
${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/LDocGen/output/logo.png \
${STAGEDIR}${PREFIX}/share/pixmaps/corsix-th.png
TOOLS_CMAKE_ON= -DBUILD_TOOLS=ON
TOOLS_CMAKE_OFF= -DBUILD_TOOLS=OFF
post-install-TOOLS-on:
${INSTALL_PROGRAM} ${WRKSRC}/tools/rnc/rnc_decode ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1656341198
SHA256 (CorsixTH-CorsixTH-v0.66_GH0.tar.gz) = 9f87ff002405501b12798a715b691496775a4f9727188eeba167143816992a0f
SIZE (CorsixTH-CorsixTH-v0.66_GH0.tar.gz) = 4117046
TIMESTAMP = 1691851664
SHA256 (CorsixTH-CorsixTH-v0.67_GH0.tar.gz) = 4e88cf1916bf4d7c304b551ddb91fb9194f110bad4663038ca73d31b939d69e3
SIZE (CorsixTH-CorsixTH-v0.67_GH0.tar.gz) = 4127698

View file

@ -1,11 +1,11 @@
--- CorsixTH/Lua/app.lua.orig 2021-06-17 02:16:54 UTC
--- CorsixTH/Lua/app.lua.orig 2023-06-25 00:50:42 UTC
+++ CorsixTH/Lua/app.lua
@@ -64,7 +64,7 @@ function App:App()
@@ -65,7 +65,7 @@ function App:App()
}
self.strings = {}
self.savegame_version = SAVEGAME_VERSION
- self.check_for_updates = true
+ self.check_for_updates = false
self.idle_tick = 0
end
--! Starts a Lua DBGp client & connects it to a DBGp server.

View file

@ -1,6 +1,6 @@
--- CorsixTH/Lua/config_finder.lua.orig 2021-06-17 02:16:54 UTC
--- CorsixTH/Lua/config_finder.lua.orig 2023-06-25 00:50:42 UTC
+++ CorsixTH/Lua/config_finder.lua
@@ -138,7 +138,7 @@ local config_defaults = {
@@ -140,7 +140,7 @@ local config_defaults = {
shift_scroll_speed = 4,
new_graphics_folder = nil,
use_new_graphics = false,
@ -8,4 +8,4 @@
+ check_for_updates = false,
room_information_dialogs = true,
allow_blocking_off_areas = false,
direct_zoom = false
direct_zoom = nil,

View file

@ -1,58 +1,51 @@
bin/corsix-th
share/pixmaps/corsix-th.png
%%TOOLS%%bin/rnc_decode
share/applications/com.corsixth.corsixth.desktop
share/icons/hicolor/scalable/apps/corsix-th.svg
share/man/man6/corsix-th.6.gz
share/metainfo/com.corsixth.corsixth.metainfo.xml
%%DATADIR%%/Bitmap/aux_ui.dat
%%DATADIR%%/Bitmap/aux_ui.spec
%%DATADIR%%/Bitmap/aux_ui.tab
%%DATADIR%%/Bitmap/bootstrap_font.bmp
%%DATADIR%%/Bitmap/bootstrap_font.dat
%%DATADIR%%/Bitmap/bootstrap_font.pal
%%DATADIR%%/Bitmap/bootstrap_font.tab
%%DATADIR%%/Bitmap/build_room_dialog_close.bmp
%%DATADIR%%/Bitmap/flag_buildable.bmp
%%DATADIR%%/Bitmap/flag_hospital.bmp
%%DATADIR%%/Bitmap/flag_passable.bmp
%%DATADIR%%/Bitmap/flag_travel_east.bmp
%%DATADIR%%/Bitmap/flag_travel_north.bmp
%%DATADIR%%/Bitmap/flag_travel_south.bmp
%%DATADIR%%/Bitmap/flag_travel_west.bmp
%%DATADIR%%/Bitmap/fullscreen_border_bottom.bmp
%%DATADIR%%/Bitmap/fullscreen_border_bottomleft.bmp
%%DATADIR%%/Bitmap/fullscreen_border_bottomright.bmp
%%DATADIR%%/Bitmap/fullscreen_border_left.bmp
%%DATADIR%%/Bitmap/fullscreen_border_right.bmp
%%DATADIR%%/Bitmap/fullscreen_border_top.bmp
%%DATADIR%%/Bitmap/fullscreen_border_topleft.bmp
%%DATADIR%%/Bitmap/fullscreen_border_topright.bmp
%%DATADIR%%/Bitmap/lib_bmp.lua
%%DATADIR%%/Bitmap/lib_spritesheet.lua
%%DATADIR%%/Bitmap/mainmenu1080.bmp
%%DATADIR%%/Bitmap/mainmenu1080.dat
%%DATADIR%%/Bitmap/mainmenu1080.pal
%%DATADIR%%/Bitmap/mainmenu480.bmp
%%DATADIR%%/Bitmap/mainmenu480.dat
%%DATADIR%%/Bitmap/mainmenu480.pal
%%DATADIR%%/Bitmap/mainmenu720.bmp
%%DATADIR%%/Bitmap/mainmenu720.dat
%%DATADIR%%/Bitmap/mainmenu720.pal
%%DATADIR%%/Bitmap/map_cell_outline.bmp
%%DATADIR%%/Bitmap/map_cell_outline_east.bmp
%%DATADIR%%/Bitmap/map_cell_outline_north.bmp
%%DATADIR%%/Bitmap/map_cell_outline_south.bmp
%%DATADIR%%/Bitmap/map_cell_outline_west.bmp
%%DATADIR%%/Bitmap/mkbootstrap.lua
%%DATADIR%%/Bitmap/mkfont.lua
%%DATADIR%%/Bitmap/mkraw.lua
%%DATADIR%%/Bitmap/mksheet.lua
%%DATADIR%%/Bitmap/readme.txt
%%DATADIR%%/Bitmap/tree_collapsed.bmp
%%DATADIR%%/Bitmap/tree_ctrl.dat
%%DATADIR%%/Bitmap/tree_ctrl.pal
%%DATADIR%%/Bitmap/tree_ctrl.spec
%%DATADIR%%/Bitmap/tree_ctrl.tab
%%DATADIR%%/Bitmap/tree_expanded.bmp
%%DATADIR%%/Bitmap/tree_leaf.bmp
%%DATADIR%%/Bitmap/tree_level.bmp
%%DATADIR%%/Campaigns/ChrizmanTV.campaign
%%DATADIR%%/Campaigns/Coffalot.map
%%DATADIR%%/Campaigns/Dethsdaw.map
%%DATADIR%%/Campaigns/Four Corners.map
%%DATADIR%%/Campaigns/Greyham Gardens.map
%%DATADIR%%/Campaigns/Holby.map
%%DATADIR%%/Campaigns/Hoppalong.map
%%DATADIR%%/Campaigns/Royal Hospital.map
%%DATADIR%%/Campaigns/Snuffit Sands.map
%%DATADIR%%/Campaigns/Tufflook.map
%%DATADIR%%/Campaigns/Upper Pukington.map
%%DATADIR%%/Campaigns/Wishinwell.map
%%DATADIR%%/Campaigns/Writhe.map
%%DATADIR%%/Campaigns/coffalot.level
%%DATADIR%%/Campaigns/dethsdaw.level
%%DATADIR%%/Campaigns/example.campaign
%%DATADIR%%/Campaigns/fourcorners.level
%%DATADIR%%/Campaigns/greyhamgardens.level
%%DATADIR%%/Campaigns/holby.level
%%DATADIR%%/Campaigns/hoppalong.level
%%DATADIR%%/Campaigns/royalhospital.level
%%DATADIR%%/Campaigns/snuffitsands.level
%%DATADIR%%/Campaigns/tufflook.level
%%DATADIR%%/Campaigns/upperpukington.level
%%DATADIR%%/Campaigns/wishinwell.level
%%DATADIR%%/Campaigns/writhe.level
%%DATADIR%%/CorsixTH.lua
%%DATADIR%%/LICENSE.txt
%%DATADIR%%/Levels/Example.map
%%DATADIR%%/Levels/avatar.level
%%DATADIR%%/Levels/avatar.map