- Update to 0.9
PR: 99401 Submitted by: Kay Lehmann <kay_lehmann web.de> (maintainer)
This commit is contained in:
parent
98ff7fc947
commit
9edb89578b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=167290
8 changed files with 91 additions and 146 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= lineakd
|
||||
PORTVERSION= 0.8.3
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.9
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR=lineak
|
||||
|
@ -28,7 +27,7 @@ CONFIGURE_ARGS+=--program-prefix=''
|
|||
PORTDOCS= README TODO AUTHORS
|
||||
|
||||
MAN1= lineakd.1
|
||||
MANCOMPRESSED= yes
|
||||
#MANCOMPRESSED= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -38,8 +37,10 @@ USE_GCC= 3.4
|
|||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lpthread||' ${WRKSRC}/lineakd/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/lineakd/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|-lpthread||' \
|
||||
${WRKSRC}/lineak/Makefile.in ${WRKSRC}/lineakd/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|-ldl||' \
|
||||
${WRKSRC}/lineak/Makefile.in ${WRKSRC}/lineakd/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (lineak/lineakd-0.8.3.tar.gz) = fc1d3add18afbb8e61b8277b89c525c6
|
||||
SHA256 (lineak/lineakd-0.8.3.tar.gz) = cfde4a06df9fb4f26f8629d4ed3320ea813ba05a25217ec4ff55bbe5da04f504
|
||||
SIZE (lineak/lineakd-0.8.3.tar.gz) = 852158
|
||||
MD5 (lineak/lineakd-0.9.tar.gz) = 8a45672a6cea666873398ecc36a5070c
|
||||
SHA256 (lineak/lineakd-0.9.tar.gz) = 39fd34f8df4d31d16adacce1191b34cef5e510b536701120906ec708be21010b
|
||||
SIZE (lineak/lineakd-0.9.tar.gz) = 991376
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- Makefile.in.orig Sat Apr 2 18:31:49 2005
|
||||
+++ Makefile.in Sat Apr 2 18:32:05 2005
|
||||
@@ -267,7 +267,7 @@
|
||||
--- Makefile.in.orig Fri May 26 14:44:53 2006
|
||||
+++ Makefile.in Fri May 26 14:45:14 2006
|
||||
@@ -224,7 +224,7 @@
|
||||
COMPILE_FIRST = lineak
|
||||
COMPILE_LAST = lineakd
|
||||
|
||||
####### kdevelop will overwrite this part!!! (begin)##########
|
||||
-SUBDIRS = lineak lineakd utils
|
||||
-SUBDIRS = lineak utils lineakd
|
||||
+SUBDIRS = lineak lineakd
|
||||
|
||||
EXTRA_DIST = lineakd.kdevprj admin AUTHORS COPYING ChangeLog INSTALL README TODO lineakd.lsm lineakd.spec lineakd-noarch.spec README_LINEAK_LIBRARY DIRECTIVES
|
||||
|
||||
####### kdevelop will overwrite this part!!! (end)############
|
||||
|
|
|
@ -1,19 +1,23 @@
|
|||
--- lineak/cdromctrl.cpp.orig Thu Oct 28 17:04:06 2004
|
||||
+++ lineak/cdromctrl.cpp Sat Jan 15 11:28:04 2005
|
||||
@@ -26,6 +26,12 @@
|
||||
--- lineak/cdromctrl.cpp.orig Fri May 26 14:34:03 2006
|
||||
+++ lineak/cdromctrl.cpp Fri May 26 14:39:48 2006
|
||||
@@ -21,7 +21,7 @@
|
||||
extern "C" {
|
||||
#include <fcntl.h>
|
||||
#include <sys/ioctl.h>
|
||||
-#if defined (__FreeBSD_kernel__) || defined(__FreeBSD_kernel__)
|
||||
+#if defined (__FreeBSD__) || defined(__FreeBSD__)
|
||||
# include <sys/cdio.h>
|
||||
# define CDROMEJECT CDIOCEJECT /*_IO('c', 107)*/
|
||||
# define CDROMCLOSETRAY CDIOCCLOSE
|
||||
#else
|
||||
@@ -37,6 +37,7 @@
|
||||
# include <scsi/scsi.h>
|
||||
# include <scsi/sg.h>
|
||||
# include <scsi/scsi_ioctl.h>
|
||||
+# include <sys/mount.h>
|
||||
+
|
||||
+# include <scsi/scsi.h>
|
||||
+# include <scsi/sg.h>
|
||||
+# include <scsi/scsi_ioctl.h>
|
||||
+
|
||||
# include <linux/version.h>
|
||||
# if LINUX_VERSION_CODE >= KERNEL_VERSION(2,5,70)
|
||||
typedef unsigned char u8;
|
||||
@@ -37,16 +43,11 @@
|
||||
#endif
|
||||
#if defined (__CYGWIN__)
|
||||
# include <windows.h>
|
||||
@@ -47,7 +48,6 @@
|
||||
|
||||
#include <sys/stat.h>
|
||||
#include <sys/types.h>
|
||||
|
@ -21,30 +25,3 @@
|
|||
|
||||
#include <stdio.h>
|
||||
#include <errno.h>
|
||||
#include <unistd.h>
|
||||
|
||||
-#include <scsi/scsi.h>
|
||||
-#include <scsi/sg.h>
|
||||
-#include <scsi/scsi_ioctl.h>
|
||||
-
|
||||
}
|
||||
#include <iostream>
|
||||
|
||||
@@ -141,6 +142,9 @@
|
||||
}
|
||||
/** OPen the tray for a scsi device */
|
||||
void cdromCtrl::openTrayScsi(){
|
||||
+ #if defined (__FreeBSD__)
|
||||
+ cdromCtrl::openTray();
|
||||
+ #else
|
||||
/* do we have a CD-ROM device configured? (extra check, not really nescessary) */
|
||||
if ( cdromdev != snull && initialized) {
|
||||
lineak_core_functions::msg("... ejecting the SCSI CD-ROM tray");
|
||||
@@ -196,6 +200,7 @@
|
||||
status = ioctl(fp, BLKRRPART);
|
||||
// return (status == 0);
|
||||
}
|
||||
+#endif
|
||||
}
|
||||
/** Set or disable the auto-eject mode. If auto-eject mode is enabled, the cdrom device
|
||||
will eject when we issue a close(fp); */
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- lineakd/Makefile.am.orig Wed Dec 29 12:07:27 2004
|
||||
+++ lineakd/Makefile.am Wed Dec 29 12:07:41 2004
|
||||
@@ -5,7 +5,7 @@
|
||||
## INCLUDES were found outside kdevelop specific part
|
||||
|
||||
lineakd_SOURCES = lineakd_core_functions.cpp cmdprefs.cpp main.cpp
|
||||
-lineakd_LDADD = -lpthread -llineak -lXext -lX11 -ldl
|
||||
+lineakd_LDADD = -lpthread -llineak -lXext -lX11
|
||||
|
||||
EXTRA_DIST = main.cpp eakprocs.h cmdprefs.cpp cmdprefs.h lineakkb.def lineakd.1.bz2 OLDCODE lineakd_core_functions.h lineakd_core_functions.cpp
|
||||
#man_MANS = lineakd.1.gz
|
|
@ -1,47 +1,46 @@
|
|||
--- lineakd/Makefile.in.orig Sat Jan 15 11:20:25 2005
|
||||
+++ lineakd/Makefile.in Sat Jan 15 11:23:02 2005
|
||||
@@ -269,7 +269,7 @@
|
||||
--- lineakd/Makefile.in.orig Wed May 24 17:26:52 2006
|
||||
+++ lineakd/Makefile.in Mon Jun 5 17:07:33 2006
|
||||
@@ -239,9 +239,9 @@
|
||||
unsermake_enable_pch_FALSE = @unsermake_enable_pch_FALSE@
|
||||
unsermake_enable_pch_TRUE = @unsermake_enable_pch_TRUE@
|
||||
lineakd_SOURCES = lineakd_core_functions.cpp cmdprefs.cpp main.cpp
|
||||
lineakd_LDADD = -llineak -lXext -lX11
|
||||
|
||||
-lineakd_LDADD = -lpthread -llineak -lXext -lX11 -ldl
|
||||
+lineakd_LDADD = -llineak -lXext -lX11
|
||||
lineakd_LDFLAGS = -rdynamic -L../lineak $(all_libraries) @X_LIBS@ @X_PRE_LIBS@
|
||||
-EXTRA_DIST = main.cpp eakprocs.h cmdprefs.cpp cmdprefs.h lineakkb.def lineakd.1.bz2 OLDCODE lineakd_core_functions.h lineakd_core_functions.cpp
|
||||
+EXTRA_DIST = main.cpp eakprocs.h cmdprefs.cpp cmdprefs.h lineakkb.def lineakd.1.gz OLDCODE lineakd_core_functions.h lineakd_core_functions.cpp
|
||||
|
||||
####### kdevelop will overwrite this part!!! (end)############
|
||||
# set the include path found by configure
|
||||
@@ -574,10 +574,10 @@
|
||||
uninstall-local
|
||||
INCLUDES = $(all_includes) -I$(top_srcdir)/lineak -I. -I..
|
||||
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/lineak -I$(top_srcdir)/lineakd -I. -I.. $(all_includes)
|
||||
#>- all: all-am
|
||||
@@ -544,10 +544,10 @@
|
||||
|
||||
#man_MANS = lineakd.1.gz
|
||||
|
||||
-lineakd.1.bz2:
|
||||
- bzip2 -c lineakd.1 > lineakd.1.bz2
|
||||
+lineakd.1.gz:
|
||||
+ gzip lineakd.1
|
||||
+ gzip -c lineakd.1 > lineakd.1.gz
|
||||
|
||||
-install-data-local: lineakd.1.bz2
|
||||
+install-data-local: lineakd.1.gz
|
||||
#>- $(mkinstalldirs) $(sysconfdir)/
|
||||
#>- $(mkinstalldirs) ${DESTDIR}$(sysconfdir)/
|
||||
#>+ 1
|
||||
$(mkinstalldirs) $(DESTDIR)$(sysconfdir)/
|
||||
@@ -590,17 +590,17 @@
|
||||
#>- $(INSTALL_DATA) $(srcdir)/lineakkb.def $(sysconfdir)/lineakkb.def
|
||||
$(mkinstalldirs) $(DESTDIR)${DESTDIR}$(sysconfdir)/
|
||||
@@ -562,7 +562,7 @@
|
||||
$(INSTALL_DATA) $(srcdir)/lineakkb.def $(DESTDIR)${DESTDIR}$(sysconfdir)/lineakkb.def
|
||||
#>- $(INSTALL_DATA) $(srcdir)/lineakd.1.bz2 ${DESTDIR}$(mandir)/man1/lineakd.1.bz2
|
||||
#>+ 1
|
||||
$(INSTALL_DATA) $(srcdir)/lineakkb.def $(DESTDIR)$(sysconfdir)/lineakkb.def
|
||||
-#>- $(INSTALL_DATA) $(srcdir)/lineakd.1.bz2 $(mandir)/man1/lineakd.1.bz2
|
||||
+#>- $(INSTALL_DATA) $(srcdir)/lineakd.1.gz $(mandir)/man1/lineakd.1.gz
|
||||
- $(INSTALL_DATA) $(srcdir)/lineakd.1.bz2 $(DESTDIR)${DESTDIR}$(mandir)/man1/lineakd.1.bz2
|
||||
+ $(INSTALL_DATA) $(srcdir)/lineakd.1.gz $(DESTDIR)${DESTDIR}$(mandir)/man1/lineakd.1.gz
|
||||
if test "$(SETKEYCODES_SUID)" != "no" ; then \
|
||||
chown root `which setkeycodes` ; \
|
||||
chmod +s `which setkeycodes` ; \
|
||||
@@ -574,7 +574,7 @@
|
||||
-rm -f $(DESTDIR)${DESTDIR}$(sysconfdir)/lineakkb.def
|
||||
#>- -rm -f ${DESTDIR}$(mandir)/man1/lineakd.1.bz2
|
||||
#>+ 1
|
||||
- $(INSTALL_DATA) $(srcdir)/lineakd.1.bz2 $(DESTDIR)$(mandir)/man1/lineakd.1.bz2
|
||||
+ $(INSTALL_DATA) $(srcdir)/lineakd.1.gz $(DESTDIR)$(mandir)/man1/lineakd.1.gz
|
||||
|
||||
uninstall-local:
|
||||
#>- -rm -f $(sysconfdir)/lineakkb.def
|
||||
#>+ 1
|
||||
-rm -f $(DESTDIR)$(sysconfdir)/lineakkb.def
|
||||
-#>- -rm -f $(mandir)/man1/lineakd.1.bz2
|
||||
+#>- -rm -f $(mandir)/man1/lineakd.1.gz
|
||||
#>+ 1
|
||||
- -rm -f $(DESTDIR)$(mandir)/man1/lineakd.1.bz2
|
||||
+ -rm -f $(DESTDIR)$(mandir)/man1/lineakd.1.gz
|
||||
- -rm -f $(DESTDIR)${DESTDIR}$(mandir)/man1/lineakd.1.bz2
|
||||
+ -rm -f $(DESTDIR)${DESTDIR}$(mandir)/man1/lineakd.1.gz
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
.NOEXPORT:
|
||||
|
|
|
@ -1,14 +1,6 @@
|
|||
--- lineakd/lineakd_core_functions.cpp.orig Wed Mar 2 13:15:38 2005
|
||||
+++ lineakd/lineakd_core_functions.cpp Sat Apr 2 18:13:06 2005
|
||||
@@ -46,6 +46,7 @@
|
||||
#include <sys/wait.h>
|
||||
}
|
||||
|
||||
+#include <lineak/lineak_core_functions.h>
|
||||
#include <lineak/definitions.h>
|
||||
#include <lineak/configdirectives.h>
|
||||
#include <lineak/saver.h>
|
||||
@@ -256,7 +257,7 @@
|
||||
--- lineakd/lineakd_core_functions.cpp.orig Fri May 26 14:49:04 2006
|
||||
+++ lineakd/lineakd_core_functions.cpp Fri May 26 14:51:07 2006
|
||||
@@ -261,7 +261,7 @@
|
||||
sigprocmask(SIG_SETMASK, &mask_set, &old_set);
|
||||
|
||||
/* now do some cleaning... */
|
||||
|
@ -17,7 +9,7 @@
|
|||
/* Clean up X */
|
||||
if (X != 0) {
|
||||
X->cleanup(myKbd);
|
||||
@@ -270,12 +271,12 @@
|
||||
@@ -275,12 +275,12 @@
|
||||
if (!plugincleanup) {
|
||||
plugincleanup = true;
|
||||
if ( plugins != NULL) {
|
||||
|
@ -33,7 +25,7 @@
|
|||
}
|
||||
}
|
||||
|
||||
@@ -283,13 +284,13 @@
|
||||
@@ -288,13 +288,13 @@
|
||||
//sigprocmask(SIG_SETMASK, &old_set, NULL);
|
||||
|
||||
/* Remove the message queue */
|
||||
|
@ -49,7 +41,7 @@
|
|||
lockCtrl lock("lineakd");
|
||||
lock.unlock();
|
||||
// exit(true);
|
||||
@@ -321,16 +322,16 @@
|
||||
@@ -326,16 +326,16 @@
|
||||
sigprocmask(SIG_SETMASK, &mask_set, &old_set);
|
||||
//bool verbose = cmdprefs.getVerbose();
|
||||
|
||||
|
@ -70,7 +62,7 @@
|
|||
/** Load the plugins */
|
||||
plugins->loadPlugins(pluginlist);
|
||||
/** Define the list of macros we support */
|
||||
@@ -370,34 +371,34 @@
|
||||
@@ -375,37 +375,37 @@
|
||||
cmdprefs.setDefaults(dnd);
|
||||
|
||||
/* reload .conf and .def file */
|
||||
|
@ -109,6 +101,10 @@
|
|||
|
||||
- msg("*** Restarting On Screen Display...");
|
||||
+ lineak_core_functions::msg("*** Restarting On Screen Display...");
|
||||
myDisplay->init(myConfig);
|
||||
myDisplay = plugins->getDisplay(myConfig);
|
||||
//myDisplay->init(myConfig);
|
||||
- msg("*** InitializePluginsDisplay...");
|
||||
+ lineak_core_functions::msg("*** InitializePluginsDisplay...");
|
||||
plugins->initializePluginsDisplay(*myDisplay);
|
||||
|
||||
donehup=false;
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- lineakd/main.cpp.orig Mon Feb 21 20:26:38 2005
|
||||
+++ lineakd/main.cpp Sat Apr 2 18:20:50 2005
|
||||
@@ -134,19 +134,19 @@
|
||||
--- lineakd/main.cpp.orig Fri May 26 14:51:44 2006
|
||||
+++ lineakd/main.cpp Fri May 26 14:53:46 2006
|
||||
@@ -136,19 +136,19 @@
|
||||
/** Load the plugins */
|
||||
plugins->loadPlugins(pluginlist);
|
||||
if (verbose) {
|
||||
|
@ -26,7 +26,7 @@
|
|||
plugins->defineDirectivesLists();
|
||||
//if (verbose) plugins->listPlugins();
|
||||
/** Get a list of macros we support so that we can inform other classes */
|
||||
@@ -307,7 +307,7 @@
|
||||
@@ -318,7 +318,7 @@
|
||||
watch_messages();
|
||||
|
||||
/* init X/Xkb with our EAK keycodes/keysyms */
|
||||
|
@ -35,7 +35,7 @@
|
|||
|
||||
if (!X->initialize(myKbd)) {
|
||||
cerr << "Could not initialize all keys. Retrying.\n";
|
||||
@@ -329,7 +329,7 @@
|
||||
@@ -340,7 +340,7 @@
|
||||
myDisplay = new displayCtrl(myConfig);
|
||||
myDisplay->init();
|
||||
}
|
||||
|
@ -44,7 +44,7 @@
|
|||
plugins->initializePluginsDisplay(*myDisplay);
|
||||
|
||||
/* alright, we're going to loop forever now. only signals can interrupt us. */
|
||||
@@ -362,23 +362,23 @@
|
||||
@@ -375,23 +375,23 @@
|
||||
// like VMWare.
|
||||
if (xev.type == MappingNotify) {
|
||||
// if (!X->xkbRemapped()) {
|
||||
|
@ -73,8 +73,8 @@
|
|||
+ lineak_core_functions::msg("Restarting the OSD.");
|
||||
myDisplay = plugins->getDisplay(myConfig);
|
||||
if (myDisplay != NULL) {
|
||||
if (very_verbose) cout << "Reiniting plugin provided On Screen Display" << endl;
|
||||
@@ -390,7 +390,7 @@
|
||||
//if (very_verbose) cout << "Reiniting plugin provided On Screen Display" << endl;
|
||||
@@ -405,7 +405,7 @@
|
||||
myDisplay->init();
|
||||
}
|
||||
// Initialize the plugin displays again.
|
||||
|
@ -83,38 +83,21 @@
|
|||
plugins->initializePluginsDisplay(*myDisplay);
|
||||
// set exec.setDisplayCtrl(myDisplay) again.
|
||||
exec.setDisplayCtrl(myDisplay);
|
||||
@@ -414,7 +414,7 @@
|
||||
}
|
||||
@@ -433,7 +433,7 @@
|
||||
|
||||
if (obj != NULL) {
|
||||
- msg("Got an object!");
|
||||
+ lineak_core_functions::msg("Got an object!");
|
||||
vmsg("Got an object!");
|
||||
- msg("Looking for SYM and PRESS");
|
||||
+ lineak_core_functions::msg("Looking for SYM and PRESS");
|
||||
if (obj->getType() == SYM && obj->getEventType() == PRESS) {
|
||||
cout << "xev.xkey.keycode = " << xev.xkey.keycode << endl;
|
||||
cout << "obj->getKeyCode() = " << obj->getKeyCode() << endl;
|
||||
@@ -435,21 +435,21 @@
|
||||
if (verbose) {
|
||||
cout << "xev.xkey.keycode = " << xev.xkey.keycode << endl;
|
||||
@@ -451,7 +451,7 @@
|
||||
}
|
||||
}
|
||||
else {
|
||||
- msg("Looking for CODE and PRESS");
|
||||
+ lineak_core_functions::msg("Looking for CODE and PRESS");
|
||||
|
||||
- msg("Looking for CODE and PRESS");
|
||||
+ lineak_core_functions::msg("Looking for CODE and PRESS");
|
||||
if (obj->getType() == CODE && obj->getEventType() == PRESS)
|
||||
{
|
||||
if (verbose) cout << xev.xkey.keycode << " = " << obj->getKeyCode() << endl;
|
||||
|
||||
if (obj->hasModifier(xev.xkey.state))
|
||||
- msg("true");
|
||||
+ lineak_core_functions::msg("true");
|
||||
else
|
||||
- msg("false");
|
||||
+ lineak_core_functions::msg("false");
|
||||
|
||||
if ((int)xev.xkey.keycode == obj->getKeyCode()
|
||||
&& obj->hasModifier((int)xev.xkey.state))
|
||||
{
|
||||
- msg("getting to the right place!");
|
||||
+ lineak_core_functions::msg("getting to the right place!");
|
||||
execute = plugins->exec(obj,xev);
|
||||
if (execute != NULL)
|
||||
execute(obj,xev);
|
||||
if (very_verbose) cout << xev.xkey.keycode << " = " << obj->getKeyCode() << endl;
|
||||
|
|
Loading…
Reference in a new issue