Upgrade to 7.6.3.
PR: ports/66200 Submitted by: maintainer
This commit is contained in:
parent
4b76b96de1
commit
9f1c9f1618
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108496
4 changed files with 21 additions and 91 deletions
|
@ -5,14 +5,13 @@
|
|||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= pike75
|
||||
PORTVERSION= 7.5.21
|
||||
PORTNAME= pike76
|
||||
PORTVERSION= 7.6.3
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ftp://pike.ida.liu.se/pub/pike/all/${PORTVERSION}/ \
|
||||
ftp://ftp.oav.net/pike/7.5/export/ \
|
||||
http://grendel.firewall.com/caudium-pkg/ \
|
||||
ftp://ftp.oav.net/pike/7.6/ \
|
||||
ftp://ftp.caudium.net/pike/official_releases/${PORTVERSION}/
|
||||
DISTNAME= Pike-v${PORTVERSION}
|
||||
DISTNAME= pike-${PORTVERSION}
|
||||
|
||||
MAINTAINER= kiwi@oav.net
|
||||
COMMENT= A dynamic programming language with a syntax similar to C++
|
||||
|
@ -28,11 +27,19 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
|||
OPTIONS= TTF "Add FreeType 1 support" on \
|
||||
FREETYPE "Add FreeType 2 support" on \
|
||||
OPT_CFLAGS "Enable additional compiliation optimizations" on \
|
||||
MYSQL "Add MySQL support" on
|
||||
MYSQL "Add MySQL support" on \
|
||||
FFMPEG "Add FFmpeg support" off \
|
||||
POSTGRESQL "Add Postgres SQL support" off \
|
||||
UNIXODBC "Add UnixODBC support (incompatible with IODBC)" off \
|
||||
IODBC "Add iODBC support (incompatible with UnixODBC)" off \
|
||||
SANE "Add SANE support" off \
|
||||
PDF "Add PDF support" off \
|
||||
SVG2 "Add SVG2 support" off \
|
||||
TDS "Add FreeTDS (Sybase and MSSQL) support" off
|
||||
|
||||
MAN1= pike.1
|
||||
|
||||
WRKSRC= ${WRKDIR}/Pike-v${PORTVERSION}/src/
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/src/
|
||||
|
||||
WANT_MESA= yes
|
||||
|
||||
|
@ -72,10 +79,6 @@ USE_BISON= yes
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} != "i386"
|
||||
BROKEN= "Does not build on !i386 (errors running pike binary during build)"
|
||||
.endif
|
||||
|
||||
PLIST_SUB+= PORTVERSION=${PORTVERSION}
|
||||
|
||||
# FreeBSD 5.0 Needs to have libgmp port to support gmp.
|
||||
|
@ -91,74 +94,6 @@ USE_PERL5= YES
|
|||
CONFIGURE_ARGS+= --without-perl
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libavcodec.so.0)
|
||||
WITH_FFMPEG= yes
|
||||
OPTIONS+= FFMPEG "Add FFmpeg support" on
|
||||
.else
|
||||
OPTIONS+= FFMPEG "Add FFmpeg support" off
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libttf.so.4)
|
||||
WITH_TTF= yes
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libfreetype.so.9)
|
||||
WITH_FREETYPE= yes
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libpq.so.3)
|
||||
WITH_POSTGRES= yes
|
||||
OPTIONS+= POSTGRES "Add Postgres SQL support" on
|
||||
.else
|
||||
OPTIONS+= POSTGRES "Add Postgres SQL support" off
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libodbc.so.1)
|
||||
WITH_UNIXODBC= yes
|
||||
OPTIONS+= UNIXODBC "Add UnixODBC support (incompatible with IODBC)" on
|
||||
.else
|
||||
OPTIONS+= UNIXODBC "Add UnixODBC support (incompatible with IODBC)" off
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libiodbc.so.2)
|
||||
WITH_IODBC= yes
|
||||
OPTIONS+= IODBC "Add iODBC support (incompatible with UnixODBC)" on
|
||||
.else
|
||||
OPTIONS+= IODBC "Add iODBC support (incompatible with UnixODBC)" off
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libsane.so.1)
|
||||
WITH_SANE= yes
|
||||
OPTIONS+= SANE "Add SANE support" on
|
||||
.else
|
||||
OPTIONS+= SANE "Add SANE support" off
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libgtkgl.so.5)
|
||||
WITH_MESA= yes
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libpdf.so.6) || exists(${LOCALBASE}/lib/libpanda.so.0)
|
||||
WITH_PDF= yes
|
||||
OPTIONS+= PDF "Add PDF support" on
|
||||
.else
|
||||
OPTIONS+= PDF "Add PDF support" off
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/lib/librsvg-2.so.2)
|
||||
WITH_SVG2= yes
|
||||
OPTIONS+= SVG2 "Add SVG2 support" on
|
||||
.else
|
||||
OPTIONS+= SVG2 "Add SVG2 support" off
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libct.so.1)
|
||||
WITH_TDS= yes
|
||||
OPTIONS+= TDS "Add FreeTDS (Sybase and MSSQL) support" on
|
||||
.else
|
||||
OPTIONS+= TDS "Add FreeTDS (Sybase and MSSQL) support" off
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_RELOCATABLE_DUMPED_MODULES)
|
||||
CONFIGURE_ARGS+= --without-relocatable-dumped-modules
|
||||
.else
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (Pike-v7.5.21.tar.gz) = 877ba7a831656bb98b0b4369e94d2603
|
||||
SIZE (Pike-v7.5.21.tar.gz) = 10141665
|
||||
MD5 (pike-7.6.3.tar.gz) = a485ddf8eb6bfa275ddf4128fac997f3
|
||||
SIZE (pike-7.6.3.tar.gz) = 10249258
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- modules/_Image_FreeType/configure.orig Tue Mar 16 14:58:23 2004
|
||||
+++ modules/_Image_FreeType/configure Tue Mar 16 14:59:04 2004
|
||||
@@ -2046,8 +2046,8 @@
|
||||
--- modules/_Image_FreeType/configure.orig Mon May 3 13:58:33 2004
|
||||
+++ modules/_Image_FreeType/configure Mon May 3 13:59:12 2004
|
||||
@@ -2048,8 +2048,8 @@
|
||||
fi
|
||||
|
||||
else
|
||||
|
@ -8,6 +8,6 @@
|
|||
-set dummy ${ac_tool_prefix}freetype-config; ac_word=$2
|
||||
+ # Extract the first word of "freetype-config", so it can be a program name with args.
|
||||
+set dummy freetype-config; ac_word=$2
|
||||
echo "$as_me:2051: checking for $ac_word" >&5
|
||||
echo "$as_me:2053: checking for $ac_word" >&5
|
||||
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
|
||||
if test "${ac_cv_path_FT_CONFIG+set}" = set; then
|
||||
|
|
|
@ -1,5 +1,4 @@
|
|||
bin/pike
|
||||
bin/pike12
|
||||
bin/hilfe
|
||||
pike/%%PORTVERSION%%/bin/pike
|
||||
pike/%%PORTVERSION%%/bin/pike.syms
|
||||
|
@ -31,9 +30,6 @@ pike/%%PORTVERSION%%/lib/modules/Yp.pmod
|
|||
pike/%%PORTVERSION%%/lib/modules/___Yp.so
|
||||
pike/%%PORTVERSION%%/lib/modules/_Charset.pmod
|
||||
pike/%%PORTVERSION%%/lib/modules/____Charset.so
|
||||
pike/%%PORTVERSION%%/lib/modules/_math.pmod
|
||||
pike/%%PORTVERSION%%/lib/modules/files.pmod
|
||||
pike/%%PORTVERSION%%/lib/modules/sprintf.pmod
|
||||
%%SYBASE:%%pike/%%PORTVERSION%%/lib/modules/sybase.so
|
||||
pike/%%PORTVERSION%%/lib/modules/Colors.pmod
|
||||
pike/%%PORTVERSION%%/lib/modules/Array.pmod
|
||||
|
@ -202,7 +198,6 @@ pike/%%PORTVERSION%%/lib/modules/Remote.pmod/Client.pike
|
|||
pike/%%PORTVERSION%%/lib/modules/Remote.pmod/Server.pike
|
||||
pike/%%PORTVERSION%%/lib/modules/Remote.pmod/remote.h
|
||||
pike/%%PORTVERSION%%/lib/modules/SSL.pmod/connection.pike
|
||||
pike/%%PORTVERSION%%/lib/modules/SSL.pmod/TODO
|
||||
pike/%%PORTVERSION%%/lib/modules/SSL.pmod/alert.pike
|
||||
pike/%%PORTVERSION%%/lib/modules/SSL.pmod/client.pike
|
||||
pike/%%PORTVERSION%%/lib/modules/SSL.pmod/context.pike
|
||||
|
@ -398,7 +393,6 @@ pike/%%PORTVERSION%%/include/pike/preprocessor.h
|
|||
pike/%%PORTVERSION%%/include/pike/program.h
|
||||
pike/%%PORTVERSION%%/include/pike/program_id.h
|
||||
pike/%%PORTVERSION%%/include/pike/queue.h
|
||||
pike/%%PORTVERSION%%/include/pike/security.h
|
||||
pike/%%PORTVERSION%%/include/pike/time_stuff.h
|
||||
pike/%%PORTVERSION%%/include/pike/stralloc.h
|
||||
pike/%%PORTVERSION%%/include/pike/stuff.h
|
||||
|
@ -432,5 +426,6 @@ pike/%%PORTVERSION%%/include/pike/aclocal.m4
|
|||
@dirrm pike/%%PORTVERSION%%/include
|
||||
@dirrm pike/%%PORTVERSION%%/bin
|
||||
@dirrm pike/%%PORTVERSION%%/lib
|
||||
@unexec rm -rf %D/pike/%%PORTVERSION%%/doc 2>&1 >/dev/null || true
|
||||
@dirrm pike/%%PORTVERSION%%
|
||||
@dirrm pike
|
||||
|
|
Loading…
Reference in a new issue