mail/claws-mail: make it depend on security/ca_root_nss

Instead of installing the Win certs bundle.

A new patch is needed so it looks for certs by default in out LOCALBASE

PR:	246944
Submitted by:	ps.ports@smyrak.com
Reviewed by:	portmaster@bsdforge.com (maintainer)
This commit is contained in:
Fernando Apesteguía 2020-06-04 05:48:34 +00:00
parent 47044b84fd
commit 9f5a4d0b89
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=537868
4 changed files with 24 additions and 8 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= claws-mail
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= mail news
COMMENT= Lightweight and featureful GTK+ based e-mail and news client
@ -19,7 +19,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libexpat.so:textproc/expat2 \
libfontconfig.so:x11-fonts/fontconfig \
libnettle.so:security/nettle
RUN_DEPENDS= mime-support>0:misc/mime-support
RUN_DEPENDS= mime-support>0:misc/mime-support \
${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
USES= autoreconf compiler:c++11-lang cpe desktop-file-utils gettext \
gettext-tools gnome pathfix pkgconfig python:3.5+ shebangfix ssl xorg
@ -60,10 +61,14 @@ THEMES_RUN_DEPENDS= claws-mail-themes>0:x11-themes/claws-mail-themes
.include "Makefile.claws"
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/src/common/ssl.c
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WRKSRC}/tools && \
${INSTALL_SCRIPT} acroread2claws-mail.pl ca-certificates.crt \
${INSTALL_SCRIPT} acroread2claws-mail.pl \
calypso_convert.pl claws-mail-compose-insert-files.pl \
cm-reparent.pl convert_mbox.pl csv2addressbook.pl ddg_search.pl \
eud2gc.py filter_conv.pl filter_conv_new.pl fix_date.sh \

View file

@ -1,6 +1,6 @@
--- configure.ac.orig 2020-04-08 14:26:12.215936000 -0700
+++ configure.ac 2020-04-08 14:30:01.861284000 -0700
@@ -1325,7 +1325,7 @@
--- configure.ac.orig 2019-12-16 09:16:04 UTC
+++ configure.ac
@@ -1325,7 +1325,7 @@ fi
dnl Python *********************************************************************
missing_python=""
AM_PATH_PYTHON([2.5], [
@ -9,7 +9,7 @@
if test x"$PYTHON_CONFIG" = x"" ; then
AC_PATH_PROG(PYTHON_CONFIG, python-config)
fi
@@ -1344,7 +1344,7 @@
@@ -1344,7 +1344,7 @@ AM_PATH_PYTHON([2.5], [
_save_libs="$LIBS"
if test x"$platform_win32" = xno; then
# libpython.so

View file

@ -0,0 +1,12 @@
--- src/common/ssl.c.orig 2018-12-21 09:33:36 UTC
+++ src/common/ssl.c
@@ -196,6 +196,9 @@ const gchar *claws_ssl_get_cert_file(void)
#ifndef G_OS_WIN32
const char *cert_files[]={
"/etc/ssl/cert.pem",
+ // Also search in LOCALBASE directory to
+ // workaround potential lack of /etc symlink
+ "%%LOCALBASE%%/share/certs/ca-root-nss.crt",
"/etc/pki/tls/certs/ca-bundle.crt",
"/etc/certs/ca-bundle.crt",
"/etc/ssl/ca-bundle.pem",

View file

@ -236,7 +236,6 @@ libdata/pkgconfig/claws-mail.pc
man/man1/claws-mail.1.gz
share/applications/claws-mail.desktop
%%DATADIR%%/acroread2claws-mail.pl
%%DATADIR%%/ca-certificates.crt
%%DATADIR%%/calypso_convert.pl
%%DATADIR%%/claws-mail-compose-insert-files.pl
%%DATADIR%%/cm-reparent.pl