- Update to 2.4b
- Add new rc.d script PR: 96824 Submitted by: Rui Lopes <rgl___ruilopes.com> Approved by: maintainer timeout (14 days)
This commit is contained in:
parent
4eb353afb7
commit
9f61df9dc9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=162837
5 changed files with 51 additions and 17 deletions
|
@ -6,11 +6,11 @@
|
|||
#
|
||||
|
||||
PORTNAME= denyhosts
|
||||
PORTVERSION= 2.2
|
||||
DISTVERSION= 2.4b
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= DenyHosts-${PORTVERSION}
|
||||
DISTNAME= DenyHosts-${DISTVERSION}
|
||||
|
||||
MAINTAINER= janos.mohacsi@bsd.hu
|
||||
COMMENT= Script to thwart ssh attacks
|
||||
|
@ -18,10 +18,12 @@ COMMENT= Script to thwart ssh attacks
|
|||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS= yes
|
||||
|
||||
USE_RC_SUBR= denyhosts
|
||||
|
||||
DOC_FILES= CHANGELOG.txt LICENSE.txt README.txt
|
||||
|
||||
pre-configure:
|
||||
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
|
||||
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
|
||||
${WRKSRC}/daemon-control-dist \
|
||||
${WRKSRC}/denyhosts.cfg-dist \
|
||||
${WRKSRC}/setup.py
|
||||
|
@ -33,6 +35,6 @@ post-install:
|
|||
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (DenyHosts-2.2.tar.gz) = feba0e9a48dbf1fa9cbd2b5b8907f349
|
||||
SHA256 (DenyHosts-2.2.tar.gz) = 369d37528287550ae152b2cd553549c021dab3c5a6b15fea93656749e7559bfd
|
||||
SIZE (DenyHosts-2.2.tar.gz) = 40972
|
||||
MD5 (DenyHosts-2.4b.tar.gz) = c60df73b29baeadffbbb1ef8f130dd8d
|
||||
SHA256 (DenyHosts-2.4b.tar.gz) = 851a050c6eb78618605eecdfae80a1ac412b2adc99160fb9c9d275f64858a7c1
|
||||
SIZE (DenyHosts-2.4b.tar.gz) = 42206
|
||||
|
|
23
security/denyhosts/files/denyhosts.in
Normal file
23
security/denyhosts/files/denyhosts.in
Normal file
|
@ -0,0 +1,23 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
# PROVIDE: denyhosts
|
||||
# REQUIRE: DAEMON
|
||||
#
|
||||
|
||||
. %%RC_SUBR%%
|
||||
|
||||
name="denyhosts"
|
||||
rcvar=${name}_enable
|
||||
|
||||
command="%%PREFIX%%/bin/denyhosts.py"
|
||||
command_interpreter="/usr/local/bin/python"
|
||||
command_args="--config %%PREFIX%%/etc/denyhosts.conf --daemon"
|
||||
pidfile="/var/run/${name}.pid"
|
||||
|
||||
load_rc_config $name
|
||||
|
||||
: ${denyhosts_enable="NO"}
|
||||
|
||||
run_rc_command "$1"
|
|
@ -1,8 +1,5 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- denyhosts.cfg-dist.orig
|
||||
+++ denyhosts.cfg-dist
|
||||
--- denyhosts.cfg-dist.orig Sun Apr 9 14:37:46 2006
|
||||
+++ denyhosts.cfg-dist Fri May 5 11:37:13 2006
|
||||
@@ -9,10 +9,10 @@
|
||||
# argument
|
||||
#
|
||||
|
@ -16,7 +13,16 @@ $FreeBSD$
|
|||
#
|
||||
# SuSE:
|
||||
#SECURE_LOG = /var/log/messages
|
||||
@@ -23,7 +23,7 @@
|
||||
@@ -22,7 +22,7 @@
|
||||
#SECURE_LOG = /private/var/log/asl.log
|
||||
#
|
||||
# Mac OS X (v10.3 or earlier):
|
||||
-SECURE_LOG=/private/var/log/system.log
|
||||
+#SECURE_LOG=/private/var/log/system.log
|
||||
#
|
||||
########################################################################
|
||||
|
||||
@@ -31,7 +31,7 @@
|
||||
# HOSTS_DENY: the file which contains restricted host access information
|
||||
#
|
||||
# Most operating systems:
|
||||
|
@ -25,7 +31,7 @@ $FreeBSD$
|
|||
#
|
||||
# Some BSD (FreeBSD) Unixes:
|
||||
#HOSTS_DENY = /etc/hosts.allow
|
||||
@@ -66,7 +66,7 @@
|
||||
@@ -90,7 +90,7 @@
|
||||
# To block all services for the offending host:
|
||||
#BLOCK_SERVICE = ALL
|
||||
# To block only sshd:
|
||||
|
@ -34,7 +40,7 @@ $FreeBSD$
|
|||
# To only record the offending host and nothing else (if using
|
||||
# an auxilary file to list the hosts). Refer to:
|
||||
# http://denyhosts.sourceforge.net/faq.html#aux
|
||||
@@ -126,7 +126,7 @@
|
||||
@@ -150,7 +150,7 @@
|
||||
# Note: it is recommended that you use an absolute pathname
|
||||
# for this value (eg. /home/foo/denyhosts/data)
|
||||
#
|
||||
|
@ -43,7 +49,7 @@ $FreeBSD$
|
|||
#
|
||||
#######################################################################
|
||||
|
||||
@@ -152,7 +152,7 @@
|
||||
@@ -176,7 +176,7 @@
|
||||
# the corresponding hostname will be looked up and reported as well
|
||||
# (if available).
|
||||
#
|
||||
|
@ -52,7 +58,7 @@ $FreeBSD$
|
|||
#
|
||||
######################################################################
|
||||
|
||||
@@ -168,10 +168,10 @@
|
||||
@@ -192,10 +192,10 @@
|
||||
# running at a time.
|
||||
#
|
||||
# Redhat/Fedora:
|
||||
|
|
|
@ -29,6 +29,9 @@ bin/denyhosts.py
|
|||
%%PYTHON_SITELIBDIR%%/DenyHosts/plugin.py
|
||||
%%PYTHON_SITELIBDIR%%/DenyHosts/plugin.pyc
|
||||
%%PYTHON_SITELIBDIR%%/DenyHosts/plugin.pyo
|
||||
%%PYTHON_SITELIBDIR%%/DenyHosts/purgecounter.py
|
||||
%%PYTHON_SITELIBDIR%%/DenyHosts/purgecounter.pyc
|
||||
%%PYTHON_SITELIBDIR%%/DenyHosts/purgecounter.pyo
|
||||
%%PYTHON_SITELIBDIR%%/DenyHosts/constants.py
|
||||
%%PYTHON_SITELIBDIR%%/DenyHosts/constants.pyc
|
||||
%%PYTHON_SITELIBDIR%%/DenyHosts/constants.pyo
|
||||
|
|
Loading…
Reference in a new issue